471,595 Members | 1,832 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,595 software developers and data experts.

TRACE doesn't work on the remote box

Jay
I have an ASP.NET app that works on my box.
When I deployed it to the server, it doesn't work
It calls a webmethod, and looks like that call doesn't work.There is no
exception thrown.
So, I wanted to look at the trace. But nothing gets logged there too.
Although, On my box, the logging works, the webmethod works.

Oct 23 '06 #1
4 1706
Have you got Trace turned off anywhere (like in your Web.config, or in your
page?

--
David Wier
MVP/ASPInsider
http://aspnet101.com
http://aspexpress.com

"Jay" <Ja*@microsoft.comwrote in message
news:eO**************@TK2MSFTNGP03.phx.gbl...
I have an ASP.NET app that works on my box.
When I deployed it to the server, it doesn't work
It calls a webmethod, and looks like that call doesn't work.There is no
exception thrown.
So, I wanted to look at the trace. But nothing gets logged there too.
Although, On my box, the logging works, the webmethod works.

Oct 23 '06 #2
Jay
The same code works on my box.
I haven't changed anything while deploying to the remote server.
Where do I check that anyways?

"Elmo Watson" <sp*****@yahoo.comwrote in message
news:Oe**************@TK2MSFTNGP02.phx.gbl...
Have you got Trace turned off anywhere (like in your Web.config, or in
your
page?

--
David Wier
MVP/ASPInsider
http://aspnet101.com
http://aspexpress.com

"Jay" <Ja*@microsoft.comwrote in message
news:eO**************@TK2MSFTNGP03.phx.gbl...
>I have an ASP.NET app that works on my box.
When I deployed it to the server, it doesn't work
It calls a webmethod, and looks like that call doesn't work.There is no
exception thrown.
So, I wanted to look at the trace. But nothing gets logged there too.
Although, On my box, the logging works, the webmethod works.


Oct 23 '06 #3
You were talking about Tracing though - whether it works or not - if you
want to do tracing, it needs to be turned on somewhere
You can do it inside the web.config file, or you on each web page where you
want tracing. For instance, you can turn it off everywhere (completely) in
the Web.config, but enable it in the page directive in your web page.

--
David Wier
MVP/ASPInsider
http://aspnet101.com
http://aspexpress.com

"Jay" <Ja*@microsoft.comwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
The same code works on my box.
I haven't changed anything while deploying to the remote server.
Where do I check that anyways?

"Elmo Watson" <sp*****@yahoo.comwrote in message
news:Oe**************@TK2MSFTNGP02.phx.gbl...
Have you got Trace turned off anywhere (like in your Web.config, or in
your
page?

Oct 23 '06 #4
Jay
I have this in my web.config file:
<system.diagnostics>

<trace autoflush="false" indentsize="4">

<listeners>

<add name="myListener" type="System.Diagnostics.TextWriterTraceListener"
initializeData="C:\\temp\\guestpulls\\Guestpull.lo g" />

<remove name="Default" />

</listeners>

</trace>

</system.diagnostics>

--------------------------

In my Code, I have the line:

Trace.WriteLine("Initialize(): Hello!");

Nothing gets logged to my log file on the remote server.

(On my local box, it works)

"David Wier" <da********@noSpamhotmail.comwrote in message
news:O8**************@TK2MSFTNGP02.phx.gbl...
You were talking about Tracing though - whether it works or not - if you
want to do tracing, it needs to be turned on somewhere
You can do it inside the web.config file, or you on each web page where
you
want tracing. For instance, you can turn it off everywhere (completely) in
the Web.config, but enable it in the page directive in your web page.

--
David Wier
MVP/ASPInsider
http://aspnet101.com
http://aspexpress.com

"Jay" <Ja*@microsoft.comwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
>The same code works on my box.
I haven't changed anything while deploying to the remote server.
Where do I check that anyways?

"Elmo Watson" <sp*****@yahoo.comwrote in message
news:Oe**************@TK2MSFTNGP02.phx.gbl...
Have you got Trace turned off anywhere (like in your Web.config, or in
your
page?


Oct 23 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Joe Rattz | last post: by
5 posts views Thread by guy | last post: by
9 posts views Thread by Joe Rattz | last post: by
3 posts views Thread by Simon | last post: by
2 posts views Thread by tshad | last post: by
3 posts views Thread by | last post: by
reply views Thread by leo001 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.