468,765 Members | 1,384 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,765 developers. It's quick & easy.

No fields in FormView

Hi,

I have a FormView where nothing gets rendered past the opening
<ItemTemplatetag. The FormView Header renders but nothing else. If I put
garbage in an Eval statement, no errors are raised and the page loads but,
of course, with no data in the FormView. If I put a div inside the
ItemTemplate, it does not render.

In Design view, my FormView shows up just as a grey form and says:
'Right-click or choose the Edit Templates . . .". I have noticed that with
FormView controls that work properly in the sample code I have looked at,
they appear, in design view, showing the bound fields and it says 'Data
Bound'. When I opened the control in design view, each of fields said 'data
bound' in the properties window but they don't act that way.

I set the DataSourceID to an ObjectDataSource that works fine with a
DetailsView control.

Thanks for any ideas.

Steve


Oct 3 '06 #1
1 1216
I was setting the mode for the FormView to Insert but I did not have an
Insert template declared. I hit my head against the wall on this all day and
figured it out right after posting.
Oct 3 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by le_mo_mo | last post: by
2 posts views Thread by sck10 | last post: by
6 posts views Thread by Chris | last post: by
reply views Thread by mkidd | last post: by
reply views Thread by COHENMARVIN | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by Marin | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.