By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,441 Members | 1,766 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,441 IT Pros & Developers. It's quick & easy.

Problem with Virtual directory on my local machine.

P: n/a
I am trying to use my IIS web server on my local machine for testing my web
site.

The problem is that periodically it will not use the virtual directory for
the root.

This happens for my logon page, for instance.

If I have the following Virtual Directory: Staff.

I would call this by using http://localhost/Staff/default.aspx.

This works fine most of the time. But if I tried to uset
http://localhost/Staff/App/page.aspx, I get a 404 error. You need to log on
to get to this page, so the program works as expected and calls my Logon
page, but it calls it without the Virtual Directory - even though the
Virtual Directory is in the ReturnURL parameter:

http://localhost/App/EELogin.aspx?Re...pp%2fpage.aspx

It should be:

http://localhost/Staff/App/EELogin.a...pp%2fpage.aspx

As I said it works for other things that start from the root, such as my
images and buttons (/images/button.jpg for example).

Why doesn't it use the Virtual Directory for this case?

Thanks,

Tom
Sep 28 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Is the virtual directory set up as an application in IIS. To check, go to
the property pages. If you see Create, it is not. If you see Remove, it is.
If not, create it. If you still have problems, make sure it is in the
correct Application pool (if you use both 1.1 and 2.0 is generally the only
time this is a problem).

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA
http://gregorybeamer.spaces.live.com

*************************************************
Think outside of the box!
*************************************************
"tshad" <ts**********@ftsolutions.comwrote in message
news:um****************@TK2MSFTNGP03.phx.gbl...
>I am trying to use my IIS web server on my local machine for testing my web
site.

The problem is that periodically it will not use the virtual directory for
the root.

This happens for my logon page, for instance.

If I have the following Virtual Directory: Staff.

I would call this by using http://localhost/Staff/default.aspx.

This works fine most of the time. But if I tried to uset
http://localhost/Staff/App/page.aspx, I get a 404 error. You need to log
on to get to this page, so the program works as expected and calls my
Logon page, but it calls it without the Virtual Directory - even though
the Virtual Directory is in the ReturnURL parameter:

http://localhost/App/EELogin.aspx?Re...pp%2fpage.aspx

It should be:

http://localhost/Staff/App/EELogin.a...pp%2fpage.aspx

As I said it works for other things that start from the root, such as my
images and buttons (/images/button.jpg for example).

Why doesn't it use the Virtual Directory for this case?

Thanks,

Tom

Sep 29 '06 #2

P: n/a
"Cowboy (Gregory A. Beamer)" <No************@comcast.netNoSpamMwrote in
message news:es**************@TK2MSFTNGP05.phx.gbl...
Is the virtual directory set up as an application in IIS. To check, go to
the property pages. If you see Create, it is not. If you see Remove, it
is. If not, create it. If you still have problems, make sure it is in the
correct Application pool (if you use both 1.1 and 2.0 is generally the
only time this is a problem).
It is set as an application (has the Remove button)

I don't have 2.0 loaded on my machine. I am running an XP Professional.

Most of the stuff works fine but the logon page is causing the problem. I
also have another post where the Logon page is also having a problem with my
SSL page. If I hit a link in my email that goes to a secure page and the
Logon gets called, it says it can't open the page. Works fine if I leave
the https and port out or if I go to a page that doesn't require a logon.
It seems my 2 problems may be related.

I have my Logon page in my web.config set as:
<authentication mode="Forms">
<forms name="staffing"
loginUrl="/appl/EELogin.aspx"
timeout="400"
protection="All"
path="/" />

Not sure if this is the problem but since both of my issues seem to involve
the Logon page I assume there is something wrong with the setup.

Thanks,

Tom
>
--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA
http://gregorybeamer.spaces.live.com

*************************************************
Think outside of the box!
*************************************************
"tshad" <ts**********@ftsolutions.comwrote in message
news:um****************@TK2MSFTNGP03.phx.gbl...
>>I am trying to use my IIS web server on my local machine for testing my
web site.

The problem is that periodically it will not use the virtual directory
for the root.

This happens for my logon page, for instance.

If I have the following Virtual Directory: Staff.

I would call this by using http://localhost/Staff/default.aspx.

This works fine most of the time. But if I tried to uset
http://localhost/Staff/App/page.aspx, I get a 404 error. You need to log
on to get to this page, so the program works as expected and calls my
Logon page, but it calls it without the Virtual Directory - even though
the Virtual Directory is in the ReturnURL parameter:

http://localhost/App/EELogin.aspx?Re...pp%2fpage.aspx

It should be:

http://localhost/Staff/App/EELogin.a...pp%2fpage.aspx

As I said it works for other things that start from the root, such as my
images and buttons (/images/button.jpg for example).

Why doesn't it use the Virtual Directory for this case?

Thanks,

Tom


Sep 29 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.