By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,115 Members | 898 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,115 IT Pros & Developers. It's quick & easy.

method or property is not available because a document window is not active.

P: n/a
hi experts,
im doing some staff bween th the aspx + MS Word.chellcheck,
and and which running on my ypc is no problem ( windows xp , activation
by ASPNET ), buts someshow when i try to deploy to server ( windows
2003 ) + IIS 6.0 , hen which giee the error =
Object reference not set to an instance of an object.This method or
property is not available because a document window is not active.

and i have try to configure for the component service, but still
cannot.

from the event viewer which come some error:
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This
security permission can be modified using the Component Services
administrative tool.

and under the windows 2003, activation by NETWORK Service ( not aspnet
)

and the problem is no matter how i add component service ( even
everyone ) , the thing still not allow me to acess the DCOM.

i try many things and chk more info from knowledge base , but still
cannot, so i would like to post this subject here, hope can get some
help.

best rgards

Sep 22 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Start here
http://support.microsoft.com/default...;en-us;Q288367

Regards

John Timney (MVP)
VISIT MY WEBSITE:
http://www.johntimney.com
<ia*****@gmail.comwrote in message
news:11*********************@m73g2000cwd.googlegro ups.com...
hi experts,
im doing some staff bween th the aspx + MS Word.chellcheck,
and and which running on my ypc is no problem ( windows xp , activation
by ASPNET ), buts someshow when i try to deploy to server ( windows
2003 ) + IIS 6.0 , hen which giee the error =
Object reference not set to an instance of an object.This method or
property is not available because a document window is not active.

and i have try to configure for the component service, but still
cannot.

from the event viewer which come some error:
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This
security permission can be modified using the Component Services
administrative tool.

and under the windows 2003, activation by NETWORK Service ( not aspnet
)

and the problem is no matter how i add component service ( even
everyone ) , the thing still not allow me to acess the DCOM.

i try many things and chk more info from knowledge base , but still
cannot, so i would like to post this subject here, hope can get some
help.

best rgards

Sep 22 '06 #2

P: n/a
Hi John,
thanks for ur quick response, i have seen this article
before and also follow the step to do it, but the only one thing
different is i use "remote desktop connection" instead of directly goto
"console" and do the changes for the DCOM setting, so i changed it just
now (using console), but since still the same error, do u think i have
to restart the server ? or any other way that we can test for the DCOM.

here have one more information, when i try my web page ( which calling
the MS word ) , then under the "windows task manager" appear the
"WINWORD.EXE" under the processes tab and the "user name" is "NETWORK
SERVICE" and the event viewer under "system" still give the error.

pls let me know what else information u need , i can provide u ,
many many thanks
John Timney (MVP) wrote:
Start here
http://support.microsoft.com/default...;en-us;Q288367

Regards

John Timney (MVP)
VISIT MY WEBSITE:
http://www.johntimney.com
<ia*****@gmail.comwrote in message
news:11*********************@m73g2000cwd.googlegro ups.com...
hi experts,
im doing some staff bween th the aspx + MS Word.chellcheck,
and and which running on my ypc is no problem ( windows xp , activation
by ASPNET ), buts someshow when i try to deploy to server ( windows
2003 ) + IIS 6.0 , hen which giee the error =
Object reference not set to an instance of an object.This method or
property is not available because a document window is not active.

and i have try to configure for the component service, but still
cannot.

from the event viewer which come some error:
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This
security permission can be modified using the Component Services
administrative tool.

and under the windows 2003, activation by NETWORK Service ( not aspnet
)

and the problem is no matter how i add component service ( even
everyone ) , the thing still not allow me to acess the DCOM.

i try many things and chk more info from knowledge base , but still
cannot, so i would like to post this subject here, hope can get some
help.

best rgards
Sep 22 '06 #3

P: n/a
You may have it configured to run correctly already but that doesn't mean
that you can invoke all of the features of MS word. I dont know if invoking
the spell checker in word may cause a security problem if it tries to invoke
a window on the server for example against an account that has no profile to
launch any desktop processes.

Theres an old example here that also references that micrsoft article you
could take a look at.
http://www.4guysfromrolla.com/webtech/062402-1.shtml

Certainly using remote desktop/console would make no difference to whether
you could set dcom or not. Personally I would not use word like this,a s
its not a server product and will cause you no end of perfromance problems
in the end.

Regards

John Timney (MVP)
VISIT MY WEBSITE:
http://www.johntimney.com

<ia*****@gmail.comwrote in message
news:11**********************@m73g2000cwd.googlegr oups.com...
Hi John,
thanks for ur quick response, i have seen this article
before and also follow the step to do it, but the only one thing
different is i use "remote desktop connection" instead of directly goto
"console" and do the changes for the DCOM setting, so i changed it just
now (using console), but since still the same error, do u think i have
to restart the server ? or any other way that we can test for the DCOM.

here have one more information, when i try my web page ( which calling
the MS word ) , then under the "windows task manager" appear the
"WINWORD.EXE" under the processes tab and the "user name" is "NETWORK
SERVICE" and the event viewer under "system" still give the error.

pls let me know what else information u need , i can provide u ,
many many thanks
John Timney (MVP) wrote:
>Start here
http://support.microsoft.com/default...;en-us;Q288367

Regards

John Timney (MVP)
VISIT MY WEBSITE:
http://www.johntimney.com
<ia*****@gmail.comwrote in message
news:11*********************@m73g2000cwd.googlegr oups.com...
hi experts,
im doing some staff bween th the aspx + MS Word.chellcheck,
and and which running on my ypc is no problem ( windows xp , activation
by ASPNET ), buts someshow when i try to deploy to server ( windows
2003 ) + IIS 6.0 , hen which giee the error =
Object reference not set to an instance of an object.This method or
property is not available because a document window is not active.

and i have try to configure for the component service, but still
cannot.

from the event viewer which come some error:
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This
security permission can be modified using the Component Services
administrative tool.

and under the windows 2003, activation by NETWORK Service ( not aspnet
)

and the problem is no matter how i add component service ( even
everyone ) , the thing still not allow me to acess the DCOM.

i try many things and chk more info from knowledge base , but still
cannot, so i would like to post this subject here, hope can get some
help.

best rgards

Sep 22 '06 #4

P: n/a
Hi john,
i already try again and again to setup the DCOM setting, but still
facing the same problem, now i have few double
1. bcos which give me under the ASPX
< Object reference not set to an instance of an object.This method or
property is not available because a document window is not active. >
And under the event viewer is about the
<
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This
security permission can be modified using the Component Services
administrative tool.>

so , im thinking is really need to use "network service" user to open
the ms word for the first time, bcos i saw some others info which
mention that have invlove with the registry, so is any way we can u the
particular user to open the msword instead of using the windows login
(default), like c:\winword.exe -u "network service" the user to initial
the application.

reference:
http://groups.google.com.sg/group/mi...8d98418cce242e

2. another thing is i even add the "network service" under the
"administrators groups" to make sure the "network service" can go thru
all the application.

3. i have try to use windows 2000, windows xp + office 2003, all are
working fine.

many thanks for ur advise

best regards

John Timney (MVP) wrote:
You may have it configured to run correctly already but that doesn't mean
that you can invoke all of the features of MS word. I dont know if invoking
the spell checker in word may cause a security problem if it tries to invoke
a window on the server for example against an account that has no profile to
launch any desktop processes.

Theres an old example here that also references that micrsoft article you
could take a look at.
http://www.4guysfromrolla.com/webtech/062402-1.shtml

Certainly using remote desktop/console would make no difference to whether
you could set dcom or not. Personally I would not use word like this,a s
its not a server product and will cause you no end of perfromance problems
in the end.

Regards

John Timney (MVP)
VISIT MY WEBSITE:
http://www.johntimney.com

<ia*****@gmail.comwrote in message
news:11**********************@m73g2000cwd.googlegr oups.com...
Hi John,
thanks for ur quick response, i have seen this article
before and also follow the step to do it, but the only one thing
different is i use "remote desktop connection" instead of directly goto
"console" and do the changes for the DCOM setting, so i changed it just
now (using console), but since still the same error, do u think i have
to restart the server ? or any other way that we can test for the DCOM.

here have one more information, when i try my web page ( which calling
the MS word ) , then under the "windows task manager" appear the
"WINWORD.EXE" under the processes tab and the "user name" is "NETWORK
SERVICE" and the event viewer under "system" still give the error.

pls let me know what else information u need , i can provide u ,
many many thanks
John Timney (MVP) wrote:
Start here
http://support.microsoft.com/default...;en-us;Q288367

Regards

John Timney (MVP)
VISIT MY WEBSITE:
http://www.johntimney.com
<ia*****@gmail.comwrote in message
news:11*********************@m73g2000cwd.googlegro ups.com...
hi experts,
im doing some staff bween th the aspx + MS Word.chellcheck,
and and which running on my ypc is no problem ( windows xp , activation
by ASPNET ), buts someshow when i try to deploy to server ( windows
2003 ) + IIS 6.0 , hen which giee the error =
Object reference not set to an instance of an object.This method or
property is not available because a document window is not active.

and i have try to configure for the component service, but still
cannot.

from the event viewer which come some error:
The machine-default permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This
security permission can be modified using the Component Services
administrative tool.

and under the windows 2003, activation by NETWORK Service ( not aspnet
)

and the problem is no matter how i add component service ( even
everyone ) , the thing still not allow me to acess the DCOM.

i try many things and chk more info from knowledge base , but still
cannot, so i would like to post this subject here, hope can get some
help.

best rgards
Sep 25 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.