By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,925 Members | 732 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,925 IT Pros & Developers. It's quick & easy.

Webparts dll?

P: n/a
Hello,

I'd like to know which dll I have to reference when I use the
System.Web.UI.WebControls.Webparts namespace.

Thanks,

Brian

Sep 19 '06 #1
Share this Question
Share on Google+
6 Replies


P: n/a
re:
System.Web.UI.WebControls.Webparts
It's its own namespace:
http://quickstarts.asp.net/QuickStar...trols.WebParts

....and it resides in System.Web


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<br************@hotmail.comwrote in message
news:11**********************@e3g2000cwe.googlegro ups.com...
Hello,

I'd like to know which dll I have to reference when I use the
System.Web.UI.WebControls.Webparts namespace.

Thanks,

Brian

Sep 19 '06 #2

P: n/a
I should have specified that it's in system.web.dll

btw, VS 2005's Object Browser is great for finding out
in which dll a namespace resides.

Just search for the namespace and then highlight its container.

In this case, searching for System.Web.UI.WebControls.Webparts returns:

namespace System.Web.UI.WebControls.WebParts
Member of System.Web

Then, highlighting System.Web returns :

Assembly System.Web
Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\ System.Web.dll

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:u2**************@TK2MSFTNGP04.phx.gbl...
re:
>System.Web.UI.WebControls.Webparts

It's its own namespace:
http://quickstarts.asp.net/QuickStar...trols.WebParts

...and it resides in System.Web


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<br************@hotmail.comwrote in message
news:11**********************@e3g2000cwe.googlegro ups.com...
>Hello,

I'd like to know which dll I have to reference when I use the
System.Web.UI.WebControls.Webparts namespace.

Thanks,

Brian


Sep 19 '06 #3

P: n/a
Hello,

Thanks for your quick response Juan!

Adding the system.web.dll to the project doesn't allow me to use the
".Webparts" namespace, it works until "System.Web.UI.WebControls", but
after ".WebControls" nothing appears, do you know why is this
happening?

Thanks again,

Brian

Sep 19 '06 #4

P: n/a
Hello,
>
Thanks for your quick response Juan!

Adding the system.web.dll to the project doesn't allow me to use the
".Webparts" namespace, it works until "System.Web.UI.WebControls", but
after ".WebControls" nothing appears, do you know why is this
happening?

Thanks again,

Brian
What version of the framework are you using? v1.1 didn't have WebParts
yet.
The version is that "v2.0.50727" part in the dll-path Juan's reply.

Hans Kesting
Sep 19 '06 #5

P: n/a
Ohh that's why then!

Thanks very much,

Brian

Sep 19 '06 #6

P: n/a
re:
What version of the framework are you using? v1.1 didn't have WebParts yet.
The version is that "v2.0.50727" part in the dll-path Juan's reply.
Thanks, Hans.
I should have made that clear.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Hans Kesting" <ne***********@spamgourmet.comwrote in message
news:mn***********************@spamgourmet.com...
>Hello,

Thanks for your quick response Juan!

Adding the system.web.dll to the project doesn't allow me to use the
".Webparts" namespace, it works until "System.Web.UI.WebControls", but
after ".WebControls" nothing appears, do you know why is this
happening?

Thanks again,

Brian

What version of the framework are you using? v1.1 didn't have WebParts yet.
The version is that "v2.0.50727" part in the dll-path Juan's reply.

Hans Kesting


Sep 19 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.