By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,652 Members | 1,694 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,652 IT Pros & Developers. It's quick & easy.

Compile on demand "cannot execute a program"

P: n/a
I have a .net v2 problem.
I develop on my workstation and deploy to a production server.
I use compile on demand, so no pre-compile is done.
When I deploy, I first must move in my new or changed pages.
Then I must restart IIS. After that, everything is good, and I run
for weeks without problems. If something should cause a
compile ( like making a change to one of the pages and then
requesting the page), the following error will (usually)occur:
Cannot execute a program.
The command being executed was
"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\vbc .exe..."

I have found several cases on the web of people having this
problem, and a few suggestions like "check lockdown tool"
configuration, and firewalls, and anti-virus settings. I have not
found any references to anyone actually fixing this problem.
It is really bugging me. The effect is shutting down the application
until I can restart IIS after hours.
I would like to get this to work rather than switching to the pre-compile

I would like suggestions on how I can figure this thing out and fix it.

The production server has asp, .net 1.1 and .net 2.0 running in seperate
application pools. There are probably 30 asp sites, 4
running on the server. I am the application guy, not the systems guy,
so I don't have a lot of expertise with authority issues.

Also, note that on the weekend, I frequently make changes and try to
check them out without restarting IIS, and I can do it probably
40% of the time without an error. But once I hit an error, it won't go
until I restart IIS.

I don't have much hair left.....

Sep 6 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.