By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,583 Members | 1,109 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,583 IT Pros & Developers. It's quick & easy.

Multiview + Infragistics maskinput controls +

P: n/a
Hi,

I want to create an asp.net page with a tabpage. On the tabpage I want
to use the WebDateChooser and WebDataInput controls of Infragistics.
These 2 controls use a mask to enter a date and bankaccountnummber, so
that no invalid date or bankaccountnumber can be inputted.

I started out with the tabcontrol of infragistics. But I also want to
use the atlas update panel, and this gives conflicts when used together
with the infragistics tabcontrol. It's no option to get rid of the
atlas updatepanel, so I started looking for an alternative tabcontrol
that works correctly when used with an atlas updatepanel.

Then I came along some guy's webpage where he created his own
tabcontrol with the asp.net multiview and the atlas updatepanel
(http://geekswithblogs.net/stevecleme...27/89438.aspx).
I added some functionality so that I'm able to set some tabs to visible
and invisible at runtime. I also changed the style so that the flicker
on the tabs is gone (background color instead of background images) and
so that it fits in with the rest of the pages. This works great.

Only one problem. On tab 1, there are the Infragistics WebDateChooser
control and WebDataInput control. When filling in correct values (an
existing date and an existing bankaccountnumber), then switching to
tab2, then switching back to tab 1, then the values are still there. If
I switch once more to tab2 and then back to tab1, the values are gone
and replaced by the default values of the controls. The WebDateChooser
control even looses its mask, so that all of a sudden I'm able to fill
in incorrect dates.

I managed to reproduce the problem when putting these 2 controls on the
first view of a multiview: (a) I use 2 buttons to switch from view1 to
view2 and back:

<%@ Register Assembly="Infragistics2.WebUI.WebDataInput.v6.2,
Version=6.2.20062.34, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"
Namespace="Infragistics.WebUI.WebDataInput" TagPrefix="igtxt" %>
<%@ Register Assembly="Infragistics2.WebUI.WebDateChooser.v6.2,
Version=6.2.20062.34, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"
Namespace="Infragistics.WebUI.WebSchedule" TagPrefix="igsch" %>

<asp:MultiView ID="MultiViewContent" runat="server" ActiveViewIndex="0"
Visible="true">
<asp:View ID="View1" runat="server">
<igtxt:WebDateTimeEdit ID="dateMatrimonialDate" runat="server"
Nullable="true" DataMode="DateOrNull" />
<br />
<igtxt:WebMaskEdit ID="txtBankAccount" runat="server"
DataMode="RawText" DisplayMode="Mask" InputMask="000-0000000-00"
PadChar="0" />
</asp:View>
<asp:View ID="View2" runat="server">
<asp:Label ID="someLabel" Text="Content of View 2"
runat="server" />
</asp:View>
</asp:MultiView>

<br />
<asp:Button runat="server" ID="BtnToView1" Text="To view1"
OnClick="BtnToView1_Click" />
<asp:Button runat="server" ID="BtnToView2" Text="to view2"
OnClick="BtnToView2_Click" />

and in the code:

protected void BtnToView1_Click(object sender, EventArgs e)
{
MultiViewContent.ActiveViewIndex = 0;
}

protected void BtnToView2_Click(object sender, EventArgs e)
{
MultiViewContent.ActiveViewIndex = 1;
}

works great, the values are preserved and the mask of the
WebDateChooser control stays intact.

(b) Then I put an atlas update panel around everything and the buggy
behaviour as described above starts.

So I'm sort of looking for mask input controls (date,
bankaccountnummer) for asp.net 2.0 that are compatible with the atlas
update panel.

Veerle

Sep 5 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.