469,623 Members | 993 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,623 developers. It's quick & easy.

Timeout on web page is too short, changing web.config seems to have no affect

I made the following change to my web.config file (see fragment below) but
does not seem to affect the timeout on my web page. I have a huge session
state but since I'm the only one using it, I'd like to set the timeout to
infiinity. How can I do this?
Thanks,
Siegfried
<sessionState mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data
source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="2000"
/>
Aug 9 '06 #1
2 2158
Is it the timeout on the page that is the issue, or timeout on your
connection and/or command objects? In general, timeout problems are database
timeouts and not page timeouts. If that is the case, you should look at the
database objects or, preferably, tune the database.

If this is truly session timeout, you have to leave the machine on all the
time and never turn it off. In addition, you have to ensure the worker
process never reboots (which can be dangerous).

What is the reason for permanent session? You are storing things in session?
Okay, make an object and check it on each page hit. If null (session timeoed
out), rebuild it. Easy solution that only builds the object when necessary
and does not require eternal session state.
--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

*************************************************
Think Outside the Box!
*************************************************
"Siegfried Heintze" <si*******@heintze.comwrote in message
news:e6**************@TK2MSFTNGP06.phx.gbl...
>I made the following change to my web.config file (see fragment below) but
does not seem to affect the timeout on my web page. I have a huge session
state but since I'm the only one using it, I'd like to set the timeout to
infiinity. How can I do this?
Thanks,
Siegfried
<sessionState mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data
source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="2000"
/>


Aug 10 '06 #2
You can also use the StateService to store the session state in that
way when the worker process is reset your data in session will not be
affected.

1Start the State Service from Control Panel -Services ->
StateService
2Changes the web.config to:

<sessionState mode="StateServer"
stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data

source=127.0.0.1;Trusted_Connection=yes" cookieless="false"
timeout="2000"
/>

msnews.microsoft.com wrote:
Is it the timeout on the page that is the issue, or timeout on your
connection and/or command objects? In general, timeout problems are database
timeouts and not page timeouts. If that is the case, you should look at the
database objects or, preferably, tune the database.

If this is truly session timeout, you have to leave the machine on all the
time and never turn it off. In addition, you have to ensure the worker
process never reboots (which can be dangerous).

What is the reason for permanent session? You are storing things in session?
Okay, make an object and check it on each page hit. If null (session timeoed
out), rebuild it. Easy solution that only builds the object when necessary
and does not require eternal session state.
--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

*************************************************
Think Outside the Box!
*************************************************
"Siegfried Heintze" <si*******@heintze.comwrote in message
news:e6**************@TK2MSFTNGP06.phx.gbl...
I made the following change to my web.config file (see fragment below) but
does not seem to affect the timeout on my web page. I have a huge session
state but since I'm the only one using it, I'd like to set the timeout to
infiinity. How can I do this?
Thanks,
Siegfried
<sessionState mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data
source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="2000"
/>
Aug 10 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

8 posts views Thread by Shalini | last post: by
8 posts views Thread by bdeviled | last post: by
10 posts views Thread by greenb | last post: by
3 posts views Thread by Adam Short | last post: by
6 posts views Thread by scottyman | last post: by
1 post views Thread by Siegfried Heintze | last post: by
1 post views Thread by Annie | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.