By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,939 Members | 1,600 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,939 IT Pros & Developers. It's quick & easy.

Deploy web app from VS ExpressEdition to production server? Is it possible ...

P: n/a
ivo
Hi everyone

I am having trouble with deploying VS 2005 Express Edition web app to
real server on the net.

Since VS 2005 ExpressEdition is free - is it for that reason unpossible
to do deployment ...

What do I need to copy to remote server ...

Thank you

Jul 23 '06 #1
Share this Question
Share on Google+
7 Replies


P: n/a
You shouldn't have a problem deploying the site.

Try copying all the files and folders to the server and see what happens?

"ivo" <iv**********@bj.htnet.hrwrote in message
news:11*********************@m73g2000cwd.googlegro ups.com...
Hi everyone

I am having trouble with deploying VS 2005 Express Edition web app to
real server on the net.

Since VS 2005 ExpressEdition is free - is it for that reason unpossible
to do deployment ...

What do I need to copy to remote server ...

Thank you

Jul 23 '06 #2

P: n/a
ivo
Hi

Maybe I am missing something ... here is link:
http://www.bet-live.ba/x_test/Default.aspx
I am moving 3 files to x_temp server directory ... I have a feeling
there are more files needed to be copied ... but for now I copy these 3
(this is hello world example)

1. Default.aspx
2. Default.aspx.cs
3. Web.Config

Does anybody have a clue what might be wrong here?!?

Thank you for help!
:-)

Greetings

---------------
And here is content of all 3 files:

--------------
Default.aspx
--------------
<%@ Page Language="C#" AutoEventWireup="true"
CodeFile="Default.aspx.cs" Inherits="_Default" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
<title>Untitled Page</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" runat="server"
Text="Label"></asp:Label></div>
</form>
</body>
</html>
--------------
Default.aspx.cs
--------------
using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;

public partial class _Default : System.Web.UI.Page
{
protected void Page_Load(object sender, EventArgs e)
{
this.Label1.Text = System.DateTime.Now.ToLongTimeString();
}
}

-------------
Web.Config
I did one change here ... <compilation debug="true"/to <compilation
debug="false"/>
-------------

<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<appSettings/>
<connectionStrings/>
<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="false"/>
<!--
The <authenticationsection enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<!--
The <customErrorssection enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
</configuration>

Jul 24 '06 #3

P: n/a
In your web.config file, make sure customErrors is set like this:

<customErrors mode="Off"/>

and upload it to the server again?

That way, we can see what's not working..

Ken
"ivo" <iv**********@bj.htnet.hrwrote in message
news:11**********************@p79g2000cwp.googlegr oups.com...
Hi

Maybe I am missing something ... here is link:
http://www.bet-live.ba/x_test/Default.aspx
I am moving 3 files to x_temp server directory ... I have a feeling
there are more files needed to be copied ... but for now I copy these 3
(this is hello world example)

1. Default.aspx
2. Default.aspx.cs
3. Web.Config

Does anybody have a clue what might be wrong here?!?

Thank you for help!
:-)

Greetings

---------------
And here is content of all 3 files:

--------------
Default.aspx
--------------
<%@ Page Language="C#" AutoEventWireup="true"
CodeFile="Default.aspx.cs" Inherits="_Default" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
<title>Untitled Page</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" runat="server"
Text="Label"></asp:Label></div>
</form>
</body>
</html>
--------------
Default.aspx.cs
--------------
using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;

public partial class _Default : System.Web.UI.Page
{
protected void Page_Load(object sender, EventArgs e)
{
this.Label1.Text = System.DateTime.Now.ToLongTimeString();
}
}

-------------
Web.Config
I did one change here ... <compilation debug="true"/to <compilation
debug="false"/>
-------------

<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<appSettings/>
<connectionStrings/>
<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="false"/>
<!--
The <authenticationsection enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<!--
The <customErrorssection enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
</configuration>

Jul 24 '06 #4

P: n/a
ivo
Hi

I did it like this ... still same result ...
:-|

Added extra tag ... with atribute mode set to "Off"

<customErrors mode="Off"/>

However, I am wondering ... could it be possible that .Net 1.1
Framework causes this error ... if I try to run 2.0 app ...

Cheers
Ivan
--------------------
Here is new Web.Config

<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<appSettings/>
<connectionStrings/>
<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="false"/>
<!--
The <authenticationsection enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<customErrors mode="Off"/>
<!--
The <customErrorssection enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
</configuration>

Jul 24 '06 #5

P: n/a
You have to be running .NET 2.0 for the Web if your code is for 2.0.

"ivo" <iv**********@bj.htnet.hrwrote in message
news:11**********************@p79g2000cwp.googlegr oups.com...
Hi

I did it like this ... still same result ...
:-|

Added extra tag ... with atribute mode set to "Off"

<customErrors mode="Off"/>

However, I am wondering ... could it be possible that .Net 1.1
Framework causes this error ... if I try to run 2.0 app ...

Cheers
Ivan
--------------------
Here is new Web.Config

<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<appSettings/>
<connectionStrings/>
<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="false"/>
<!--
The <authenticationsection enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<customErrors mode="Off"/>
<!--
The <customErrorssection enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
</configuration>

Jul 24 '06 #6

P: n/a
ivo
:-)

I know ...

But I dont have clear info on .Net version ... still waiting for
hosting company to tell me what version is running ...

http://www.utic-hosting.ba/bos/hosti...ex.php?paket=5

They state that ASP.NET is running ... but no version info ...

I saw that hosting company is also using aspx pages ...
https://winhost1.utic.net.ba/admin/l...2fDefault.aspx

So I took a peek to HTML source ...
.... to see is there any "signature" of .Net 2.0 or 1.1 ...

And this is what I have found ...
:
<meta name="GENERATOR" Content="Microsoft Visual Studio 7.0">
:

This 7.0 would be VS 2003 (I have 8.0 for VS 2005) ... and it looks
like (to my missfortune) probably .Net Fw 1.1 is running ...

Thanks for help ...

Much appreciated!
:-)

Cheers
Ivan

Jul 24 '06 #7

P: n/a
ivo
Just used free hosting
http://imarenic-1.at.vwdhosting.net/

and it works just fine ...

Old framework made problems ...

Thank you for help!

:-)

Jul 24 '06 #8

This discussion thread is closed

Replies have been disabled for this discussion.