469,643 Members | 1,243 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,643 developers. It's quick & easy.

install packages in .net

hi, am new to install packages in .net. i have a couple of questions
1) well i need to develop an install package for my existing web
application written in asp.net. i used the settings and deployment
option available in .net and created my install package in release
mode. i got the setup.exe and the .msi file created. after installing
it in a remote system, when i access it using the internet explorer . i
get the opening page which is a .asp page . now when i try to access a
..aspx page it displays configuration error ...

Configuration Error
Description: An error occurred during the processing of a configuration
file required to service this request. Please review the specific error
details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.

Source Error:
Line 26: "Forms", "Passport" and "None"
Line 27: -->
Line 28: <authentication mode="Windows" />
Line 29:
Line 30: <!-- AUTHORIZATION
can any one suggest me a solution??? i don understand y its behaves
like this only when i try to access a .aspx page.

2) when you try to create an install package for a web application is
the result/output always a .msi file??? or is there any other facility
to create an install package in .net???
regards
ck

Jul 11 '06 #1
1 1290
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.
Try this:
Load up internet services manager in administrative tools
locate the directory you have installed to under the appropriate web site
Ricght click it and select properties and navigate to the 'Directory' (or
home directory) tab.
Under 'Application settings' click Create.
Change execute permissions to scripts only

See if that works.
Jul 11 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by John Hunter | last post: by
1 post views Thread by Peter Hartmann | last post: by
1 post views Thread by Peter Hartmann | last post: by
4 posts views Thread by Fabian Braennstroem | last post: by
2 posts views Thread by jhalaseh | last post: by
3 posts views Thread by TonyHa | last post: by
3 posts views Thread by Anthony Smith | last post: by
1 post views Thread by Gabriel Genellina | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.