468,766 Members | 1,309 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,766 developers. It's quick & easy.

Embedding "customcontrol" inside "webusercontrol"

Hi,

I am trying to use a "customcontrol" inside a "webusercontrol" but
facing problem with the viewstate of the "customcontrol".

When I use the "customcontrol" on a page either adding it statically or
dynamically, it works fine. There is no problem with the ViewState.
Also when I use this "customcontrol" inside another "customcontrol"
there is no problem with the ViewState.

Problem arises only when I embed this "customcontrol" inside a
"webusercontrol". While debugging I found that the
"createcustomcontrols" function is not being called on postback in this
scenario. In all others scenarios this function is called.

Am I doing something wrong here or is it not possible to use custom
control in that way?

Any pointers or suggestions will be appreciated.

Thanks & Regards,
Angrez

Jun 30 '06 #1
0 940

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Alicia Haumann | last post: by
reply views Thread by Sebastien Aubry | last post: by
5 posts views Thread by Victor Fees | last post: by
reply views Thread by Stu Smith | last post: by
11 posts views Thread by Anna | last post: by
2 posts views Thread by Raghavendran Muraleetharan | last post: by
6 posts views Thread by mistabean | last post: by
reply views Thread by nbancajas | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by Marin | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.