By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,070 Members | 1,718 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,070 IT Pros & Developers. It's quick & easy.

Deploying .NET 2.0 Web App from WinXP Pro to Server 2003: 404!

P: n/a
Hi there:

I'm a veteran to ASP.NET 1.1, but new to 2.0, and I'm using VS 2005. When I
run the app on my local machine, using the built-in Web server, I have no
problems, but deploying the site to a 2003 Server machine (which is also
running several 1.1 sites) throws a persistent 404.

I've looked around and found several references to the app_offline file, for
which I've searched exhaustively and found nothing. I'm essentially running
a blank "Hello World" type site here, nothing fancy, just for purposes of
messing around with 2.0, and I cannot get anything to work. And Wrox's
Professional ASP.NET has been pretty much no help whatsoever.

The site's set up as its own site in IIS (not a virtual underneath something
else), it's using a new App Pool I set up just to keep the 2.0 stuff
separated from everything else, and in the ASP.NET tab, I've got 2.0
selected. What could be happening here? Is there some additional
requirement (i.e., having SQL 2005 Express installed -- this machine already
has SQL Server 2000) that I've missed somewhere in the documentation?

Any help would be greatly appreciated.

Thanks,
Chris
Jun 29 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Have you explicitly enabled ASP.NET 2.0 pages to be served ?

W2K3 needs specific permissions be enabled, in order to allow each ASP.NET version to run.

Open the IIS Manager, scroll on the left to "Web Service Extensions",
select that, go to the right pane and select the ASP.NET version you
want to enable and click the "Allow" button.

Repeat the sequence for all versions of ASP.NET you want to enable.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Christian Nunciato" <Ch***************@discussions.microsoft.com> wrote in message
news:1E**********************************@microsof t.com...
Hi there:

I'm a veteran to ASP.NET 1.1, but new to 2.0, and I'm using VS 2005. When I
run the app on my local machine, using the built-in Web server, I have no
problems, but deploying the site to a 2003 Server machine (which is also
running several 1.1 sites) throws a persistent 404.

I've looked around and found several references to the app_offline file, for
which I've searched exhaustively and found nothing. I'm essentially running
a blank "Hello World" type site here, nothing fancy, just for purposes of
messing around with 2.0, and I cannot get anything to work. And Wrox's
Professional ASP.NET has been pretty much no help whatsoever.

The site's set up as its own site in IIS (not a virtual underneath something
else), it's using a new App Pool I set up just to keep the 2.0 stuff
separated from everything else, and in the ASP.NET tab, I've got 2.0
selected. What could be happening here? Is there some additional
requirement (i.e., having SQL 2005 Express installed -- this machine already
has SQL Server 2000) that I've missed somewhere in the documentation?

Any help would be greatly appreciated.

Thanks,
Chris


Jun 29 '06 #2

P: n/a
Hi Juan:

Thanks much. In the Web Service Extensions node, I see ASP and ASP 1.1, but
not ASP 2.0. When I manually add the ASP.NET 2.0 DLL to the list and allow
it, then try running the page, I get a different error:

The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write
access to 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Tem porary ASP.NET
Files'.

If I try adding NETWORK SERVICE as a user on that folder, Windows complains
and suggests I don't do so. I don't mind adding these things manually, but
the absence of ASP.NET 2.0 in the Web Service Extensions node suggests
something might not have been installed properly.

What should I do?

Thanks much!
Chris

"Juan T. Llibre" wrote:
Have you explicitly enabled ASP.NET 2.0 pages to be served ?

W2K3 needs specific permissions be enabled, in order to allow each ASP.NET version to run.

Open the IIS Manager, scroll on the left to "Web Service Extensions",
select that, go to the right pane and select the ASP.NET version you
want to enable and click the "Allow" button.

Repeat the sequence for all versions of ASP.NET you want to enable.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Christian Nunciato" <Ch***************@discussions.microsoft.com> wrote in message
news:1E**********************************@microsof t.com...
Hi there:

I'm a veteran to ASP.NET 1.1, but new to 2.0, and I'm using VS 2005. When I
run the app on my local machine, using the built-in Web server, I have no
problems, but deploying the site to a 2003 Server machine (which is also
running several 1.1 sites) throws a persistent 404.

I've looked around and found several references to the app_offline file, for
which I've searched exhaustively and found nothing. I'm essentially running
a blank "Hello World" type site here, nothing fancy, just for purposes of
messing around with 2.0, and I cannot get anything to work. And Wrox's
Professional ASP.NET has been pretty much no help whatsoever.

The site's set up as its own site in IIS (not a virtual underneath something
else), it's using a new App Pool I set up just to keep the 2.0 stuff
separated from everything else, and in the ASP.NET tab, I've got 2.0
selected. What could be happening here? Is there some additional
requirement (i.e., having SQL 2005 Express installed -- this machine already
has SQL Server 2000) that I've missed somewhere in the documentation?

Any help would be greatly appreciated.

Thanks,
Chris


Jun 29 '06 #3

P: n/a
re:
If I try adding NETWORK SERVICE as a user on that folder,
Windows complains and suggests I don't do so.
You can safely ignore that...but you'll have to WRITE in the account name.
You CANNOT *select* the account from the account list...or Windows complains.

Alternately, run the following command from the .Net Framework 2.0 folder
( Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) :

aspnet_regiis -ga machinename\network service

That will give all the necessary permissions to all the directories ASP.NET needs.

See :
http://msdn.microsoft.com/library/de...aght000009.asp
for background info.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Christian Nunciato" <Ch***************@discussions.microsoft.com> wrote in message
news:62**********************************@microsof t.com... Hi Juan:

Thanks much. In the Web Service Extensions node, I see ASP and ASP 1.1, but
not ASP 2.0. When I manually add the ASP.NET 2.0 DLL to the list and allow
it, then try running the page, I get a different error:

The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write
access to 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Tem porary ASP.NET
Files'.

If I try adding NETWORK SERVICE as a user on that folder, Windows complains
and suggests I don't do so. I don't mind adding these things manually, but
the absence of ASP.NET 2.0 in the Web Service Extensions node suggests
something might not have been installed properly.

What should I do?

Thanks much!
Chris

"Juan T. Llibre" wrote:
Have you explicitly enabled ASP.NET 2.0 pages to be served ?

W2K3 needs specific permissions be enabled, in order to allow each ASP.NET version to run.

Open the IIS Manager, scroll on the left to "Web Service Extensions",
select that, go to the right pane and select the ASP.NET version you
want to enable and click the "Allow" button.

Repeat the sequence for all versions of ASP.NET you want to enable.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Christian Nunciato" <Ch***************@discussions.microsoft.com> wrote in message
news:1E**********************************@microsof t.com...
> Hi there:
>
> I'm a veteran to ASP.NET 1.1, but new to 2.0, and I'm using VS 2005. When I
> run the app on my local machine, using the built-in Web server, I have no
> problems, but deploying the site to a 2003 Server machine (which is also
> running several 1.1 sites) throws a persistent 404.
>
> I've looked around and found several references to the app_offline file, for
> which I've searched exhaustively and found nothing. I'm essentially running
> a blank "Hello World" type site here, nothing fancy, just for purposes of
> messing around with 2.0, and I cannot get anything to work. And Wrox's
> Professional ASP.NET has been pretty much no help whatsoever.
>
> The site's set up as its own site in IIS (not a virtual underneath something
> else), it's using a new App Pool I set up just to keep the 2.0 stuff
> separated from everything else, and in the ASP.NET tab, I've got 2.0
> selected. What could be happening here? Is there some additional
> requirement (i.e., having SQL 2005 Express installed -- this machine already
> has SQL Server 2000) that I've missed somewhere in the documentation?
>
> Any help would be greatly appreciated.
>
> Thanks,
> Chris


Jun 29 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.