By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,805 Members | 1,273 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,805 IT Pros & Developers. It's quick & easy.

Unable to Deploy ASP.Net 2.0 App to Local IIS

P: n/a
All,
Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1

Problem:
Apps developed (even simple "Hello WOrld") apps simply won't deploy properly
to either my local IIS instance or to a 2nd server W2003K server.

When I publish, create them as IIS apps, or copy, even after running
both/either the ASP2.) security tab or the web admin (asp based) manager
they will not enable properly.

I have:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS
- Turned off/uninstalled firewall, and Windows Defender
- Read the even log
- Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
- Re reged ASP with aspnet_regiis
- Unistalled and re-installed IIS services
- etc...

App run fine with the built in Cassini server but won't deploy, won't run,
etc...any other way. I always get a 403 (Access forbidden or 500 unknown)
error.

I have also tried hand-copying and setting permissions for anonymous
manually....also does not work....
Not sure where else to turn....
I am starting to think that ASP in VS2005 is absolute rubbish....

cheers,
t

Jun 24 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Forgot to mention I've also:
- Done a full Windows Update
- Full VS2005 repair

Is it my instance of IIS? VS2005? An ASP.Net set-up issue? Issues with XP
Media Center?

This is the most difficulty I've had with any variant of VS, IIS or
ASP...and I have been using all since ASP first released....

thx again
"Tim Brooks" <us****@msn.com> wrote in message
news:OC***************@TK2MSFTNGP02.phx.gbl...
All,
Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1

Problem:
Apps developed (even simple "Hello WOrld") apps simply won't deploy
properly to either my local IIS instance or to a 2nd server W2003K server.

When I publish, create them as IIS apps, or copy, even after running
both/either the ASP2.) security tab or the web admin (asp based) manager
they will not enable properly.

I have:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS
- Turned off/uninstalled firewall, and Windows Defender
- Read the even log
- Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
- Re reged ASP with aspnet_regiis
- Unistalled and re-installed IIS services
- etc...

App run fine with the built in Cassini server but won't deploy, won't run,
etc...any other way. I always get a 403 (Access forbidden or 500 unknown)
error.

I have also tried hand-copying and setting permissions for anonymous
manually....also does not work....
Not sure where else to turn....
I am starting to think that ASP in VS2005 is absolute rubbish....

cheers,
t

Jun 24 '06 #2

P: n/a
re:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS
Unless you've configured impersonation for the IUSR_ANONYMOUS account,
you are giving permissions to the wrong account.

Under XP, ASP.NET runs as the "MachineName\ASPNET" account.
Under W2K3, ASP.NET runs as the "MachineName\Network Service" account.

Give access permissions to the correct account.

Also, under W2K3, you need to explicitly enable ASP.NET 2.0.

Open the IIS Manager, scroll on the left to "Web Service Extensions",
select that, go to the right pane and select the ASP.NET version you
want to enable and click the "Allow" button.

Repeat the sequence for all versions of ASP.NET you want to enable.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Tim Brooks" <us****@msn.com> wrote in message news:OC***************@TK2MSFTNGP02.phx.gbl... All,
Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1

Problem:
Apps developed (even simple "Hello WOrld") apps simply won't deploy properly to either my local
IIS instance or to a 2nd server W2003K server.

When I publish, create them as IIS apps, or copy, even after running both/either the ASP2.)
security tab or the web admin (asp based) manager they will not enable properly.

I have:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS
- Turned off/uninstalled firewall, and Windows Defender
- Read the even log
- Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
- Re reged ASP with aspnet_regiis
- Unistalled and re-installed IIS services
- etc...

App run fine with the built in Cassini server but won't deploy, won't run, etc...any other way. I
always get a 403 (Access forbidden or 500 unknown) error.

I have also tried hand-copying and setting permissions for anonymous manually....also does not
work....
Not sure where else to turn....
I am starting to think that ASP in VS2005 is absolute rubbish....

cheers,
t

Jun 25 '06 #3

P: n/a
TAB
Juan,

Thanks for the response. I've since gotten it working and it all seemed to
be because of the OS. I was using a machine that came pre-built with Media
Center and, because VS2005 installed fine and ASP.Net seemed to work (and
the docs said so, too) I assumed that it did.

I have since completely rebuilt the entire machine with XP Pro...and ASP.Net
worked correctly right out of the gate. Even got debugging working, had not
worked previously for ASP.Net projects....

Oh well.....
thanks all...

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ot**************@TK2MSFTNGP05.phx.gbl...
re:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS


Unless you've configured impersonation for the IUSR_ANONYMOUS account,
you are giving permissions to the wrong account.

Under XP, ASP.NET runs as the "MachineName\ASPNET" account.
Under W2K3, ASP.NET runs as the "MachineName\Network Service" account.

Give access permissions to the correct account.

Also, under W2K3, you need to explicitly enable ASP.NET 2.0.

Open the IIS Manager, scroll on the left to "Web Service Extensions",
select that, go to the right pane and select the ASP.NET version you
want to enable and click the "Allow" button.

Repeat the sequence for all versions of ASP.NET you want to enable.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Tim Brooks" <us****@msn.com> wrote in message
news:OC***************@TK2MSFTNGP02.phx.gbl...
All,
Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1

Problem:
Apps developed (even simple "Hello WOrld") apps simply won't deploy
properly to either my local IIS instance or to a 2nd server W2003K
server.

When I publish, create them as IIS apps, or copy, even after running
both/either the ASP2.) security tab or the web admin (asp based) manager
they will not enable properly.

I have:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS
- Turned off/uninstalled firewall, and Windows Defender
- Read the even log
- Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
- Re reged ASP with aspnet_regiis
- Unistalled and re-installed IIS services
- etc...

App run fine with the built in Cassini server but won't deploy, won't
run, etc...any other way. I always get a 403 (Access forbidden or 500
unknown) error.

I have also tried hand-copying and setting permissions for anonymous
manually....also does not work....
Not sure where else to turn....
I am starting to think that ASP in VS2005 is absolute rubbish....

cheers,
t


Jun 26 '06 #4

P: n/a
> I was using a machine that came pre-built with Media Center

Thanks for reporting back on that. It's something to watch for!

Ken
Microsoft MVP [ASP.NET]

"TAB" <ta*@community.nospam.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
Juan,

Thanks for the response. I've since gotten it working and it all seemed
to be because of the OS. I was using a machine that came pre-built with
Media Center and, because VS2005 installed fine and ASP.Net seemed to work
(and the docs said so, too) I assumed that it did.

I have since completely rebuilt the entire machine with XP Pro...and
ASP.Net worked correctly right out of the gate. Even got debugging
working, had not worked previously for ASP.Net projects....

Oh well.....
thanks all...

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ot**************@TK2MSFTNGP05.phx.gbl...
re:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS


Unless you've configured impersonation for the IUSR_ANONYMOUS account,
you are giving permissions to the wrong account.

Under XP, ASP.NET runs as the "MachineName\ASPNET" account.
Under W2K3, ASP.NET runs as the "MachineName\Network Service" account.

Give access permissions to the correct account.

Also, under W2K3, you need to explicitly enable ASP.NET 2.0.

Open the IIS Manager, scroll on the left to "Web Service Extensions",
select that, go to the right pane and select the ASP.NET version you
want to enable and click the "Allow" button.

Repeat the sequence for all versions of ASP.NET you want to enable.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Tim Brooks" <us****@msn.com> wrote in message
news:OC***************@TK2MSFTNGP02.phx.gbl...
All,
Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1

Problem:
Apps developed (even simple "Hello WOrld") apps simply won't deploy
properly to either my local IIS instance or to a 2nd server W2003K
server.

When I publish, create them as IIS apps, or copy, even after running
both/either the ASP2.) security tab or the web admin (asp based) manager
they will not enable properly.

I have:
- Set to anonymous access
- Given permission to IUSR_ANONYMOUS
- Turned off/uninstalled firewall, and Windows Defender
- Read the even log
- Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
- Re reged ASP with aspnet_regiis
- Unistalled and re-installed IIS services
- etc...

App run fine with the built in Cassini server but won't deploy, won't
run, etc...any other way. I always get a 403 (Access forbidden or 500
unknown) error.

I have also tried hand-copying and setting permissions for anonymous
manually....also does not work....
Not sure where else to turn....
I am starting to think that ASP in VS2005 is absolute rubbish....

cheers,
t



Jun 26 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.