470,599 Members | 1,529 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,599 developers. It's quick & easy.

Allow anonymous access to subdirectory

Okay, so I thought this would be easy, but it's not turning out that
way. Let's see how good you guys are! :-)

I have a windows authentication-based Intranet application. An excerpt
from the web.config in the root of the application is as follows:

<authentication mode="Windows" />
<allow roles="mydomain\Domain Users" />
<deny users="*" />
<roleManager enabled="true"
<siteMap defaultProvider="XmlSiteMapProvider" enabled="true">
<add name="XmlSiteMapProvider" description="Default SiteMap provider."
type="System.Web.XmlSiteMapProvider" siteMapFile="Web.sitemap"

Then in the /admin subdirectory, I have this:
<allow roles="mydomain\Admins,mydomain\Developers,mydomai n\Budget
Admins" />
<deny users="*" />
Then in the a subdirectory inside /admin I have /property which has no
web.config and then inside property I have a folder called /external.
I want to grant anonymous users access to this /external directory...
so I added the following web.config to the /external directory:

<allow users="?" />
As for IIS, the root application authentication is integrated windows
authentication. Then for the external directory, I checked only
anonymous. This used to work in asp.net 1.x but now I'm using these
web.configs for security and it now prompts the user to log in.
However, if the user hits cancel, it shows the page. I just want to
prevent the login prompt from showing up.

Thanks in advance!

Jun 20 '06 #1
0 1463

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Kjell Kristiansson | last post: by
3 posts views Thread by David Thielen | last post: by
4 posts views Thread by cashdeskmac | last post: by
1 post views Thread by graphicsxp | last post: by
reply views Thread by =?Utf-8?B?Qm9ubmll?= | last post: by
7 posts views Thread by Fred | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.