By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,280 Members | 2,244 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,280 IT Pros & Developers. It's quick & easy.

Won't read my web.config file!!

P: n/a
Hi,
Trying to troubleshoot a web app. I'm getting the usual "set your
web.config file to customErrors mode="Off"" message.

Anyway, I DO have a web.config file in the root of the app, but it's not
reading it because i DO have customErrors mode=Off

Why won't it use this file!?
Thanks
Jun 20 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
John wrote:
Hi,
Trying to troubleshoot a web app. I'm getting the usual "set your
web.config file to customErrors mode="Off"" message.

Anyway, I DO have a web.config file in the root of the app, but it's not
reading it because i DO have customErrors mode=Off

Why won't it use this file!?
Thanks


Hi John,

this is normally caused when either
1) Your application root is a subdirectory below the wwwroot, and has
not been marked as an application, or,
2) Your application root is a virtual directory haning off of another
directory, and the virtual directory has had application removed, or,
3) (I believe), if the page you're trying to access is within a
subdirectory of the application, and the subdirectory *has* been marked
as an application.

In short, in all 3 cases, IIS is looking for web.config either too high
or too low in your directory structure, and not reading the one you've
been editing.

Damien

Jun 20 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.