By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,910 Members | 1,036 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,910 IT Pros & Developers. It's quick & easy.

Make sure that the class defined in this code file matches the 'inherits' attribute

P: n/a
Hi Gang,

On my development system I am not getting this error, but it does
happen when I upload it to my ISP. Can someone tell me why this is
happening? I don't have any user-defined controls which seems to be
the primary cause. My code is ASP 2.0/VB.

Thanks a bunch,
Christian Blackburn
---------------------------------------------------------------------------------------------------------------------------------------
Server Error in '/' Application.
--------------------------------------------------------------------------------

Compilation Error
Description: An error occurred during the compilation of a resource
required to service this request. Please review the following specific
error details and modify your source code appropriately.

Compiler Error Message: ASPNET: Make sure that the class defined in
this code file matches the 'inherits' attribute, and that it extends
the correct base class (e.g. Page or UserControl).

Source Error:

Line 6:
Line 7:
Line 8: Partial Class LoginH
Line 9: Inherits System.Web.UI.Page
Line 10:
Source File: E:\web\motoadvisor\htdocs\Login.aspx.vb Line: 8 \
---------------------------------------------------------------------------------------------------------------------------------------

Jun 14 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hi Gang,

I guess this is a pretty small group, because no-one answered my
question. However, I did figure it out and would very much like the
next guy to not suffer the same problems I did. I found so much
worthless unrelated Q+A on the web. It was an ASP.net 1.1 \bin\ folder
on the remote website that was causing the problems. Once I deleted
that folder the issue went away entirely.

Thanks,
Christian Blackburn

Jun 14 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.