By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,146 Members | 1,813 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,146 IT Pros & Developers. It's quick & easy.

Why do I get "name 'LocalSqlServer' was not found" when my app uses MySQL?

P: n/a
"The connection name 'LocalSqlServer' was not found in the applications
configuration or the connection string is empty."

I get the error above. It tells me the error is in
Line 120: <profile>
Line 121: <providers>
Line 122: <add name="AspNetSqlProfileProvider"
connectionStringName="LocalSqlServer" applicationName="/"
type="System.Web.Profile.SqlProfileProvider, System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 123: </providers>
Line 124: </profile>

in the machine.config.

Ok that's all fine and dandy, but why the heck is it even looking for
LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
Express or other Microsoft DB in the app. There is nothing in my
Web.Config or my code (unless it was autogenerated without my
knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
DB.

So what is it about an Asp.net application to make it search for the
LocalSqlServer? How can I stop it from doing that?

Jun 13 '06 #1
Share this Question
Share on Google+
6 Replies


P: n/a
That error is telling you that the SQL Server specified in your Provider
connectionStringName="LocalSqlServer"
can't be found.

If you're using MySQL as your database platform as a custom Provider,
you beed to have somthing akin to :

<add name="MySqlProfileProvider"

in web.config.

See :

http://www.codeproject.com/aspnet/My...ipProvider.asp

for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"webonomic" <we*******@gmail.com> wrote in message
news:11**********************@u72g2000cwu.googlegr oups.com... "The connection name 'LocalSqlServer' was not found in the applications
configuration or the connection string is empty."

I get the error above. It tells me the error is in
Line 120: <profile>
Line 121: <providers>
Line 122: <add name="AspNetSqlProfileProvider"
connectionStringName="LocalSqlServer" applicationName="/"
type="System.Web.Profile.SqlProfileProvider, System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 123: </providers>
Line 124: </profile>

in the machine.config.

Ok that's all fine and dandy, but why the heck is it even looking for
LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
Express or other Microsoft DB in the app. There is nothing in my
Web.Config or my code (unless it was autogenerated without my
knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
DB.

So what is it about an Asp.net application to make it search for the
LocalSqlServer? How can I stop it from doing that?

Jun 13 '06 #2

P: n/a
the LocalSqlServer set up in the machine.config file is the one that
stores your Session variables, and other browser data ... as far as i
know you can't disable it (but i could be wrong) so if you are using a
mysql database you need to edit that machine.config file to point to
your mysql server ... i'm not sure if there's anything else that needs
to be done, but google around and you'll find something =)

Juan T. Llibre wrote:
That error is telling you that the SQL Server specified in your Provider
connectionStringName="LocalSqlServer"


can't be found.

If you're using MySQL as your database platform as a custom Provider,
you beed to have somthing akin to :

<add name="MySqlProfileProvider"

in web.config.

See :

http://www.codeproject.com/aspnet/My...ipProvider.asp

for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"webonomic" <we*******@gmail.com> wrote in message
news:11**********************@u72g2000cwu.googlegr oups.com...
"The connection name 'LocalSqlServer' was not found in the applications
configuration or the connection string is empty."

I get the error above. It tells me the error is in
Line 120: <profile>
Line 121: <providers>
Line 122: <add name="AspNetSqlProfileProvider"
connectionStringName="LocalSqlServer" applicationName="/"
type="System.Web.Profile.SqlProfileProvider, System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 123: </providers>
Line 124: </profile>

in the machine.config.

Ok that's all fine and dandy, but why the heck is it even looking for
LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
Express or other Microsoft DB in the app. There is nothing in my
Web.Config or my code (unless it was autogenerated without my
knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
DB.

So what is it about an Asp.net application to make it search for the
LocalSqlServer? How can I stop it from doing that?


Jun 14 '06 #3

P: n/a
re:
as far as i know you can't disable it
Sure you can :

<remove name="LocalSqlServer"/>

Then, you can clear the connection strings :

<connectionStrings>
<clear />
<add providerName="blah, blah...>

and then, clear the default provider and specify a custom provider:

<membership defaultProvider="YourSqlProvider">
<providers>
<clear />
<add name="YourSqlProvider"

See :
http://www.codeproject.com/aspnet/My...ipProvider.asp
for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<di***********@gmail.com> wrote in message
news:11**********************@h76g2000cwa.googlegr oups.com...
the LocalSqlServer set up in the machine.config file is the one that
stores your Session variables, and other browser data ... as far as i
know you can't disable it (but i could be wrong) so if you are using a
mysql database you need to edit that machine.config file to point to
your mysql server ... i'm not sure if there's anything else that needs
to be done, but google around and you'll find something =)

Juan T. Llibre wrote: That error is telling you that the SQL Server specified in your Provider
connectionStringName="LocalSqlServer"


can't be found.

If you're using MySQL as your database platform as a custom Provider,
you beed to have somthing akin to :

<add name="MySqlProfileProvider"

in web.config.

See :

http://www.codeproject.com/aspnet/My...ipProvider.asp

for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"webonomic" <we*******@gmail.com> wrote in message
news:11**********************@u72g2000cwu.googlegr oups.com...
"The connection name 'LocalSqlServer' was not found in the applications
configuration or the connection string is empty."

I get the error above. It tells me the error is in
Line 120: <profile>
Line 121: <providers>
Line 122: <add name="AspNetSqlProfileProvider"
connectionStringName="LocalSqlServer" applicationName="/"
type="System.Web.Profile.SqlProfileProvider, System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 123: </providers>
Line 124: </profile>

in the machine.config.

Ok that's all fine and dandy, but why the heck is it even looking for
LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
Express or other Microsoft DB in the app. There is nothing in my
Web.Config or my code (unless it was autogenerated without my
knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
DB.

So what is it about an Asp.net application to make it search for the
LocalSqlServer? How can I stop it from doing that?


Jun 14 '06 #4

P: n/a
=) ok, you can do that, what i meant was i don't know what asp.net will
do if it doesn't have a sql server to stash session variables in ... i
don't know if it can function w/o it, or if it has some kind of in
memory db it can fall back to
Juan T. Llibre wrote:
re:
as far as i know you can't disable it


Sure you can :

<remove name="LocalSqlServer"/>

Then, you can clear the connection strings :

<connectionStrings>
<clear />
<add providerName="blah, blah...>

and then, clear the default provider and specify a custom provider:

<membership defaultProvider="YourSqlProvider">
<providers>
<clear />
<add name="YourSqlProvider"

See :
http://www.codeproject.com/aspnet/My...ipProvider.asp
for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<di***********@gmail.com> wrote in message
news:11**********************@h76g2000cwa.googlegr oups.com...
the LocalSqlServer set up in the machine.config file is the one that
stores your Session variables, and other browser data ... as far as i
know you can't disable it (but i could be wrong) so if you are using a
mysql database you need to edit that machine.config file to point to
your mysql server ... i'm not sure if there's anything else that needs
to be done, but google around and you'll find something =)

Juan T. Llibre wrote:
That error is telling you that the SQL Server specified in your Provider
connectionStringName="LocalSqlServer"


can't be found.

If you're using MySQL as your database platform as a custom Provider,
you beed to have somthing akin to :

<add name="MySqlProfileProvider"

in web.config.

See :

http://www.codeproject.com/aspnet/My...ipProvider.asp

for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"webonomic" <we*******@gmail.com> wrote in message
news:11**********************@u72g2000cwu.googlegr oups.com...
"The connection name 'LocalSqlServer' was not found in the applications
configuration or the connection string is empty."

I get the error above. It tells me the error is in
Line 120: <profile>
Line 121: <providers>
Line 122: <add name="AspNetSqlProfileProvider"
connectionStringName="LocalSqlServer" applicationName="/"
type="System.Web.Profile.SqlProfileProvider, System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 123: </providers>
Line 124: </profile>

in the machine.config.

Ok that's all fine and dandy, but why the heck is it even looking for
LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
Express or other Microsoft DB in the app. There is nothing in my
Web.Config or my code (unless it was autogenerated without my
knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
DB.

So what is it about an Asp.net application to make it search for the
LocalSqlServer? How can I stop it from doing that?


Jun 14 '06 #5

P: n/a
re:
what i meant was i don't know what asp.net will do
if it doesn't have a sql server to stash session variables in ...
There's two other sessionState modes :

Inproc and StateServer.
You can also setup a custom session state service.

See : http://msdn2.microsoft.com/en-us/library/ms178586.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<di***********@gmail.com> wrote in message
news:11**********************@g10g2000cwb.googlegr oups.com...
=) ok, you can do that, what i meant was i don't know what asp.net will
do if it doesn't have a sql server to stash session variables in ... i
don't know if it can function w/o it, or if it has some kind of in
memory db it can fall back to
Juan T. Llibre wrote: re:
as far as i know you can't disable it


Sure you can :

<remove name="LocalSqlServer"/>

Then, you can clear the connection strings :

<connectionStrings>
<clear />
<add providerName="blah, blah...>

and then, clear the default provider and specify a custom provider:

<membership defaultProvider="YourSqlProvider">
<providers>
<clear />
<add name="YourSqlProvider"

See :
http://www.codeproject.com/aspnet/My...ipProvider.asp
for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<di***********@gmail.com> wrote in message
news:11**********************@h76g2000cwa.googlegr oups.com...
the LocalSqlServer set up in the machine.config file is the one that
stores your Session variables, and other browser data ... as far as i
know you can't disable it (but i could be wrong) so if you are using a
mysql database you need to edit that machine.config file to point to
your mysql server ... i'm not sure if there's anything else that needs
to be done, but google around and you'll find something =)

Juan T. Llibre wrote:
That error is telling you that the SQL Server specified in your Provider
connectionStringName="LocalSqlServer"


can't be found.

If you're using MySQL as your database platform as a custom Provider,
you beed to have somthing akin to :

<add name="MySqlProfileProvider"

in web.config.

See :

http://www.codeproject.com/aspnet/My...ipProvider.asp

for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"webonomic" <we*******@gmail.com> wrote in message
news:11**********************@u72g2000cwu.googlegr oups.com...
"The connection name 'LocalSqlServer' was not found in the applications
configuration or the connection string is empty."

I get the error above. It tells me the error is in
Line 120: <profile>
Line 121: <providers>
Line 122: <add name="AspNetSqlProfileProvider"
connectionStringName="LocalSqlServer" applicationName="/"
type="System.Web.Profile.SqlProfileProvider, System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 123: </providers>
Line 124: </profile>

in the machine.config.

Ok that's all fine and dandy, but why the heck is it even looking for
LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
Express or other Microsoft DB in the app. There is nothing in my
Web.Config or my code (unless it was autogenerated without my
knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
DB.

So what is it about an Asp.net application to make it search for the
LocalSqlServer? How can I stop it from doing that?

Jun 15 '06 #6

P: n/a
ah, nifty =) thanks!
Juan T. Llibre wrote:
re:
what i meant was i don't know what asp.net will do
if it doesn't have a sql server to stash session variables in ...


There's two other sessionState modes :

Inproc and StateServer.
You can also setup a custom session state service.

See : http://msdn2.microsoft.com/en-us/library/ms178586.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<di***********@gmail.com> wrote in message
news:11**********************@g10g2000cwb.googlegr oups.com...
=) ok, you can do that, what i meant was i don't know what asp.net will
do if it doesn't have a sql server to stash session variables in ... i
don't know if it can function w/o it, or if it has some kind of in
memory db it can fall back to
Juan T. Llibre wrote:
re:
as far as i know you can't disable it


Sure you can :

<remove name="LocalSqlServer"/>

Then, you can clear the connection strings :

<connectionStrings>
<clear />
<add providerName="blah, blah...>

and then, clear the default provider and specify a custom provider:

<membership defaultProvider="YourSqlProvider">
<providers>
<clear />
<add name="YourSqlProvider"

See :
http://www.codeproject.com/aspnet/My...ipProvider.asp
for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<di***********@gmail.com> wrote in message
news:11**********************@h76g2000cwa.googlegr oups.com...
the LocalSqlServer set up in the machine.config file is the one that
stores your Session variables, and other browser data ... as far as i
know you can't disable it (but i could be wrong) so if you are using a
mysql database you need to edit that machine.config file to point to
your mysql server ... i'm not sure if there's anything else that needs
to be done, but google around and you'll find something =)

Juan T. Llibre wrote:
That error is telling you that the SQL Server specified in your Provider

> connectionStringName="LocalSqlServer"

can't be found.

If you're using MySQL as your database platform as a custom Provider,
you beed to have somthing akin to :

<add name="MySqlProfileProvider"

in web.config.

See :

http://www.codeproject.com/aspnet/My...ipProvider.asp

for sample access code to MySql using ASP.NET 2.0.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"webonomic" <we*******@gmail.com> wrote in message
news:11**********************@u72g2000cwu.googlegr oups.com...
> "The connection name 'LocalSqlServer' was not found in the applications
> configuration or the connection string is empty."
>
> I get the error above. It tells me the error is in
> Line 120: <profile>
> Line 121: <providers>
> Line 122: <add name="AspNetSqlProfileProvider"
> connectionStringName="LocalSqlServer" applicationName="/"
> type="System.Web.Profile.SqlProfileProvider, System.Web,
> Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
> Line 123: </providers>
> Line 124: </profile>
>
> in the machine.config.
>
> Ok that's all fine and dandy, but why the heck is it even looking for
> LocalSqlServer? I am using MySQL as the DB. I don't have a SQL
> Express or other Microsoft DB in the app. There is nothing in my
> Web.Config or my code (unless it was autogenerated without my
> knowledge) that suggests I am using a SQL Express or MSSQL or MSAccess
> DB.
>
> So what is it about an Asp.net application to make it search for the
> LocalSqlServer? How can I stop it from doing that?
>


Jun 15 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.