469,578 Members | 1,607 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,578 developers. It's quick & easy.

HTTP 403 error on a newly created web site

I created a new website, using the ASP .NET Website template. Before I
did anything, I tried running it in debug mode. This worked, giving a
blank page. I then moved the site to become the default site on my
machine. At first, I had issues with an XML error that came up. After
I setup IIS to use ASP .NET 2.0, I started getting the 403 -- You
are not authorized to view this page, when I try to look at localhost.

Is there some code that is needed?

Thanks,

Ed Lorden
Consultant
Jun 2 '06 #1
4 2352
What have you done to troubleshoot. I can think of half a dozen steps I
would take before posting to half a dozen newsgroups.

Had this been an interview question, I wouldn't hire you
"Edward Lorden" <el*****@hotmail.com> wrote in message
news:OJ**************@TK2MSFTNGP04.phx.gbl...
I created a new website, using the ASP .NET Website template. Before I did
anything, I tried running it in debug mode. This worked, giving a blank
page. I then moved the site to become the default site on my machine. At
first, I had issues with an XML error that came up. After I setup IIS to
use ASP .NET 2.0, I started getting the 403 -- You are not authorized to
view this page, when I try to look at localhost.

Is there some code that is needed?

Thanks,

Ed Lorden
Consultant

Jun 2 '06 #2

Thank you, Jeff, for the spam that helps not one wit learn. Now, if
you've got something useful to say, say it. I would greatly appreciate
any help I can be given to learn what I should do. That is what I
thought these newsgroups were for. If you want to take it offline, that
is fine too.
Thanks,

Ed

Jeff Dillon wrote:
What have you done to troubleshoot. I can think of half a dozen steps I
would take before posting to half a dozen newsgroups.

Had this been an interview question, I wouldn't hire you
"Edward Lorden" <el*****@hotmail.com> wrote in message
news:OJ**************@TK2MSFTNGP04.phx.gbl...
I created a new website, using the ASP .NET Website template. Before I did
anything, I tried running it in debug mode. This worked, giving a blank
page. I then moved the site to become the default site on my machine. At
first, I had issues with an XML error that came up. After I setup IIS to
use ASP .NET 2.0, I started getting the 403 -- You are not authorized to
view this page, when I try to look at localhost.

Is there some code that is needed?

Thanks,

Ed Lorden
Consultant


Jun 2 '06 #3
Nah, just throw up your hands. There is no hope.

You can just expect people to solve all your problems..that entitlement
attitude that seems to be so common.

I am happy to help, and instruct, anyone, if they don't expect someone to do
their work for them.

Or, you can try to troubleshoot. It "seems" to be a permissions issue. Here
is what I would do:

* Create a one-line test.htm page and test

* Turn on Anonymous

* Make sure you are in the local Admin group

* View Event Log

* Try a different vdir on the same machine, with no web.config or
global.asax

* Remove web.config and global.asax from the root, and test a one-line
test.aspx

* Get a book


"Edward Lorden" <el*****@hotmail.com> wrote in message
news:e5**************@TK2MSFTNGP05.phx.gbl...

Thank you, Jeff, for the spam that helps not one wit learn. Now, if
you've got something useful to say, say it. I would greatly appreciate
any help I can be given to learn what I should do. That is what I thought
these newsgroups were for. If you want to take it offline, that is fine
too.
Thanks,

Ed

Jeff Dillon wrote:
What have you done to troubleshoot. I can think of half a dozen steps I
would take before posting to half a dozen newsgroups.

Had this been an interview question, I wouldn't hire you
"Edward Lorden" <el*****@hotmail.com> wrote in message
news:OJ**************@TK2MSFTNGP04.phx.gbl...
I created a new website, using the ASP .NET Website template. Before I
did anything, I tried running it in debug mode. This worked, giving a
blank page. I then moved the site to become the default site on my
machine. At first, I had issues with an XML error that came up. After
I setup IIS to use ASP .NET 2.0, I started getting the 403 -- You are
not authorized to view this page, when I try to look at localhost.

Is there some code that is needed?

Thanks,

Ed Lorden
Consultant


Jun 2 '06 #4
Thanks for the help. I don't care what anybody say about you. You're
really a nice guy.

Ed

Jeff Dillon wrote:
Nah, just throw up your hands. There is no hope.

You can just expect people to solve all your problems..that entitlement
attitude that seems to be so common.

I am happy to help, and instruct, anyone, if they don't expect someone to do
their work for them.

Or, you can try to troubleshoot. It "seems" to be a permissions issue. Here
is what I would do:

* Create a one-line test.htm page and test

* Turn on Anonymous

* Make sure you are in the local Admin group

* View Event Log

* Try a different vdir on the same machine, with no web.config or
global.asax

* Remove web.config and global.asax from the root, and test a one-line
test.aspx

* Get a book


"Edward Lorden" <el*****@hotmail.com> wrote in message
news:e5**************@TK2MSFTNGP05.phx.gbl...
Thank you, Jeff, for the spam that helps not one wit learn. Now, if
you've got something useful to say, say it. I would greatly appreciate
any help I can be given to learn what I should do. That is what I thought
these newsgroups were for. If you want to take it offline, that is fine
too.
Thanks,

Ed

Jeff Dillon wrote:
What have you done to troubleshoot. I can think of half a dozen steps I
would take before posting to half a dozen newsgroups.

Had this been an interview question, I wouldn't hire you
"Edward Lorden" <el*****@hotmail.com> wrote in message
news:OJ**************@TK2MSFTNGP04.phx.gbl...
I created a new website, using the ASP .NET Website template. Before I
did anything, I tried running it in debug mode. This worked, giving a
blank page. I then moved the site to become the default site on my
machine. At first, I had issues with an XML error that came up. After
I setup IIS to use ASP .NET 2.0, I started getting the 403 -- You are
not authorized to view this page, when I try to look at localhost.

Is there some code that is needed?

Thanks,

Ed Lorden
Consultant

Jun 2 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by pptran | last post: by
8 posts views Thread by biro man | last post: by
1 post views Thread by Rik Hoeflaak | last post: by
4 posts views Thread by mcwooq | last post: by
21 posts views Thread by one2001boy | last post: by
16 posts views Thread by Harry Simpson | last post: by
reply views Thread by suresh191 | last post: by
4 posts views Thread by guiromero | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.