By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,357 Members | 982 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,357 IT Pros & Developers. It's quick & easy.

Membership Provider Error

P: n/a
Hi

This is Vishal this side.I have been trying to create a new sample website
using the new Membership Provider Class.

Now when I try to a create a new website and then hit on the Website
Administrator Tool and then hit on Security I get this error

"There is a problem with your selected data store. This can be caused by an
invalid server name or credentials, or by insufficient permission. It can
also be caused by the role manager feature not being enabled. Click the
button below to be redirected to a page where you can choose a new data
store.

The following message may help in diagnosing the problem: Unable to connect
to SQL Server database. "

Where do we specify the SQL Server Database details?
I appreciate if you anyone help fix this issue.

Regards,

Vishal Gupta
May 16 '06 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Please review the Membership documentation...

http://msdn2.microsoft.com/en-us/library/yh26yfzy.aspx

Specifically, you configure ASP.NET applications to use Membership in the
<connectionstrings>, <providers> and <membership> elements in the application's web.config :

http://msdn2.microsoft.com/en-us/library/6e9y4s5t.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:ux**************@TK2MSFTNGP04.phx.gbl...
Hi

This is Vishal this side.I have been trying to create a new sample website
using the new Membership Provider Class.

Now when I try to a create a new website and then hit on the Website
Administrator Tool and then hit on Security I get this error

"There is a problem with your selected data store. This can be caused by an
invalid server name or credentials, or by insufficient permission. It can
also be caused by the role manager feature not being enabled. Click the
button below to be redirected to a page where you can choose a new data
store.

The following message may help in diagnosing the problem: Unable to connect
to SQL Server database. "

Where do we specify the SQL Server Database details?
I appreciate if you anyone help fix this issue.

Regards,

Vishal Gupta

May 16 '06 #2

P: n/a
Thanks, it works by providing the connection string ,provider, membership
entries in the web.config.I also had to manually install the aspnetdb
through the aspnet_regsql utiltily.

However, I still have a doubt in all the videos i saw on ASP.net Membership
classes it works simply without providing any of these entries or any such
settings.(http://msdn.microsoft.com/asp.net/le...todevelopment/)
Is there some settings at the time installation or any rights which we need
to take care.
Please let me know if you have clues.
Vishal

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Please review the Membership documentation...

http://msdn2.microsoft.com/en-us/library/yh26yfzy.aspx

Specifically, you configure ASP.NET applications to use Membership in the
<connectionstrings>, <providers> and <membership> elements in the
application's web.config :

http://msdn2.microsoft.com/en-us/library/6e9y4s5t.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:ux**************@TK2MSFTNGP04.phx.gbl...
Hi

This is Vishal this side.I have been trying to create a new sample
website
using the new Membership Provider Class.

Now when I try to a create a new website and then hit on the Website
Administrator Tool and then hit on Security I get this error

"There is a problem with your selected data store. This can be caused by
an
invalid server name or credentials, or by insufficient permission. It can
also be caused by the role manager feature not being enabled. Click the
button below to be redirected to a page where you can choose a new data
store.

The following message may help in diagnosing the problem: Unable to
connect
to SQL Server database. "

Where do we specify the SQL Server Database details?
I appreciate if you anyone help fix this issue.

Regards,

Vishal Gupta


May 16 '06 #3

P: n/a
I tried the same thing (installing VS2005) on Windows 2003 x64 bit OS and
when i create a new website and hit on Website Adminstration Tool (WSAT)
and ther after hit on Security tab, everything works perfect and i am able
to create users/roles....
I wanted to know why is not working on my local system. It is Windows XP
with a network domain account.
Does the WSAT tool require some adminsitrative privileges to run or what ??

Please help...................

"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:eR**************@TK2MSFTNGP03.phx.gbl...
Thanks, it works by providing the connection string ,provider, membership
entries in the web.config.I also had to manually install the aspnetdb
through the aspnet_regsql utiltily.

However, I still have a doubt in all the videos i saw on ASP.net
Membership classes it works simply without providing any of these entries
or any such
settings.(http://msdn.microsoft.com/asp.net/le...todevelopment/)
Is there some settings at the time installation or any rights which we
need to take care.
Please let me know if you have clues.
Vishal

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Please review the Membership documentation...

http://msdn2.microsoft.com/en-us/library/yh26yfzy.aspx

Specifically, you configure ASP.NET applications to use Membership in the
<connectionstrings>, <providers> and <membership> elements in the
application's web.config :

http://msdn2.microsoft.com/en-us/library/6e9y4s5t.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:ux**************@TK2MSFTNGP04.phx.gbl...
Hi

This is Vishal this side.I have been trying to create a new sample
website
using the new Membership Provider Class.

Now when I try to a create a new website and then hit on the Website
Administrator Tool and then hit on Security I get this error

"There is a problem with your selected data store. This can be caused by
an
invalid server name or credentials, or by insufficient permission. It
can
also be caused by the role manager feature not being enabled. Click the
button below to be redirected to a page where you can choose a new data
store.

The following message may help in diagnosing the problem: Unable to
connect
to SQL Server database. "

Where do we specify the SQL Server Database details?
I appreciate if you anyone help fix this issue.

Regards,

Vishal Gupta



May 16 '06 #4

P: n/a
Did you install SQL Server 2005 Express locally ?
The default installation requires SQL Server 2005 Express.

You have to do some customization if you want to run Membership against other databases.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:uh**************@TK2MSFTNGP02.phx.gbl...
I tried the same thing (installing VS2005) on Windows 2003 x64 bit OS and when i create a new
website and hit on Website Adminstration Tool (WSAT)
and ther after hit on Security tab, everything works perfect and i am able to create
users/roles....
I wanted to know why is not working on my local system. It is Windows XP with a network domain
account.
Does the WSAT tool require some adminsitrative privileges to run or what ??

Please help...................

"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:eR**************@TK2MSFTNGP03.phx.gbl...
Thanks, it works by providing the connection string ,provider, membership entries in the
web.config.I also had to manually install the aspnetdb through the aspnet_regsql utiltily.

However, I still have a doubt in all the videos i saw on ASP.net Membership classes it works
simply without providing any of these entries or any such
settings.(http://msdn.microsoft.com/asp.net/le...todevelopment/)
Is there some settings at the time installation or any rights which we need to take care.
Please let me know if you have clues.
Vishal

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Please review the Membership documentation...

http://msdn2.microsoft.com/en-us/library/yh26yfzy.aspx

Specifically, you configure ASP.NET applications to use Membership in the
<connectionstrings>, <providers> and <membership> elements in the application's web.config :

http://msdn2.microsoft.com/en-us/library/6e9y4s5t.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:ux**************@TK2MSFTNGP04.phx.gbl...
Hi

This is Vishal this side.I have been trying to create a new sample website
using the new Membership Provider Class.

Now when I try to a create a new website and then hit on the Website
Administrator Tool and then hit on Security I get this error

"There is a problem with your selected data store. This can be caused by an
invalid server name or credentials, or by insufficient permission. It can
also be caused by the role manager feature not being enabled. Click the
button below to be redirected to a page where you can choose a new data
store.

The following message may help in diagnosing the problem: Unable to connect
to SQL Server database. "

Where do we specify the SQL Server Database details?
I appreciate if you anyone help fix this issue.

Regards,

Vishal Gupta



May 16 '06 #5

P: n/a
Yes i have SQL Sever 2005 on my local machine.The only point to note is that
earlier both SQL2000 and SQL2005 was installed with 2000 been the default
instance.But now i have removed 2000 from my machine.

Enclosed is the SQL Server detail

Microsoft SQL Server Management Studio 9.00.1399.00
Microsoft Analysis Services Client Tools 2005.090.1399.00
Microsoft Data Access Components (MDAC) 2000.085.1117.00
(xpsp_sp2_rtm.040803-2158)
Microsoft MSXML 2.6 3.0 4.0 5.0 6.0
Microsoft Internet Explorer 6.0.2900.2180
Microsoft .NET Framework 2.0.50727.42
Operating System 5.1.2600
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:ej**************@TK2MSFTNGP04.phx.gbl...
Did you install SQL Server 2005 Express locally ?
The default installation requires SQL Server 2005 Express.

You have to do some customization if you want to run Membership against
other databases.

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:uh**************@TK2MSFTNGP02.phx.gbl...
I tried the same thing (installing VS2005) on Windows 2003 x64 bit OS and
when i create a new website and hit on Website Adminstration Tool (WSAT)
and ther after hit on Security tab, everything works perfect and i am
able to create users/roles....
I wanted to know why is not working on my local system. It is Windows XP
with a network domain account.
Does the WSAT tool require some adminsitrative privileges to run or what
??

Please help...................

"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:eR**************@TK2MSFTNGP03.phx.gbl...
Thanks, it works by providing the connection string ,provider,
membership entries in the web.config.I also had to manually install the
aspnetdb through the aspnet_regsql utiltily.

However, I still have a doubt in all the videos i saw on ASP.net
Membership classes it works simply without providing any of these
entries or any such
settings.(http://msdn.microsoft.com/asp.net/le...todevelopment/)
Is there some settings at the time installation or any rights which we
need to take care.
Please let me know if you have clues.
Vishal

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Please review the Membership documentation...

http://msdn2.microsoft.com/en-us/library/yh26yfzy.aspx

Specifically, you configure ASP.NET applications to use Membership in
the
<connectionstrings>, <providers> and <membership> elements in the
application's web.config :

http://msdn2.microsoft.com/en-us/library/6e9y4s5t.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Vishal Gupta" <vi**********@acs-inc.com> wrote in message
news:ux**************@TK2MSFTNGP04.phx.gbl...
> Hi
>
> This is Vishal this side.I have been trying to create a new sample
> website
> using the new Membership Provider Class.
>
> Now when I try to a create a new website and then hit on the Website
> Administrator Tool and then hit on Security I get this error
>
> "There is a problem with your selected data store. This can be caused
> by an
> invalid server name or credentials, or by insufficient permission. It
> can
> also be caused by the role manager feature not being enabled. Click
> the
> button below to be redirected to a page where you can choose a new
> data
> store.
>
> The following message may help in diagnosing the problem: Unable to
> connect
> to SQL Server database. "
>
>
>
> Where do we specify the SQL Server Database details?
>
>
> I appreciate if you anyone help fix this issue.
>
>
>
> Regards,
>
> Vishal Gupta
>
>



May 16 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.