By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,635 Members | 2,227 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,635 IT Pros & Developers. It's quick & easy.

error in exporting Crystal Report in ASP.net - URGENT

P: n/a
I am getting this error in exporting a crystal report (having two
subreports) using C# code. i got the following exception at Export
statement.

Exception Details:
CrystalDecisions.CrystalReports.Engine.ExportExcep tion: Error in File
C:\WINDOWS\TEMP\temp_015d322b-ea06-426e-92d3-656ad11ef627.rpt: Error
detected by export DLL:

..........................here is the report
information..........................
my report is bind with dataset. report has two subreports. dataset has
two tables.
report has one Image field which is coming from Database. image type is
JPEG.
report has 4 fields that has free text coming from database. this text
includes a line break in text as it is entered from a web page.
.................................................. .................................................. ..........................

if any one know the solution, please let me know as i am stuck into it
and could not find a way.....

May 10 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
I'm not 100% sure but I had a similar error a few years back and it was
because the application using Crystal Reports did not have proper
access to the C:\WINDOWS\TEMP directory.

May 10 '06 #2

P: n/a
I have given EveryOne user write permission this folder but still
getting this error

May 10 '06 #3

P: n/a
Weird. I remember giving write permissions to the ASP.NET account and
it fixed my problem. Good luck!

May 11 '06 #4

P: n/a
it is still not working. to make sure, i created a simple text file to
make sure that user has write permission on folder but that worked. but
crystal export is not working on windows 2003 server.
even i found one reply on net that due to fonts this error may come but
it is not the case, my report is having Arial font completely. it is
working fine on Win XP but not on Win 2003 machine.

any help pease??????

May 11 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.