By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,745 Members | 812 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,745 IT Pros & Developers. It's quick & easy.

Overriding AllowPaging and PageSize set in skin file

P: n/a
I am working on part of an application most of which is being developed
outside of my group. I may actually have two problems here. I have a GridView
for which the columns are generated dynamically from a manager class called
by the code behind for the page containing the GridView. The grid appears to
display properly. The HyperLinkField generated dynamically works just fine.
This application has a default.skin file which sets AllowPaging to true and
PageSize to 20. It seems to apply to any gridview generated within the
application.

My GridView generates with the Paging controls at the bottom of the form.
However, when I click any of the other page numbers, I get a Http Exception
for which I have no information other than that. Is there a way I can handle
this in the code behind?

For what I am doing, I don't really need to AllowPaging so another way to
solve this issue would be to override AllowPaging but if I set AllowPaging =
false in the GridView tag, it has no effect. Is there a way to override this?

Thank you!
Steve
May 5 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
You can create another skin for the GridView you do not want the allowpaging
attribute to be overriden by the previous one and set the SkinID of the
GridView to this new skin. I hope this helps
"Stephen Hatfield" <St*************@discussions.microsoft.com> wrote in
message news:DD**********************************@microsof t.com...
I am working on part of an application most of which is being developed
outside of my group. I may actually have two problems here. I have a
GridView
for which the columns are generated dynamically from a manager class
called
by the code behind for the page containing the GridView. The grid appears
to
display properly. The HyperLinkField generated dynamically works just
fine.
This application has a default.skin file which sets AllowPaging to true
and
PageSize to 20. It seems to apply to any gridview generated within the
application.

My GridView generates with the Paging controls at the bottom of the form.
However, when I click any of the other page numbers, I get a Http
Exception
for which I have no information other than that. Is there a way I can
handle
this in the code behind?

For what I am doing, I don't really need to AllowPaging so another way to
solve this issue would be to override AllowPaging but if I set AllowPaging
=
false in the GridView tag, it has no effect. Is there a way to override
this?

Thank you!
Steve

May 5 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.