By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,606 Members | 3,832 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,606 IT Pros & Developers. It's quick & easy.

Running ASP.NEt on windows media center OS in Debug mode.

P: n/a
Hi all,

My new computer has Microsoft Windows XP Media Center Edition as the
operating system. I am trying to run VStudio 2003 , ASP.NET on IIS 5.0
but every single time i run the source code of my application , it shows me
the message "unable to run debugging, please try running it using the option
"start with out debugging" which then start the application.

Can any body tell me why this is happening, coudl it be the OS with which
VS2203 ASP.NEt is not compatible with?

thanks
Sameer
Apr 23 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hey, Sameer. I had the same problem with VS.NET 2002.

I noticed that my IIS wasn't configured to handle ASP.NET. You can
check that at

* Start->Control Panel->Administrative Tools->Internet Information
Services
* Then expand the (local computer) and right-click Default Web site and
select Properties.
*Select the "Home Directory" tab and hit the "Configuration..." button
near the bottom right.

In the "Mappings" tab, you should see mappings to files with extensions
like *.asax, *.ascx, *.aspc, etc. etc.

If not, then you need to register the .NET framework with IIS. There's
an EXE file called "aspnet_regiis.exe" in each installation of the .NET
Framework that will do this for you. On my machine I ran the following
commands at the command prompt (The info I read told me to use the "-r"
extension, so I just did that without looking further into it):

C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\aspne t_regiis.exe -r
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -r

Now I have .NET set up in IIS. Since I ran the registration for .NET
version 1.1.4322 after the 1.0 one, it looks like my IIS is set to use
version 1.1. I believe if I ran the 1.0 registration again, I'd be set
up for 1.0.
I haven't tested it out yet, but I think this will work (I'm still
waiting for VS.NET to reinstall while I'm writing this... I wish I had
found this first.. ugh). I'll report back if it's successful.

-Stephen

-------------------------------------------------------------------------------------------------------------------------

sameer wrote:
Hi all,

My new computer has Microsoft Windows XP Media Center Edition as the
operating system. I am trying to run VStudio 2003 , ASP.NET on IIS 5.0
but every single time i run the source code of my application , it shows me
the message "unable to run debugging, please try running it using the option
"start with out debugging" which then start the application.

Can any body tell me why this is happening, coudl it be the OS with which
VS2203 ASP.NEt is not compatible with?

thanks
Sameer


May 3 '06 #2

P: n/a
thanks for your help stephen, i did ran the registration tool before itself,
if not then IIS does not support ASP.Net at all. I think in my case it is the
operating system that does not support debugging itself.

thanks

"st*************@verizon.net" wrote:
Hey, Sameer. I had the same problem with VS.NET 2002.

I noticed that my IIS wasn't configured to handle ASP.NET. You can
check that at

* Start->Control Panel->Administrative Tools->Internet Information
Services
* Then expand the (local computer) and right-click Default Web site and
select Properties.
*Select the "Home Directory" tab and hit the "Configuration..." button
near the bottom right.

In the "Mappings" tab, you should see mappings to files with extensions
like *.asax, *.ascx, *.aspc, etc. etc.

If not, then you need to register the .NET framework with IIS. There's
an EXE file called "aspnet_regiis.exe" in each installation of the .NET
Framework that will do this for you. On my machine I ran the following
commands at the command prompt (The info I read told me to use the "-r"
extension, so I just did that without looking further into it):

C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\aspne t_regiis.exe -r
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -r

Now I have .NET set up in IIS. Since I ran the registration for .NET
version 1.1.4322 after the 1.0 one, it looks like my IIS is set to use
version 1.1. I believe if I ran the 1.0 registration again, I'd be set
up for 1.0.
I haven't tested it out yet, but I think this will work (I'm still
waiting for VS.NET to reinstall while I'm writing this... I wish I had
found this first.. ugh). I'll report back if it's successful.

-Stephen

-------------------------------------------------------------------------------------------------------------------------

sameer wrote:
Hi all,

My new computer has Microsoft Windows XP Media Center Edition as the
operating system. I am trying to run VStudio 2003 , ASP.NET on IIS 5.0
but every single time i run the source code of my application , it shows me
the message "unable to run debugging, please try running it using the option
"start with out debugging" which then start the application.

Can any body tell me why this is happening, coudl it be the OS with which
VS2203 ASP.NEt is not compatible with?

thanks
Sameer


May 3 '06 #3

P: n/a
I am apparently running Windows XP Media Center Edition 2002 with
Service Pack 2.

My problem is solved now after I registered .NET with IIS. I also
reinstalled VS.NET Pro (2002) at the same time, so that might have
helped too.

The only other thing I did was to add some Users to some of the
Security Groups in the Computer Management. I did a few just trying
things out, but that was before I did the registration again. Here's
some I did:

* Added the ASPNET user to the Administrators Group
* Added ASPNET to the COMPUTERNAME Admins Group
* I may have added Administrator, IUSR_COMPUTERNAME, IWAM_COMPUTERNAME,
& my current user to the "Debugger Users" & "VS Developers" Groups

The only other thing I can think of is that I reran the Windows
Component Update CD. Other than that, this is pretty much a new
computer I just got up and running.

May 4 '06 #4

P: n/a
Stephen , after u mentioned it to me i though let me try it again and boom it
is working now... i reran the aspnet tool and boom i can debug now.

thanks for your help

"st*************@verizon.net" wrote:
I am apparently running Windows XP Media Center Edition 2002 with
Service Pack 2.

My problem is solved now after I registered .NET with IIS. I also
reinstalled VS.NET Pro (2002) at the same time, so that might have
helped too.

The only other thing I did was to add some Users to some of the
Security Groups in the Computer Management. I did a few just trying
things out, but that was before I did the registration again. Here's
some I did:

* Added the ASPNET user to the Administrators Group
* Added ASPNET to the COMPUTERNAME Admins Group
* I may have added Administrator, IUSR_COMPUTERNAME, IWAM_COMPUTERNAME,
& my current user to the "Debugger Users" & "VS Developers" Groups

The only other thing I can think of is that I reran the Windows
Component Update CD. Other than that, this is pretty much a new
computer I just got up and running.

May 5 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.