By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,763 Members | 1,609 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,763 IT Pros & Developers. It's quick & easy.

forms authentction against sql server 2000

P: n/a
Hi,

I'm using sql server 2000 on a remote machine and I have a login.aspx page
with a simple bare bone login control on the page for entering login
information.

I have a virtaul directory setup that points to the physical directory, and
when I access that login page from the virtual directory path say (
http://localhost/test/login.aspx) and entering username, passowrd, I get

"An error has occurred while establishing a connection to the server. When
connecting to SQL Server 2005, this failure may be caused by the fact that
under the default settings SQL Server does not allow remote connections.
(provider: Named Pipes Provider, error: 40 - Could not open a connection to
SQL Server)]
System.Data.SqlClient.SqlInternalConnection.OnErro r(SqlException exception,
Boolean breakConnection) +73510"

What's the problem? When I launch the same page from within Visual studio
(which lauches its build-in web server), entering my login informaiton,
bang, i get through just fine.

I checked the follwing

1. Using ASP.NET configuration tool in VS 2005, I created some new user
2. Uisng Enteprrise manager of sql 2000, I see the new users being created
in the remote db.
3. I enabled Named Pipes and TCP/IP on the remote sql server 2000
4. I'm able to login from the build in webserver.
below is my connection string

<connectionStrings>
<remove name="LocalSqlServer" />
<add name="LocalSqlServer" connectionString="Data Source=NEMO;Initial
Catalog=TestDB;Integrated Security=false; User ID=test password=test;"
providerName="System.Data.SqlClient" />
</connectionStrings>

What gives? Is there anything in the IIS 5.1 that I need to configure?

thanks.
Apr 12 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Are you using the same Connectionstring from the Visual Studio.
Try using Query Analyzer using the same login and see.
And " Integrated Security=false;"
is this not suppose to be set to true?
Patrick

"Liming" <ro*****@nospam.nospam> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
Hi,

I'm using sql server 2000 on a remote machine and I have a login.aspx page
with a simple bare bone login control on the page for entering login
information.

I have a virtaul directory setup that points to the physical directory,
and when I access that login page from the virtual directory path say (
http://localhost/test/login.aspx) and entering username, passowrd, I get

"An error has occurred while establishing a connection to the server. When
connecting to SQL Server 2005, this failure may be caused by the fact that
under the default settings SQL Server does not allow remote connections.
(provider: Named Pipes Provider, error: 40 - Could not open a connection
to SQL Server)]
System.Data.SqlClient.SqlInternalConnection.OnErro r(SqlException
exception, Boolean breakConnection) +73510"

What's the problem? When I launch the same page from within Visual studio
(which lauches its build-in web server), entering my login informaiton,
bang, i get through just fine.

I checked the follwing

1. Using ASP.NET configuration tool in VS 2005, I created some new user
2. Uisng Enteprrise manager of sql 2000, I see the new users being
created in the remote db.
3. I enabled Named Pipes and TCP/IP on the remote sql server 2000
4. I'm able to login from the build in webserver.
below is my connection string

<connectionStrings>
<remove name="LocalSqlServer" />
<add name="LocalSqlServer" connectionString="Data Source=NEMO;Initial
Catalog=TestDB;Integrated Security=false; User ID=test password=test;"
providerName="System.Data.SqlClient" />
</connectionStrings>

What gives? Is there anything in the IIS 5.1 that I need to configure?

thanks.

Apr 12 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.