By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,201 Members | 920 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,201 IT Pros & Developers. It's quick & easy.

Error connecting to SQLExpress 2005 locally (error: 26 - Error Locating Server/Instance Specified)

P: n/a
Hello,

I'm a newbie here and was wondering anyone could help me with this.

I have a simple ASP.NET 2 web application running perfectly fine with
IIS and SQLServerExpress installed locally on my WinXP as a testing
server (I created the app in Visual Studio.NET 2005).

When deploying this app on the production server (running Win2000
Server, IIS and SQLServerExpress 2005), I'm getting the following
message when calling an aspx data-bound page from a browser:

An error has occurred while establishing a connection to the server.
When connecting to SQL Server 2005, this failure may be caused by the
fact that under the default settings SQL Server does not allow remote
connections. (provider: SQL Network Interfaces, error: 26 - Error
Locating Server/Instance Specified)

On the production server, I have the SQLServerExpress installed locally
on C: drive and the database is located on D: drive (on the same
directory as the app).

Connection string used in the webconfig file:
connectionString="Server=SERVERNAME\SQLEXPRESS;Att achDbFilename=D:\Inetpub\App_Data\registration.mdf ;Database=registration;Trusted_Connection=yes;"
providerName="System.Data.SqlClient"

Does anyone know how to solve this issue? Any help would be greatly
appreciated.

Thanks,
Harry

Mar 27 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Networking protocols are disabled by default in SQL Server Express.

If someone simply installs Express and chooses all the defaults, SQL Server Express will only
be able to have connections originating on the local machine where SQL Server is installed.

You need to expressly enable networking protocols on the production server.

Follow the instructions outlined at :

http://blogs.msdn.com/sqlexpress/arc...05/415084.aspx
and
http://forums.microsoft.com/MSDN/Sho...71795&SiteID=1


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"hfk0" <he**@infoventures.com> wrote in message
news:11**********************@z34g2000cwc.googlegr oups.com...
Hello,

I'm a newbie here and was wondering anyone could help me with this.

I have a simple ASP.NET 2 web application running perfectly fine with
IIS and SQLServerExpress installed locally on my WinXP as a testing
server (I created the app in Visual Studio.NET 2005).

When deploying this app on the production server (running Win2000
Server, IIS and SQLServerExpress 2005), I'm getting the following
message when calling an aspx data-bound page from a browser:

An error has occurred while establishing a connection to the server.
When connecting to SQL Server 2005, this failure may be caused by the
fact that under the default settings SQL Server does not allow remote
connections. (provider: SQL Network Interfaces, error: 26 - Error
Locating Server/Instance Specified)

On the production server, I have the SQLServerExpress installed locally
on C: drive and the database is located on D: drive (on the same
directory as the app).

Connection string used in the webconfig file:
connectionString="Server=SERVERNAME\SQLEXPRESS;Att achDbFilename=D:\Inetpub\App_Data\registration.mdf ;Database=registration;Trusted_Connection=yes;"
providerName="System.Data.SqlClient"

Does anyone know how to solve this issue? Any help would be greatly
appreciated.

Thanks,
Harry

Mar 27 '06 #2

P: n/a
Hi Juan,

I did enable TCP and name pipes for both local and remote connections,
but still no luck.

I've searched all posts related to this issue in this group but still
haven't found a solution yet.

I'm only using windows authentication on the production server and I
can't even access it there, let alone remotely. Could it be that I'm
missing something on the connection string? I've also allowed
permission to everyone (just for the sake of testing it) on the folder
where the database resides, which is on drive D:. Could this be a
problem as well?

Mar 27 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.