469,363 Members | 2,484 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,363 developers. It's quick & easy.

copyright symbol in web.config

How can I add a copyright symbol to a web.config file? I cannot use the © or
char(169) statements, I need to pass the string onto another application.

The following works on Window XP Professional, IIS 5.1, but fails on Windows
Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value="© 2006 Tele Atlas, Rel. 07/2005."></add>


I suspect the utf-8 encoding is causing the problem, but have not been able
to change to utf-16 or us-ascii with any success.

Thanks, Richard

Mar 7 '06 #1
9 5727
How about: &copy;

"moWhite" <mo*****@discussions.microsoft.com> wrote in message
news:01**********************************@microsof t.com...
How can I add a copyright symbol to a web.config file? I cannot use the
or
char(169) statements, I need to pass the string onto another application.

The following works on Window XP Professional, IIS 5.1, but fails on
Windows
Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value=" 2006 Tele Atlas, Rel. 07/2005."></add>
.

I suspect the utf-8 encoding is causing the problem, but have not been
able
to change to utf-16 or us-ascii with any success.

Thanks, Richard

Mar 7 '06 #2
Nope. I should have included © in my list with © and char(169). (c) doesn't
work for my marketing folk either.

Any "extended" character would probably suffer the same problem; not just
the copyright symbol.

Richard

"Scott M." wrote:
How about: ©

"moWhite" <mo*****@discussions.microsoft.com> wrote in message
news:01**********************************@microsof t.com...
How can I add a copyright symbol to a web.config file? I cannot use the ©
or
char(169) statements, I need to pass the string onto another application.

The following works on Window XP Professional, IIS 5.1, but fails on
Windows
Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value="© 2006 Tele Atlas, Rel. 07/2005."></add>
.

I suspect the utf-8 encoding is causing the problem, but have not been
able
to change to utf-16 or us-ascii with any success.

Thanks, Richard


Mar 7 '06 #3
How about

value="&#xA9; 2006 Tele Atlas, Rel. 07/2005."

OR

value="© 2006 Tele Atlas, Rel. 07/2005."

HTH,
Stephen
"moWhite" <mo*****@discussions.microsoft.com> wrote in message
news:01**********************************@microsof t.com...
How can I add a copyright symbol to a web.config file? I cannot use the
or
char(169) statements, I need to pass the string onto another application.

The following works on Window XP Professional, IIS 5.1, but fails on
Windows
Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value=" 2006 Tele Atlas, Rel. 07/2005."></add>
.

I suspect the utf-8 encoding is causing the problem, but have not been
able
to change to utf-16 or us-ascii with any success.

Thanks, Richard

Mar 8 '06 #4
Thus wrote moWhite,
How can I add a copyright symbol to a web.config file? I cannot use
the or char(169) statements, I need to pass the string onto another
application.

The following works on Window XP Professional, IIS 5.1, but fails on
Windows Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value=" 2006 Tele Atlas, Rel. 07/2005."></add>

I suspect the utf-8 encoding is causing the problem, but have not been
able to change to utf-16 or us-ascii with any success.


is a Unicode character, so UTF-8 cannot be the problem. Do you really save
the web.config as UTF-8?

Cheers,
--
Joerg Jooss
ne********@joergjooss.de
Mar 8 '06 #5
Thanks for the response. I tried © © and get the same web config error. I'm
assuming that ੩ would give the same result.

Has anyone been able to get any special character in a web.config with
encoding set to utf-8?

Richard

"Stephen Ahn" wrote:
How about

value="© 2006 Tele Atlas, Rel. 07/2005."

OR

value="© 2006 Tele Atlas, Rel. 07/2005."

HTH,
Stephen
"moWhite" <mo*****@discussions.microsoft.com> wrote in message
news:01**********************************@microsof t.com...
How can I add a copyright symbol to a web.config file? I cannot use the ©
or
char(169) statements, I need to pass the string onto another application.

The following works on Window XP Professional, IIS 5.1, but fails on
Windows
Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value="© 2006 Tele Atlas, Rel. 07/2005."></add>
.

I suspect the utf-8 encoding is causing the problem, but have not been
able
to change to utf-16 or us-ascii with any success.

Thanks, Richard


Mar 8 '06 #6
I'm not sure what you mean by "save the web.config as UTF-8". I'm setting
the encoding attribute to utf-8 in the xml declaration, but I use either
notepad or VS 2003 IDE to edit and save the actual file. I would assume that
its a dos or windows text file. The copyright symbol © shows up fine in the
actual file.

Richard

"Joerg Jooss" wrote:
Thus wrote moWhite,
How can I add a copyright symbol to a web.config file? I cannot use
the © or char(169) statements, I need to pass the string onto another
application.

The following works on Window XP Professional, IIS 5.1, but fails on
Windows Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value="© 2006 Tele Atlas, Rel. 07/2005."></add>

I suspect the utf-8 encoding is causing the problem, but have not been
able to change to utf-16 or us-ascii with any success.


© is a Unicode character, so UTF-8 cannot be the problem. Do you really save
the web.config as UTF-8?

Cheers,
--
Joerg Jooss
ne********@joergjooss.de

Mar 8 '06 #7
Thus wrote moWhite,
I'm not sure what you mean by "save the web.config as UTF-8". I'm
setting the encoding attribute to utf-8 in the xml declaration, but I
use either notepad or VS 2003 IDE to edit and save the actual file. I
would assume that its a dos or windows text file. The copyright
symbol shows up fine in the actual file.


Simply setting an XML declaration with encoding attribute doesn't mean the
file actual uses that encoding. In Notepad, you can select the encoding in
the Save As dialog. In VS2005, you can select the encoding under File->Advanced
Save Options.

Cheers,
--
Joerg Jooss
ne********@joergjooss.de
Mar 8 '06 #8
You are exactly correct. I use a file compare program to compare my web
config files on various servers and keep them in sync. It changes the
encoding to ANSI. I've made the correction and am no longer failing on the
copyright symbol. This has been a problem for months with zero solution.

Thanks, Richard
"Joerg Jooss" wrote:
Thus wrote moWhite,
I'm not sure what you mean by "save the web.config as UTF-8". I'm
setting the encoding attribute to utf-8 in the xml declaration, but I
use either notepad or VS 2003 IDE to edit and save the actual file. I
would assume that its a dos or windows text file. The copyright
symbol © shows up fine in the actual file.


Simply setting an XML declaration with encoding attribute doesn't mean the
file actual uses that encoding. In Notepad, you can select the encoding in
the Save As dialog. In VS2005, you can select the encoding under File->Advanced
Save Options.

Cheers,
--
Joerg Jooss
ne********@joergjooss.de

Mar 8 '06 #9
Would using (c) as opposed to be an option?

....Just a thought.

Mar 8 '06 #10

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Eric Moors | last post: by
reply views Thread by Nemtos | last post: by
4 posts views Thread by Jacob | last post: by
5 posts views Thread by SalamElias | last post: by
5 posts views Thread by Stuart | last post: by
3 posts views Thread by Radith Silva | last post: by
1 post views Thread by vsp15584 | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.