471,578 Members | 1,455 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,578 software developers and data experts.

Deploying VWD Express App to IIS using SQL Express w/ Membership i

Okay, I'm 18 hours into this now and am at a loss. What I've done is create
an application on my local workstation using VWD Express using the
membership/roles provider and SQL Server Express configured for local
authentication. I have an aspnetdb database in my app_data folder configured
with several users. Everything works fine when I run the application from my
workstation.

I've tried several attempts to copy the app to my w23k server running sql
express and can't get it to run. I've created a virtual directory and
configured it to run ASP.NET 2.0. Then I've copied the files, including the
aspnetdb files and I still can not login. I've tried using the aspnet_reqsql
tool, but all that does is give me another aspnetdb database without any
information in it.

I've read about changing connection strings, application names, and changing
the account the database runs in from the NETWORK SERVICE ACCOUNT. I still
don't understand a lot of this. I'm primarily a sysadmin that's had to write
this application due to our vendor not being responsive. It's a simple app
that uses the membership/roles login features of ASP.NET 2.0 and some data
controls to allow various users the ability to view information from our
database.

I have complete control over the web server and can reinstall everything,
including the OS if need be. Heck I reinstalled SQL EXPRESS two times today.

I'm looking for a step by step article, whitepaper, etc. on how to deploy a
VWD Express application that uses the membership/roles features in ASP.NET
2.0 and SQL Server Express 2005 with Windows Authentication to a Windows 2003
Server that has a default installation of SQL Server Express 2005 on it.

I can change primarily anything on the server, build it from scratch,
install anything on it. I just need to transfer my application to run on it.

It runs fine from the workstation.

Any help or links to such information would be most helpful.

Thanks in Advance,
Carl M.
St. Louis

PS A reasonable hourly fee is not out of the question. However if it's to
much I'll pay the MS fee of 295
Mar 1 '06 #1
3 1502

hi carl. did you ever get this resolved? i'm having the same exact
problem...been pulling my hair out for 3 days on it. the only advice
i've gotten is "you need to upgrade to sql server 2005 developer
edition", but that can't be right. i just can't imagine that this
system (vs2005, asp.net 2.0, membership, sql 2005 express) would only
work within a development environment. here's a thread i started at
the ASP.NET forums.

http://forums.asp.net/1222171/ShowPost.aspx

if you, or anyone has some practical advice on this...PLEASE send it my
way. Thanks!

--
dubious49
------------------------------------------------------------------------
Posted via http://www.codecomments.com
------------------------------------------------------------------------

Mar 11 '06 #2
No, I haven't resolved this. I've taken the login controls out and
restricted access via the firewall. However now the server is almost a waste
of money because it only serves this one application.

I've got a ton of things on my plate, here in a couple of weeks I have to
get it work for another project so I'll detail my trial and tribulations here.

BTW, the link didn't work. You can email me directly at c m i l l o s h (a
t) g m a i l (d o t) c o m

"dubious49" wrote:

hi carl. did you ever get this resolved? i'm having the same exact
problem...been pulling my hair out for 3 days on it. the only advice
i've gotten is "you need to upgrade to sql server 2005 developer
edition", but that can't be right. i just can't imagine that this
system (vs2005, asp.net 2.0, membership, sql 2005 express) would only
work within a development environment. here's a thread i started at
the ASP.NET forums.

http://forums.asp.net/1222171/ShowPost.aspx

if you, or anyone has some practical advice on this...PLEASE send it my
way. Thanks!

--
dubious49
------------------------------------------------------------------------
Posted via http://www.codecomments.com
------------------------------------------------------------------------

Mar 11 '06 #3
Any resolution for this? I'm also having the same problem, but would
like to retain the login functionality.

Mar 20 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by geek-y-guy | last post: by
1 post views Thread by OGG | last post: by
2 posts views Thread by =?Utf-8?B?SXbDoW4gU2Fpbno=?= | last post: by
reply views Thread by XIAOLAOHU | last post: by
reply views Thread by leo001 | last post: by
reply views Thread by lumer26 | last post: by
reply views Thread by Vinnie | last post: by
1 post views Thread by lumer26 | last post: by
reply views Thread by lumer26 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.