471,071 Members | 1,516 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,071 software developers and data experts.

System.UnauthorizedAccessException: Access to the path ...Temporary ASP.NET Files.. is denied.

Hi all,

I have developed an application in VS .NET 2003 (framework 1.1) on a XP
platform. It is working fine in that PC.

Now, I setup new PC with same configuration for another develper.
Whenever I execute the application it gives, Unauthorize Exception
error and it's not execting the application property.

The Error message is as follows,
================================================== =============

Server Error in '/myApp' Application.
--------------------------------------------------------------------------------

Access to the path
"C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temp orary ASP.NET
Files\myApp\dc572ed2\cf08d790\hash.web" is denied.
Description: An unhandled exception occurred during the execution of
the current web request. Please review the stack trace for more
information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the
path "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temp orary ASP.NET
Files\myApp\dc572ed2\cf08d790\hash.web" is denied.

ASP.NET is not authorized to access the requested resource. Consider
granting access rights to the resource to the ASP.NET request identity.
ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS
5 or Network Service on IIS 6) that is used if the application is not
impersonating. If the application is impersonating via <identity
impersonate="true"/>, the identity will be the anonymous user
(typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET write access to a file, right-click the file in
Explorer, choose "Properties" and select the Security tab. Click "Add"
to add the appropriate user or group. Highlight the ASP.NET account,
and check the boxes for the desired access.
================================================== =============

During the investigation I found that there is no folder called myApp
created under the "Temporary ASP .NET Files". I have set full privilege
to the ASPNET user account and to the Developer.

Nothing has been changed in the Web.Config also.

How can I solve the problem? TIA.

Feb 24 '06 #1
4 28645
Hi Anbu,
Go to the C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Tempo rary ASP.NET
Files
And give the folder "ASPNET acct" at leasr read and right permissions.
Since you are using WIN XP you might not see the SECURITY OPTIONS if you
right clcik
If thats the case just go to TOOLS in your Explorer >Folder Options > View
and uncheck "Use simple file sharing(recommended)"
Hope that helps
Patrick
"Anbu" <t_**************@yahoo.co.in> wrote in message
news:11**********************@v46g2000cwv.googlegr oups.com...
Hi all,

I have developed an application in VS .NET 2003 (framework 1.1) on a XP
platform. It is working fine in that PC.

Now, I setup new PC with same configuration for another develper.
Whenever I execute the application it gives, Unauthorize Exception
error and it's not execting the application property.

The Error message is as follows,
================================================== =============

Server Error in '/myApp' Application.
--------------------------------------------------------------------------------

Access to the path
"C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temp orary ASP.NET
Files\myApp\dc572ed2\cf08d790\hash.web" is denied.
Description: An unhandled exception occurred during the execution of
the current web request. Please review the stack trace for more
information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the
path "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temp orary ASP.NET
Files\myApp\dc572ed2\cf08d790\hash.web" is denied.

ASP.NET is not authorized to access the requested resource. Consider
granting access rights to the resource to the ASP.NET request identity.
ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS
5 or Network Service on IIS 6) that is used if the application is not
impersonating. If the application is impersonating via <identity
impersonate="true"/>, the identity will be the anonymous user
(typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET write access to a file, right-click the file in
Explorer, choose "Properties" and select the Security tab. Click "Add"
to add the appropriate user or group. Highlight the ASP.NET account,
and check the boxes for the desired access.
================================================== =============

During the investigation I found that there is no folder called myApp
created under the "Temporary ASP .NET Files". I have set full privilege
to the ASPNET user account and to the Developer.

Nothing has been changed in the Web.Config also.

How can I solve the problem? TIA.

Feb 25 '06 #2
Patrick,

Thanks for your reply. I was not working properly. I'm replacing the
fresh image on the system, to try from scratch.

Feb 27 '06 #3
All the privileges given to the user ASPNET and the developer. No idea
why it's not working...

Even I tried to replace the system with the new image as in the
previous post. I desperately require some help

Feb 27 '06 #4
Since I used impersonate=true, i had to set access privilege to the
impersonated user. It's working fine now.

Mar 9 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by genc_ymeri | last post: by
7 posts views Thread by Peter Afonin | last post: by
1 post views Thread by nygiantswin2005 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.