471,092 Members | 1,151 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,092 software developers and data experts.

Configuration issue: WAT fails to create aspnetdb.mdf database!

Problem summary:
Web Site Admin Tool is not generating the application services database
(aspnetdb.mdf) in a SS 2005 only environment; i.e. The DB is not found under
the app_data directory.

The Question:
What configuration am I missing to allow WAT to create the application
services database?

Scenarios I tried:
On a dedicated developer workstation running WXP w/ SP2, I installed
- SQL Server '05 (without SQLEXPRESS)
- vStudio '05

-- SS 2005 is running and has no problems
-- IIS is running and has no problems

Logged in as a member of the Administrators group, within vStudio 2005,
I try to run the Web Site Admin Tool (WAT), the site opens. Next when I
click on the SECURITY tab, I get the following error:
"Unable to connect to SQL Server database"

Clicking the [Choose Data Source] button takes me to the PROVIDER tab, and
when I click on either of the two choices, I get the same error message:
"Could not establish a connection to the database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to create and
configure the database, and then return to this tool to set the provider."

1) Running the aspnet_regsql tool as a wizard and specifying:
- YLW4WSDVLPR2 -- the localserver name
- aspnetdb for the database name
the utility completes successfully.

Trying again to use the Web Site Admin Tool, the database is not to be found
under the app_data diretory and the same error senario unforlds.

2) Running the aspnet_regsql tool from the command line as:
aspnet_regsql.exe -E -S localhost -A all
comletes successfully, but the DB is not to be found.

Additional config info:
The machine.config connection string was changed to refer to the correct SS
'05
e.g.
".\SQLEXPRESS" was changed to "YLW4WSDVLPR2"
"User Instance=True" is removed

The vStudio application's web.config connection string is empty.

Any suggestions???? will be appreciated
(found nothing relevant in this or other newgroup)
Feb 8 '06 #1
0 1787

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by te goody | last post: by
reply views Thread by RAM | last post: by
10 posts views Thread by Pete | last post: by
4 posts views Thread by SAL | last post: by
6 posts views Thread by Mr. X. | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.