By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,886 Members | 1,107 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,886 IT Pros & Developers. It's quick & easy.

Website Administration Tool not working from published application

P: n/a
When I try to run the Website Administration Tool from my published
application using

http://localhost/myapp/webadmin.axd

I am getting a "resource not found" error message. I can use the Admin
tool from the IDE however.

I noticed some people referring to a directory called
c:\Inetpub\wwwroot\aspnet_webadmin\, which i do not have on my system.

I do not have that, but DO have a
C:\Inetpub\wwwroot\aspnet_client\system_web\2_0_50 727

I ran a iisnet_regiis to repair, but still cannot use the Website Admin
tool.

Anyone know what I am doing wrong?

Thanks,

-M

Feb 1 '06 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Beuller? Beueller?

Feb 5 '06 #2

P: n/a
I have this exact same problem. Can someone please respond?

MSDN says a simple aspnet_regiis -i will resolve any missing file
relating to the aspnet_webadmin directory, but this does not work on my
xp pro system. Maybe it only works on a system utilizing iis 6.0 (i.e.
Windows Server 2003)?

Feb 18 '06 #3

P: n/a
I had the same problem, but found the solution.

I'm running 2k5 Team Edition, with a sql 2000 database in the back and IE7
beta 2 in the front. I made two mistakes. The first mistake was using the
IE7 beta. It would time out rather than show me the helpful error messages
that the Web App Admin Tool shows when it cannot connect to the database.
Uninstalling IE7 allowed me to troubleshoot these errors. The second mistake
was not installing SQL 2k5 Express. Why is that a mistake? Because the
default provider is configured for sql 2k5 and is incompatible with sql 2k.
It was also a mistake because it is near friggin impossible to add an effing
provider. If you know how to add a new provider that supports sql 2k, then
you aren't reading this. Anyhow, to get ASPNET 2.0 working with your current
instance of sql 2000, you need to first get your sql server configured
correctly. To do this, do the aspnet_regsql.exe thing. You'll need to run
the correct one, which is accessible when you run the "Visual Studio 2005
command prompt". Its under Proggy files, Visual studio 2005, Visual studio
tools. Once you've done that, you have to trick the Web App Admin tool to
use this database rather than the nonexistant 2k5 express database (how
incredibly goddamn stupid is that?). Create a connection string to your Sql
2000 database (make sure it works!), and add the following section to your
website's web.config file:

<connectionStrings>
<remove name="LocalSqlServer"/>
<add name="LocalSqlServer" connectionString="PUT YOUR CONNECTION STRING
HERE!" />
</connectionStrings>

Notice that you nuke the connection string that the default provider uses,
then replace it with your connection string. This section should be added
right after the <configuration xmlns="...> line at the top of web.config.
Once you've done this, save web.config and attempt to use the Web Application
Tool again. It should work! I'd like to thank Microsoft for giving us all
these great new features in 2.0, and damn them to hell for turning web apps
from just another application (add a DLL project to your web app solution?
No problem! Namespaces in your classes? No problem!) into some weird
bastardized child-monster with app_code directories and crippled integration
into the IDE (I have to use a TOOL in a WEBPAGE to change settings in my
APPLICATION???) and solutions that are projects...
"mm****@tampabay.rr.com" wrote:
I have this exact same problem. Can someone please respond?

MSDN says a simple aspnet_regiis -i will resolve any missing file
relating to the aspnet_webadmin directory, but this does not work on my
xp pro system. Maybe it only works on a system utilizing iis 6.0 (i.e.
Windows Server 2003)?

Apr 11 '06 #4

P: n/a
re:
If you know how to add a new provider that supports sql 2k, then you aren't reading this.
It might be worthwhile for you to step through Scott Guthrie's tutorial that shows you how to
configure ASP.NET to use Membership, Role Management, and Personalization services with
SQL Server 2000 instead of SQL Express

http://weblogs.asp.net/scottgu/archi...25/423703.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"William Sullivan" <Wi*************@discussions.microsoft.com> wrote in message
news:E0**********************************@microsof t.com...I had the same problem, but found the solution.

I'm running 2k5 Team Edition, with a sql 2000 database in the back and IE7
beta 2 in the front. I made two mistakes. The first mistake was using the
IE7 beta. It would time out rather than show me the helpful error messages
that the Web App Admin Tool shows when it cannot connect to the database.
Uninstalling IE7 allowed me to troubleshoot these errors. The second mistake
was not installing SQL 2k5 Express. Why is that a mistake? Because the
default provider is configured for sql 2k5 and is incompatible with sql 2k.
It was also a mistake because it is near friggin impossible to add an effing
provider. If you know how to add a new provider that supports sql 2k, then
you aren't reading this. Anyhow, to get ASPNET 2.0 working with your current
instance of sql 2000, you need to first get your sql server configured
correctly. To do this, do the aspnet_regsql.exe thing. You'll need to run
the correct one, which is accessible when you run the "Visual Studio 2005
command prompt". Its under Proggy files, Visual studio 2005, Visual studio
tools. Once you've done that, you have to trick the Web App Admin tool to
use this database rather than the nonexistant 2k5 express database (how
incredibly goddamn stupid is that?). Create a connection string to your Sql
2000 database (make sure it works!), and add the following section to your
website's web.config file:

<connectionStrings>
<remove name="LocalSqlServer"/>
<add name="LocalSqlServer" connectionString="PUT YOUR CONNECTION STRING
HERE!" />
</connectionStrings>

Notice that you nuke the connection string that the default provider uses,
then replace it with your connection string. This section should be added
right after the <configuration xmlns="...> line at the top of web.config.
Once you've done this, save web.config and attempt to use the Web Application
Tool again. It should work! I'd like to thank Microsoft for giving us all
these great new features in 2.0, and damn them to hell for turning web apps
from just another application (add a DLL project to your web app solution?
No problem! Namespaces in your classes? No problem!) into some weird
bastardized child-monster with app_code directories and crippled integration
into the IDE (I have to use a TOOL in a WEBPAGE to change settings in my
APPLICATION???) and solutions that are projects...
"mm****@tampabay.rr.com" wrote:
I have this exact same problem. Can someone please respond?

MSDN says a simple aspnet_regiis -i will resolve any missing file
relating to the aspnet_webadmin directory, but this does not work on my
xp pro system. Maybe it only works on a system utilizing iis 6.0 (i.e.
Windows Server 2003)?

Apr 11 '06 #5

P: n/a
Hi all,

Just want to comment on this thread.

Seems like every discussion about this matter (setting up DB provider for
membership) and all the samples/references given by some MVPs always
refering to LOCALHOST in their solution. Aren't they all forget that people
build an ASP.NET appl are plans to host their appl in an commercial hosting
provider, whom most of them can't afford the fancy of dedicated servers -
most of them hosts on shared hosting, like me, so they just CAN'T touch or
tweak or reconfigure the IIS, or run the aspnet_regsql.exe utility from
within their Control Panel.

Anyone of you know - or even developed - of an ASP.NET 2.0 application, runs
on the shared hosting, implemented .NET 2.0's built-in
Authentication/authorization classes 'right-out-of-the-box' runs on the
shared hosting? If so, that I might humbly (:) request your advice please.

I built one. It works perfectly. Every thing just runs smoothly, the Login
control, the new-user registration form, change password, login view, role
management. Set up all my roles and authorizations with that handy 'Website
Administration Tool'. I'm so happy. Man, I have to admit, I save a lot of
tedious works of working with that security measures in .NET 2.0 than I was
using .NET 1.1.

Then come the time to upload all those hardwork to my production server,
which is a shared hosting. And I just to face the real thing that it's not
working just like on my development machine.
I then posted this issue on forums like this (where MVPs and ASP.NET
hotshots gathers and give their valuable advice to novices and newbies like
me...), never got a definite answer that pinpoint my error or ways how to
solve the problem. Funny... coz those hotshots can answers and advices some
more advanced topics/problems easily. but just passed out on my questions.

Just a little bit dissapointed though, but still got my hope because of all
investments I made in this 6 months on this new technology.

It's just reminds me on how easy it is to do things like these with classic
ASP and with tools like Dreamweaver MX. A TRULY Drag-and-drop development
tool available that even VS2005 can't beat.

Regards,
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:e8**************@TK2MSFTNGP05.phx.gbl...
re:
If you know how to add a new provider that supports sql 2k, then you
aren't reading this.


It might be worthwhile for you to step through Scott Guthrie's tutorial
that shows you how to
configure ASP.NET to use Membership, Role Management, and Personalization
services with
SQL Server 2000 instead of SQL Express

http://weblogs.asp.net/scottgu/archi...25/423703.aspx

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"William Sullivan" <Wi*************@discussions.microsoft.com> wrote in
message news:E0**********************************@microsof t.com...
I had the same problem, but found the solution.

I'm running 2k5 Team Edition, with a sql 2000 database in the back and
IE7
beta 2 in the front. I made two mistakes. The first mistake was using
the
IE7 beta. It would time out rather than show me the helpful error
messages
that the Web App Admin Tool shows when it cannot connect to the database.
Uninstalling IE7 allowed me to troubleshoot these errors. The second
mistake
was not installing SQL 2k5 Express. Why is that a mistake? Because the
default provider is configured for sql 2k5 and is incompatible with sql
2k.
It was also a mistake because it is near friggin impossible to add an
effing
provider. If you know how to add a new provider that supports sql 2k,
then
you aren't reading this. Anyhow, to get ASPNET 2.0 working with your
current
instance of sql 2000, you need to first get your sql server configured
correctly. To do this, do the aspnet_regsql.exe thing. You'll need to
run
the correct one, which is accessible when you run the "Visual Studio 2005
command prompt". Its under Proggy files, Visual studio 2005, Visual
studio
tools. Once you've done that, you have to trick the Web App Admin tool
to
use this database rather than the nonexistant 2k5 express database (how
incredibly goddamn stupid is that?). Create a connection string to your
Sql
2000 database (make sure it works!), and add the following section to
your
website's web.config file:

<connectionStrings>
<remove name="LocalSqlServer"/>
<add name="LocalSqlServer" connectionString="PUT YOUR CONNECTION STRING
HERE!" />
</connectionStrings>

Notice that you nuke the connection string that the default provider
uses,
then replace it with your connection string. This section should be
added
right after the <configuration xmlns="...> line at the top of web.config.
Once you've done this, save web.config and attempt to use the Web
Application
Tool again. It should work! I'd like to thank Microsoft for giving us
all
these great new features in 2.0, and damn them to hell for turning web
apps
from just another application (add a DLL project to your web app
solution?
No problem! Namespaces in your classes? No problem!) into some weird
bastardized child-monster with app_code directories and crippled
integration
into the IDE (I have to use a TOOL in a WEBPAGE to change settings in my
APPLICATION???) and solutions that are projects...


"mm****@tampabay.rr.com" wrote:
I have this exact same problem. Can someone please respond?

MSDN says a simple aspnet_regiis -i will resolve any missing file
relating to the aspnet_webadmin directory, but this does not work on my
xp pro system. Maybe it only works on a system utilizing iis 6.0 (i.e.
Windows Server 2003)?


Apr 12 '06 #6

P: n/a
The truth is that after your website it deployed the Web Admin Tool
will not longer work. This is by design. Imagine if some anonymous
person can log on to the Web Admin tool and make configuration changes
on your website. So, the Web Admin Tool was design to give you an easy
way to configure you website during development. The Admin tool itself
uses classes in the .NET framework to make changes to your web.config.
This is a free tool provided my Microsoft. However, if you want to do
certain admin suff like add users, add roles, switch providers, etc.
You have to build your own admin section of your website just like you
did before using ASP and ASP 1.1. The only difference is that this
time, you don't have to write the business logic, and data access logic
code to to access the database or configuration file in order to make
these changes. You should strive to use the built-in .NET framework
classes provide by .NET 2.0 like the Membership and Roles API, Profiles
API, etc to manage your web applicaiton.

Apr 12 '06 #7

P: n/a

Seems to me a lot of people would be in this situation and re-inventing the
wheel so to speak to solve this problem. Does anyone have a basic set of web
pages that do what the security pages do in the web administration tool so we
don't have to roll our own?

Or perhaps a writeup on how to adapt the pages and components in the
security folder for use on a remote server?

I pushed the ASP.NETWebAdminFiles folder up to the server as a subfolder on
my site and tried to load the security.aspx page to no avail, so come
coaching would be helpful. We're all on deadlines and looking for shortcuts!
Thanks.
"tdavisjr" wrote:
The truth is that after your website it deployed the Web Admin Tool
will not longer work. This is by design. Imagine if some anonymous
person can log on to the Web Admin tool and make configuration changes
on your website. So, the Web Admin Tool was design to give you an easy
way to configure you website during development. The Admin tool itself
uses classes in the .NET framework to make changes to your web.config.
This is a free tool provided my Microsoft. However, if you want to do
certain admin suff like add users, add roles, switch providers, etc.
You have to build your own admin section of your website just like you
did before using ASP and ASP 1.1. The only difference is that this
time, you don't have to write the business logic, and data access logic
code to to access the database or configuration file in order to make
these changes. You should strive to use the built-in .NET framework
classes provide by .NET 2.0 like the Membership and Roles API, Profiles
API, etc to manage your web applicaiton.

Jun 18 '06 #8

This discussion thread is closed

Replies have been disabled for this discussion.