468,272 Members | 1,956 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,272 developers. It's quick & easy.

ASP.Net prefers Firefox?

Jim
I had Firefox set as my default browser, but I wanted to change back to IE
when testing my webservices.

Easy enough....(in IE) Tools>Internet Options>Programs then check "Internet
Explorer should check to see whether it is the default browser". I
restarted IE and responded "Yes" to whether to make IE the default browser.

I then started Firefox and selected "No" when it asked if it should be the
default browser.

I restarted IE again and was not asked if it should be the default browser,
because it was already set to be the default browser by the preceeding
steps.

The problem is that ASP.Net 2.0 starts Firefox when testing webservices.
Why?

I would uninstall Firefox, but I really like some of the plugins available
with Firefox that have no equivilent in IE and that shouldn't be needed to
make VS 2005 behave.

To test whether IE was really the new default browser, I clicked Start>Run
and typed in the URL of my website. IE started as expected.

I again ran the webservice from VS 2005 and it started Firefox.

I even restarted VS 2005 and it still starts Firefox when testing the
webservice.

Anybody seen this before? Any ideas?

Jim

Jan 14 '06 #1
3 1176
When you right-click on an aspx file within the IDE and select "start in
browser..."(or something like that), a dialog popups allow you to select
which browser to open with.

Search for the "Set as default" button on the dialog. Select "Internet
Explorer" then press it.

"Jim" <re***@groups.please> 撰寫於郵件新聞:lm*******************@bignews5.bell south.net...
I had Firefox set as my default browser, but I wanted to change back to IE
when testing my webservices.

Easy enough....(in IE) Tools>Internet Options>Programs then check
"Internet Explorer should check to see whether it is the default browser".
I restarted IE and responded "Yes" to whether to make IE the default
browser.

I then started Firefox and selected "No" when it asked if it should be the
default browser.

I restarted IE again and was not asked if it should be the default
browser, because it was already set to be the default browser by the
preceeding steps.

The problem is that ASP.Net 2.0 starts Firefox when testing webservices.
Why?

I would uninstall Firefox, but I really like some of the plugins available
with Firefox that have no equivilent in IE and that shouldn't be needed to
make VS 2005 behave.

To test whether IE was really the new default browser, I clicked Start>Run
and typed in the URL of my website. IE started as expected.

I again ran the webservice from VS 2005 and it started Firefox.

I even restarted VS 2005 and it still starts Firefox when testing the
webservice.

Anybody seen this before? Any ideas?

Jim

Jan 14 '06 #2
Jim

"Lau Lei Cheong" <le****@yehoo.com.hk> wrote in message
news:uL**************@tk2msftngp13.phx.gbl...
When you right-click on an aspx file within the IDE and select "start in
browser..."(or something like that), a dialog popups allow you to select
which browser to open with.

Search for the "Set as default" button on the dialog. Select "Internet
Explorer" then press it.


Right-click the ASMX, choose "Browse with..." and the dialog box that you
mentioned pops up which allows you to set the default browser for the ASMX
files.

FYI....although I uninstalled Firefox, it still shows as an option in this
dialog box.

Thanks for the help!

Jim
Jan 14 '06 #3
Yes. That's an option stored in VS.NET IDE, and given there's not that many
people with VS.NET installed(let alone choosing it as default browser in
IDE), Firefox have no way to know it's existance.

So uninstalling Firefox certainly won't remove the reference.

"Jim" <re***@groups.please> 撰寫於郵件新聞:uH*******************@bignews5.bell south.net...

"Lau Lei Cheong" <le****@yehoo.com.hk> wrote in message
news:uL**************@tk2msftngp13.phx.gbl...
When you right-click on an aspx file within the IDE and select "start in
browser..."(or something like that), a dialog popups allow you to select
which browser to open with.

Search for the "Set as default" button on the dialog. Select "Internet
Explorer" then press it.


Right-click the ASMX, choose "Browse with..." and the dialog box that you
mentioned pops up which allows you to set the default browser for the ASMX
files.

FYI....although I uninstalled Firefox, it still shows as an option in this
dialog box.

Thanks for the help!

Jim

Jan 15 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.

By using this site, you agree to our Privacy Policy and Terms of Use.