By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,965 Members | 1,417 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,965 IT Pros & Developers. It's quick & easy.

disabling html validation does not seem to stck

P: n/a
Hi,

I suddenly started getting a lot of errors from html validation (some CSS)

so I followed the following instructions to disable it.

If you'd rather not have these types of HTML validation errors show up in
your error-list, you can disable this functionality by selecting the
Tools->Options menu item in VS or Visual Web Developer. Select the
TextEditor->Html->Validation tree option in the left-hand side of the
options window, and uncheck the "Show Errors" checkbox:

But ... the problem is that unclicking check does not seem to stick.

When I click on the page, "show errors" check box checks itself on, and I
cannot get to the design mode.

How can I get visual web developer to stop checking for validation errors???

Any help is deeply appreciated.

Thanks

Nalaka


Jan 12 '06 #1
Share this Question
Share on Google+
12 Replies


P: n/a
and also... yesterday it all seem ok....
And today suddenly VWD desided to check on this page.

I tested... dragging and dropping and image to the designer.
But in the html view... it complains that the "img" tag is missing an "alt"
tag.

Seems like 1. drag-and-drop, and then 2.validation are working on two
different validation models.

1. How can I bring both to the latest validation requiremnts?
2. How do I get the old ones to ignore validation?
Thanks a bunch
Nalaka

"Nalaka" <na******@nospam.nospam> wrote in message
news:us**************@TK2MSFTNGP09.phx.gbl...
Hi,

I suddenly started getting a lot of errors from html validation (some CSS)

so I followed the following instructions to disable it.

If you'd rather not have these types of HTML validation errors show up in
your error-list, you can disable this functionality by selecting the
Tools->Options menu item in VS or Visual Web Developer. Select the
TextEditor->Html->Validation tree option in the left-hand side of the
options window, and uncheck the "Show Errors" checkbox:

But ... the problem is that unclicking check does not seem to stick.

When I click on the page, "show errors" check box checks itself on, and I
cannot get to the design mode.

How can I get visual web developer to stop checking for validation
errors???

Any help is deeply appreciated.

Thanks

Nalaka


Jan 12 '06 #2

P: n/a
Hi...
Also html validation complains about colors like royalblue...
How can I add these new colors to the css... ask it to ignore colors.
Thanks again
Nalaka
"Nalaka" <na******@nospam.nospam> wrote in message
news:us**************@TK2MSFTNGP09.phx.gbl...
Hi,

I suddenly started getting a lot of errors from html validation (some CSS)

so I followed the following instructions to disable it.

If you'd rather not have these types of HTML validation errors show up in
your error-list, you can disable this functionality by selecting the
Tools->Options menu item in VS or Visual Web Developer. Select the
TextEditor->Html->Validation tree option in the left-hand side of the
options window, and uncheck the "Show Errors" checkbox:

But ... the problem is that unclicking check does not seem to stick.

When I click on the page, "show errors" check box checks itself on, and I
cannot get to the design mode.

How can I get visual web developer to stop checking for validation
errors???

Any help is deeply appreciated.

Thanks

Nalaka


Jan 12 '06 #3

P: n/a
Hi Nalaka,

Welcome.
For the VS 2005 ASP.NET html editor, it now includes not only HTML content
validating , but also the Accessiblity checking, so not sure whether the
warning and errors also indicate some accessiblity checking, you can right
click the page in solution explorer and choose the "Check Accessibility..."
item to view the accessibility setting... Also for HTML checking, what's
your current setting , IE6 or XHTML .... ? Seems my local vs 2005
environment default to IE6 and won't be reset by the changes in IDE's html
editor...
Also, you can consider copy the project on some box which has vs 2005 to
check the behavior, if that works ok, you can try comparing the settings...

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Thu, 12 Jan 2006 12:03:29 -0800
| Lines: 56
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370429
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi...
| Also html validation complains about colors like royalblue...
| How can I add these new colors to the css... ask it to ignore colors.
|
|
| Thanks again
| Nalaka
|
|
| "Nalaka" <na******@nospam.nospam> wrote in message
| news:us**************@TK2MSFTNGP09.phx.gbl...
| > Hi,
| >
| > I suddenly started getting a lot of errors from html validation (some
CSS)
| >
| > so I followed the following instructions to disable it.
| >
| > If you'd rather not have these types of HTML validation errors show up
in
| > your error-list, you can disable this functionality by selecting the
| > Tools->Options menu item in VS or Visual Web Developer. Select the
| > TextEditor->Html->Validation tree option in the left-hand side of the
| > options window, and uncheck the "Show Errors" checkbox:
| >
| >
| >
| >
| >
| > But ... the problem is that unclicking check does not seem to stick.
| >
| > When I click on the page, "show errors" check box checks itself on, and
I
| > cannot get to the design mode.
| >
| >
| >
| > How can I get visual web developer to stop checking for validation
| > errors???
| >
| >
| >
| >
| >
| > Any help is deeply appreciated.
| >
| >
| >
| > Thanks
| >
| > Nalaka
| >
| >
| >
| >
| >
| >
|
|
|

Jan 13 '06 #4

P: n/a
Thanks Steven,

After reading this link, I realized that I want VWD to tell me incorrect
markup.
http://msdn2.microsoft.com/en-us/library/f940516c.aspx

But let me swith to the "design mode" from the "Source mode".
VWD reports all these (HTML) inconsistancies as errors, and will not let me
swith to the design mode.
(project compiles fine)

1. How can I switch to the design mode, even when there are validation
checks?
2. Is there a way to downgrade such errors to Warnings?

Coping these pages to another environment did not help.
and no visible difference between ones that does not show errors and
these.... except for may be the file date.
Thanks
Nalaka



"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:Nk**************@TK2MSFTNGXA02.phx.gbl...
Hi Nalaka,

Welcome.
For the VS 2005 ASP.NET html editor, it now includes not only HTML content
validating , but also the Accessiblity checking, so not sure whether the
warning and errors also indicate some accessiblity checking, you can right
click the page in solution explorer and choose the "Check
Accessibility..."
item to view the accessibility setting... Also for HTML checking, what's
your current setting , IE6 or XHTML .... ? Seems my local vs 2005
environment default to IE6 and won't be reset by the changes in IDE's html
editor...
Also, you can consider copy the project on some box which has vs 2005 to
check the behavior, if that works ok, you can try comparing the
settings...

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Thu, 12 Jan 2006 12:03:29 -0800
| Lines: 56
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370429
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi...
| Also html validation complains about colors like royalblue...
| How can I add these new colors to the css... ask it to ignore colors.
|
|
| Thanks again
| Nalaka
|
|
| "Nalaka" <na******@nospam.nospam> wrote in message
| news:us**************@TK2MSFTNGP09.phx.gbl...
| > Hi,
| >
| > I suddenly started getting a lot of errors from html validation (some
CSS)
| >
| > so I followed the following instructions to disable it.
| >
| > If you'd rather not have these types of HTML validation errors show up
in
| > your error-list, you can disable this functionality by selecting the
| > Tools->Options menu item in VS or Visual Web Developer. Select the
| > TextEditor->Html->Validation tree option in the left-hand side of the
| > options window, and uncheck the "Show Errors" checkbox:
| >
| >
| >
| >
| >
| > But ... the problem is that unclicking check does not seem to stick.
| >
| > When I click on the page, "show errors" check box checks itself on,
and
I
| > cannot get to the design mode.
| >
| >
| >
| > How can I get visual web developer to stop checking for validation
| > errors???
| >
| >
| >
| >
| >
| > Any help is deeply appreciated.
| >
| >
| >
| > Thanks
| >
| > Nalaka
| >
| >
| >
| >
| >
| >
|
|
|

Jan 13 '06 #5

P: n/a
Hi,
For an example, now... following error now gets generated.
(But this is code generated by the VWD designer itself.)

Error 110 Validation (Internet Explorer 6): Element 'table' cannot be nested
within element 'span'.
Thanks
Nalaka

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:Nk**************@TK2MSFTNGXA02.phx.gbl...
Hi Nalaka,

Welcome.
For the VS 2005 ASP.NET html editor, it now includes not only HTML content
validating , but also the Accessiblity checking, so not sure whether the
warning and errors also indicate some accessiblity checking, you can right
click the page in solution explorer and choose the "Check
Accessibility..."
item to view the accessibility setting... Also for HTML checking, what's
your current setting , IE6 or XHTML .... ? Seems my local vs 2005
environment default to IE6 and won't be reset by the changes in IDE's html
editor...
Also, you can consider copy the project on some box which has vs 2005 to
check the behavior, if that works ok, you can try comparing the
settings...

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Thu, 12 Jan 2006 12:03:29 -0800
| Lines: 56
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370429
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi...
| Also html validation complains about colors like royalblue...
| How can I add these new colors to the css... ask it to ignore colors.
|
|
| Thanks again
| Nalaka
|
|
| "Nalaka" <na******@nospam.nospam> wrote in message
| news:us**************@TK2MSFTNGP09.phx.gbl...
| > Hi,
| >
| > I suddenly started getting a lot of errors from html validation (some
CSS)
| >
| > so I followed the following instructions to disable it.
| >
| > If you'd rather not have these types of HTML validation errors show up
in
| > your error-list, you can disable this functionality by selecting the
| > Tools->Options menu item in VS or Visual Web Developer. Select the
| > TextEditor->Html->Validation tree option in the left-hand side of the
| > options window, and uncheck the "Show Errors" checkbox:
| >
| >
| >
| >
| >
| > But ... the problem is that unclicking check does not seem to stick.
| >
| > When I click on the page, "show errors" check box checks itself on,
and
I
| > cannot get to the design mode.
| >
| >
| >
| > How can I get visual web developer to stop checking for validation
| > errors???
| >
| >
| >
| >
| >
| > Any help is deeply appreciated.
| >
| >
| >
| > Thanks
| >
| > Nalaka
| >
| >
| >
| >
| >
| >
|
|
|

Jan 13 '06 #6

P: n/a
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or other
markup language syntax error. Is it possible that you post a simpflief aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370731
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility..."
| > item to view the accessibility setting... Also for HTML checking, what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005 to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:370429
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors show
up
| > in
| > | > your error-list, you can disable this functionality by selecting the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 16 '06 #7

P: n/a
Hi Steven,
I have a zip file of
1. .aspx
2. aspx.cs
3. .bmp showing color related errors in VWD

I cannot attach the .zip file to this (it complains)
How can I send it to you.

Thanks
Nalaka


"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:1$**************@TK2MSFTNGXA02.phx.gbl...
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or
other
markup language syntax error. Is it possible that you post a simpflief
aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370731
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether
the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility..."
| > item to view the accessibility setting... Also for HTML checking,
what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005
to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:370429
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore
colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors
show
up
| > in
| > | > your error-list, you can disable this functionality by selecting
the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select
the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to
stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself
on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 16 '06 #8

P: n/a
Hi Steven
Attached .zip has
1. .aspx
2. .aspx.cs

Notice the color related errors.

I could not attach a screenm shot (.bmp) of errors showing up in VWD.
How can I email it to you?

Thanks
Nalaka


"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:1$**************@TK2MSFTNGXA02.phx.gbl...
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or
other
markup language syntax error. Is it possible that you post a simpflief
aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370731
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether
the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility..."
| > item to view the accessibility setting... Also for HTML checking,
what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005
to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:370429
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore
colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors
show
up
| > in
| > | > your error-list, you can disable this functionality by selecting
the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select
the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to
stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself
on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|



Jan 16 '06 #9

P: n/a
Hi Steven
Will email (to st*****@online.microsoft.com) a file with Attached .zip.
Has
1. .aspx
2. .aspx.cs
3. screen shot (.bmp) of the color related errors.
Thanks
Nalaka


"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:1$**************@TK2MSFTNGXA02.phx.gbl...
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or
other
markup language syntax error. Is it possible that you post a simpflief
aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:370731
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether
the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility..."
| > item to view the accessibility setting... Also for HTML checking,
what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005
to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:370429
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore
colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors
show
up
| > in
| > | > your error-list, you can disable this functionality by selecting
the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select
the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to
stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself
on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 16 '06 #10

P: n/a
Hi Nalaka,

I've got the attached files and performed some tests on my side. Yes, I did
see those errors listed when try swtiching from html source file to
design-view.... And I find that there do exists many serious errors in
your aspx html template which will certainly prevent the design-view to
display the page..... e.g:

one error indicate that there is </p> tag without a mapped <p> start tag,
and there is also some other errors indicate some html tags are nested like:

<span> <p> ... </span></p>

this is also not allowed.... Not sure how you generate the html content, I
think you may consider scratch a new page and reconstruct the page content
since this page's html source seems have been somewhat corrupted....

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
<O5*************@TK2MSFTNGP14.phx.gbl>
<1$**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Mon, 16 Jan 2006 13:52:28 -0800
| Lines: 279
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <eA**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:371260
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Steven
| Attached .zip has
| 1. .aspx
| 2. .aspx.cs
|
| Notice the color related errors.
|
| I could not attach a screenm shot (.bmp) of errors showing up in VWD.
| How can I email it to you?
|
| Thanks
| Nalaka
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:1$**************@TK2MSFTNGXA02.phx.gbl...
| > If the designer is complaining about can not swtich from source view to
| > designview, there must exists some serious error, not generic html or
| > other
| > markup language syntax error. Is it possible that you post a simpflief
| > aspx
| > page's content to me so that we can have a test?
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > <ex**************@TK2MSFTNGP10.phx.gbl>
| > <Nk**************@TK2MSFTNGXA02.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Fri, 13 Jan 2006 12:19:09 -0800
| > | Lines: 127
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Original
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:370731
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi,
| > | For an example, now... following error now gets generated.
| > | (But this is code generated by the VWD designer itself.)
| > |
| > | Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
| > nested
| > | within element 'span'.
| > |
| > |
| > | Thanks
| > | Nalaka
| > |
| > |
| > |
| > |
| > |
| > | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > | > Hi Nalaka,
| > | >
| > | > Welcome.
| > | > For the VS 2005 ASP.NET html editor, it now includes not only HTML
| > content
| > | > validating , but also the Accessiblity checking, so not sure
whether
| > the
| > | > warning and errors also indicate some accessiblity checking, you can
| > right
| > | > click the page in solution explorer and choose the "Check
| > | > Accessibility..."
| > | > item to view the accessibility setting... Also for HTML checking,
| > what's
| > | > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > | > environment default to IE6 and won't be reset by the changes in
IDE's
| > html
| > | > editor...
| > | > Also, you can consider copy the project on some box which has vs
2005
| > to
| > | > check the behavior, if that works ok, you can try comparing the
| > | > settings...
| > | >
| > | > Regards,
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | >
| > | >
| > | >
| > | > --------------------
| > | > | From: "Nalaka" <na******@nospam.nospam>
| > | > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | > | Subject: Re: disabling html validation does not seem to stck
| > | > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | > | Lines: 56
| > | > | X-Priority: 3
| > | > | X-MSMail-Priority: Normal
| > | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | > | X-RFC2646: Format=Flowed; Response
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | > | Path:
| > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | > microsoft.public.dotnet.framework.aspnet:370429
| > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > |
| > | > | Hi...
| > | > | Also html validation complains about colors like royalblue...
| > | > | How can I add these new colors to the css... ask it to ignore
| > colors.
| > | > |
| > | > |
| > | > | Thanks again
| > | > | Nalaka
| > | > |
| > | > |
| > | > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > | > Hi,
| > | > | >
| > | > | > I suddenly started getting a lot of errors from html validation
| > (some
| > | > CSS)
| > | > | >
| > | > | > so I followed the following instructions to disable it.
| > | > | >
| > | > | > If you'd rather not have these types of HTML validation errors
| > show
| > up
| > | > in
| > | > | > your error-list, you can disable this functionality by
selecting
| > the
| > | > | > Tools->Options menu item in VS or Visual Web Developer. Select
| > the
| > | > | > TextEditor->Html->Validation tree option in the left-hand side
of
| > the
| > | > | > options window, and uncheck the "Show Errors" checkbox:
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | > But ... the problem is that unclicking check does not seem to
| > stick.
| > | > | >
| > | > | > When I click on the page, "show errors" check box checks itself
| > on,
| > | > and
| > | > I
| > | > | > cannot get to the design mode.
| > | > | >
| > | > | >
| > | > | >
| > | > | > How can I get visual web developer to stop checking for
validation
| > | > | > errors???
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | > Any help is deeply appreciated.
| > | > | >
| > | > | >
| > | > | >
| > | > | > Thanks
| > | > | >
| > | > | > Nalaka
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > |
| > | > |
| > | > |
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 17 '06 #11

P: n/a
thanks Steven... I will get back to you....
may be if I fix the other errors.. then color errors will dissapear.
"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:k3**************@TK2MSFTNGXA02.phx.gbl...
Hi Nalaka,

I've got the attached files and performed some tests on my side. Yes, I
did
see those errors listed when try swtiching from html source file to
design-view.... And I find that there do exists many serious errors in
your aspx html template which will certainly prevent the design-view to
display the page..... e.g:

one error indicate that there is </p> tag without a mapped <p> start tag,
and there is also some other errors indicate some html tags are nested
like:

<span> <p> ... </span></p>

this is also not allowed.... Not sure how you generate the html content,
I
think you may consider scratch a new page and reconstruct the page content
since this page's html source seems have been somewhat corrupted....

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
<O5*************@TK2MSFTNGP14.phx.gbl>
<1$**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Mon, 16 Jan 2006 13:52:28 -0800
| Lines: 279
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <eA**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:371260
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Steven
| Attached .zip has
| 1. .aspx
| 2. .aspx.cs
|
| Notice the color related errors.
|
| I could not attach a screenm shot (.bmp) of errors showing up in VWD.
| How can I email it to you?
|
| Thanks
| Nalaka
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:1$**************@TK2MSFTNGXA02.phx.gbl...
| > If the designer is complaining about can not swtich from source view
to
| > designview, there must exists some serious error, not generic html or
| > other
| > markup language syntax error. Is it possible that you post a simpflief
| > aspx
| > page's content to me so that we can have a test?
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > <ex**************@TK2MSFTNGP10.phx.gbl>
| > <Nk**************@TK2MSFTNGXA02.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Fri, 13 Jan 2006 12:19:09 -0800
| > | Lines: 127
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Original
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:370731
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi,
| > | For an example, now... following error now gets generated.
| > | (But this is code generated by the VWD designer itself.)
| > |
| > | Error 110 Validation (Internet Explorer 6): Element 'table' cannot
be
| > nested
| > | within element 'span'.
| > |
| > |
| > | Thanks
| > | Nalaka
| > |
| > |
| > |
| > |
| > |
| > | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > | > Hi Nalaka,
| > | >
| > | > Welcome.
| > | > For the VS 2005 ASP.NET html editor, it now includes not only HTML
| > content
| > | > validating , but also the Accessiblity checking, so not sure
whether
| > the
| > | > warning and errors also indicate some accessiblity checking, you
can
| > right
| > | > click the page in solution explorer and choose the "Check
| > | > Accessibility..."
| > | > item to view the accessibility setting... Also for HTML checking,
| > what's
| > | > your current setting , IE6 or XHTML .... ? Seems my local vs
2005
| > | > environment default to IE6 and won't be reset by the changes in
IDE's
| > html
| > | > editor...
| > | > Also, you can consider copy the project on some box which has vs
2005
| > to
| > | > check the behavior, if that works ok, you can try comparing the
| > | > settings...
| > | >
| > | > Regards,
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | >
| > | >
| > | >
| > | > --------------------
| > | > | From: "Nalaka" <na******@nospam.nospam>
| > | > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | > | Subject: Re: disabling html validation does not seem to stck
| > | > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | > | Lines: 56
| > | > | X-Priority: 3
| > | > | X-MSMail-Priority: Normal
| > | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | > | X-RFC2646: Format=Flowed; Response
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | > | Path:
| > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | > microsoft.public.dotnet.framework.aspnet:370429
| > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > |
| > | > | Hi...
| > | > | Also html validation complains about colors like royalblue...
| > | > | How can I add these new colors to the css... ask it to ignore
| > colors.
| > | > |
| > | > |
| > | > | Thanks again
| > | > | Nalaka
| > | > |
| > | > |
| > | > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > | > Hi,
| > | > | >
| > | > | > I suddenly started getting a lot of errors from html
validation
| > (some
| > | > CSS)
| > | > | >
| > | > | > so I followed the following instructions to disable it.
| > | > | >
| > | > | > If you'd rather not have these types of HTML validation errors
| > show
| > up
| > | > in
| > | > | > your error-list, you can disable this functionality by
selecting
| > the
| > | > | > Tools->Options menu item in VS or Visual Web Developer.
Select
| > the
| > | > | > TextEditor->Html->Validation tree option in the left-hand side
of
| > the
| > | > | > options window, and uncheck the "Show Errors" checkbox:
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | > But ... the problem is that unclicking check does not seem to
| > stick.
| > | > | >
| > | > | > When I click on the page, "show errors" check box checks
itself
| > on,
| > | > and
| > | > I
| > | > | > cannot get to the design mode.
| > | > | >
| > | > | >
| > | > | >
| > | > | > How can I get visual web developer to stop checking for
validation
| > | > | > errors???
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | > Any help is deeply appreciated.
| > | > | >
| > | > | >
| > | > | >
| > | > | > Thanks
| > | > | >
| > | > | > Nalaka
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > | >
| > | > |
| > | > |
| > | > |
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 17 '06 #12

P: n/a
That's fine. Good luck!

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <us**************@TK2MSFTNGP09.phx.gbl>
<ex**************@TK2MSFTNGP10.phx.gbl>
<Nk**************@TK2MSFTNGXA02.phx.gbl>
<O5*************@TK2MSFTNGP14.phx.gbl>
<1$**************@TK2MSFTNGXA02.phx.gbl>
<eA**************@TK2MSFTNGP10.phx.gbl>
<k3**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Tue, 17 Jan 2006 09:33:29 -0800
| Lines: 283
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <e7**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:371480
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| thanks Steven... I will get back to you....
| may be if I fix the other errors.. then color errors will dissapear.
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:k3**************@TK2MSFTNGXA02.phx.gbl...
| > Hi Nalaka,
| >
| > I've got the attached files and performed some tests on my side. Yes, I
| > did
| > see those errors listed when try swtiching from html source file to
| > design-view.... And I find that there do exists many serious errors in
| > your aspx html template which will certainly prevent the design-view to
| > display the page..... e.g:
| >
| > one error indicate that there is </p> tag without a mapped <p> start
tag,
| > and there is also some other errors indicate some html tags are nested
| > like:
| >
| > <span> <p> ... </span></p>
| >
| > this is also not allowed.... Not sure how you generate the html
content,
| > I
| > think you may consider scratch a new page and reconstruct the page
content
| > since this page's html source seems have been somewhat corrupted....
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > <ex**************@TK2MSFTNGP10.phx.gbl>
| > <Nk**************@TK2MSFTNGXA02.phx.gbl>
| > <O5*************@TK2MSFTNGP14.phx.gbl>
| > <1$**************@TK2MSFTNGXA02.phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Mon, 16 Jan 2006 13:52:28 -0800
| > | Lines: 279
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Original
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <eA**************@TK2MSFTNGP10.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:371260
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi Steven
| > | Attached .zip has
| > | 1. .aspx
| > | 2. .aspx.cs
| > |
| > | Notice the color related errors.
| > |
| > | I could not attach a screenm shot (.bmp) of errors showing up in VWD.
| > | How can I email it to you?
| > |
| > | Thanks
| > | Nalaka
| > |
| > |
| > |
| > |
| > | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | news:1$**************@TK2MSFTNGXA02.phx.gbl...
| > | > If the designer is complaining about can not swtich from source
view
| > to
| > | > designview, there must exists some serious error, not generic html
or
| > | > other
| > | > markup language syntax error. Is it possible that you post a
simpflief
| > | > aspx
| > | > page's content to me so that we can have a test?
| > | >
| > | > Regards,
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | > --------------------
| > | > | From: "Nalaka" <na******@nospam.nospam>
| > | > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | > <ex**************@TK2MSFTNGP10.phx.gbl>
| > | > <Nk**************@TK2MSFTNGXA02.phx.gbl>
| > | > | Subject: Re: disabling html validation does not seem to stck
| > | > | Date: Fri, 13 Jan 2006 12:19:09 -0800
| > | > | Lines: 127
| > | > | X-Priority: 3
| > | > | X-MSMail-Priority: Normal
| > | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | > | X-RFC2646: Format=Flowed; Original
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | > | Message-ID: <O5*************@TK2MSFTNGP14.phx.gbl>
| > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | > | Path:
| > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
| > | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | > microsoft.public.dotnet.framework.aspnet:370731
| > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > |
| > | > | Hi,
| > | > | For an example, now... following error now gets generated.
| > | > | (But this is code generated by the VWD designer itself.)
| > | > |
| > | > | Error 110 Validation (Internet Explorer 6): Element 'table'
cannot
| > be
| > | > nested
| > | > | within element 'span'.
| > | > |
| > | > |
| > | > | Thanks
| > | > | Nalaka
| > | > |
| > | > |
| > | > |
| > | > |
| > | > |
| > | > | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in
message
| > | > | news:Nk**************@TK2MSFTNGXA02.phx.gbl...
| > | > | > Hi Nalaka,
| > | > | >
| > | > | > Welcome.
| > | > | > For the VS 2005 ASP.NET html editor, it now includes not only
HTML
| > | > content
| > | > | > validating , but also the Accessiblity checking, so not sure
| > whether
| > | > the
| > | > | > warning and errors also indicate some accessiblity checking,
you
| > can
| > | > right
| > | > | > click the page in solution explorer and choose the "Check
| > | > | > Accessibility..."
| > | > | > item to view the accessibility setting... Also for HTML
checking,
| > | > what's
| > | > | > your current setting , IE6 or XHTML .... ? Seems my local vs
| > 2005
| > | > | > environment default to IE6 and won't be reset by the changes in
| > IDE's
| > | > html
| > | > | > editor...
| > | > | > Also, you can consider copy the project on some box which has vs
| > 2005
| > | > to
| > | > | > check the behavior, if that works ok, you can try comparing the
| > | > | > settings...
| > | > | >
| > | > | > Regards,
| > | > | >
| > | > | > Steven Cheng
| > | > | > Microsoft Online Support
| > | > | >
| > | > | > Get Secure! www.microsoft.com/security
| > | > | > (This posting is provided "AS IS", with no warranties, and
confers
| > no
| > | > | > rights.)
| > | > | >
| > | > | >
| > | > | >
| > | > | > --------------------
| > | > | > | From: "Nalaka" <na******@nospam.nospam>
| > | > | > | References: <us**************@TK2MSFTNGP09.phx.gbl>
| > | > | > | Subject: Re: disabling html validation does not seem to stck
| > | > | > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | > | > | Lines: 56
| > | > | > | X-Priority: 3
| > | > | > | X-MSMail-Priority: Normal
| > | > | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | > | > | X-RFC2646: Format=Flowed; Response
| > | > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | > | > | Message-ID: <ex**************@TK2MSFTNGP10.phx.gbl>
| > | > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | > | > | Path:
| > | > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| > | > | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | > | > microsoft.public.dotnet.framework.aspnet:370429
| > | > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > | > |
| > | > | > | Hi...
| > | > | > | Also html validation complains about colors like royalblue...
| > | > | > | How can I add these new colors to the css... ask it to ignore
| > | > colors.
| > | > | > |
| > | > | > |
| > | > | > | Thanks again
| > | > | > | Nalaka
| > | > | > |
| > | > | > |
| > | > | > | "Nalaka" <na******@nospam.nospam> wrote in message
| > | > | > | news:us**************@TK2MSFTNGP09.phx.gbl...
| > | > | > | > Hi,
| > | > | > | >
| > | > | > | > I suddenly started getting a lot of errors from html
| > validation
| > | > (some
| > | > | > CSS)
| > | > | > | >
| > | > | > | > so I followed the following instructions to disable it.
| > | > | > | >
| > | > | > | > If you'd rather not have these types of HTML validation
errors
| > | > show
| > | > up
| > | > | > in
| > | > | > | > your error-list, you can disable this functionality by
| > selecting
| > | > the
| > | > | > | > Tools->Options menu item in VS or Visual Web Developer.
| > Select
| > | > the
| > | > | > | > TextEditor->Html->Validation tree option in the left-hand
side
| > of
| > | > the
| > | > | > | > options window, and uncheck the "Show Errors" checkbox:
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | > But ... the problem is that unclicking check does not seem
to
| > | > stick.
| > | > | > | >
| > | > | > | > When I click on the page, "show errors" check box checks
| > itself
| > | > on,
| > | > | > and
| > | > | > I
| > | > | > | > cannot get to the design mode.
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | > How can I get visual web developer to stop checking for
| > validation
| > | > | > | > errors???
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | > Any help is deeply appreciated.
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | > Thanks
| > | > | > | >
| > | > | > | > Nalaka
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > | >
| > | > | > |
| > | > | > |
| > | > | > |
| > | > | >
| > | > |
| > | > |
| > | > |
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 18 '06 #13

This discussion thread is closed

Replies have been disabled for this discussion.