By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,290 Members | 1,481 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,290 IT Pros & Developers. It's quick & easy.

Root URL/ Application path problem with running debugger

P: n/a
This one is going to be hard to explain so please bear with me.

I have a web project in folder "myapp". This is where the web config lives.
I've set this to be the IIS webroot. The file "login.aspx" in this folder
is the start page.

What I want is for when I run the debugger, the url of the start page to
read as:
http://localhost:1306/login.aspx

But it is showing up as http://localhost:1306/myapp/login.aspx

If I right click on the "ASP .NET Development Server" icon in the lower
right tray, I see:

Physical path: C:\projects\myapp
Virtual path: /myapp
Port 1306
Root URL: http://localhost:1306/myapp

But I can't find where I can change these settings to read:
Virtual path: /
RootURL: http://localhost:1306/

Does someone know how I can do this?

Thanks in advance!
Jan 6 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
I believe you have 2 different things going on here. First you talk of having
set "myapp" to be the IIS web root. However, then you talk about using the
built-in Development server ("Cassini-meanie"), which doesn't use IIS at all.

Once you get this sorted out, be happy to take another look at it.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"anyeone" wrote:
This one is going to be hard to explain so please bear with me.

I have a web project in folder "myapp". This is where the web config lives.
I've set this to be the IIS webroot. The file "login.aspx" in this folder
is the start page.

What I want is for when I run the debugger, the url of the start page to
read as:
http://localhost:1306/login.aspx

But it is showing up as http://localhost:1306/myapp/login.aspx

If I right click on the "ASP .NET Development Server" icon in the lower
right tray, I see:

Physical path: C:\projects\myapp
Virtual path: /myapp
Port 1306
Root URL: http://localhost:1306/myapp

But I can't find where I can change these settings to read:
Virtual path: /
RootURL: http://localhost:1306/

Does someone know how I can do this?

Thanks in advance!

Jan 6 '06 #2

P: n/a
I'm not an expert on the inner workings of the debugger, so if IIS doesn't
apply with the debugger please ignore that part of my statement.

The basic issue remains the same as Imentioned before. I am trying to run
using the built-in development server but because of the client's
architectural constraints, I need the URL to be
http://localhost:1306/login.aspx without the server forcing the foldername
into the path. If you know what settings I need to modify in order for the
development server to run in this way, I would appreciate the help in
configuring it. If you need more information from me in order to assist,
then please let me know what information that is.

Thanks

"Peter Bromberg [C# MVP]" wrote:
I believe you have 2 different things going on here. First you talk of having
set "myapp" to be the IIS web root. However, then you talk about using the
built-in Development server ("Cassini-meanie"), which doesn't use IIS at all.

Once you get this sorted out, be happy to take another look at it.
Peter

Jan 6 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.