By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,917 Members | 1,313 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,917 IT Pros & Developers. It's quick & easy.

ASP.NET process identity does not have read permissions to the global assembly cache

P: n/a
I'm trying to set up a test environment for an ASP.NET site on a Windows XP
Pro box. I installed IIS5.1 and then .Net V2.

I put up a web site that contains just a simple Default.aspx "hello world"
page. When I try to connect, I get the "Server Unavailable" page. Plain HTML
pages are served with no problems.

Looking at the Event Viewer Application section I see two error entries:

aspnet_wp.exe (PID: 1676) stopped unexpectedly.

Failed to execute the request because the ASP.NET process identity does
not have read permissions to the global assembly cache. Error:
0x80070005 Access is denied.

I have checked the permissions, the ASPNET account has read on C:\, and Read
& Execute on C:\Windows with "inherit below." I turned off the GAC "Cache
Viewer" shell extension and checked the security on the folders in the GAC,
the permissions were inheriting correctly. I added "Write" to the GAC
folders manually.

None of this made any difference. I tried adding ASPNET to the
Administrators group and restarting IIS, still the same error. I've
reinstalled .Net a couple of times with no change.

I'm having trouble figuring out what the error really means. The process
list contains aspnet_wp running under the ASPNET account even though it
"stopped unexpectedly."

In an attempt to run the worker process under System, I tried modifying the
machine.config processModel element userName/password attributes in the
CONFIG folder and restarting IIS. This didn't make any difference either,
and the aspnet_wp process still shows as running under ASPNET. I'm new to
ASP.NET so I'm not sure if that's normal.

I've been able to get ASP.NET working on a couple of similar machines with
no problems, but I'm not sure what to do in this case. I don't want to
flatten the machine unless I have to.

Anyone out there familiar with this error or know any ways to solve it?

Thanks,

Mike N.
Jan 6 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hi Mike,

Welcome to MSDN newsgroup!

Based on my experience, the current problem was caused by the ASPNET
account not having the correct permissions on the system. I suggest you
perform below steps:

1 Using aspnet_regiis -u;
2 Delete the ASPNET account;
3 Using aspnet_regiis -i;

If the problem still occurs, please change the <processModel> tag to have
the userName run as SYSTEM. If the application works fine after
modification, I recommend you grant the ASPNET account's permissions listed
in the following article:
http://msdn.microsoft.com/library/de...us/dnnetsec/ht
ml/SecNetHT01.asp

Then, please changing userName back in <processModel> tag and check whether
the problem still occurs.

I hope the above information helps, if you have any questions or concerns,
please do not hesitate to let me know. I am standing by to help you.

Regards,

Yuan Ren [MSFT]
Microsoft Online Support

Jan 6 '06 #2

P: 4
I'm having the exact same issue as Mike.

I changed my process model tag as suggested by Yuan and still have the same issue.

My messages, etc. are the same as what Mike is experiencing.

I have also uninstalled IIS and reinstalled it. Deleted the ASPNET user and used aspnet_regiis as suggested. I also uninstalled .net 1.1 and the service pack as part of the process and reinstalled.

Any other suggestions would be appreciated as I am quickly coming to flattening the machine given the time I have already spent.

Thank you,
Brent
Feb 16 '06 #3

P: 4
Hi,

After hours of trying to fix this and searching online I thought I would try bumping this up one more time for suggestions before reformatting the machine on Monday.

Thanks in advance for any ideas/suggestions you may have.

Brent
Feb 17 '06 #4

P: 4
On the machine this was happening on I had a SprintPCS card installed.

http://support.microsoft.com/?kbid=910435

Search for bmnet.dll on your machine if you are having a similar problem. That file indicates that this is probably it. Also after running that removal tool suggested in the article I had to reboot my machine to get it to work again.
Feb 17 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.