469,625 Members | 1,091 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,625 developers. It's quick & easy.

How to force a page refresh?

Is there a way to force a page refresh, so users will not receive a cached
version of a page, even if they have their browser set to never check for a
newer version of page?

Thank you!
Jan 4 '06 #1
4 2376
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
You can lead a fish to a bicycle,
but it takes a very long time,
and the bicycle has to *want* to change.

"Paul Drummond" <no**********@yahoo.com> wrote in message
news:mT******************@tornado.rdc-kc.rr.com...
Is there a way to force a page refresh, so users will not receive a cached
version of a page, even if they have their browser set to never check for
a newer version of page?

Thank you!

Jan 4 '06 #2
<meta http-equiv="Refresh" content="300">

"Paul Drummond" wrote:
Is there a way to force a page refresh, so users will not receive a cached
version of a page, even if they have their browser set to never check for a
newer version of page?

Thank you!

Jan 4 '06 #3
Hello Paul,
Is there a way to force a page refresh, so users will not receive a
cached version of a page, even if they have their browser set to never
check for a newer version of page?


I don't think so. This is a web client specific behaviour to ignore HTTP
protocol features, such as Cache-Control headers. And no, META tags won't
cut it either.
--
Joerg Jooss
ne********@joergjooss.de
Jan 4 '06 #4
Hello myself,
Hello Paul,
Is there a way to force a page refresh, so users will not receive a
cached version of a page, even if they have their browser set to
never check for a newer version of page?

I don't think so. This is a web client specific behaviour to ignore
HTTP protocol features, such as Cache-Control headers. And no, META
tags won't cut it either.


Well, the Refresh trick should work, *if* that behaviour is what you want.
You still have to make sure though that the page has not been cached by some
upstream proxy server by setting Cache-Control: no-cache (See System.Web.HttpCachePolicy).

Cheers,
--
Joerg Jooss
ne********@joergjooss.de
Jan 4 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Marco Maroni | last post: by
10 posts views Thread by Fred Nelson | last post: by
1 post views Thread by =?Utf-8?B?QnJ5YW4=?= | last post: by
reply views Thread by Summercool | last post: by
2 posts views Thread by =?Utf-8?B?U2lsa0NpdHlGbG9yaWRh?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.