By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,529 Members | 1,899 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,529 IT Pros & Developers. It's quick & easy.

vs2005 debugging on ws2k3 server

P: n/a
I am almost at the end of my rope - I have to go through this process
everytime a new version of studio is released or it is installed on a new
machine - what a (^%&$^& pain.

I am trying to debug a web app from within vs.net 2005 locally on windows
2003 server
I just cannot get debugging to work anywhere other than localhost
I completely uninstalled the ie enhanced security
I've been through all of the doc's i can google

I get the error "Unable to start debugging on the web server. Logon failure
: unknown user name or bad password."
This has to be a bogus message as the user name and password are known and
good for localhost so they must be for any site on the local machine.

As I was going through the docs on this issue i noticed that this machine
has no Debug Users or VSDevelopers groups setup, so I added them and added
NETWORK SERVICES and my user account - to no avail. Should these accounts
have been there or are they no longer used with 2005 ?

Gerry

Dec 22 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Did you try manually attaching the process and see if that works?
Did you try using FileSystem to create new projects and check if you are
able to debug that?
Did you take FileMon/Regmon logs to find out if there are any access denied
messages in the log files while you are trying to debug?
Did you verify that your apps are opening in Local Intranet and if the
Internet Settings for security of Local Intranet has -> Automatic logon with
current username and password selected??
What about the IISLogs? Can you paste the entries after you create a new app
and try to debug it?

Supposedly, 2005 debugging should be more smooth, unless there are any
installation issues!

Hope that helps... For more checks... Here are a couple of good articles
that you might use to assist you in diagnosing ASP.NET debugging issues:

306172 INFO: Common Errors When You Debug ASP.NET Applications in Visual
Studio
http://support.microsoft.com/?id=306172

The VS7 Debugger doesnt work. What can I do?
http://www.gotdotnet.com/team/csharp...erproblems.doc

--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]


"gerry" wrote:
I am almost at the end of my rope - I have to go through this process
everytime a new version of studio is released or it is installed on a new
machine - what a (^%&$^& pain.

I am trying to debug a web app from within vs.net 2005 locally on windows
2003 server
I just cannot get debugging to work anywhere other than localhost
I completely uninstalled the ie enhanced security
I've been through all of the doc's i can google

I get the error "Unable to start debugging on the web server. Logon failure
: unknown user name or bad password."
This has to be a bogus message as the user name and password are known and
good for localhost so they must be for any site on the local machine.

As I was going through the docs on this issue i noticed that this machine
has no Debug Users or VSDevelopers groups setup, so I added them and added
NETWORK SERVICES and my user account - to no avail. Should these accounts
have been there or are they no longer used with 2005 ?

Gerry

Dec 22 '05 #2

P: n/a
Hi Rahul,
thanks fopr you reply , please see my responses inline below.

I turned on logon failure audit and found that the account logon that is
failing is my own.
I am an admin on the machine as well as a domain admin.

Based on another reference I found I also turned on kerberos logging and
find that this is a kerberos error KDC_ERR_S_PRINCIPAL_UNKNOWN
So I guess that now I will be spending another hair pulling day trying to
decipher this kerberos glop.
I am thinking that maybe this has something to do with this being a 2003
server on a 2000 domain.

But then again , why does this work for localhost ?

Gerry
"Rahul Soni" <Ra*******@discussions.microsoft.com> wrote in message
news:D0**********************************@microsof t.com...
Did you try manually attaching the process and see if that works?
yes I can debug fine after manually attaching.
Did you try using FileSystem to create new projects and check if you are
able to debug that?
yes file system based sites seem to work fine.
Did you take FileMon/Regmon logs to find out if there are any access denied messages in the log files while you are trying to debug?
neither show any errors at all.
Did you verify that your apps are opening in Local Intranet and if the
Internet Settings for security of Local Intranet has -> Automatic logon with current username and password selected??
by default this site is in the internet zone although I would have thought
it should be intranet as it is a local domain ie. http://dev.mydomain.com
I set the setting is as stated for both internet & intranet
adding the site to the intranet zone made no difference
What about the IISLogs? Can you paste the entries after you create a new app and try to debug it?
nada - no entries in any log files anywhere that I can find.
there are the expected entries if I start without debugging
but nothing if I try to debug.

Supposedly, 2005 debugging should be more smooth, unless there are any
installation issues!

Hope that helps... For more checks... Here are a couple of good articles
that you might use to assist you in diagnosing ASP.NET debugging issues:

306172 INFO: Common Errors When You Debug ASP.NET Applications in Visual
Studio
http://support.microsoft.com/?id=306172

The VS7 Debugger doesnt work. What can I do?
http://www.gotdotnet.com/team/csharp...lvedebuggerpro
blems.doc
--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]


"gerry" wrote:
I am almost at the end of my rope - I have to go through this process
everytime a new version of studio is released or it is installed on a new machine - what a (^%&$^& pain.

I am trying to debug a web app from within vs.net 2005 locally on windows 2003 server
I just cannot get debugging to work anywhere other than localhost
I completely uninstalled the ie enhanced security
I've been through all of the doc's i can google

I get the error "Unable to start debugging on the web server. Logon failure : unknown user name or bad password."
This has to be a bogus message as the user name and password are known and good for localhost so they must be for any site on the local machine.

As I was going through the docs on this issue i noticed that this machine has no Debug Users or VSDevelopers groups setup, so I added them and added NETWORK SERVICES and my user account - to no avail. Should these accounts have been there or are they no longer used with 2005 ?

Gerry

Dec 22 '05 #3

P: n/a
By default this site is in the internet zone although I would have thought it
should be intranet as it is a local domain ie. http://dev.mydomain.com I set
the setting is as stated for both internet & intranet adding the site to the
intranet zone made no difference

---> The sites typically show in the Internet Zone because it has two dots
in the name. Can you try removing one of the dots for testing purposes and
see if that helps?

What about the IISLogs? Can you paste the entries after you create a new app
and try to debug it?

nada - no entries in any log files anywhere that I can find. there are the
expected etries if I start without debugging but nothing if I try to debug.

---> Well, that doesn't look good. There should be some entries with debug
verb sent and some error codes showing up. Search for the word "debug" in
your IISLogs and you should find them. If you don't see "debug" verbs being
sent at all check your IIS Settings. As a thumbrule, there has to be DEBUG
verb in your IISLogs when you try to debug any app.

HTH,
--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]

Dec 22 '05 #4

P: n/a
this is definitely a kerberos related problem - here are the event log items
recorded when I try to debug :

Security
Date: 12/23/2005
Source: Security
Time: 9:15:33 AM
Category: Logon/Logoff
Type: Failure Aud
EventID: 537
User: NT AUTHORITY\SYSTEM
Computer: MYPC

Logon Failure:
Reason: An error occurred during logon
User Name: gerry
Domain: MYDOMAIN
Logon Type: 3
Logon Process: čuZ
Authentication Package: NTLM
Workstation Name: MYPC
Status code: 0xC000006D
Substatus code: 0x0
Caller User Name: -
Caller Domain: -
Caller Logon ID: -
Caller Process ID: -
Transited Services: -
Source Network Address: 10.0.0.30
Source Port: 0
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

System
Date: 12/23/2005
Source: Kerberos
Time: 9:15:33 AM
Category: None
Type: Error
EventID: 3
User: N/A
Computer: MYPC

A Kerberos Error Message was received:
on logon session
Client Time:
Server Time: 14:15:33.0000 12/23/2005 Z
Error Code: 0x7 KDC_ERR_S_PRINCIPAL_UNKNOWN
Extended Error:
Client Realm:
Client Name:
Server Realm: MYDOMAIN.CA
Server Name: krbtgt/MYDOMAIN.CA
Target Name: cifs/te*******************@MYDOMAIN.CA
Error Text:
File: 9
Line: ae0
Error Data is in record data.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

I have looked into this and am just baffled by the whole kerberos thing.
I don't have time to waste screwing with this so I have decided to open my
http web site as a file based site in vs that way i can debug in vs and test
across the network as well.

Gerry


"Rahul Soni" <Ra*******@discussions.microsoft.com> wrote in message
news:8F**********************************@microsof t.com...
By default this site is in the internet zone although I would have thought it should be intranet as it is a local domain ie. http://dev.mydomain.com I set the setting is as stated for both internet & intranet adding the site to the intranet zone made no difference

---> The sites typically show in the Internet Zone because it has two dots
in the name. Can you try removing one of the dots for testing purposes and
see if that helps?
I just manually added the site to the intranet zone - no effect.

What about the IISLogs? Can you paste the entries after you create a new app and try to debug it?

nada - no entries in any log files anywhere that I can find. there are the
expected etries if I start without debugging but nothing if I try to debug.
---> Well, that doesn't look good. There should be some entries with debug
verb sent and some error codes showing up. Search for the word "debug" in
your IISLogs and you should find them. If you don't see "debug" verbs being sent at all check your IIS Settings. As a thumbrule, there has to be DEBUG
verb in your IISLogs when you try to debug any app.
well you are assuming that a request is being sent to IIS.
it looks to me like the process is never even getting to the point of
actually sending any type of request to IIS.

HTH,
--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]

Dec 23 '05 #5

P: n/a
Hmm, yes you are right. It is indeed because of the Kerberos tickets.

Another couple of things to check and if it doesn't work, u may proceed with
what you decided...

1) http://support.microsoft.com/?id=215383

First follow the above article and if that doesn't help you can try the
following as well...

2) In your Internet Explorer settings.... Go to the Advanced tab and uncheck
"Enable Integrated Windows Authentication (requires restart)"

Restart your IDE and try debugging again.

Also, if you could just share the IISLogs containing the debug verbs I would
have got ample clues to figure out what went wrong. Let me have those if
possible...

--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]


"gerry" wrote:
this is definitely a kerberos related problem - here are the event log items
recorded when I try to debug :

Security
Date: 12/23/2005
Source: Security
Time: 9:15:33 AM
Category: Logon/Logoff
Type: Failure Aud
EventID: 537
User: NT AUTHORITY\SYSTEM
Computer: MYPC

Logon Failure:
Reason: An error occurred during logon
User Name: gerry
Domain: MYDOMAIN
Logon Type: 3
Logon Process: èuZ
Authentication Package: NTLM
Workstation Name: MYPC
Status code: 0xC000006D
Substatus code: 0x0
Caller User Name: -
Caller Domain: -
Caller Logon ID: -
Caller Process ID: -
Transited Services: -
Source Network Address: 10.0.0.30
Source Port: 0
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

System
Date: 12/23/2005
Source: Kerberos
Time: 9:15:33 AM
Category: None
Type: Error
EventID: 3
User: N/A
Computer: MYPC

A Kerberos Error Message was received:
on logon session
Client Time:
Server Time: 14:15:33.0000 12/23/2005 Z
Error Code: 0x7 KDC_ERR_S_PRINCIPAL_UNKNOWN
Extended Error:
Client Realm:
Client Name:
Server Realm: MYDOMAIN.CA
Server Name: krbtgt/MYDOMAIN.CA
Target Name: cifs/te*******************@MYDOMAIN.CA
Error Text:
File: 9
Line: ae0
Error Data is in record data.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

I have looked into this and am just baffled by the whole kerberos thing.
I don't have time to waste screwing with this so I have decided to open my
http web site as a file based site in vs that way i can debug in vs and test
across the network as well.

Gerry


"Rahul Soni" <Ra*******@discussions.microsoft.com> wrote in message
news:8F**********************************@microsof t.com...
By default this site is in the internet zone although I would have thought

it
should be intranet as it is a local domain ie. http://dev.mydomain.com I

set
the setting is as stated for both internet & intranet adding the site to

the
intranet zone made no difference

---> The sites typically show in the Internet Zone because it has two dots
in the name. Can you try removing one of the dots for testing purposes and
see if that helps?


I just manually added the site to the intranet zone - no effect.

What about the IISLogs? Can you paste the entries after you create a new

app
and try to debug it?

nada - no entries in any log files anywhere that I can find. there are the
expected etries if I start without debugging but nothing if I try to

debug.

---> Well, that doesn't look good. There should be some entries with debug
verb sent and some error codes showing up. Search for the word "debug" in
your IISLogs and you should find them. If you don't see "debug" verbs

being
sent at all check your IIS Settings. As a thumbrule, there has to be DEBUG
verb in your IISLogs when you try to debug any app.


well you are assuming that a request is being sent to IIS.
it looks to me like the process is never even getting to the point of
actually sending any type of request to IIS.

HTH,
--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]


Dec 23 '05 #6

P: n/a
Hi Rahul ,

neither suggestion has had any effect.

I can't share the IIS logs with you , as I stated earlier , there are no
entries in the iis logs when this error occurs.
If I "Start Without Debugging" then things work as they should and i get IIS
log entries
If I "Start Debugging" then I get the error dialog and there are no IIS log
entries whatsoever.

Gerry
"Rahul Soni" <Ra*******@discussions.microsoft.com> wrote in message
news:D8**********************************@microsof t.com...
Hmm, yes you are right. It is indeed because of the Kerberos tickets.

Another couple of things to check and if it doesn't work, u may proceed with what you decided...

1) http://support.microsoft.com/?id=215383

First follow the above article and if that doesn't help you can try the
following as well...

2) In your Internet Explorer settings.... Go to the Advanced tab and uncheck "Enable Integrated Windows Authentication (requires restart)"

Restart your IDE and try debugging again.

Also, if you could just share the IISLogs containing the debug verbs I would have got ample clues to figure out what went wrong. Let me have those if
possible...

--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]


"gerry" wrote:
this is definitely a kerberos related problem - here are the event log items recorded when I try to debug :

Security
Date: 12/23/2005
Source: Security
Time: 9:15:33 AM
Category: Logon/Logoff
Type: Failure Aud
EventID: 537
User: NT AUTHORITY\SYSTEM
Computer: MYPC

Logon Failure:
Reason: An error occurred during logon
User Name: gerry
Domain: MYDOMAIN
Logon Type: 3
Logon Process: čuZ
Authentication Package: NTLM
Workstation Name: MYPC
Status code: 0xC000006D
Substatus code: 0x0
Caller User Name: -
Caller Domain: -
Caller Logon ID: -
Caller Process ID: -
Transited Services: -
Source Network Address: 10.0.0.30
Source Port: 0
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

System
Date: 12/23/2005
Source: Kerberos
Time: 9:15:33 AM
Category: None
Type: Error
EventID: 3
User: N/A
Computer: MYPC

A Kerberos Error Message was received:
on logon session
Client Time:
Server Time: 14:15:33.0000 12/23/2005 Z
Error Code: 0x7 KDC_ERR_S_PRINCIPAL_UNKNOWN
Extended Error:
Client Realm:
Client Name:
Server Realm: MYDOMAIN.CA
Server Name: krbtgt/MYDOMAIN.CA
Target Name: cifs/te*******************@MYDOMAIN.CA
Error Text:
File: 9
Line: ae0
Error Data is in record data.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

I have looked into this and am just baffled by the whole kerberos thing.
I don't have time to waste screwing with this so I have decided to open my http web site as a file based site in vs that way i can debug in vs and test across the network as well.

Gerry


"Rahul Soni" <Ra*******@discussions.microsoft.com> wrote in message
news:8F**********************************@microsof t.com...
By default this site is in the internet zone although I would have thought
it
should be intranet as it is a local domain ie.
http://dev.mydomain.com I set
the setting is as stated for both internet & intranet adding the site
to the
intranet zone made no difference

---> The sites typically show in the Internet Zone because it has two
dots in the name. Can you try removing one of the dots for testing purposes and see if that helps?


I just manually added the site to the intranet zone - no effect.

What about the IISLogs? Can you paste the entries after you create a new app
and try to debug it?

nada - no entries in any log files anywhere that I can find. there are

the expected etries if I start without debugging but nothing if I try to

debug.

---> Well, that doesn't look good. There should be some entries with debug verb sent and some error codes showing up. Search for the word "debug" in your IISLogs and you should find them. If you don't see "debug" verbs

being
sent at all check your IIS Settings. As a thumbrule, there has to be DEBUG verb in your IISLogs when you try to debug any app.


well you are assuming that a request is being sent to IIS.
it looks to me like the process is never even getting to the point of
actually sending any type of request to IIS.

HTH,
--
Thanks,
Rahul Soni

[A problem well stated is a problem half solved!!]


Dec 23 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.