By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,375 Members | 1,368 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,375 IT Pros & Developers. It's quick & easy.

Remote debugging, I have tried absolutely everything, still no go!

P: n/a
Hello,

I use Visual Studio .Net 2003 Professional (Trial version) on Windows XP
Professional (Dutch version). I have a Windows Server 2003 with IIS 6 (UK
version). There is no domain, just a workgroup 'Servers' and a workgroup
'Acme'. My Web Project is in the root of a web site. Not the default
website, a new website, so it's not a virtual folder, it is a website with a
host header like this: project.acme.test

On the Windows Server 2003, I ran the Visual Studio setup and chose only the
Remote Debugging components.

Now I cannot debug with Visual Studio. Here the error message:

---------------------------
Microsoft Development Environment
---------------------------
Error while trying to run project: Unable to start debugging on the web
server. Toegang geweigerd. (the last 2 words are Dutch for: "Access denied")

Click Help for more information.
---------------------------
OK Help
---------------------------

I have tried: all suggestions I get when clicking Help. To be clear: I can
answer all questions this Help asked with the proper answers that should
allow me to debug. For instance, the Help file starts with: Are you running
a version of Windows that allows the VS debugger to automatically attach to
a Web application? The answer is yes, I run Windows XP Professional. This
way I went through the whole Help document. No result.

Then I went through mr. Min Kwan Park's excellent document:
http://www.gotdotnet.com/team/csharp...erproblems.doc.
Well first of all, my specific error message is not there. But I still went
throught all relevant options for my situation, but without any result!

I am going completely crazy with frustration, and would appreciate any help
enormously!

Sincerely

-Michiel
Dec 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Doh! I feel silly, I just found out it was my Windows Firewall that blocked
Visual Stduio debugging. But that's typical for Windows XP SP2, which is
something that was not yet considered in many documentation found on the
internet or supplied with VS 2003. So anyway, if you have this problme, turn
off the firewall, or get the utility provided by Microsoft for configuring
XP SP2 for remote debugging (that way, you keep the safety of the SP2
firewall). Find that utility here:

http://support.microsoft.com/kb/841177/

What a lifesaver!

-Michiel
"Michiel" <michiel_at_elan_dot_netherlands> schreef in bericht
news:uP**************@TK2MSFTNGP14.phx.gbl...
Hello,

I use Visual Studio .Net 2003 Professional (Trial version) on Windows XP
Professional (Dutch version). I have a Windows Server 2003 with IIS 6 (UK
version). There is no domain, just a workgroup 'Servers' and a workgroup
'Acme'. My Web Project is in the root of a web site. Not the default
website, a new website, so it's not a virtual folder, it is a website with
a host header like this: project.acme.test

On the Windows Server 2003, I ran the Visual Studio setup and chose only
the Remote Debugging components.

Now I cannot debug with Visual Studio. Here the error message:

---------------------------
Microsoft Development Environment
---------------------------
Error while trying to run project: Unable to start debugging on the web
server. Toegang geweigerd. (the last 2 words are Dutch for: "Access
denied")

Click Help for more information.
---------------------------
OK Help
---------------------------

I have tried: all suggestions I get when clicking Help. To be clear: I can
answer all questions this Help asked with the proper answers that should
allow me to debug. For instance, the Help file starts with: Are you
running a version of Windows that allows the VS debugger to automatically
attach to a Web application? The answer is yes, I run Windows XP
Professional. This way I went through the whole Help document. No result.

Then I went through mr. Min Kwan Park's excellent document:
http://www.gotdotnet.com/team/csharp...erproblems.doc.
Well first of all, my specific error message is not there. But I still
went throught all relevant options for my situation, but without any
result!

I am going completely crazy with frustration, and would appreciate any
help enormously!

Sincerely

-Michiel

Dec 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.