470,591 Members | 2,085 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,591 developers. It's quick & easy.

master pages and image URL

Hi,
When an image is put on a master page... the url to th eimage is set relatve
to the master page.
(at least don't know how top set an absolute URL to image)

But the when a content page is shown, all images (inclding masterpage) are
resoved relative to the content page location.

get get around this I copy all master page images to the sub folders
too......

this happens with the .ascx (user controls) too....

is there another soulution to setting up these image urls so that I dont
have to duplicate it.
thanks in advance.
Nalaka
Dec 19 '05 #1
5 1550
Have you tried giving the image url in format such as

"~/images/image.gif"
e.g tilde at start of the path. ~ refers to the root of the web application

For longer explanation, please see:
http://www.aspnetpro.com/newslettera...200311kd_l.asp

--
Teemu Keiski
ASP.NET MVP, AspInsider
Finland, EU
http://blogs.aspadvice.com/joteke
"Nalaka" <na******@nospam.nospam> wrote in message
news:uK*************@TK2MSFTNGP15.phx.gbl...
Hi,
When an image is put on a master page... the url to th eimage is set
relatve to the master page.
(at least don't know how top set an absolute URL to image)

But the when a content page is shown, all images (inclding masterpage) are
resoved relative to the content page location.

get get around this I copy all master page images to the sub folders
too......

this happens with the .ascx (user controls) too....

is there another soulution to setting up these image urls so that I dont
have to duplicate it.
thanks in advance.
Nalaka

Dec 19 '05 #2
Thanks.. will try

"Teemu Keiski" <jo****@aspalliance.com> wrote in message
news:ua**************@tk2msftngp13.phx.gbl...
Have you tried giving the image url in format such as

"~/images/image.gif"
e.g tilde at start of the path. ~ refers to the root of the web
application

For longer explanation, please see:
http://www.aspnetpro.com/newslettera...200311kd_l.asp

--
Teemu Keiski
ASP.NET MVP, AspInsider
Finland, EU
http://blogs.aspadvice.com/joteke
"Nalaka" <na******@nospam.nospam> wrote in message
news:uK*************@TK2MSFTNGP15.phx.gbl...
Hi,
When an image is put on a master page... the url to th eimage is set
relatve to the master page.
(at least don't know how top set an absolute URL to image)

But the when a content page is shown, all images (inclding masterpage)
are resoved relative to the content page location.

get get around this I copy all master page images to the sub folders
too......

this happens with the .ascx (user controls) too....

is there another soulution to setting up these image urls so that I dont
have to duplicate it.
thanks in advance.
Nalaka


Dec 19 '05 #3
Thanks for Teemu's good suggestion.

Hi Nalaka,

As Teemu has mentioned , the "~/...." path point to the ASP.NET's
application root. So if you're using asp.net server control , we can always
use this style path since it is easy to locate resource.... And for some
cases that we will embeded static html element that'll point to some
resources, we may need to use static path , such as /.../..... which
start from website root (not web app root...) or just reletive path.....

In addition, we can also programmatically embeded asp.net applicaiton root
path in html like:

<img src='<%= ResolveUrl("~/Images/titlebar.gif") %>' />

Hope also helps.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <uK*************@TK2MSFTNGP15.phx.gbl>
<ua**************@tk2msftngp13.phx.gbl>
| Subject: Re: master pages and image URL
| Date: Mon, 19 Dec 2005 11:20:28 -0800
| Lines: 47
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <#0**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:365769
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Thanks.. will try
|
| "Teemu Keiski" <jo****@aspalliance.com> wrote in message
| news:ua**************@tk2msftngp13.phx.gbl...
| > Have you tried giving the image url in format such as
| >
| > "~/images/image.gif"
| > e.g tilde at start of the path. ~ refers to the root of the web
| > application
| >
| > For longer explanation, please see:
| >
http://www.aspnetpro.com/newslettera..._l/asp200311kd
_l.asp
| >
| > --
| > Teemu Keiski
| > ASP.NET MVP, AspInsider
| > Finland, EU
| > http://blogs.aspadvice.com/joteke
| >
| >
| > "Nalaka" <na******@nospam.nospam> wrote in message
| > news:uK*************@TK2MSFTNGP15.phx.gbl...
| >> Hi,
| >> When an image is put on a master page... the url to th eimage is set
| >> relatve to the master page.
| >> (at least don't know how top set an absolute URL to image)
| >>
| >> But the when a content page is shown, all images (inclding masterpage)
| >> are resoved relative to the content page location.
| >>
| >> get get around this I copy all master page images to the sub folders
| >> too......
| >>
| >> this happens with the .ascx (user controls) too....
| >>
| >> is there another soulution to setting up these image urls so that I
dont
| >> have to duplicate it.
| >>
| >>
| >> thanks in advance.
| >> Nalaka
| >>
| >>
| >
| >
|
|
|

Dec 20 '05 #4
thanks....
let me try...... <img src='<%= ResolveUrl("~/Images/titlebar.gif") %>' />
imageUrl did not like "~/xxx" directly.

Nalaka

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:yn****************@TK2MSFTNGXA02.phx.gbl...
Thanks for Teemu's good suggestion.

Hi Nalaka,

As Teemu has mentioned , the "~/...." path point to the ASP.NET's
application root. So if you're using asp.net server control , we can
always
use this style path since it is easy to locate resource.... And for some
cases that we will embeded static html element that'll point to some
resources, we may need to use static path , such as /.../..... which
start from website root (not web app root...) or just reletive path.....

In addition, we can also programmatically embeded asp.net applicaiton root
path in html like:

<img src='<%= ResolveUrl("~/Images/titlebar.gif") %>' />

Hope also helps.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <uK*************@TK2MSFTNGP15.phx.gbl>
<ua**************@tk2msftngp13.phx.gbl>
| Subject: Re: master pages and image URL
| Date: Mon, 19 Dec 2005 11:20:28 -0800
| Lines: 47
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <#0**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:365769
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Thanks.. will try
|
| "Teemu Keiski" <jo****@aspalliance.com> wrote in message
| news:ua**************@tk2msftngp13.phx.gbl...
| > Have you tried giving the image url in format such as
| >
| > "~/images/image.gif"
| > e.g tilde at start of the path. ~ refers to the root of the web
| > application
| >
| > For longer explanation, please see:
| >
http://www.aspnetpro.com/newslettera..._l/asp200311kd
_l.asp
| >
| > --
| > Teemu Keiski
| > ASP.NET MVP, AspInsider
| > Finland, EU
| > http://blogs.aspadvice.com/joteke
| >
| >
| > "Nalaka" <na******@nospam.nospam> wrote in message
| > news:uK*************@TK2MSFTNGP15.phx.gbl...
| >> Hi,
| >> When an image is put on a master page... the url to th eimage is set
| >> relatve to the master page.
| >> (at least don't know how top set an absolute URL to image)
| >>
| >> But the when a content page is shown, all images (inclding
masterpage)
| >> are resoved relative to the content page location.
| >>
| >> get get around this I copy all master page images to the sub folders
| >> too......
| >>
| >> this happens with the .ascx (user controls) too....
| >>
| >> is there another soulution to setting up these image urls so that I
dont
| >> have to duplicate it.
| >>
| >>
| >> thanks in advance.
| >> Nalaka
| >>
| >>
| >
| >
|
|
|

Dec 20 '05 #5
You're welcome Nalaka,

If anything else we can help, please feel free to post here.

regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospam.nospam>
| References: <uK*************@TK2MSFTNGP15.phx.gbl>
<ua**************@tk2msftngp13.phx.gbl>
<#0**************@TK2MSFTNGP12.phx.gbl>
<yn**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: master pages and image URL
| Date: Tue, 20 Dec 2005 09:22:57 -0800
| Lines: 114
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <Oa*************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:366022
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| thanks....
| let me try...... <img src='<%= ResolveUrl("~/Images/titlebar.gif") %>' />
| imageUrl did not like "~/xxx" directly.
|
| Nalaka
|
|
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:yn****************@TK2MSFTNGXA02.phx.gbl...
| > Thanks for Teemu's good suggestion.
| >
| > Hi Nalaka,
| >
| > As Teemu has mentioned , the "~/...." path point to the ASP.NET's
| > application root. So if you're using asp.net server control , we can
| > always
| > use this style path since it is easy to locate resource.... And for
some
| > cases that we will embeded static html element that'll point to some
| > resources, we may need to use static path , such as /.../..... which
| > start from website root (not web app root...) or just reletive path.....
| >
| > In addition, we can also programmatically embeded asp.net applicaiton
root
| > path in html like:
| >
| > <img src='<%= ResolveUrl("~/Images/titlebar.gif") %>' />
| >
| > Hope also helps.
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospam.nospam>
| > | References: <uK*************@TK2MSFTNGP15.phx.gbl>
| > <ua**************@tk2msftngp13.phx.gbl>
| > | Subject: Re: master pages and image URL
| > | Date: Mon, 19 Dec 2005 11:20:28 -0800
| > | Lines: 47
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <#0**************@TK2MSFTNGP12.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc.ca 199.60.181.9
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:365769
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Thanks.. will try
| > |
| > | "Teemu Keiski" <jo****@aspalliance.com> wrote in message
| > | news:ua**************@tk2msftngp13.phx.gbl...
| > | > Have you tried giving the image url in format such as
| > | >
| > | > "~/images/image.gif"
| > | > e.g tilde at start of the path. ~ refers to the root of the web
| > | > application
| > | >
| > | > For longer explanation, please see:
| > | >
| >
http://www.aspnetpro.com/newslettera..._l/asp200311kd
| > _l.asp
| > | >
| > | > --
| > | > Teemu Keiski
| > | > ASP.NET MVP, AspInsider
| > | > Finland, EU
| > | > http://blogs.aspadvice.com/joteke
| > | >
| > | >
| > | > "Nalaka" <na******@nospam.nospam> wrote in message
| > | > news:uK*************@TK2MSFTNGP15.phx.gbl...
| > | >> Hi,
| > | >> When an image is put on a master page... the url to th eimage is
set
| > | >> relatve to the master page.
| > | >> (at least don't know how top set an absolute URL to image)
| > | >>
| > | >> But the when a content page is shown, all images (inclding
| > masterpage)
| > | >> are resoved relative to the content page location.
| > | >>
| > | >> get get around this I copy all master page images to the sub
folders
| > | >> too......
| > | >>
| > | >> this happens with the .ascx (user controls) too....
| > | >>
| > | >> is there another soulution to setting up these image urls so that I
| > dont
| > | >> have to duplicate it.
| > | >>
| > | >>
| > | >> thanks in advance.
| > | >> Nalaka
| > | >>
| > | >>
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Dec 21 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by JimHeavey | last post: by
3 posts views Thread by Admin.TalkPC | last post: by
5 posts views Thread by =?Utf-8?B?QW50?= | last post: by
8 posts views Thread by Cirene | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.