By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,356 Members | 1,023 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,356 IT Pros & Developers. It's quick & easy.

Could Not Load Assembly

P: n/a
My first ASP.NET application on Visual Studio 2005 and .NET Framework 2.0

The application compiles and executes correctly on the development machine.
I then publish it to an empty directory on the development machine. I then
copy that directory to the remote server that contains numerous directories
and some of them are using .NET Framework 1.1 (1.1 and 2.0 are both
installed on the server).

When I call the page I get the message ...

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load the assembly 'App_Web_whgweftt'. Make
sure that it is compiled before accessing the page.

Source Error:

Line 1: <%@ page language="C#" autoeventwireup="true" inherits="_Default,
App_Web_whgweftt" %>
Line 2:
Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Source File: C:\Domains\tlatla.net\thom\default.aspx Line: 1
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET
Version:1.1.4322.2032

I'm not sure what the error actually is or from where it is expecting to
load the assembly.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

Dec 13 '05 #1
Share this Question
Share on Google+
13 Replies


P: n/a
your vdir in iis is mapped to asp.net 1.1, change it to 2.0 (asp.net tab
under properties).

-- bruce (sqlwork.com)
"Thom Little" <th**@tlanet.net> wrote in message
news:uz**************@TK2MSFTNGP14.phx.gbl...
My first ASP.NET application on Visual Studio 2005 and .NET Framework 2.0

The application compiles and executes correctly on the development
machine. I then publish it to an empty directory on the development
machine. I then copy that directory to the remote server that contains
numerous directories and some of them are using .NET Framework 1.1 (1.1
and 2.0 are both installed on the server).

When I call the page I get the message ...

Parser Error
Description: An error occurred during the parsing of a resource required
to service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load the assembly 'App_Web_whgweftt'. Make
sure that it is compiled before accessing the page.

Source Error:

Line 1: <%@ page language="C#" autoeventwireup="true" inherits="_Default,
App_Web_whgweftt" %>
Line 2:
Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Source File: C:\Domains\tlatla.net\thom\default.aspx Line: 1
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
ASP.NET Version:1.1.4322.2032

I'm not sure what the error actually is or from where it is expecting to
load the assembly.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

Dec 13 '05 #2

P: n/a
I got a new 2.0 webspace defined on the remote server (it took a while) and
tried two tests. One was to copy my "published directory" to the root of
the new webspace. The other was to copy all the files in the directory to
the root of the new webspace.

From directory in new webspace ...

Server Error in '/' Application.
--------------------------------------------------------------------------------

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load the assembly 'App_Web_wvnwbatv'. Make
sure that it is compiled before accessing the page.

Source Error:

Line 1: <%@ page language="C#" autoeventwireup="true" inherits="_Default,
App_Web_wvnwbatv" %>
Line 2:
Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Source File: /thom/Default.aspx Line: 1
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET
Version:2.0.50727.42
From the root of the new webspace ...
Server Error in '/' Application.
--------------------------------------------------------------------------------

The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its
dependencies) could have been removed, had its name changed, or is
temporarily unavailable. Please review the following URL and make sure that
it is spelled correctly.

Requested URL: /Default.aspx
I would not have gotten this far without your suggestion.

Apparently you are only allowed to set the Framework version on the root
(and all the subdirectories) or a webspace. I would like to be able to set
it on a directory-by-directory basis but apparently that is not allowed.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Bruce Barker" <br******************@safeco.com> wrote in message
news:uB**************@TK2MSFTNGP15.phx.gbl...
your vdir in iis is mapped to asp.net 1.1, change it to 2.0 (asp.net tab
under properties).

-- bruce (sqlwork.com)

Dec 14 '05 #3

P: n/a
Hi Thom,

As for ASP.NET web application it is application virtual directory based.
So each web application need to be deployed into a certain IIS Virtual
Directory (mark as application...). A normal physical dir under IIS root
site is not enough, it is a normal virtual directory, but not configured as
application.... So I suggest you first use IIS's manager (inetmgr.exe) to
create a new virtual directory and configure it as application, you can
change a virutal dir to an application virtual dir through:

1. In IIS manager console, select that virtual dir's node and right click
properties menu.
(you can just select the virtual directory you created formly that contains
your application's file....)

2. In the "Directory" or "Virtual Directory" panel, check the "Application
Name" entry field to see whether it is enabled, if not, click the "Create"
button on the right side to create it as an application virtual dir.....

After you create the virtual directory as an application virtual dir, the
ASP.NET application in that virutal dir will run as a single alone
application.....

In addition, notice that ASP.NET application will always inherit
configuration setting from machine.config to IIS site's root web.config to
its own web.config.... So be sure that if you need to run both asp.net
1.1 and asp.net 2.0 web application, you'll need to create two websites
(only available for server OS like windows 2003 server) and one configured
for asp.net 1.1 and another configured for asp.net 2.0 ....

Here are the technet reference about IIS6 ASP.NET application deployment:

#Overview of Deploying ASP.NET Applications (IIS 6.0)
http://www.microsoft.com/technet/pro.../Library/IIS/6
4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx

Hope helps. If there're anything unclear, please feel free to post here.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Wed, 14 Dec 2005 00:37:44 -0500
| Lines: 67
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Response
| Message-ID: <#K**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:364681
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| I got a new 2.0 webspace defined on the remote server (it took a while)
and
| tried two tests. One was to copy my "published directory" to the root of
| the new webspace. The other was to copy all the files in the directory to
| the root of the new webspace.
|
| From directory in new webspace ...
|
| Server Error in '/' Application.
|
----------------------------------------------------------------------------
----
|
| Parser Error
| Description: An error occurred during the parsing of a resource required
to
| service this request. Please review the following specific parse error
| details and modify your source file appropriately.
|
| Parser Error Message: Could not load the assembly 'App_Web_wvnwbatv'.
Make
| sure that it is compiled before accessing the page.
|
| Source Error:
|
| Line 1: <%@ page language="C#" autoeventwireup="true"
inherits="_Default,
| App_Web_wvnwbatv" %>
| Line 2:
| Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
| "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
|
| Source File: /thom/Default.aspx Line: 1
|
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:2.0.50727.42;
ASP.NET
| Version:2.0.50727.42
|
|
| From the root of the new webspace ...
|
|
| Server Error in '/' Application.
|
----------------------------------------------------------------------------
----
|
| The resource cannot be found.
| Description: HTTP 404. The resource you are looking for (or one of its
| dependencies) could have been removed, had its name changed, or is
| temporarily unavailable. Please review the following URL and make sure
that
| it is spelled correctly.
|
| Requested URL: /Default.aspx
|
|
| I would not have gotten this far without your suggestion.
|
| Apparently you are only allowed to set the Framework version on the root
| (and all the subdirectories) or a webspace. I would like to be able to
set
| it on a directory-by-directory basis but apparently that is not allowed.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Bruce Barker" <br******************@safeco.com> wrote in message
| news:uB**************@TK2MSFTNGP15.phx.gbl...
| > your vdir in iis is mapped to asp.net 1.1, change it to 2.0 (asp.net
tab
| > under properties).
| >
| > -- bruce (sqlwork.com)
|
|
|

Dec 14 '05 #4

P: n/a
Thank you for the information. I will persue it with my hoisting service
when a window of opportunity opens Wednesday afternoon.

(Getting through the first one is ALWAYS the toughest.)

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:cG**************@TK2MSFTNGXA02.phx.gbl...
Hi Thom,

As for ASP.NET web application it is application virtual directory based.
So each web application need to be deployed into a certain IIS Virtual
Directory (mark as application...). A normal physical dir under IIS root
site is not enough, it is a normal virtual directory, but not configured
as
application.... So I suggest you first use IIS's manager (inetmgr.exe)
to
create a new virtual directory and configure it as application, you can
change a virutal dir to an application virtual dir through:

1. In IIS manager console, select that virtual dir's node and right click
properties menu.
(you can just select the virtual directory you created formly that
contains
your application's file....)

2. In the "Directory" or "Virtual Directory" panel, check the "Application
Name" entry field to see whether it is enabled, if not, click the "Create"
button on the right side to create it as an application virtual dir.....

After you create the virtual directory as an application virtual dir, the
ASP.NET application in that virutal dir will run as a single alone
application.....

In addition, notice that ASP.NET application will always inherit
configuration setting from machine.config to IIS site's root web.config to
its own web.config.... So be sure that if you need to run both asp.net
1.1 and asp.net 2.0 web application, you'll need to create two websites
(only available for server OS like windows 2003 server) and one configured
for asp.net 1.1 and another configured for asp.net 2.0 ....

Here are the technet reference about IIS6 ASP.NET application deployment:

#Overview of Deploying ASP.NET Applications (IIS 6.0)
http://www.microsoft.com/technet/pro.../Library/IIS/6
4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx

Hope helps. If there're anything unclear, please feel free to post here.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Dec 14 '05 #5

P: n/a
Thanks for your quick response Thom,

If you meet any further questions, please feel free to post here.....

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Wed, 14 Dec 2005 02:52:23 -0500
| Lines: 62
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Original
| Message-ID: <Om*************@tk2msftngp13.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msft ngp13.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:364696
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Thank you for the information. I will persue it with my hoisting service
| when a window of opportunity opens Wednesday afternoon.
|
| (Getting through the first one is ALWAYS the toughest.)
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:cG**************@TK2MSFTNGXA02.phx.gbl...
| > Hi Thom,
| >
| > As for ASP.NET web application it is application virtual directory
based.
| > So each web application need to be deployed into a certain IIS Virtual
| > Directory (mark as application...). A normal physical dir under IIS root
| > site is not enough, it is a normal virtual directory, but not
configured
| > as
| > application.... So I suggest you first use IIS's manager
(inetmgr.exe)
| > to
| > create a new virtual directory and configure it as application, you can
| > change a virutal dir to an application virtual dir through:
| >
| > 1. In IIS manager console, select that virtual dir's node and right
click
| > properties menu.
| > (you can just select the virtual directory you created formly that
| > contains
| > your application's file....)
| >
| > 2. In the "Directory" or "Virtual Directory" panel, check the
"Application
| > Name" entry field to see whether it is enabled, if not, click the
"Create"
| > button on the right side to create it as an application virtual dir.....
| >
| > After you create the virtual directory as an application virtual dir,
the
| > ASP.NET application in that virutal dir will run as a single alone
| > application.....
| >
| > In addition, notice that ASP.NET application will always inherit
| > configuration setting from machine.config to IIS site's root web.config
to
| > its own web.config.... So be sure that if you need to run both asp.net
| > 1.1 and asp.net 2.0 web application, you'll need to create two websites
| > (only available for server OS like windows 2003 server) and one
configured
| > for asp.net 1.1 and another configured for asp.net 2.0 ....
| >
| > Here are the technet reference about IIS6 ASP.NET application
deployment:
| >
| > #Overview of Deploying ASP.NET Applications (IIS 6.0)
| >
http://www.microsoft.com/technet/pro.../Library/IIS/6
| > 4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx
| >
| > Hope helps. If there're anything unclear, please feel free to post here.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
|
|
|

Dec 15 '05 #6

P: n/a
The remote servers using Windows Server 2000 and IIS 5.0.

The provider reports that ...

There is no "Directories" choice in the properties view. There is a 'Home
Directory" tab and a "Directory Security" tab.

In the "Home Directory" tab under "Application Settings" "Default
Application" appears in a box and "Remove" button is alongside of it. Am
meeting Susan at the Peterborough Diner and will be back in about an hour
and a half.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Thom Little" <th**@tlanet.net> wrote in message
news:Om*************@tk2msftngp13.phx.gbl...
Thank you for the information. I will persue it with my hoisting service
when a window of opportunity opens Wednesday afternoon.

(Getting through the first one is ALWAYS the toughest.)

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:cG**************@TK2MSFTNGXA02.phx.gbl...
Hi Thom,

As for ASP.NET web application it is application virtual directory based.
So each web application need to be deployed into a certain IIS Virtual
Directory (mark as application...). A normal physical dir under IIS root
site is not enough, it is a normal virtual directory, but not configured
as
application.... So I suggest you first use IIS's manager (inetmgr.exe)
to
create a new virtual directory and configure it as application, you can
change a virutal dir to an application virtual dir through:

1. In IIS manager console, select that virtual dir's node and right click
properties menu.
(you can just select the virtual directory you created formly that
contains
your application's file....)

2. In the "Directory" or "Virtual Directory" panel, check the
"Application
Name" entry field to see whether it is enabled, if not, click the
"Create"
button on the right side to create it as an application virtual dir.....

After you create the virtual directory as an application virtual dir, the
ASP.NET application in that virutal dir will run as a single alone
application.....

In addition, notice that ASP.NET application will always inherit
configuration setting from machine.config to IIS site's root web.config
to
its own web.config.... So be sure that if you need to run both asp.net
1.1 and asp.net 2.0 web application, you'll need to create two websites
(only available for server OS like windows 2003 server) and one
configured
for asp.net 1.1 and another configured for asp.net 2.0 ....

Here are the technet reference about IIS6 ASP.NET application deployment:

#Overview of Deploying ASP.NET Applications (IIS 6.0)
http://www.microsoft.com/technet/pro.../Library/IIS/6
4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx

Hope helps. If there're anything unclear, please feel free to post here.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


Dec 15 '05 #7

P: n/a
Hey Thom,

Yes, that's right , the "Home Directory" setting is just the one I
mentioned, this is the particular one because it's the root directory of
that IIS website(not a normal virtual directory). Generally we can deploy
our asp.net web application just under a normal virtual directory, no
necessarily under the website's root....

Feel free to let me know if need any help.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
<Om*************@tk2msftngp13.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Wed, 14 Dec 2005 20:34:11 -0500
| Lines: 86
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Response
| Message-ID: <#2**************@TK2MSFTNGP15.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:364984
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| The remote servers using Windows Server 2000 and IIS 5.0.
|
| The provider reports that ...
|
| There is no "Directories" choice in the properties view. There is a 'Home
| Directory" tab and a "Directory Security" tab.
|
| In the "Home Directory" tab under "Application Settings" "Default
| Application" appears in a box and "Remove" button is alongside of it. Am
| meeting Susan at the Peterborough Diner and will be back in about an hour
| and a half.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Thom Little" <th**@tlanet.net> wrote in message
| news:Om*************@tk2msftngp13.phx.gbl...
| > Thank you for the information. I will persue it with my hoisting
service
| > when a window of opportunity opens Wednesday afternoon.
| >
| > (Getting through the first one is ALWAYS the toughest.)
| >
| > --
| > -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| > --
| >
| > "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > news:cG**************@TK2MSFTNGXA02.phx.gbl...
| >> Hi Thom,
| >>
| >> As for ASP.NET web application it is application virtual directory
based.
| >> So each web application need to be deployed into a certain IIS Virtual
| >> Directory (mark as application...). A normal physical dir under IIS
root
| >> site is not enough, it is a normal virtual directory, but not
configured
| >> as
| >> application.... So I suggest you first use IIS's manager
(inetmgr.exe)
| >> to
| >> create a new virtual directory and configure it as application, you can
| >> change a virutal dir to an application virtual dir through:
| >>
| >> 1. In IIS manager console, select that virtual dir's node and right
click
| >> properties menu.
| >> (you can just select the virtual directory you created formly that
| >> contains
| >> your application's file....)
| >>
| >> 2. In the "Directory" or "Virtual Directory" panel, check the
| >> "Application
| >> Name" entry field to see whether it is enabled, if not, click the
| >> "Create"
| >> button on the right side to create it as an application virtual
dir.....
| >>
| >> After you create the virtual directory as an application virtual dir,
the
| >> ASP.NET application in that virutal dir will run as a single alone
| >> application.....
| >>
| >> In addition, notice that ASP.NET application will always inherit
| >> configuration setting from machine.config to IIS site's root
web.config
| >> to
| >> its own web.config.... So be sure that if you need to run both
asp.net
| >> 1.1 and asp.net 2.0 web application, you'll need to create two websites
| >> (only available for server OS like windows 2003 server) and one
| >> configured
| >> for asp.net 1.1 and another configured for asp.net 2.0 ....
| >>
| >> Here are the technet reference about IIS6 ASP.NET application
deployment:
| >>
| >> #Overview of Deploying ASP.NET Applications (IIS 6.0)
| >>
http://www.microsoft.com/technet/pro.../Library/IIS/6
| >> 4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx
| >>
| >> Hope helps. If there're anything unclear, please feel free to post
here.
| >>
| >> Thanks,
| >>
| >> Steven Cheng
| >> Microsoft Online Support
| >>
| >> Get Secure! www.microsoft.com/security
| >> (This posting is provided "AS IS", with no warranties, and confers no
| >> rights.)
| >
| >
|
|
|

Dec 15 '05 #8

P: n/a
Unfortuantly ...

Since it was already set as I reported, he did nothing. It (of course) is
not working.

What action does he need to take to activate this connection?

(Sorry my last message was a little obtuse.)

Also ... it seems that I can choose 1.1 or 2.0 on the root and all
subdirectories must be the same version (your comment about inheritance).

I have not yet seen a 2.0 application running on his remote server.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:dj**************@TK2MSFTNGXA02.phx.gbl...
Hey Thom,

Yes, that's right , the "Home Directory" setting is just the one I
mentioned, this is the particular one because it's the root directory of
that IIS website(not a normal virtual directory). Generally we can deploy
our asp.net web application just under a normal virtual directory, no
necessarily under the website's root....

Feel free to let me know if need any help.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
<Om*************@tk2msftngp13.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Wed, 14 Dec 2005 20:34:11 -0500
| Lines: 86
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Response
| Message-ID: <#2**************@TK2MSFTNGP15.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:364984
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| The remote servers using Windows Server 2000 and IIS 5.0.
|
| The provider reports that ...
|
| There is no "Directories" choice in the properties view. There is a
'Home
| Directory" tab and a "Directory Security" tab.
|
| In the "Home Directory" tab under "Application Settings" "Default
| Application" appears in a box and "Remove" button is alongside of it. Am
| meeting Susan at the Peterborough Diner and will be back in about an
hour
| and a half.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Thom Little" <th**@tlanet.net> wrote in message
| news:Om*************@tk2msftngp13.phx.gbl...
| > Thank you for the information. I will persue it with my hoisting
service
| > when a window of opportunity opens Wednesday afternoon.
| >
| > (Getting through the first one is ALWAYS the toughest.)
| >
| > --
| > -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| > --
| >
| > "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > news:cG**************@TK2MSFTNGXA02.phx.gbl...
| >> Hi Thom,
| >>
| >> As for ASP.NET web application it is application virtual directory
based.
| >> So each web application need to be deployed into a certain IIS
Virtual
| >> Directory (mark as application...). A normal physical dir under IIS
root
| >> site is not enough, it is a normal virtual directory, but not
configured
| >> as
| >> application.... So I suggest you first use IIS's manager
(inetmgr.exe)
| >> to
| >> create a new virtual directory and configure it as application, you
can
| >> change a virutal dir to an application virtual dir through:
| >>
| >> 1. In IIS manager console, select that virtual dir's node and right
click
| >> properties menu.
| >> (you can just select the virtual directory you created formly that
| >> contains
| >> your application's file....)
| >>
| >> 2. In the "Directory" or "Virtual Directory" panel, check the
| >> "Application
| >> Name" entry field to see whether it is enabled, if not, click the
| >> "Create"
| >> button on the right side to create it as an application virtual
dir.....
| >>
| >> After you create the virtual directory as an application virtual dir,
the
| >> ASP.NET application in that virutal dir will run as a single alone
| >> application.....
| >>
| >> In addition, notice that ASP.NET application will always inherit
| >> configuration setting from machine.config to IIS site's root
web.config
| >> to
| >> its own web.config.... So be sure that if you need to run both
asp.net
| >> 1.1 and asp.net 2.0 web application, you'll need to create two
websites
| >> (only available for server OS like windows 2003 server) and one
| >> configured
| >> for asp.net 1.1 and another configured for asp.net 2.0 ....
| >>
| >> Here are the technet reference about IIS6 ASP.NET application
deployment:
| >>
| >> #Overview of Deploying ASP.NET Applications (IIS 6.0)
| >>
http://www.microsoft.com/technet/pro.../Library/IIS/6
| >> 4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx
| >>
| >> Hope helps. If there're anything unclear, please feel free to post
here.
| >>
| >> Thanks,
| >>
| >> Steven Cheng
| >> Microsoft Online Support
| >>
| >> Get Secure! www.microsoft.com/security
| >> (This posting is provided "AS IS", with no warranties, and confers no
| >> rights.)
| >
| >
|
|
|

Dec 15 '05 #9

P: n/a
Thanks for your response Thom,

En, it's better to keep the root site's ASP.NET version mapping the same
woth its children virtual dirs. Can you create a new website for testing?

Also, we can run the aspnet_regiis.exe to configure IIS website's asp.net
mapping which is under the

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

location....

Currently, I'd suggest you first try successfully creating a virtual dir
under a certain website. and put a ASP.NET page (very simple hello world
page which print out the asp.net version..... , you can use
System.Environment.Version to get runtime version info...) in the virtual
dir to get it work.....

Also, if you feel necessary I can attach some screen shot of my local
environment's IIS configuration.... Please feel free to let me know
what's setting you're currenly confused at...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
<Om*************@tk2msftngp13.phx.gbl>
<#2**************@TK2MSFTNGP15.phx.gbl>
<dj**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Wed, 14 Dec 2005 23:23:11 -0500
| Lines: 169
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#o*************@TK2MSFTNGP15.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:365006
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Unfortuantly ...
|
| Since it was already set as I reported, he did nothing. It (of course)
is
| not working.
|
| What action does he need to take to activate this connection?
|
| (Sorry my last message was a little obtuse.)
|
| Also ... it seems that I can choose 1.1 or 2.0 on the root and all
| subdirectories must be the same version (your comment about inheritance).
|
| I have not yet seen a 2.0 application running on his remote server.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:dj**************@TK2MSFTNGXA02.phx.gbl...
| > Hey Thom,
| >
| > Yes, that's right , the "Home Directory" setting is just the one I
| > mentioned, this is the particular one because it's the root directory of
| > that IIS website(not a normal virtual directory). Generally we can
deploy
| > our asp.net web application just under a normal virtual directory, no
| > necessarily under the website's root....
| >
| > Feel free to let me know if need any help.
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| > --------------------
| > | From: "Thom Little" <th**@tlanet.net>
| > | References: <uz**************@TK2MSFTNGP14.phx.gbl>
| > <uB**************@TK2MSFTNGP15.phx.gbl>
| > <#K**************@TK2MSFTNGP12.phx.gbl>
| > <cG**************@TK2MSFTNGXA02.phx.gbl>
| > <Om*************@tk2msftngp13.phx.gbl>
| > | Subject: Re: Could Not Load Assembly
| > | Date: Wed, 14 Dec 2005 20:34:11 -0500
| > | Lines: 86
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| > | X-RFC2646: Format=Flowed; Response
| > | Message-ID: <#2**************@TK2MSFTNGP15.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: 65.99.185.176
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:364984
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | The remote servers using Windows Server 2000 and IIS 5.0.
| > |
| > | The provider reports that ...
| > |
| > | There is no "Directories" choice in the properties view. There is a
| > 'Home
| > | Directory" tab and a "Directory Security" tab.
| > |
| > | In the "Home Directory" tab under "Application Settings" "Default
| > | Application" appears in a box and "Remove" button is alongside of it.
Am
| > | meeting Susan at the Peterborough Diner and will be back in about an
| > hour
| > | and a half.
| > |
| > | --
| > | -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| > | --
| > |
| > | "Thom Little" <th**@tlanet.net> wrote in message
| > | news:Om*************@tk2msftngp13.phx.gbl...
| > | > Thank you for the information. I will persue it with my hoisting
| > service
| > | > when a window of opportunity opens Wednesday afternoon.
| > | >
| > | > (Getting through the first one is ALWAYS the toughest.)
| > | >
| > | > --
| > | > -- Thom Little -- www.tlanet.net -- Thom Little Associates,
Ltd.
| > | > --
| > | >
| > | > "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | > news:cG**************@TK2MSFTNGXA02.phx.gbl...
| > | >> Hi Thom,
| > | >>
| > | >> As for ASP.NET web application it is application virtual directory
| > based.
| > | >> So each web application need to be deployed into a certain IIS
| > Virtual
| > | >> Directory (mark as application...). A normal physical dir under IIS
| > root
| > | >> site is not enough, it is a normal virtual directory, but not
| > configured
| > | >> as
| > | >> application.... So I suggest you first use IIS's manager
| > (inetmgr.exe)
| > | >> to
| > | >> create a new virtual directory and configure it as application,
you
| > can
| > | >> change a virutal dir to an application virtual dir through:
| > | >>
| > | >> 1. In IIS manager console, select that virtual dir's node and right
| > click
| > | >> properties menu.
| > | >> (you can just select the virtual directory you created formly that
| > | >> contains
| > | >> your application's file....)
| > | >>
| > | >> 2. In the "Directory" or "Virtual Directory" panel, check the
| > | >> "Application
| > | >> Name" entry field to see whether it is enabled, if not, click the
| > | >> "Create"
| > | >> button on the right side to create it as an application virtual
| > dir.....
| > | >>
| > | >> After you create the virtual directory as an application virtual
dir,
| > the
| > | >> ASP.NET application in that virutal dir will run as a single alone
| > | >> application.....
| > | >>
| > | >> In addition, notice that ASP.NET application will always inherit
| > | >> configuration setting from machine.config to IIS site's root
| > web.config
| > | >> to
| > | >> its own web.config.... So be sure that if you need to run both
| > asp.net
| > | >> 1.1 and asp.net 2.0 web application, you'll need to create two
| > websites
| > | >> (only available for server OS like windows 2003 server) and one
| > | >> configured
| > | >> for asp.net 1.1 and another configured for asp.net 2.0 ....
| > | >>
| > | >> Here are the technet reference about IIS6 ASP.NET application
| > deployment:
| > | >>
| > | >> #Overview of Deploying ASP.NET Applications (IIS 6.0)
| > | >>
| >
http://www.microsoft.com/technet/pro.../Library/IIS/6
| > | >> 4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx
| > | >>
| > | >> Hope helps. If there're anything unclear, please feel free to post
| > here.
| > | >>
| > | >> Thanks,
| > | >>
| > | >> Steven Cheng
| > | >> Microsoft Online Support
| > | >>
| > | >> Get Secure! www.microsoft.com/security
| > | >> (This posting is provided "AS IS", with no warranties, and confers
no
| > | >> rights.)
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Dec 15 '05 #10

P: n/a
He actually created a new webspace for testing. I have a simple html file
in it to prove that it can be served correctly for HTTP. I have a simple
ASP 2.0 application in it also.

The space is at Thom.Little and I have a mapping for that name and
www.Thom.Little in my hosts file.

A few screenshots that show a correctly configured website root would be
quite helpful. If they exist somewhere on the internet, just knowing the
URL would be as helpful.

I simply need a 2.0 webspace that is open to the public.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:Qu*************@TK2MSFTNGXA02.phx.gbl...
Thanks for your response Thom,

En, it's better to keep the root site's ASP.NET version mapping the same
woth its children virtual dirs. Can you create a new website for testing?

Also, we can run the aspnet_regiis.exe to configure IIS website's asp.net
mapping which is under the

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

location....

Currently, I'd suggest you first try successfully creating a virtual dir
under a certain website. and put a ASP.NET page (very simple hello world
page which print out the asp.net version..... , you can use
System.Environment.Version to get runtime version info...) in the virtual
dir to get it work.....

Also, if you feel necessary I can attach some screen shot of my local
environment's IIS configuration.... Please feel free to let me know
what's setting you're currenly confused at...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
<Om*************@tk2msftngp13.phx.gbl>
<#2**************@TK2MSFTNGP15.phx.gbl>
<dj**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Wed, 14 Dec 2005 23:23:11 -0500
| Lines: 169
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#o*************@TK2MSFTNGP15.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:365006
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Unfortuantly ...
|
| Since it was already set as I reported, he did nothing. It (of course)
is
| not working.
|
| What action does he need to take to activate this connection?
|
| (Sorry my last message was a little obtuse.)
|
| Also ... it seems that I can choose 1.1 or 2.0 on the root and all
| subdirectories must be the same version (your comment about
inheritance).
|
| I have not yet seen a 2.0 application running on his remote server.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:dj**************@TK2MSFTNGXA02.phx.gbl...
| > Hey Thom,
| >
| > Yes, that's right , the "Home Directory" setting is just the one I
| > mentioned, this is the particular one because it's the root directory
of
| > that IIS website(not a normal virtual directory). Generally we can
deploy
| > our asp.net web application just under a normal virtual directory, no
| > necessarily under the website's root....
| >
| > Feel free to let me know if need any help.
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| > --------------------
| > | From: "Thom Little" <th**@tlanet.net>
| > | References: <uz**************@TK2MSFTNGP14.phx.gbl>
| > <uB**************@TK2MSFTNGP15.phx.gbl>
| > <#K**************@TK2MSFTNGP12.phx.gbl>
| > <cG**************@TK2MSFTNGXA02.phx.gbl>
| > <Om*************@tk2msftngp13.phx.gbl>
| > | Subject: Re: Could Not Load Assembly
| > | Date: Wed, 14 Dec 2005 20:34:11 -0500
| > | Lines: 86
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| > | X-RFC2646: Format=Flowed; Response
| > | Message-ID: <#2**************@TK2MSFTNGP15.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: 65.99.185.176
| > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:364984
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | The remote servers using Windows Server 2000 and IIS 5.0.
| > |
| > | The provider reports that ...
| > |
| > | There is no "Directories" choice in the properties view. There is a
| > 'Home
| > | Directory" tab and a "Directory Security" tab.
| > |
| > | In the "Home Directory" tab under "Application Settings" "Default
| > | Application" appears in a box and "Remove" button is alongside of
it.
Am
| > | meeting Susan at the Peterborough Diner and will be back in about an
| > hour
| > | and a half.
| > |
| > | --
| > | -- Thom Little -- www.tlanet.net -- Thom Little Associates,
Ltd.
| > | --
| > |
| > | "Thom Little" <th**@tlanet.net> wrote in message
| > | news:Om*************@tk2msftngp13.phx.gbl...
| > | > Thank you for the information. I will persue it with my hoisting
| > service
| > | > when a window of opportunity opens Wednesday afternoon.
| > | >
| > | > (Getting through the first one is ALWAYS the toughest.)
| > | >
| > | > --
| > | > -- Thom Little -- www.tlanet.net -- Thom Little Associates,
Ltd.
| > | > --
| > | >
| > | > "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in
message
| > | > news:cG**************@TK2MSFTNGXA02.phx.gbl...
| > | >> Hi Thom,
| > | >>
| > | >> As for ASP.NET web application it is application virtual
directory
| > based.
| > | >> So each web application need to be deployed into a certain IIS
| > Virtual
| > | >> Directory (mark as application...). A normal physical dir under
IIS
| > root
| > | >> site is not enough, it is a normal virtual directory, but not
| > configured
| > | >> as
| > | >> application.... So I suggest you first use IIS's manager
| > (inetmgr.exe)
| > | >> to
| > | >> create a new virtual directory and configure it as application,
you
| > can
| > | >> change a virutal dir to an application virtual dir through:
| > | >>
| > | >> 1. In IIS manager console, select that virtual dir's node and
right
| > click
| > | >> properties menu.
| > | >> (you can just select the virtual directory you created formly
that
| > | >> contains
| > | >> your application's file....)
| > | >>
| > | >> 2. In the "Directory" or "Virtual Directory" panel, check the
| > | >> "Application
| > | >> Name" entry field to see whether it is enabled, if not, click the
| > | >> "Create"
| > | >> button on the right side to create it as an application virtual
| > dir.....
| > | >>
| > | >> After you create the virtual directory as an application virtual
dir,
| > the
| > | >> ASP.NET application in that virutal dir will run as a single
alone
| > | >> application.....
| > | >>
| > | >> In addition, notice that ASP.NET application will always inherit
| > | >> configuration setting from machine.config to IIS site's root
| > web.config
| > | >> to
| > | >> its own web.config.... So be sure that if you need to run both
| > asp.net
| > | >> 1.1 and asp.net 2.0 web application, you'll need to create two
| > websites
| > | >> (only available for server OS like windows 2003 server) and one
| > | >> configured
| > | >> for asp.net 1.1 and another configured for asp.net 2.0 ....
| > | >>
| > | >> Here are the technet reference about IIS6 ASP.NET application
| > deployment:
| > | >>
| > | >> #Overview of Deploying ASP.NET Applications (IIS 6.0)
| > | >>
| >
http://www.microsoft.com/technet/pro.../Library/IIS/6
| > | >> 4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx
| > | >>
| > | >> Hope helps. If there're anything unclear, please feel free to
post
| > here.
| > | >>
| > | >> Thanks,
| > | >>
| > | >> Steven Cheng
| > | >> Microsoft Online Support
| > | >>
| > | >> Get Secure! www.microsoft.com/security
| > | >> (This posting is provided "AS IS", with no warranties, and
confers
no
| > | >> rights.)
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Dec 15 '05 #11

P: n/a
Thanks for your response Thom.

Actually publishing an ASP.NET web app and expose it to public internet are
two separate things. As for ASP.NET, we just need to make sure it is
correctly configured in IIS and can be visisted locally. After that, it's
the DNS and other network setting which need to make it visitable to public
internet.....

Also, I'll try capture some screen shot of my local test 2003(IIS6/ASP.NET
2) environment and update you soon....

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
<Om*************@tk2msftngp13.phx.gbl>
<#2**************@TK2MSFTNGP15.phx.gbl>
<dj**************@TK2MSFTNGXA02.phx.gbl>
<#o*************@TK2MSFTNGP15.phx.gbl>
<Qu*************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Thu, 15 Dec 2005 02:18:59 -0500
| Lines: 268
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Original
| Message-ID: <us**************@TK2MSFTNGP11.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP11.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:365019
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| He actually created a new webspace for testing. I have a simple html
file
| in it to prove that it can be served correctly for HTTP. I have a simple
| ASP 2.0 application in it also.
|
| The space is at Thom.Little and I have a mapping for that name and
| www.Thom.Little in my hosts file.
|
| A few screenshots that show a correctly configured website root would be
| quite helpful. If they exist somewhere on the internet, just knowing the
| URL would be as helpful.
|
| I simply need a 2.0 webspace that is open to the public.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Qu*************@TK2MSFTNGXA02.phx.gbl...
| > Thanks for your response Thom,
| >
| > En, it's better to keep the root site's ASP.NET version mapping the same
| > woth its children virtual dirs. Can you create a new website for
testing?
| >
| > Also, we can run the aspnet_regiis.exe to configure IIS website's
asp.net
| > mapping which is under the
| >
| > C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
| >
| > location....
| >
| > Currently, I'd suggest you first try successfully creating a virtual dir
| > under a certain website. and put a ASP.NET page (very simple hello world
| > page which print out the asp.net version..... , you can use
| > System.Environment.Version to get runtime version info...) in the
virtual
| > dir to get it work.....
| >
| > Also, if you feel necessary I can attach some screen shot of my local
| > environment's IIS configuration.... Please feel free to let me know
| > what's setting you're currenly confused at...
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| > --------------------
| > | From: "Thom Little" <th**@tlanet.net>
| > | References: <uz**************@TK2MSFTNGP14.phx.gbl>
| > <uB**************@TK2MSFTNGP15.phx.gbl>
| > <#K**************@TK2MSFTNGP12.phx.gbl>
| > <cG**************@TK2MSFTNGXA02.phx.gbl>
| > <Om*************@tk2msftngp13.phx.gbl>
| > <#2**************@TK2MSFTNGP15.phx.gbl>
| > <dj**************@TK2MSFTNGXA02.phx.gbl>
| > | Subject: Re: Could Not Load Assembly
| > | Date: Wed, 14 Dec 2005 23:23:11 -0500
| > | Lines: 169
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| > | X-RFC2646: Format=Flowed; Original
| > | Message-ID: <#o*************@TK2MSFTNGP15.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: 65.99.185.176
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:365006
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Unfortuantly ...
| > |
| > | Since it was already set as I reported, he did nothing. It (of
course)
| > is
| > | not working.
| > |
| > | What action does he need to take to activate this connection?
| > |
| > | (Sorry my last message was a little obtuse.)
| > |
| > | Also ... it seems that I can choose 1.1 or 2.0 on the root and all
| > | subdirectories must be the same version (your comment about
| > inheritance).
| > |
| > | I have not yet seen a 2.0 application running on his remote server.
| > |
| > | --
| > | -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| > | --
| > |
| > | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | news:dj**************@TK2MSFTNGXA02.phx.gbl...
| > | > Hey Thom,
| > | >
| > | > Yes, that's right , the "Home Directory" setting is just the one I
| > | > mentioned, this is the particular one because it's the root
directory
| > of
| > | > that IIS website(not a normal virtual directory). Generally we can
| > deploy
| > | > our asp.net web application just under a normal virtual directory,
no
| > | > necessarily under the website's root....
| > | >
| > | > Feel free to let me know if need any help.
| > | >
| > | > Regards,
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | > --------------------
| > | > | From: "Thom Little" <th**@tlanet.net>
| > | > | References: <uz**************@TK2MSFTNGP14.phx.gbl>
| > | > <uB**************@TK2MSFTNGP15.phx.gbl>
| > | > <#K**************@TK2MSFTNGP12.phx.gbl>
| > | > <cG**************@TK2MSFTNGXA02.phx.gbl>
| > | > <Om*************@tk2msftngp13.phx.gbl>
| > | > | Subject: Re: Could Not Load Assembly
| > | > | Date: Wed, 14 Dec 2005 20:34:11 -0500
| > | > | Lines: 86
| > | > | X-Priority: 3
| > | > | X-MSMail-Priority: Normal
| > | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| > | > | X-RFC2646: Format=Flowed; Response
| > | > | Message-ID: <#2**************@TK2MSFTNGP15.phx.gbl>
| > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | NNTP-Posting-Host: 65.99.185.176
| > | > | Path:
| > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP15.phx.gbl
| > | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | > microsoft.public.dotnet.framework.aspnet:364984
| > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > |
| > | > | The remote servers using Windows Server 2000 and IIS 5.0.
| > | > |
| > | > | The provider reports that ...
| > | > |
| > | > | There is no "Directories" choice in the properties view. There is
a
| > | > 'Home
| > | > | Directory" tab and a "Directory Security" tab.
| > | > |
| > | > | In the "Home Directory" tab under "Application Settings" "Default
| > | > | Application" appears in a box and "Remove" button is alongside of
| > it.
| > Am
| > | > | meeting Susan at the Peterborough Diner and will be back in about
an
| > | > hour
| > | > | and a half.
| > | > |
| > | > | --
| > | > | -- Thom Little -- www.tlanet.net -- Thom Little Associates,
| > Ltd.
| > | > | --
| > | > |
| > | > | "Thom Little" <th**@tlanet.net> wrote in message
| > | > | news:Om*************@tk2msftngp13.phx.gbl...
| > | > | > Thank you for the information. I will persue it with my
hoisting
| > | > service
| > | > | > when a window of opportunity opens Wednesday afternoon.
| > | > | >
| > | > | > (Getting through the first one is ALWAYS the toughest.)
| > | > | >
| > | > | > --
| > | > | > -- Thom Little -- www.tlanet.net -- Thom Little Associates,
| > Ltd.
| > | > | > --
| > | > | >
| > | > | > "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in
| > message
| > | > | > news:cG**************@TK2MSFTNGXA02.phx.gbl...
| > | > | >> Hi Thom,
| > | > | >>
| > | > | >> As for ASP.NET web application it is application virtual
| > directory
| > | > based.
| > | > | >> So each web application need to be deployed into a certain IIS
| > | > Virtual
| > | > | >> Directory (mark as application...). A normal physical dir
under
| > IIS
| > | > root
| > | > | >> site is not enough, it is a normal virtual directory, but not
| > | > configured
| > | > | >> as
| > | > | >> application.... So I suggest you first use IIS's manager
| > | > (inetmgr.exe)
| > | > | >> to
| > | > | >> create a new virtual directory and configure it as application,
| > you
| > | > can
| > | > | >> change a virutal dir to an application virtual dir through:
| > | > | >>
| > | > | >> 1. In IIS manager console, select that virtual dir's node and
| > right
| > | > click
| > | > | >> properties menu.
| > | > | >> (you can just select the virtual directory you created formly
| > that
| > | > | >> contains
| > | > | >> your application's file....)
| > | > | >>
| > | > | >> 2. In the "Directory" or "Virtual Directory" panel, check the
| > | > | >> "Application
| > | > | >> Name" entry field to see whether it is enabled, if not, click
the
| > | > | >> "Create"
| > | > | >> button on the right side to create it as an application virtual
| > | > dir.....
| > | > | >>
| > | > | >> After you create the virtual directory as an application
virtual
| > dir,
| > | > the
| > | > | >> ASP.NET application in that virutal dir will run as a single
| > alone
| > | > | >> application.....
| > | > | >>
| > | > | >> In addition, notice that ASP.NET application will always
inherit
| > | > | >> configuration setting from machine.config to IIS site's root
| > | > web.config
| > | > | >> to
| > | > | >> its own web.config.... So be sure that if you need to run
both
| > | > asp.net
| > | > | >> 1.1 and asp.net 2.0 web application, you'll need to create two
| > | > websites
| > | > | >> (only available for server OS like windows 2003 server) and one
| > | > | >> configured
| > | > | >> for asp.net 1.1 and another configured for asp.net 2.0 ....
| > | > | >>
| > | > | >> Here are the technet reference about IIS6 ASP.NET application
| > | > deployment:
| > | > | >>
| > | > | >> #Overview of Deploying ASP.NET Applications (IIS 6.0)
| > | > | >>
| > | >
| >
http://www.microsoft.com/technet/pro.../Library/IIS/6
| > | > | >> 4ac3577-7746-4fbd-a5e6-e50bdecf7a24.mspx
| > | > | >>
| > | > | >> Hope helps. If there're anything unclear, please feel free to
| > post
| > | > here.
| > | > | >>
| > | > | >> Thanks,
| > | > | >>
| > | > | >> Steven Cheng
| > | > | >> Microsoft Online Support
| > | > | >>
| > | > | >> Get Secure! www.microsoft.com/security
| > | > | >> (This posting is provided "AS IS", with no warranties, and
| > confers
| > no
| > | > | >> rights.)
| > | > | >
| > | > | >
| > | > |
| > | > |
| > | > |
| > | >
| > |
| > |
| > |
| >
|
|
|

Dec 16 '05 #12

P: n/a
Actually the problem is in the hinterland between the two areas or
responsibility.

It is now operating and your screenshots will not be necessary.

The original test condition that failed ...

Remote Server 2000 running IIS 5.0
ASP.NET 1.1 and ASP.NET 2.0 installed on remote server
No ASP.NET 2.0 application ever installed on the remote server
New webspace created on remote server with ASP.NET 2.0 specified.

Deployment ...
Deployed to d:\Deploy (an empty directory on the local machine)
FTP everything in the directory to new empty webspace.
Not Found failure occurred.

Correction ...
Delete all files in new webspace.
Tell Visual Studio 2005 to deploy directly to that location.
The deployment ran for a VERY long time.
Test succeeded.

Cleared d:\Deploy
Published again to it.
Cleared remote webspace
FTPd all files to cleared area
Test succeeded

My ASSUMPTION is that some final ASP.NET 2.0 configuration initialization
was done on IIS 5.0 on the Remote Server and it was only triggered by
directly running the FIRST deployment to the server or webspace. After that
first deployment you can either directly deploy or deploy locally and FTP
the result.

I've tried everything I can think of to make it fail again except running it
in a new webspace that has never had ASP.NET 2.0 deployed to it.

--
-- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
--

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:xV**************@TK2MSFTNGXA02.phx.gbl...
Thanks for your response Thom.

Actually publishing an ASP.NET web app and expose it to public internet
are
two separate things. As for ASP.NET, we just need to make sure it is
correctly configured in IIS and can be visisted locally. After that, it's
the DNS and other network setting which need to make it visitable to
public
internet.....

Also, I'll try capture some screen shot of my local test 2003(IIS6/ASP.NET
2) environment and update you soon....

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Dec 16 '05 #13

P: n/a
Thanks for your followup Thom,

Glad that you've got the deployment working now.
Also, based the steps you mentioned, I agree that there has some
initialize task which is not correctly done originally that cause the
failure..... Anyway, I suggest you can also create some other simple
projects and try deploying them through multiple approachs, that can help
us get more familiar with the deployment and understanding the process
better....

And if there're anything else we can help later, please feel free to post
here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Thom Little" <th**@tlanet.net>
| References: <uz**************@TK2MSFTNGP14.phx.gbl>
<uB**************@TK2MSFTNGP15.phx.gbl>
<#K**************@TK2MSFTNGP12.phx.gbl>
<cG**************@TK2MSFTNGXA02.phx.gbl>
<Om*************@tk2msftngp13.phx.gbl>
<#2**************@TK2MSFTNGP15.phx.gbl>
<dj**************@TK2MSFTNGXA02.phx.gbl>
<#o*************@TK2MSFTNGP15.phx.gbl>
<Qu*************@TK2MSFTNGXA02.phx.gbl>
<us**************@TK2MSFTNGP11.phx.gbl>
<xV**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: Could Not Load Assembly
| Date: Fri, 16 Dec 2005 12:29:38 -0500
| Lines: 67
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
| X-RFC2646: Format=Flowed; Original
| Message-ID: <OX**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: 65.99.185.176
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:365365
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Actually the problem is in the hinterland between the two areas or
| responsibility.
|
| It is now operating and your screenshots will not be necessary.
|
| The original test condition that failed ...
|
| Remote Server 2000 running IIS 5.0
| ASP.NET 1.1 and ASP.NET 2.0 installed on remote server
| No ASP.NET 2.0 application ever installed on the remote server
| New webspace created on remote server with ASP.NET 2.0 specified.
|
| Deployment ...
| Deployed to d:\Deploy (an empty directory on the local machine)
| FTP everything in the directory to new empty webspace.
| Not Found failure occurred.
|
| Correction ...
| Delete all files in new webspace.
| Tell Visual Studio 2005 to deploy directly to that location.
| The deployment ran for a VERY long time.
| Test succeeded.
|
| Cleared d:\Deploy
| Published again to it.
| Cleared remote webspace
| FTPd all files to cleared area
| Test succeeded
|
| My ASSUMPTION is that some final ASP.NET 2.0 configuration initialization
| was done on IIS 5.0 on the Remote Server and it was only triggered by
| directly running the FIRST deployment to the server or webspace. After
that
| first deployment you can either directly deploy or deploy locally and FTP
| the result.
|
| I've tried everything I can think of to make it fail again except running
it
| in a new webspace that has never had ASP.NET 2.0 deployed to it.
|
| --
| -- Thom Little -- www.tlanet.net -- Thom Little Associates, Ltd.
| --
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:xV**************@TK2MSFTNGXA02.phx.gbl...
| > Thanks for your response Thom.
| >
| > Actually publishing an ASP.NET web app and expose it to public internet
| > are
| > two separate things. As for ASP.NET, we just need to make sure it is
| > correctly configured in IIS and can be visisted locally. After that,
it's
| > the DNS and other network setting which need to make it visitable to
| > public
| > internet.....
| >
| > Also, I'll try capture some screen shot of my local test
2003(IIS6/ASP.NET
| > 2) environment and update you soon....
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
|
|
|

Dec 19 '05 #14

This discussion thread is closed

Replies have been disabled for this discussion.