423,818 Members | 2,250 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 423,818 IT Pros & Developers. It's quick & easy.

Question about "Configuration Error" Message

P: n/a
Hi, simple(?) question about asp.net configuration..

I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When I'm
first start application the follow message shown.
=========
Server Error in '/QuickStartv20' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details
below and modify your configuration file appropriately.

Parser Error Message: An error occurred loading a configuration file: Failed
to start monitoring changes to 'd:\inetpub\wwwroot' because access is denied.

Source Error:
[No relevant source lines]
Source File: d:\inetpub\wwwroot\web.config Line: 0
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET
Version:2.0.50727.42
=====================================

What's the problem? I can't imagine what's wrong...
Is there any body can tell me about, what's wrong???
and How can I fix this???

Have a Good day~~
Dec 2 '05 #1
Share this Question
Share on Google+
10 Replies


P: n/a
Hi Baho,

Welcome to ASPNET newsgroup.
From your description, after you installed the ASP.NET 2.0 QuickStart
examples on your machine, you get some Erros when starting running the
application, yes?

Based on the error message you pasted, I think this is a file access
permission issue. Seems the ASP.NET process idenitity dosn't have the
sufficient permission to access the webapplicaiton folder. Would you
please help me gather the following info:

1. What's your machine's OS version (IIS version)?

2. Where did you installed the quickstart example, directly under the IIS
default site's physical dir(inetpub\wwwroot...)?

3. What's the current process idenitity which is used to running the
ASP.NET applcation(this depends on the things in #1 , the OS version)...

Please feel free to post here if there're anything else you found or I've
misunderstood.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Question about "Configuration Error" Message
| thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| Subject: Question about "Configuration Error" Message
| Date: Thu, 1 Dec 2005 22:40:02 -0800
| Lines: 35
| Message-ID: <85**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362249
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi, simple(?) question about asp.net configuration..
|
| I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When I'm
| first start application the follow message shown.
| =========
| Server Error in '/QuickStartv20' Application.
----------------------------------------------------------------------------
----
|
| Configuration Error
| Description: An error occurred during the processing of a configuration
file
| required to service this request. Please review the specific error
details
| below and modify your configuration file appropriately.
|
| Parser Error Message: An error occurred loading a configuration file:
Failed
| to start monitoring changes to 'd:\inetpub\wwwroot' because access is
denied.
|
| Source Error:
|
|
| [No relevant source lines]
|
|
| Source File: d:\inetpub\wwwroot\web.config Line: 0
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:2.0.50727.42;
ASP.NET
| Version:2.0.50727.42
| =====================================
|
| What's the problem? I can't imagine what's wrong...
| Is there any body can tell me about, what's wrong???
| and How can I fix this???
|
| Have a Good day~~
|

Dec 2 '05 #2

P: n/a
Hi Steven

Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
examples on my machine. My machine environment details are
---------------------------------
1. OS version:
Windows XP Professional, SP2
ASP.NET version 2.0.50727

2. IIS physical directory:
D:\Inetpub\wwwroot

3. QuickStart Sample dir:
D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\QuickStart

4. current process identifier
aspnet_wp.exe 3628
inetinfo.exe 1968
---------------------------------
Hi Baho,

Welcome to ASPNET newsgroup.
From your description, after you installed the ASP.NET 2.0 QuickStart
examples on your machine, you get some Erros when starting running the
application, yes?

Based on the error message you pasted, I think this is a file access
permission issue. Seems the ASP.NET process idenitity dosn't have the
sufficient permission to access the webapplicaiton folder. Would you
please help me gather the following info:

1. What's your machine's OS version (IIS version)?

2. Where did you installed the quickstart example, directly under the IIS
default site's physical dir(inetpub\wwwroot...)?

3. What's the current process idenitity which is used to running the
ASP.NET applcation(this depends on the things in #1 , the OS version)...

Please feel free to post here if there're anything else you found or I've
misunderstood.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Question about "Configuration Error" Message
| thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| Subject: Question about "Configuration Error" Message
| Date: Thu, 1 Dec 2005 22:40:02 -0800
| Lines: 35
| Message-ID: <85**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362249
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi, simple(?) question about asp.net configuration..
|
| I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When I'm
| first start application the follow message shown.
| =========
| Server Error in '/QuickStartv20' Application.
----------------------------------------------------------------------------
----
|
| Configuration Error
| Description: An error occurred during the processing of a configuration
file
| required to service this request. Please review the specific error
details
| below and modify your configuration file appropriately.
|
| Parser Error Message: An error occurred loading a configuration file:
Failed
| to start monitoring changes to 'd:\inetpub\wwwroot' because access is
denied.
|
| Source Error:
|
|
| [No relevant source lines]
|
|
| Source File: d:\inetpub\wwwroot\web.config Line: 0
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:2.0.50727.42;
ASP.NET
| Version:2.0.50727.42
| =====================================
|
| What's the problem? I can't imagine what's wrong...
| Is there any body can tell me about, what's wrong???
| and How can I fix this???
|
| Have a Good day~~
|

Dec 3 '05 #3

P: n/a
Thanks for your quick response Baho,

So your machine is WINXP sp2 /IIS5.
Currently, I'd suggest you first try changing your ASP.NET's running
process's Account from default machine\aspnet to the LOCALSYSTEM to as to
make sure whether this is a permission problem of the asp.net process
idenitity. To change the process identity, you can follow the below steps:

1. locate the machine.config file under your .NET framework 2.0's intalling
folder like:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG

2. Open the machine.config file and find the <processModel> element, by
default it is configured as:

<processModel autoConfig="true" />

, we need to change it to below:

<processModel autoConfig="true" userName="System"/>

so as to let the ASP.NET worker process running under the local system
account(which has the most powerful permission and privileges on local
system...)

3. Restart IIS through "iisreset" command
Then, test your asp.net 2.0 applicaiton again to see whether it can
works......

Also, this is just for testing only, generally we do not recommend asp.net
process running under local system account. Also, the machine.config's
<processModel> element is used for IIS5 isolate model. For IIS6/win2k3
server, it by default use applicaiton pool model which is different from
this.

Anyway, please have a try to see whether it works and feel free to post
here if there're anything unclear...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| Thread-Topic: Question about "Configuration Error" Message
| thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
| Subject: RE: Question about "Configuration Error" Message
| Date: Fri, 2 Dec 2005 18:20:02 -0800
| Lines: 129
| Message-ID: <14**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362458
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Steven
|
| Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| examples on my machine. My machine environment details are
| ---------------------------------
| 1. OS version:
| Windows XP Professional, SP2
| ASP.NET version 2.0.50727
|
| 2. IIS physical directory:
| D:\Inetpub\wwwroot
|
| 3. QuickStart Sample dir:
| D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\QuickStart
|
| 4. current process identifier
| aspnet_wp.exe 3628
| inetinfo.exe 1968
| ---------------------------------
|
| > Hi Baho,
| >
| > Welcome to ASPNET newsgroup.
| > From your description, after you installed the ASP.NET 2.0 QuickStart
| > examples on your machine, you get some Erros when starting running the
| > application, yes?
| >
| > Based on the error message you pasted, I think this is a file access
| > permission issue. Seems the ASP.NET process idenitity dosn't have the
| > sufficient permission to access the webapplicaiton folder. Would you
| > please help me gather the following info:
| >
| > 1. What's your machine's OS version (IIS version)?
| >
| > 2. Where did you installed the quickstart example, directly under the
IIS
| > default site's physical dir(inetpub\wwwroot...)?
| >
| > 3. What's the current process idenitity which is used to running the
| > ASP.NET applcation(this depends on the things in #1 , the OS
version)...
| >
| > Please feel free to post here if there're anything else you found or
I've
| > misunderstood.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| >
| >
| >
| > --------------------
| > | Thread-Topic: Question about "Configuration Error" Message
| > | thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| > | X-WBNR-Posting-Host: 210.182.98.176
| > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| > | Subject: Question about "Configuration Error" Message
| > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| > | Lines: 35
| > | Message-ID: <85**********************************@microsoft.co m>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:362249
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi, simple(?) question about asp.net configuration..
| > |
| > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When
I'm
| > | first start application the follow message shown.
| > | =========
| > | Server Error in '/QuickStartv20' Application.
| >
----------------------------------------------------------------------------
| > ----
| > |
| > | Configuration Error
| > | Description: An error occurred during the processing of a
configuration
| > file
| > | required to service this request. Please review the specific error
| > details
| > | below and modify your configuration file appropriately.
| > |
| > | Parser Error Message: An error occurred loading a configuration file:
| > Failed
| > | to start monitoring changes to 'd:\inetpub\wwwroot' because access is
| > denied.
| > |
| > | Source Error:
| > |
| > |
| > | [No relevant source lines]
| > |
| > |
| > | Source File: d:\inetpub\wwwroot\web.config Line: 0
| > |
| > |
| >
----------------------------------------------------------------------------
| > ----
| > | Version Information: Microsoft .NET Framework Version:2.0.50727.42;
| > ASP.NET
| > | Version:2.0.50727.42
| > | =====================================
| > |
| > | What's the problem? I can't imagine what's wrong...
| > | Is there any body can tell me about, what's wrong???
| > | and How can I fix this???
| > |
| > | Have a Good day~~
| > |
| >
| >
|

Dec 5 '05 #4

P: n/a
Thank you Steven ^^ It's works..

But one more question... You said it was the permission of the asp.net
process. then what's the default permission shoule "default machine\aspnet"
account have for that foler, file or something others?
"Steven Cheng[MSFT]" wrote: Thanks for your quick response Baho,

So your machine is WINXP sp2 /IIS5.
Currently, I'd suggest you first try changing your ASP.NET's running
process's Account from default machine\aspnet to the LOCALSYSTEM to as to
make sure whether this is a permission problem of the asp.net process
idenitity. To change the process identity, you can follow the below steps:

1. locate the machine.config file under your .NET framework 2.0's intalling
folder like:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG

2. Open the machine.config file and find the <processModel> element, by
default it is configured as:

<processModel autoConfig="true" />

, we need to change it to below:

<processModel autoConfig="true" userName="System"/>

so as to let the ASP.NET worker process running under the local system
account(which has the most powerful permission and privileges on local
system...)

3. Restart IIS through "iisreset" command
Then, test your asp.net 2.0 applicaiton again to see whether it can
works......

Also, this is just for testing only, generally we do not recommend asp.net
process running under local system account. Also, the machine.config's
<processModel> element is used for IIS5 isolate model. For IIS6/win2k3
server, it by default use applicaiton pool model which is different from
this.

Anyway, please have a try to see whether it works and feel free to post
here if there're anything unclear...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| Thread-Topic: Question about "Configuration Error" Message
| thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
| Subject: RE: Question about "Configuration Error" Message
| Date: Fri, 2 Dec 2005 18:20:02 -0800
| Lines: 129
| Message-ID: <14**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362458
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Steven
|
| Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| examples on my machine. My machine environment details are
| ---------------------------------
| 1. OS version:
| Windows XP Professional, SP2
| ASP.NET version 2.0.50727
|
| 2. IIS physical directory:
| D:\Inetpub\wwwroot
|
| 3. QuickStart Sample dir:
| D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\QuickStart
|
| 4. current process identifier
| aspnet_wp.exe 3628
| inetinfo.exe 1968
| ---------------------------------
|
| > Hi Baho,
| >
| > Welcome to ASPNET newsgroup.
| > From your description, after you installed the ASP.NET 2.0 QuickStart
| > examples on your machine, you get some Erros when starting running the
| > application, yes?
| >
| > Based on the error message you pasted, I think this is a file access
| > permission issue. Seems the ASP.NET process idenitity dosn't have the
| > sufficient permission to access the webapplicaiton folder. Would you
| > please help me gather the following info:
| >
| > 1. What's your machine's OS version (IIS version)?
| >
| > 2. Where did you installed the quickstart example, directly under the
IIS
| > default site's physical dir(inetpub\wwwroot...)?
| >
| > 3. What's the current process idenitity which is used to running the
| > ASP.NET applcation(this depends on the things in #1 , the OS
version)...
| >
| > Please feel free to post here if there're anything else you found or
I've
| > misunderstood.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| >
| >
| >
| > --------------------
| > | Thread-Topic: Question about "Configuration Error" Message
| > | thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| > | X-WBNR-Posting-Host: 210.182.98.176
| > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| > | Subject: Question about "Configuration Error" Message
| > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| > | Lines: 35
| > | Message-ID: <85**********************************@microsoft.co m>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:362249
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi, simple(?) question about asp.net configuration..
| > |
| > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When
I'm
| > | first start application the follow message shown.
| > | =========
| > | Server Error in '/QuickStartv20' Application.
| >
----------------------------------------------------------------------------
| > ----
| > |
| > | Configuration Error
| > | Description: An error occurred during the processing of a
configuration
| > file
| > | required to service this request. Please review the specific error
| > details
| > | below and modify your configuration file appropriately.
| > |
| > | Parser Error Message: An error occurred loading a configuration file:
| > Failed
| > | to start monitoring changes to 'd:\inetpub\wwwroot' because access is
| > denied.
| > |
| > | Source Error:
| > |
| > |
| > | [No relevant source lines]
| > |
| > |
| > | Source File: d:\inetpub\wwwroot\web.config Line: 0
| > |
| > |
| >
----------------------------------------------------------------------------
| > ----
| > | Version Information: Microsoft .NET Framework Version:2.0.50727.42;
| > ASP.NET
| > | Version:2.0.50727.42
| > | =====================================
| > |
| > | What's the problem? I can't imagine what's wrong...
| > | Is there any body can tell me about, what's wrong???
| > | and How can I fix this???
| > |
| > | Have a Good day~~
| > |
| >
| >
|

Dec 5 '05 #5

P: n/a
Thanks for your quick response Baho,

So the problem is that the ASPNET worker process dosn't have sufficient
permission. And as for:

what's the default permission shoule "default machine\aspnet"
account have for that foler, file or something others?
=========================
Good question, here is a msdn article described the permissions a normal
ASP.NET process account should have:

#How To Create a Custom Account to Run ASP.NET
http://msdn.microsoft.com/library/en...asp?frame=true

So as I mentioned before, local system is just used to confirm that this is
a security permission problem. We're recommended to still use the default
Machine\ASPNET account. And you can swtich back your asp.net's process
idenitity back to "Machine" and check the permissions step by step through
the above article....

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Question about "Configuration Error" Message
| thread-index: AcX5djq94c8ySidxTxSiSr4DaxOilg==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
<14**********************************@microsoft.co m>
<qL*************@TK2MSFTNGXA02.phx.gbl>
| Subject: RE: Question about "Configuration Error" Message
| Date: Mon, 5 Dec 2005 00:31:03 -0800
| Lines: 226
| Message-ID: <B9**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362698
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Thank you Steven ^^ It's works..
|
| But one more question... You said it was the permission of the asp.net
| process. then what's the default permission shoule "default
machine\aspnet"
| account have for that foler, file or something others?
|
| >"Steven Cheng[MSFT]" wrote:
|
| > Thanks for your quick response Baho,
| >
| > So your machine is WINXP sp2 /IIS5.
| > Currently, I'd suggest you first try changing your ASP.NET's running
| > process's Account from default machine\aspnet to the LOCALSYSTEM to as
to
| > make sure whether this is a permission problem of the asp.net process
| > idenitity. To change the process identity, you can follow the below
steps:
| >
| > 1. locate the machine.config file under your .NET framework 2.0's
intalling
| > folder like:
| >
| > C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG
| >
| > 2. Open the machine.config file and find the <processModel> element, by
| > default it is configured as:
| >
| > <processModel autoConfig="true" />
| >
| > , we need to change it to below:
| >
| > <processModel autoConfig="true" userName="System"/>
| >
| > so as to let the ASP.NET worker process running under the local system
| > account(which has the most powerful permission and privileges on local
| > system...)
| >
| > 3. Restart IIS through "iisreset" command
| >
| >
| > Then, test your asp.net 2.0 applicaiton again to see whether it can
| > works......
| >
| > Also, this is just for testing only, generally we do not recommend
asp.net
| > process running under local system account. Also, the machine.config's
| > <processModel> element is used for IIS5 isolate model. For IIS6/win2k3
| > server, it by default use applicaiton pool model which is different
from
| > this.
| >
| > Anyway, please have a try to see whether it works and feel free to post
| > here if there're anything unclear...
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | Thread-Topic: Question about "Configuration Error" Message
| > | thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| > | X-WBNR-Posting-Host: 210.182.98.176
| > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| > | References: <85**********************************@microsoft.co m>
| > <Df**************@TK2MSFTNGXA02.phx.gbl>
| > | Subject: RE: Question about "Configuration Error" Message
| > | Date: Fri, 2 Dec 2005 18:20:02 -0800
| > | Lines: 129
| > | Message-ID: <14**********************************@microsoft.co m>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:362458
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi Steven
| > |
| > | Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| > | examples on my machine. My machine environment details are
| > | ---------------------------------
| > | 1. OS version:
| > | Windows XP Professional, SP2
| > | ASP.NET version 2.0.50727
| > |
| > | 2. IIS physical directory:
| > | D:\Inetpub\wwwroot
| > |
| > | 3. QuickStart Sample dir:
| > | D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\QuickStart
| > |
| > | 4. current process identifier
| > | aspnet_wp.exe 3628
| > | inetinfo.exe 1968
| > | ---------------------------------
| > |
| > | > Hi Baho,
| > | >
| > | > Welcome to ASPNET newsgroup.
| > | > From your description, after you installed the ASP.NET 2.0
QuickStart
| > | > examples on your machine, you get some Erros when starting running
the
| > | > application, yes?
| > | >
| > | > Based on the error message you pasted, I think this is a file
access
| > | > permission issue. Seems the ASP.NET process idenitity dosn't have
the
| > | > sufficient permission to access the webapplicaiton folder. Would
you
| > | > please help me gather the following info:
| > | >
| > | > 1. What's your machine's OS version (IIS version)?
| > | >
| > | > 2. Where did you installed the quickstart example, directly under
the
| > IIS
| > | > default site's physical dir(inetpub\wwwroot...)?
| > | >
| > | > 3. What's the current process idenitity which is used to running
the
| > | > ASP.NET applcation(this depends on the things in #1 , the OS
| > version)...
| > | >
| > | > Please feel free to post here if there're anything else you found
or
| > I've
| > | > misunderstood.
| > | >
| > | > Thanks,
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > --------------------
| > | > | Thread-Topic: Question about "Configuration Error" Message
| > | > | thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| > | > | X-WBNR-Posting-Host: 210.182.98.176
| > | > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| > | > | Subject: Question about "Configuration Error" Message
| > | > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| > | > | Lines: 35
| > | > | Message-ID: <85**********************************@microsoft.co m>
| > | > | MIME-Version: 1.0
| > | > | Content-Type: text/plain;
| > | > | charset="Utf-8"
| > | > | Content-Transfer-Encoding: 7bit
| > | > | X-Newsreader: Microsoft CDO for Windows 2000
| > | > | Content-Class: urn:content-classes:message
| > | > | Importance: normal
| > | > | Priority: normal
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > | > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| > | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | > microsoft.public.dotnet.framework.aspnet:362249
| > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > |
| > | > | Hi, simple(?) question about asp.net configuration..
| > | > |
| > | > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But,
When
| > I'm
| > | > | first start application the follow message shown.
| > | > | =========
| > | > | Server Error in '/QuickStartv20' Application.
| > | >
| >
----------------------------------------------------------------------------
| > | > ----
| > | > |
| > | > | Configuration Error
| > | > | Description: An error occurred during the processing of a
| > configuration
| > | > file
| > | > | required to service this request. Please review the specific
error
| > | > details
| > | > | below and modify your configuration file appropriately.
| > | > |
| > | > | Parser Error Message: An error occurred loading a configuration
file:
| > | > Failed
| > | > | to start monitoring changes to 'd:\inetpub\wwwroot' because
access is
| > | > denied.
| > | > |
| > | > | Source Error:
| > | > |
| > | > |
| > | > | [No relevant source lines]
| > | > |
| > | > |
| > | > | Source File: d:\inetpub\wwwroot\web.config Line: 0
| > | > |
| > | > |
| > | >
| >
----------------------------------------------------------------------------
| > | > ----
| > | > | Version Information: Microsoft .NET Framework
Version:2.0.50727.42;
| > | > ASP.NET
| > | > | Version:2.0.50727.42
| > | > | =====================================
| > | > |
| > | > | What's the problem? I can't imagine what's wrong...
| > | > | Is there any body can tell me about, what's wrong???
| > | > | and How can I fix this???
| > | > |
| > | > | Have a Good day~~
| > | > |
| > | >
| > | >
| > |
| >
| >
|

Dec 5 '05 #6

P: n/a
Hi Baho,

Any further questions or anything else we can help, if so, please feel free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
<14**********************************@microsoft.co m>
<qL*************@TK2MSFTNGXA02.phx.gbl>
<B9**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configuration Error" Message
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <52*************@TK2MSFTNGXA02.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362701
| NNTP-Posting-Host: tomcatimport2.phx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =========================
| Good question, here is a msdn article described the permissions a normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that this
is
| a security permission problem. We're recommended to still use the default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configuration Error" Message
| | thread-index: AcX5djq94c8ySidxTxSiSr4DaxOilg==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | References: <85**********************************@microsoft.co m>
| <Df**************@TK2MSFTNGXA02.phx.gbl>
| <14**********************************@microsoft.co m>
| <qL*************@TK2MSFTNGXA02.phx.gbl>
| | Subject: RE: Question about "Configuration Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9**********************************@microsoft.co m>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:362698
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | > Thanks for your quick response Baho,
| | >
| | > So your machine is WINXP sp2 /IIS5.
| | > Currently, I'd suggest you first try changing your ASP.NET's running
| | > process's Account from default machine\aspnet to the LOCALSYSTEM to
as
| to
| | > make sure whether this is a permission problem of the asp.net process
| | > idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | > 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | > folder like:
| | >
| | > C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG
| | >
| | > 2. Open the machine.config file and find the <processModel> element,
by
| | > default it is configured as:
| | >
| | > <processModel autoConfig="true" />
| | >
| | > , we need to change it to below:
| | >
| | > <processModel autoConfig="true" userName="System"/>
| | >
| | > so as to let the ASP.NET worker process running under the local
system
| | > account(which has the most powerful permission and privileges on
local
| | > system...)
| | >
| | > 3. Restart IIS through "iisreset" command
| | >
| | >
| | > Then, test your asp.net 2.0 applicaiton again to see whether it can
| | > works......
| | >
| | > Also, this is just for testing only, generally we do not recommend
| asp.net
| | > process running under local system account. Also, the
machine.config's
| | > <processModel> element is used for IIS5 isolate model. For
IIS6/win2k3
| | > server, it by default use applicaiton pool model which is different
| from
| | > this.
| | >
| | > Anyway, please have a try to see whether it works and feel free to
post
| | > here if there're anything unclear...
| | >
| | > Thanks,
| | >
| | > Steven Cheng
| | > Microsoft Online Support
| | >
| | > Get Secure! www.microsoft.com/security
| | > (This posting is provided "AS IS", with no warranties, and confers no
| | > rights.)
| | >
| | >
| | >
| | > --------------------
| | > | Thread-Topic: Question about "Configuration Error" Message
| | > | thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| | > | X-WBNR-Posting-Host: 210.182.98.176
| | > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | > | References: <85**********************************@microsoft.co m>
| | > <Df**************@TK2MSFTNGXA02.phx.gbl>
| | > | Subject: RE: Question about "Configuration Error" Message
| | > | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | > | Lines: 129
| | > | Message-ID: <14**********************************@microsoft.co m>
| | > | MIME-Version: 1.0
| | > | Content-Type: text/plain;
| | > | charset="Utf-8"
| | > | Content-Transfer-Encoding: 7bit
| | > | X-Newsreader: Microsoft CDO for Windows 2000
| | > | Content-Class: urn:content-classes:message
| | > | Importance: normal
| | > | Priority: normal
| | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | > | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| | > | Xref: TK2MSFTNGXA02.phx.gbl
| | > microsoft.public.dotnet.framework.aspnet:362458
| | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | > |
| | > | Hi Steven
| | > |
| | > | Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| | > | examples on my machine. My machine environment details are
| | > | ---------------------------------
| | > | 1. OS version:
| | > | Windows XP Professional, SP2
| | > | ASP.NET version 2.0.50727
| | > |
| | > | 2. IIS physical directory:
| | > | D:\Inetpub\wwwroot
| | > |
| | > | 3. QuickStart Sample dir:
| | > | D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\QuickStart
| | > |
| | > | 4. current process identifier
| | > | aspnet_wp.exe 3628
| | > | inetinfo.exe 1968
| | > | ---------------------------------
| | > |
| | > | > Hi Baho,
| | > | >
| | > | > Welcome to ASPNET newsgroup.
| | > | > From your description, after you installed the ASP.NET 2.0
| QuickStart
| | > | > examples on your machine, you get some Erros when starting
running
| the
| | > | > application, yes?
| | > | >
| | > | > Based on the error message you pasted, I think this is a file
| access
| | > | > permission issue. Seems the ASP.NET process idenitity dosn't have
| the
| | > | > sufficient permission to access the webapplicaiton folder. Would
| you
| | > | > please help me gather the following info:
| | > | >
| | > | > 1. What's your machine's OS version (IIS version)?
| | > | >
| | > | > 2. Where did you installed the quickstart example, directly under
| the
| | > IIS
| | > | > default site's physical dir(inetpub\wwwroot...)?
| | > | >
| | > | > 3. What's the current process idenitity which is used to running
| the
| | > | > ASP.NET applcation(this depends on the things in #1 , the OS
| | > version)...
| | > | >
| | > | > Please feel free to post here if there're anything else you found
| or
| | > I've
| | > | > misunderstood.
| | > | >
| | > | > Thanks,
| | > | >
| | > | > Steven Cheng
| | > | > Microsoft Online Support
| | > | >
| | > | > Get Secure! www.microsoft.com/security
| | > | > (This posting is provided "AS IS", with no warranties, and
confers
| no
| | > | > rights.)
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | > --------------------
| | > | > | Thread-Topic: Question about "Configuration Error" Message
| | > | > | thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| | > | > | X-WBNR-Posting-Host: 210.182.98.176
| | > | > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | > | > | Subject: Question about "Configuration Error" Message
| | > | > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| | > | > | Lines: 35
| | > | > | Message-ID: <85**********************************@microsoft.co m>
| | > | > | MIME-Version: 1.0
| | > | > | Content-Type: text/plain;
| | > | > | charset="Utf-8"
| | > | > | Content-Transfer-Encoding: 7bit
| | > | > | X-Newsreader: Microsoft CDO for Windows 2000
| | > | > | Content-Class: urn:content-classes:message
| | > | > | Importance: normal
| | > | > | Priority: normal
| | > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | > | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | > | > | Path:
| TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| | > | > | Xref: TK2MSFTNGXA02.phx.gbl
| | > | > microsoft.public.dotnet.framework.aspnet:362249
| | > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | > | > |
| | > | > | Hi, simple(?) question about asp.net configuration..
| | > | > |
| | > | > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But,
| When
| | > I'm
| | > | > | first start application the follow message shown.
| | > | > | =========
| | > | > | Server Error in '/QuickStartv20' Application.
| | > | >
| | >
|
----------------------------------------------------------------------------
| | > | > ----
| | > | > |
| | > | > | Configuration Error
| | > | > | Description: An error occurred during the processing of a
| | > configuration
| | > | > file
| | > | > | required to service this request. Please review the specific
| error
| | > | > details
| | > | > | below and modify your configuration file appropriately.
| | > | > |
| | > | > | Parser Error Message: An error occurred loading a configuration
| file:
| | > | > Failed
| | > | > | to start monitoring changes to 'd:\inetpub\wwwroot' because
| access is
| | > | > denied.
| | > | > |
| | > | > | Source Error:
| | > | > |
| | > | > |
| | > | > | [No relevant source lines]
| | > | > |
| | > | > |
| | > | > | Source File: d:\inetpub\wwwroot\web.config Line: 0
| | > | > |
| | > | > |
| | > | >
| | >
|
----------------------------------------------------------------------------
| | > | > ----
| | > | > | Version Information: Microsoft .NET Framework
| Version:2.0.50727.42;
| | > | > ASP.NET
| | > | > | Version:2.0.50727.42
| | > | > | =====================================
| | > | > |
| | > | > | What's the problem? I can't imagine what's wrong...
| | > | > | Is there any body can tell me about, what's wrong???
| | > | > | and How can I fix this???
| | > | > |
| | > | > | Have a Good day~~
| | > | > |
| | > | >
| | > | >
| | > |
| | >
| | >
| |
|
|

Dec 7 '05 #7

P: n/a
Ok now I have have a question for you.,.

I have a similar problem but this solution as not fixed it for me. Whenever
I try to start an ASPX or ASMX page via the IIS server
(http://localhost/beachdrne/default.aspx) the browser beeps and then appears
to just hang. I have reset the machine.Config for both 2.0 and 1.1. Neither
of these seems to work.

Any ideas?

I can tell you if I create a web site using the file system option they will
work.

I have uninstalled and reinstalled IIS several times and run the
aspnet_regiis -i several times.
"Steven Cheng[MSFT]" wrote:
Hi Baho,

Any further questions or anything else we can help, if so, please feel free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
<14**********************************@microsoft.co m>
<qL*************@TK2MSFTNGXA02.phx.gbl>
<B9**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configuration Error" Message
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <52*************@TK2MSFTNGXA02.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362701
| NNTP-Posting-Host: tomcatimport2.phx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =========================
| Good question, here is a msdn article described the permissions a normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that this
is
| a security permission problem. We're recommended to still use the default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configuration Error" Message
| | thread-index: AcX5djq94c8ySidxTxSiSr4DaxOilg==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | References: <85**********************************@microsoft.co m>
| <Df**************@TK2MSFTNGXA02.phx.gbl>
| <14**********************************@microsoft.co m>
| <qL*************@TK2MSFTNGXA02.phx.gbl>
| | Subject: RE: Question about "Configuration Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9**********************************@microsoft.co m>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:362698
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | Thanks for your quick response Baho,
| | >
| | So your machine is WINXP sp2 /IIS5.
| | Currently, I'd suggest you first try changing your ASP.NET's running
| | process's Account from default machine\aspnet to the LOCALSYSTEM to
as
| to
| | make sure whether this is a permission problem of the asp.net process
| | idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | folder like:
| | >
| | C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG
| | >
| | 2. Open the machine.config file and find the <processModelelement,
by
| | default it is configured as:
| | >
| | <processModel autoConfig="true" />
| | >
| | , we need to change it to below:
| | >
| | <processModel autoConfig="true" userName="System"/>
| | >
| | so as to let the ASP.NET worker process running under the local
system
| | account(which has the most powerful permission and privileges on
local
| | system...)
| | >
| | 3. Restart IIS through "iisreset" command
| | >
| | >
| | Then, test your asp.net 2.0 applicaiton again to see whether it can
| | works......
| | >
| | Also, this is just for testing only, generally we do not recommend
| asp.net
| | process running under local system account. Also, the
machine.config's
| | <processModelelement is used for IIS5 isolate model. For
IIS6/win2k3
| | server, it by default use applicaiton pool model which is different
| from
| | this.
| | >
| | Anyway, please have a try to see whether it works and feel free to
post
| | here if there're anything unclear...
| | >
| | Thanks,
| | >
| | Steven Cheng
| | Microsoft Online Support
| | >
| | Get Secure! www.microsoft.com/security
| | (This posting is provided "AS IS", with no warranties, and confers no
| | rights.)
| | >
| | >
| | >
| | --------------------
| | | Thread-Topic: Question about "Configuration Error" Message
| | | thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| | | X-WBNR-Posting-Host: 210.182.98.176
| | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | | References: <85**********************************@microsoft.co m>
| | <Df**************@TK2MSFTNGXA02.phx.gbl>
| | | Subject: RE: Question about "Configuration Error" Message
| | | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | | Lines: 129
| | | Message-ID: <14**********************************@microsoft.co m>
| | | MIME-Version: 1.0
| | | Content-Type: text/plain;
| | | charset="Utf-8"
| | | Content-Transfer-Encoding: 7bit
| | | X-Newsreader: Microsoft CDO for Windows 2000
| | | Content-Class: urn:content-classes:message
| | | Importance: normal
| | | Priority: normal
| | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| | | Xref: TK2MSFTNGXA02.phx.gbl
| | microsoft.public.dotnet.framework.aspnet:362458
| | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | |
| | | Hi Steven
| | |
| | | Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| | | examples on my machine. My machine environment details are
| | | ---------------------------------
| | | 1. OS version:
| | | Windows XP Professional, SP2
| | | ASP.NET version 2.0.50727
| | |
| | | 2. IIS physical directory:
| | | D:\Inetpub\wwwroot
| | |
| | | 3. QuickStart Sample dir:
| | | D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\QuickStart
| | |
| | | 4. current process identifier
| | | aspnet_wp.exe 3628
| | | inetinfo.exe 1968
| | | ---------------------------------
| | |
| | | Hi Baho,
| | | >
| | | Welcome to ASPNET newsgroup.
| | | From your description, after you installed the ASP.NET 2.0
| QuickStart
| | | examples on your machine, you get some Erros when starting
running
| the
| | | application, yes?
| | | >
| | | Based on the error message you pasted, I think this is a file
| access
| | | permission issue. Seems the ASP.NET process idenitity dosn't have
| the
| | | sufficient permission to access the webapplicaiton folder. Would
| you
| | | please help me gather the following info:
| | | >
| | | 1. What's your machine's OS version (IIS version)?
| | | >
| | | 2. Where did you installed the quickstart example, directly under
| the
| | IIS
| | | default site's physical dir(inetpub\wwwroot...)?
| | | >
| | | 3. What's the current process idenitity which is used to running
| the
| | | ASP.NET applcation(this depends on the things in #1 , the OS
| | version)...
| | | >
| | | Please feel free to post here if there're anything else you found
| or
| | I've
| | | misunderstood.
| | | >
| | | Thanks,
| | | >
| | | Steven Cheng
| | | Microsoft Online Support
| | | >
| | | Get Secure! www.microsoft.com/security
| | | (This posting is provided "AS IS", with no warranties, and
confers
| no
| | | rights.)
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | --------------------
| | | | Thread-Topic: Question about "Configuration Error" Message
| | | | thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| | | | X-WBNR-Posting-Host: 210.182.98.176
| | | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | | | Subject: Question about "Configuration Error" Message
| | | | Date: Thu, 1 Dec 2005 22:40:02 -0800
| | | | Lines: 35
| | | | Message-ID: <85**********************************@microsoft.co m>
| | | | MIME-Version: 1.0
| | | | Content-Type: text/plain;
| | | | charset="Utf-8"
| | | | Content-Transfer-Encoding: 7bit
| | | | X-Newsreader: Microsoft CDO for Windows 2000
| | | | Content-Class: urn:content-classes:message
| | | | Importance: normal
| | | | Priority: normal
| | | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | | | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | | | Path:
| TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| | | | Xref: TK2MSFTNGXA02.phx.gbl
| | | microsoft.public.dotnet.framework.aspnet:362249
| | | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | | |
Oct 9 '06 #8

P: n/a
What happens if you just run http://localhost ?

or http://127.0.0.1 ?

Jeff
"Perryt" <Pe****@discussions.microsoft.comwrote in message
news:C2**********************************@microsof t.com...
Ok now I have have a question for you.,.

I have a similar problem but this solution as not fixed it for me.
Whenever
I try to start an ASPX or ASMX page via the IIS server
(http://localhost/beachdrne/default.aspx) the browser beeps and then
appears
to just hang. I have reset the machine.Config for both 2.0 and 1.1.
Neither
of these seems to work.

Any ideas?

I can tell you if I create a web site using the file system option they
will
work.

I have uninstalled and reinstalled IIS several times and run the
aspnet_regiis -i several times.
"Steven Cheng[MSFT]" wrote:
>Hi Baho,

Any further questions or anything else we can help, if so, please feel
free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
<14**********************************@microsoft.c om>
<qL*************@TK2MSFTNGXA02.phx.gbl>
<B9**********************************@microsoft.c om>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configuration Error" Message
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <52*************@TK2MSFTNGXA02.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362701
| NNTP-Posting-Host: tomcatimport2.phx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =========================
| Good question, here is a msdn article described the permissions a
normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that
this
is
| a security permission problem. We're recommended to still use the
default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configuration Error" Message
| | thread-index: AcX5djq94c8ySidxTxSiSr4DaxOilg==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | References: <85**********************************@microsoft.co m>
| <Df**************@TK2MSFTNGXA02.phx.gbl>
| <14**********************************@microsoft.co m>
| <qL*************@TK2MSFTNGXA02.phx.gbl>
| | Subject: RE: Question about "Configuration Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9**********************************@microsoft.co m>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:362698
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the
asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | Thanks for your quick response Baho,
| | >
| | So your machine is WINXP sp2 /IIS5.
| | Currently, I'd suggest you first try changing your ASP.NET's
running
| | process's Account from default machine\aspnet to the LOCALSYSTEM
to
as
| to
| | make sure whether this is a permission problem of the asp.net
process
| | idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | folder like:
| | >
| | C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG
| | >
| | 2. Open the machine.config file and find the <processModel>
element,
by
| | default it is configured as:
| | >
| | <processModel autoConfig="true" />
| | >
| | , we need to change it to below:
| | >
| | <processModel autoConfig="true" userName="System"/>
| | >
| | so as to let the ASP.NET worker process running under the local
system
| | account(which has the most powerful permission and privileges on
local
| | system...)
| | >
| | 3. Restart IIS through "iisreset" command
| | >
| | >
| | Then, test your asp.net 2.0 applicaiton again to see whether it can
| | works......
| | >
| | Also, this is just for testing only, generally we do not recommend
| asp.net
| | process running under local system account. Also, the
machine.config's
| | <processModelelement is used for IIS5 isolate model. For
IIS6/win2k3
| | server, it by default use applicaiton pool model which is different
| from
| | this.
| | >
| | Anyway, please have a try to see whether it works and feel free to
post
| | here if there're anything unclear...
| | >
| | Thanks,
| | >
| | Steven Cheng
| | Microsoft Online Support
| | >
| | Get Secure! www.microsoft.com/security
| | (This posting is provided "AS IS", with no warranties, and confers
no
| | rights.)
| | >
| | >
| | >
| | --------------------
| | | Thread-Topic: Question about "Configuration Error" Message
| | | thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| | | X-WBNR-Posting-Host: 210.182.98.176
| | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | | References: <85**********************************@microsoft.co m>
| | <Df**************@TK2MSFTNGXA02.phx.gbl>
| | | Subject: RE: Question about "Configuration Error" Message
| | | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | | Lines: 129
| | | Message-ID: <14**********************************@microsoft.co m>
| | | MIME-Version: 1.0
| | | Content-Type: text/plain;
| | | charset="Utf-8"
| | | Content-Transfer-Encoding: 7bit
| | | X-Newsreader: Microsoft CDO for Windows 2000
| | | Content-Class: urn:content-classes:message
| | | Importance: normal
| | | Priority: normal
| | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSF TNGXA03.phx.gbl
| | | Xref: TK2MSFTNGXA02.phx.gbl
| | microsoft.public.dotnet.framework.aspnet:362458
| | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | |
| | | Hi Steven
| | |
| | | Yes, I've got error. After you installed the ASP.NET 2.0
QuickStart
| | | examples on my machine. My machine environment details are
| | | ---------------------------------
| | | 1. OS version:
| | | Windows XP Professional, SP2
| | | ASP.NET version 2.0.50727
| | |
| | | 2. IIS physical directory:
| | | D:\Inetpub\wwwroot
| | |
| | | 3. QuickStart Sample dir:
| | | D:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\QuickStart
| | |
| | | 4. current process identifier
| | | aspnet_wp.exe 3628
| | | inetinfo.exe 1968
| | | ---------------------------------
| | |
| | | Hi Baho,
| | | >
| | | Welcome to ASPNET newsgroup.
| | | From your description, after you installed the ASP.NET 2.0
| QuickStart
| | | examples on your machine, you get some Erros when starting
running
| the
| | | application, yes?
| | | >
| | | Based on the error message you pasted, I think this is a file
| access
| | | permission issue. Seems the ASP.NET process idenitity dosn't
have
| the
| | | sufficient permission to access the webapplicaiton folder.
Would
| you
| | | please help me gather the following info:
| | | >
| | | 1. What's your machine's OS version (IIS version)?
| | | >
| | | 2. Where did you installed the quickstart example, directly
under
| the
| | IIS
| | | default site's physical dir(inetpub\wwwroot...)?
| | | >
| | | 3. What's the current process idenitity which is used to
running
| the
| | | ASP.NET applcation(this depends on the things in #1 , the OS
| | version)...
| | | >
| | | Please feel free to post here if there're anything else you
found
| or
| | I've
| | | misunderstood.
| | | >
| | | Thanks,
| | | >
| | | Steven Cheng
| | | Microsoft Online Support
| | | >
| | | Get Secure! www.microsoft.com/security
| | | (This posting is provided "AS IS", with no warranties, and
confers
| no
| | | rights.)
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | --------------------
| | | | Thread-Topic: Question about "Configuration Error" Message
| | | | thread-index: AcX3CzjCdckva5nJSQO1GEyzHD3TGQ==
| | | | X-WBNR-Posting-Host: 210.182.98.176
| | | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | | | Subject: Question about "Configuration Error" Message
| | | | Date: Thu, 1 Dec 2005 22:40:02 -0800
| | | | Lines: 35
| | | | Message-ID:
<85**********************************@microsoft.c om>
| | | | MIME-Version: 1.0
| | | | Content-Type: text/plain;
| | | | charset="Utf-8"
| | | | Content-Transfer-Encoding: 7bit
| | | | X-Newsreader: Microsoft CDO for Windows 2000
| | | | Content-Class: urn:content-classes:message
| | | | Importance: normal
| | | | Priority: normal
| | | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | | | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | | | Path:
| TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| | | | Xref: TK2MSFTNGXA02.phx.gbl
| | | microsoft.public.dotnet.framework.aspnet:362249
| | | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | | |

Oct 9 '06 #9

P: n/a
The default.html page I have at Http://localhost loads just fine. Also .ASP
pages load fine it seems to only be th .NET pages that have the issue.

"Jeff Dillon" wrote:
What happens if you just run http://localhost ?

or http://127.0.0.1 ?

Jeff
"Perryt" <Pe****@discussions.microsoft.comwrote in message
news:C2**********************************@microsof t.com...
Ok now I have have a question for you.,.

I have a similar problem but this solution as not fixed it for me.
Whenever
I try to start an ASPX or ASMX page via the IIS server
(http://localhost/beachdrne/default.aspx) the browser beeps and then
appears
to just hang. I have reset the machine.Config for both 2.0 and 1.1.
Neither
of these seems to work.

Any ideas?

I can tell you if I create a web site using the file system option they
will
work.

I have uninstalled and reinstalled IIS several times and run the
aspnet_regiis -i several times.
"Steven Cheng[MSFT]" wrote:
Hi Baho,

Any further questions or anything else we can help, if so, please feel
free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85**********************************@microsoft.co m>
<Df**************@TK2MSFTNGXA02.phx.gbl>
<14**********************************@microsoft.co m>
<qL*************@TK2MSFTNGXA02.phx.gbl>
<B9**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configuration Error" Message
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <52*************@TK2MSFTNGXA02.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:362701
| NNTP-Posting-Host: tomcatimport2.phx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =========================
| Good question, here is a msdn article described the permissions a
normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that
this
is
| a security permission problem. We're recommended to still use the
default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configuration Error" Message
| | thread-index: AcX5djq94c8ySidxTxSiSr4DaxOilg==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | References: <85**********************************@microsoft.co m>
| <Df**************@TK2MSFTNGXA02.phx.gbl>
| <14**********************************@microsoft.co m>
| <qL*************@TK2MSFTNGXA02.phx.gbl>
| | Subject: RE: Question about "Configuration Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9**********************************@microsoft.co m>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:362698
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the
asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | Thanks for your quick response Baho,
| | >
| | So your machine is WINXP sp2 /IIS5.
| | Currently, I'd suggest you first try changing your ASP.NET's
running
| | process's Account from default machine\aspnet to the LOCALSYSTEM
to
as
| to
| | make sure whether this is a permission problem of the asp.net
process
| | idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | folder like:
| | >
| | C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONF IG
| | >
| | 2. Open the machine.config file and find the <processModel>
element,
by
| | default it is configured as:
| | >
| | <processModel autoConfig="true" />
| | >
| | , we need to change it to below:
| | >
| | <processModel autoConfig="true" userName="System"/>
| | >
| | so as to let the ASP.NET worker process running under the local
system
| | account(which has the most powerful permission and privileges on
local
| | system...)
| | >
| | 3. Restart IIS through "iisreset" command
| | >
| | >
| | Then, test your asp.net 2.0 applicaiton again to see whether it can
| | works......
| | >
| | Also, this is just for testing only, generally we do not recommend
| asp.net
| | process running under local system account. Also, the
machine.config's
| | <processModelelement is used for IIS5 isolate model. For
IIS6/win2k3
| | server, it by default use applicaiton pool model which is different
| from
| | this.
| | >
| | Anyway, please have a try to see whether it works and feel free to
post
| | here if there're anything unclear...
| | >
| | Thanks,
| | >
| | Steven Cheng
| | Microsoft Online Support
| | >
| | Get Secure! www.microsoft.com/security
| | (This posting is provided "AS IS", with no warranties, and confers
no
| | rights.)
| | >
| | >
| | >
| | --------------------
| | | Thread-Topic: Question about "Configuration Error" Message
| | | thread-index: AcX3sBD65EPm92MaQzSgIHOQBE34Gw==
| | | X-WBNR-Posting-Host: 210.182.98.176
| | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroups.nospam>
| | | References: <85**********************************@microsoft.co m>
| | <Df**************@TK2MSFTNGXA02.phx.gbl>
| | | Subject: RE: Question about "Configuration Error" Message
| | | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | | Lines: 129
| | | Message-ID: <14**********************************@microsoft.co m>
| | | MIME-Version: 1.0
| | | Content-Type: text/plain;
| | | charset="Utf-8"
| | | Content-Transfer-Encoding: 7bit
| | | X-Newsreader: Microsoft CDO for Windows 2000
| | | Content-Class: urn:content-classes:message
| | | Importance: normal
| | | Priority: normal
| | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| | | Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| | | Xref: TK2MSFTNGXA02.phx.gbl
| | microsoft.public.dotnet.framework.aspnet:362458
| | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | |
| | | Hi Steven
| | |
| | | Yes, I've got error. After you installed the ASP.NET 2.0
QuickStart
| | | examples on my machine. My machine environment details are
| | | ---------------------------------
| | | 1. OS version:
| | | Windows XP Professional, SP2
| | | ASP.NET version 2.0.50727
| | |
| | | 2. IIS physical directory:
| | | D:\Inetpub\wwwroot
| | |
| | | 3. QuickStart Sample dir:
| | | D:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\QuickStart
| | |
| | | 4. current process identifier
| | | aspnet_wp.exe 3628
| | | inetinfo.exe 1968
| | | ---------------------------------
| | |
| | | Hi Baho,
| | | >
| | | Welcome to ASPNET newsgroup.
| | | From your description, after you installed the ASP.NET 2.0
| QuickStart
| | | examples on your machine, you get some Erros when starting
running
| the
| | | application, yes?
| | | >
| | | Based on the error message you pasted, I think this is a file
| access
| | | permission issue. Seems the ASP.NET process idenitity dosn't
have
| the
| | | sufficient permission to access the webapplicaiton folder.
Would
| you
| | | please help me gather the following info:
| | | >
| | | 1. What's your machine's OS version (IIS version)?
| | | >
| | | 2. Where did you installed the quickstart example, directly
under
| the
| | IIS
| | | default site's physical dir(inetpub\wwwroot...)?
| | | >
| | | 3. What's the current process idenitity which is used to
running
| the
| | | ASP.NET applcation(this depends on the things in #1 , the OS
| | version)...
| | | >
| | | Please feel free to post here if there're anything else you
found
| or
Oct 9 '06 #10

P: n/a
Don't know if you solved this yet, but I ran into the exact same thing.
It ended up that bmnet.dll and inetinfo.exe were stepping on each
other. The dll is used by compression agents for wireless modem cards
supplied by Cingular and Sprint. Just remove it and create the
connections by hand (connection managers are for wooses anyway). There
may be a newer versions out there that fix the issue.

Rob Greenfield
Chief Scientist
SCL Holdings

Oct 25 '06 #11

This discussion thread is closed

Replies have been disabled for this discussion.