By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,154 Members | 1,050 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,154 IT Pros & Developers. It's quick & easy.

Walkthrough: Creating a Web Page to Display Access Database Data

P: n/a
Walkthrough: Creating a Web Page to Display Access Database Data

I've started the above walkthrough. However, near the beginning it gives
the following instructions

To set permissions in the App_Data folder
In Windows Explorer, move to the root folder for the Web site.

The default location for your new Web site is c:\inetpub\wwwroot\AccessSample.

If the App_Data folder does not already exist, create one.

By default, Visual Web Developer creates the folder when you create a new
Web site.

Right-click the App_Data folder, click Properties, and then click the
Security tab.

My problem is that there is no security tab. The other tabs - general,
sharing,web sharing and customize are there.

By the way, the folder is in the iis folder, and my iis is correctly
configured.

dennist685
Nov 23 '05 #1
Share this Question
Share on Google+
9 Replies


P: n/a
Are you using simple file sharing ?
If you are, turn it off, so the security tab shows.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"dennist685" <de********@newsgroup.nospam> wrote in message
news:89**********************************@microsof t.com...
Walkthrough: Creating a Web Page to Display Access Database Data

I've started the above walkthrough. However, near the beginning it gives
the following instructions

To set permissions in the App_Data folder
In Windows Explorer, move to the root folder for the Web site.

The default location for your new Web site is c:\inetpub\wwwroot\AccessSample.

If the App_Data folder does not already exist, create one.

By default, Visual Web Developer creates the folder when you create a new
Web site.

Right-click the App_Data folder, click Properties, and then click the
Security tab.

My problem is that there is no security tab. The other tabs - general,
sharing,web sharing and customize are there.

By the way, the folder is in the iis folder, and my iis is correctly
configured.

dennist685

Nov 23 '05 #2

P: n/a
Nowhere in the walkthrough is there a choice or step of selecting simple file
sharing. I certainly don't mean to. I simply open up a folder in the
localhost folder, nd within that folder there is app_data. The walkthrough
says the security tab should show, but it doesnt.

This is asp.net 2.0, not 1.1; could that make the difference?

dennist685
Nov 23 '05 #3

P: n/a
Hi Dennist,

Not very sure about the walkthrough's complete context... I think the
security setting here means the NTFS permission setting. And for IIS6, in
the IIS manager (inetmgr), we can right click a directory and choose the
"permissions" menu item in the menu, then the NTFS security setting dialog
will popup. Is this the things you're looking for?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| Thread-Topic: Walkthrough: Creating a Web Page to Display Access Database
Da
| thread-index: AcXvRTywh1BmDhaFT7C+V3ngcx39wA==
| X-WBNR-Posting-Host: 85.64.135.196
| From: "=?Utf-8?B?ZGVubmlzdDY4NQ==?=" <de********@newsgroup.nospam>
| References: <89**********************************@microsoft.co m>
<uQ**************@TK2MSFTNGP14.phx.gbl>
| Subject: Re: Walkthrough: Creating a Web Page to Display Access Database
Da
| Date: Tue, 22 Nov 2005 01:15:10 -0800
| Lines: 8
| Message-ID: <01**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:360055
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Nowhere in the walkthrough is there a choice or step of selecting simple
file
| sharing. I certainly don't mean to. I simply open up a folder in the
| localhost folder, nd within that folder there is app_data. The
walkthrough
| says the security tab should show, but it doesnt.
|
| This is asp.net 2.0, not 1.1; could that make the difference?
|
| dennist685
|

Nov 23 '05 #4

P: n/a
re:
The walkthrough says the security tab should show, but it doesnt.
The security tab is an operating system feature, not an ASP.NET one.

I assumed you were using Windows XP. Are you ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"dennist685" <de********@newsgroup.nospam> wrote in message
news:01**********************************@microsof t.com... Nowhere in the walkthrough is there a choice or step of selecting simple file
sharing. I certainly don't mean to. I simply open up a folder in the
localhost folder, nd within that folder there is app_data. The walkthrough
says the security tab should show, but it doesnt.

This is asp.net 2.0, not 1.1; could that make the difference?

dennist685

Nov 23 '05 #5

P: n/a
yes, xp pro

"Juan T. Llibre" wrote:
re:
The walkthrough says the security tab should show, but it doesnt.


The security tab is an operating system feature, not an ASP.NET one.

I assumed you were using Windows XP. Are you ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"dennist685" <de********@newsgroup.nospam> wrote in message
news:01**********************************@microsof t.com...
Nowhere in the walkthrough is there a choice or step of selecting simple file
sharing. I certainly don't mean to. I simply open up a folder in the
localhost folder, nd within that folder there is app_data. The walkthrough
says the security tab should show, but it doesnt.

This is asp.net 2.0, not 1.1; could that make the difference?

dennist685


Nov 23 '05 #6

P: n/a
I figured as much. That's a well-known problem in XP Pro.

To disable simple file sharing for Windows XP :

1. Click Start, and then click My Computer.
2. On the Tools menu, click Folder Options, and then click the View tab.
3. In the Advanced Settings section,
clear the Use simple file sharing (Recommended) check box.
4. Click OK.

Now, check if the security tab is there.
I don't remember if a reboot is needed, but if it is, reboot and then check.

Be careful with adding/removing permissions after you disable simple
file sharing, though, at least until you've learned what you're doing, OK ?

You can *reall* cause havoc if you take away the wro0ng permissions,
or if you open up your system too much by giving unneeded users
permissions over your file system.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"dennist685" <de********@newsgroup.nospam> wrote in message
news:C4**********************************@microsof t.com...
yes, xp pro

"Juan T. Llibre" wrote:

re:
>The walkthrough says the security tab should show, but it doesnt.


The security tab is an operating system feature, not an ASP.NET one.

I assumed you were using Windows XP. Are you ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"dennist685" <de********@newsgroup.nospam> wrote in message
news:01**********************************@microsof t.com...
> Nowhere in the walkthrough is there a choice or step of selecting simple file
> sharing. I certainly don't mean to. I simply open up a folder in the
> localhost folder, nd within that folder there is app_data. The walkthrough
> says the security tab should show, but it doesnt.
>
> This is asp.net 2.0, not 1.1; could that make the difference?
>
> dennist685

Nov 23 '05 #7

P: n/a
Worked like a charm. Didn't have to reboot. However, I;m in a quandry. Who
do I give the rights to?

dennist685?
Administrator - how do I know if iis or sqlserver recognizes me as the
administrator?

I have sqlserver set as mixed authentification - e.g. windows - dennist685
is the only user, and a name and password, which is dennist685 plus my
password.

dennist685
Nov 23 '05 #8

P: n/a
Thanks for the reply, Steven,

I don't know if what you propose is what I'm looking for. How do I find
inetmgr, and once finding it, how do I click a directory? Or do I click a
directory first.

Dennist685
Nov 23 '05 #9

P: n/a
Hi Dennist,

I've noticed yours session with Juan. Actually the things I mentioend is
targeting windows 2003 server/ IIS6, where we can directly manage the
file/folder's NTFS permission in IIS manager ( inetmgr.exe). we can just
launch it through:

start--->Run:

Type "inetmgr.exe"

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| Thread-Topic: Walkthrough: Creating a Web Page to Display Access Database
Da
| thread-index: AcXv+2Ot1H+mxfjlRIOhdnDza61exQ==
| X-WBNR-Posting-Host: 192.117.113.41
| From: "=?Utf-8?B?ZGVubmlzdDY4NQ==?=" <de********@newsgroup.nospam>
| References: <89**********************************@microsoft.co m>
<uQ**************@TK2MSFTNGP14.phx.gbl>
<01**********************************@microsoft.co m>
<53**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: Walkthrough: Creating a Web Page to Display Access Database
Da
| Date: Tue, 22 Nov 2005 22:59:03 -0800
| Lines: 7
| Message-ID: <BF**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:360328
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Thanks for the reply, Steven,
|
| I don't know if what you propose is what I'm looking for. How do I find
| inetmgr, and once finding it, how do I click a directory? Or do I click
a
| directory first.
|
| Dennist685
|

Nov 23 '05 #10

This discussion thread is closed

Replies have been disabled for this discussion.