By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,011 Members | 2,967 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,011 IT Pros & Developers. It's quick & easy.

Error "The Page Cannot Be Found"

P: n/a
Hi,
I have set up an asp.net website on another PC in order to test it. The
site was fine on my PC, but on the new PC all the pages give the error "The
Page Cannot Be Found". Some legacy pages (ASP, as opposed to ASP.Net) work
fine.

The old PC was running Windows 2000 Server, and the new PC I am testing on
is running Windows Server 2003.

Thanks in advance,
Martin

--
Martin Eyles
ma**********@NOSPAM.bytronic.com
Nov 20 '05 #1
Share this Question
Share on Google+
9 Replies


P: n/a
Have you tried running command aspregiis ?

Start -> Run - > aspregiis.exe -i

"Martin Eyles" wrote:
Hi,
I have set up an asp.net website on another PC in order to test it. The
site was fine on my PC, but on the new PC all the pages give the error "The
Page Cannot Be Found". Some legacy pages (ASP, as opposed to ASP.Net) work
fine.

The old PC was running Windows 2000 Server, and the new PC I am testing on
is running Windows Server 2003.

Thanks in advance,
Martin

--
Martin Eyles
ma**********@NOSPAM.bytronic.com

Nov 20 '05 #2

P: n/a
"Sreejith Ram" <Sr*********@discussions.microsoft.com> wrote in message
news:72**********************************@microsof t.com...
Have you tried running command aspregiis ?

Start -> Run - > aspregiis.exe -i


I have just tried it, and get the response that aspregiis.exe does not
exist. Have tried searching for the file, and cannot find it.

--
Martin Eyles
ma**********@NOSPAM.bytronic.com
Nov 20 '05 #3

P: n/a
Try :

aspnet_regiis -i

If that, still, returns a file not found message, open a command window at
drive:\WINDOWSdirectory\Microsoft.NET\Framework\vx .x.xxxxx
where x.x.xxxxx stands for the version of the .Net Framework you're running.

Then, run aspnet_regiis -i from that directory.
Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Martin Eyles" <ma**********@NOSPAM.bytronic.com> wrote in message
news:11*************@corp.supernews.com...
"Sreejith Ram" <Sr*********@discussions.microsoft.com> wrote in message
news:72**********************************@microsof t.com...
Have you tried running command aspregiis ?

Start -> Run - > aspregiis.exe -i


I have just tried it, and get the response that aspregiis.exe does not
exist. Have tried searching for the file, and cannot find it.

--
Martin Eyles

Nov 20 '05 #4

P: n/a
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u8**************@TK2MSFTNGP15.phx.gbl...
Try :

aspnet_regiis -i
Still file not found
If that, still, returns a file not found message, open a command window at
drive:\WINDOWSdirectory\Microsoft.NET\Framework\vx .x.xxxxx
where x.x.xxxxx stands for the version of the .Net Framework you're running.
Then, run aspnet_regiis -i from that directory.


Yes, that does run (I chose 1.1, as my website was developed in that).
However, it doesn't make the .aspx pages work! I tried rebooting after
running this, and it still doesn't work.

Martin

--
Martin Eyles
ma**********@NOSPAM.bytronic.com
Nov 20 '05 #5

P: n/a
re:
it doesn't make the .aspx pages work!
What is the error returned ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Martin Eyles" <ma**********@NOSPAM.bytronic.com> wrote in message
news:11*************@corp.supernews.com... "Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u8**************@TK2MSFTNGP15.phx.gbl...
If that, still, returns a file not found message, open a command window at
drive:\WINDOWSdirectory\Microsoft.NET\Framework\vx .x.xxxxx
where x.x.xxxxx stands for the version of the .Net Framework you're

running.

Then, run aspnet_regiis -i from that directory.


Yes, that does run (I chose 1.1, as my website was developed in that).
However, it doesn't make the .aspx pages work! I tried rebooting after
running this, and it still doesn't work.

Nov 20 '05 #6

P: n/a
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:et****************@TK2MSFTNGP09.phx.gbl...
"Martin Eyles" <ma**********@NOSPAM.bytronic.com> wrote in message
news:11*************@corp.supernews.com...
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u8**************@TK2MSFTNGP15.phx.gbl...

If that, still, returns a file not found message, open a command window at drive:\WINDOWSdirectory\Microsoft.NET\Framework\vx .x.xxxxx
where x.x.xxxxx stands for the version of the .Net Framework you're

running.

Then, run aspnet_regiis -i from that directory.


Yes, that does run (I chose 1.1, as my website was developed in that).
However, it doesn't make the .aspx pages work! I tried rebooting after
running this, and it still doesn't work.


re:
it doesn't make the .aspx pages work!


What is the error returned ?


The same as always "The Page Cannot Be Found". (HTTP Error 404 - File or
directory no found.)

I get this error for all .aspx pages, but not for.asp pages.

--
Martin Eyles
ma**********@NOSPAM.bytronic.com
Nov 20 '05 #7

P: n/a
I had not noticed this before:
the new PC I am testing on is running Windows Server 2003
Have you enabled aspx pages on your Windows Server 2003 ?
They come disabled by default.

Open the IIS Manager, scroll down on the left to "Web Service Extensions",
go to the right pane, select the version of ASP.NET you want to allow,
and click the "Allow" button.

You can allow more than one version if you're going to use them.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Martin Eyles" <ma**********@NOSPAM.bytronic.com> wrote in message
news:11*************@corp.supernews.com... "Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:et****************@TK2MSFTNGP09.phx.gbl...
"Martin Eyles" <ma**********@NOSPAM.bytronic.com> wrote in message
news:11*************@corp.supernews.com...
> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
> news:u8**************@TK2MSFTNGP15.phx.gbl...

>> If that, still, returns a file not found message, open a command window at >> drive:\WINDOWSdirectory\Microsoft.NET\Framework\vx .x.xxxxx
>> where x.x.xxxxx stands for the version of the .Net Framework you're
> running.
>>
>> Then, run aspnet_regiis -i from that directory.


> Yes, that does run (I chose 1.1, as my website was developed in that).
> However, it doesn't make the .aspx pages work! I tried rebooting after
> running this, and it still doesn't work.


re:
> it doesn't make the .aspx pages work!


What is the error returned ?


The same as always "The Page Cannot Be Found". (HTTP Error 404 - File or
directory no found.)

I get this error for all .aspx pages, but not for.asp pages.

--
Martin Eyles
ma**********@NOSPAM.bytronic.com

Nov 20 '05 #8

P: n/a
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:ef**************@tk2msftngp13.phx.gbl...
I had not noticed this before:
the new PC I am testing on is running Windows Server 2003


Have you enabled aspx pages on your Windows Server 2003 ?
They come disabled by default.

Open the IIS Manager, scroll down on the left to "Web Service Extensions",
go to the right pane, select the version of ASP.NET you want to allow,
and click the "Allow" button.

You can allow more than one version if you're going to use them.


Thank you very much! It works! Why did it just work in win2k server (my
development machine) - is it something that the visual studio installer
changes?

Thanks Again,
Martin

--
Martin Eyles
ma**********@NOSPAM.bytronic.com
Nov 20 '05 #9

P: n/a
re:
Thank you very much! It works!
You're very much welcome!
I wish I had noticed that you are using W2K3 earlier.

;-)

re: Why did it just work in win2k server (my development machine)
- is it something that the visual studio installer changes?
No. Having to enable ASP.NET ( and other http services,
like CGI, SSI, etc. ) is something IIS 6.0 defaults to.

There was a lot of criticism of Microsoft for letting its web server ( IIS )
be wide open to attacks out of the box when inexperienced hands were using it.

The less http services are running, the less surface is exposed to potential attackers.
Once people know what they're doing, they can turn on whatever services they want.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Martin Eyles" <ma**********@NOSPAM.bytronic.com> wrote in message
news:11*************@corp.supernews.com... "Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:ef**************@tk2msftngp13.phx.gbl...
I had not noticed this before:
>the new PC I am testing on is running Windows Server 2003


Have you enabled aspx pages on your Windows Server 2003 ?
They come disabled by default.

Open the IIS Manager, scroll down on the left to "Web Service Extensions",
go to the right pane, select the version of ASP.NET you want to allow,
and click the "Allow" button.

You can allow more than one version if you're going to use them.


Thank you very much! It works! Why did it just work in win2k server (my
development machine) - is it something that the visual studio installer
changes?

Thanks Again,
Martin

--
Martin Eyles
ma**********@NOSPAM.bytronic.com

Nov 20 '05 #10

This discussion thread is closed

Replies have been disabled for this discussion.