By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,810 Members | 818 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,810 IT Pros & Developers. It's quick & easy.

Asp Application with the aspx files and assemblies in a shared directory in another machine

P: n/a
Hi

I have asp application in a machine with a virtual directory referring a
shared directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier


Nov 19 '05 #1
Share this Question
Share on Google+
27 Replies


P: n/a
It looks like your application is not compiled. You can switch CodeBehind=
to Src= if you wish to deploy the global.asax.cs file. The other option is
to compile and put the compiled DLL in the bin folder.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***********************************************
Think Outside the Box!
***********************************************
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a
shared directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier

Nov 19 '05 #2

P: n/a
Thanks but is not the case.

My application is complied, I can see the assembly en my remote bin
directory
Anyway thanks, any clue?
"Cowboy (Gregory A. Beamer)" <No************@comcast.netNoSpamM> escribió en
el mensaje news:%2****************@tk2msftngp13.phx.gbl...
It looks like your application is not compiled. You can switch CodeBehind=
to Src= if you wish to deploy the global.asax.cs file. The other option is
to compile and put the compiled DLL in the bin folder.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***********************************************
Think Outside the Box!
***********************************************
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a
shared directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier


Nov 19 '05 #3

P: n/a
Elaborate on "load any aspx page". Do you mean you're redirecting to it?
How exactly are you referring or loading it?

Also, did you make sure to include the DLL file in the bin folder with the
ASPX?

--------------------------------------------------------------------------------
All that glitters has a high refractive index.
www.mendhak.com
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a
shared directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier

Nov 19 '05 #4

P: n/a
Hi

"When I try to load any aspx page" = Put the url in my browser to tray see
the page

Yes, The dll file is in the bin folder and the folder has nt permissions set
to full to everyone count
"S.M. Altaf [MVP]" <sm*****@PLEASEDONTSPAMMEmsn.com> escribió en el mensaje
news:uT**************@TK2MSFTNGP15.phx.gbl...
Elaborate on "load any aspx page". Do you mean you're redirecting to it?
How exactly are you referring or loading it?

Also, did you make sure to include the DLL file in the bin folder with the
ASPX?

--------------------------------------------------------------------------------
All that glitters has a high refractive index.
www.mendhak.com
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a
shared directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier


Nov 19 '05 #5

P: n/a
re:
I have asp application in a machine with a virtual directory referring a shared
directory in another machine
Does the account that ASP.NET is running as have
read/execute rights to the shared directory in the other machine ?

It's the ASP.NET account that's connecting and which needs
access to \\calamaro2\tmp\global.asax , not your server.

Run the code snippet at :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

and give the user which that snippet returns,
the appropiate permissions to \\calamaro2\tmp\

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl... Hi

I have asp application in a machine with a virtual directory referring a shared
directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier

Nov 19 '05 #6

P: n/a
Sorry, Javier.

I sent the wrong link.

Use the code snippet at :
http://www.aspnetfaq.com/default.asp...&CategoryId=39
and not the one in the previous reply.

Everything else in the previous reply stands as it is.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...
Thanks but is not the case.

My application is complied, I can see the assembly en my remote bin directory
Anyway thanks, any clue?
"Cowboy (Gregory A. Beamer)" <No************@comcast.netNoSpamM> escribió en el mensaje
news:%2****************@tk2msftngp13.phx.gbl...
It looks like your application is not compiled. You can switch CodeBehind= to Src= if
you wish to deploy the global.asax.cs file. The other option is to compile and put the
compiled DLL in the bin folder.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***********************************************
Think Outside the Box!
***********************************************
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a shared
directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier



Nov 19 '05 #7

P: n/a
The problem is, Javier, that ASP.NET doesn't have read
permission for \\calamaro2\tmp\global.asax as explained
in my last replies.

Sorry about sending the wrong link.

My second reply has the correct link :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

Assign the account returned by that snippet, read permission
to \\calamaro2\tmp\global.asax and all your pages will display.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA**************@TK2MSFTNGP09.phx.gbl...
Hi

"When I try to load any aspx page" = Put the url in my browser to tray see the page

Yes, The dll file is in the bin folder and the folder has nt permissions set to full to
everyone count
"S.M. Altaf [MVP]" <sm*****@PLEASEDONTSPAMMEmsn.com> escribió en el mensaje
news:uT**************@TK2MSFTNGP15.phx.gbl...
Elaborate on "load any aspx page". Do you mean you're redirecting to it? How exactly
are you referring or loading it?

Also, did you make sure to include the DLL file in the bin folder with the ASPX?

--------------------------------------------------------------------------------
All that glitters has a high refractive index.
www.mendhak.com
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a shared
directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier



Nov 19 '05 #8

P: n/a

Yes, the shared directory has full access for everyone account.

I can't run any code because any page can be loaded it
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OG***************@TK2MSFTNGP10.phx.gbl...
re:
I have asp application in a machine with a virtual directory referring a
shared directory in another machine


Does the account that ASP.NET is running as have
read/execute rights to the shared directory in the other machine ?

It's the ASP.NET account that's connecting and which needs
access to \\calamaro2\tmp\global.asax , not your server.

Run the code snippet at :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

and give the user which that snippet returns,
the appropiate permissions to \\calamaro2\tmp\

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a
shared directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier


Nov 19 '05 #9

P: n/a
I think that the permisions are granted, everyone has full access

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:%2****************@TK2MSFTNGP15.phx.gbl...
The problem is, Javier, that ASP.NET doesn't have read
permission for \\calamaro2\tmp\global.asax as explained
in my last replies.

Sorry about sending the wrong link.

My second reply has the correct link :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

Assign the account returned by that snippet, read permission
to \\calamaro2\tmp\global.asax and all your pages will display.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA**************@TK2MSFTNGP09.phx.gbl...
Hi

"When I try to load any aspx page" = Put the url in my browser to tray
see the page

Yes, The dll file is in the bin folder and the folder has nt permissions
set to full to everyone count
"S.M. Altaf [MVP]" <sm*****@PLEASEDONTSPAMMEmsn.com> escribió en el
mensaje news:uT**************@TK2MSFTNGP15.phx.gbl...
Elaborate on "load any aspx page". Do you mean you're redirecting to
it? How exactly are you referring or loading it?

Also, did you make sure to include the DLL file in the bin folder with
the ASPX?

--------------------------------------------------------------------------------
All that glitters has a high refractive index.
www.mendhak.com
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring
a shared directory in another machine

When I try to load any aspx page of my portal I get the following
error:
Mensaje de error del analizador: We can't load the type
'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier




Nov 19 '05 #10

P: n/a
re:
Yes, the shared directory has full access for everyone account.
Sure it does, for the everyone account at *that* machine,
but not for any account at *your* machine.

The everyone account at the shared directory in another machine
does *not* include *any* acount in your machine.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Yes, the shared directory has full access for everyone account.

I can't run any code because any page can be loaded it
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OG***************@TK2MSFTNGP10.phx.gbl...
re:
I have asp application in a machine with a virtual directory referring a shared
directory in another machine


Does the account that ASP.NET is running as have
read/execute rights to the shared directory in the other machine ?

It's the ASP.NET account that's connecting and which needs
access to \\calamaro2\tmp\global.asax , not your server.

Run the code snippet at :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

and give the user which that snippet returns,
the appropiate permissions to \\calamaro2\tmp\

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring a shared
directory in another machine

When I try to load any aspx page of my portal I get the following error:
Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier



Nov 19 '05 #11

P: n/a
Thanks I understand you now but How can I grant a permission for another
user in another machine?

I must declare a user with the same login and password in both machines?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:eQ**************@TK2MSFTNGP10.phx.gbl...
re:
Yes, the shared directory has full access for everyone account.


Sure it does, for the everyone account at *that* machine,
but not for any account at *your* machine.

The everyone account at the shared directory in another machine
does *not* include *any* acount in your machine.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...

Yes, the shared directory has full access for everyone account.

I can't run any code because any page can be loaded it
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OG***************@TK2MSFTNGP10.phx.gbl...
re:
I have asp application in a machine with a virtual directory referring
a shared directory in another machine

Does the account that ASP.NET is running as have
read/execute rights to the shared directory in the other machine ?

It's the ASP.NET account that's connecting and which needs
access to \\calamaro2\tmp\global.asax , not your server.

Run the code snippet at :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

and give the user which that snippet returns,
the appropiate permissions to \\calamaro2\tmp\

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
Hi

I have asp application in a machine with a virtual directory referring
a shared directory in another machine

When I try to load any aspx page of my portal I get the following
error:
Mensaje de error del analizador: We can't load the type
'JULIAN.Global'.

Error:

Línea 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="JULIAN.Global" %>
Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
Any clue?

Thanks

Javier



Nov 19 '05 #12

P: n/a
re:
I must declare a user with the same login and password in both machines?
Yes. Also, you must set ASP.NET to run *as* that account.

In other words, you must set <identity impersonate...> in web.config.

<identity
impersonate = "true"
userName = "TheUser"
password = "ThePassword"
/>

When your machine communicates with the machine which is
hosting the shared directory, the credentials it will pass are :

userName = "TheUser"
password = "ThePassword"

Since you created an account with those same credentials
at your shared directory's machine, you will have access.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl... Thanks I understand you now but How can I grant a permission for another user in
another machine?

I must declare a user with the same login and password in both machines?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:eQ**************@TK2MSFTNGP10.phx.gbl...
re:
Yes, the shared directory has full access for everyone account.


Sure it does, for the everyone account at *that* machine,
but not for any account at *your* machine.

The everyone account at the shared directory in another machine
does *not* include *any* acount in your machine.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...

Yes, the shared directory has full access for everyone account.

I can't run any code because any page can be loaded it
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OG***************@TK2MSFTNGP10.phx.gbl...
re:
> I have asp application in a machine with a virtual directory referring a shared
> directory in another machine

Does the account that ASP.NET is running as have
read/execute rights to the shared directory in the other machine ?

It's the ASP.NET account that's connecting and which needs
access to \\calamaro2\tmp\global.asax , not your server.

Run the code snippet at :
http://www.aspnetfaq.com/default.asp...&CategoryId=39

and give the user which that snippet returns,
the appropiate permissions to \\calamaro2\tmp\

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
> Hi
>
> I have asp application in a machine with a virtual directory referring a shared
> directory in another machine
>
> When I try to load any aspx page of my portal I get the following error:
>
>
> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>
> Error:
>
> Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
>
>
> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>
>
> Any clue?
>
> Thanks
>
> Javier

Nov 19 '05 #13

P: n/a
Thanks but I have tested it and it doesn't work.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:en*************@TK2MSFTNGP15.phx.gbl...
re:
I must declare a user with the same login and password in both machines?


Yes. Also, you must set ASP.NET to run *as* that account.

In other words, you must set <identity impersonate...> in web.config.

<identity
impersonate = "true"
userName = "TheUser"
password = "ThePassword"
/>

When your machine communicates with the machine which is
hosting the shared directory, the credentials it will pass are :

userName = "TheUser"
password = "ThePassword"

Since you created an account with those same credentials
at your shared directory's machine, you will have access.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl...
Thanks I understand you now but How can I grant a permission for another
user in another machine?

I must declare a user with the same login and password in both machines?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:eQ**************@TK2MSFTNGP10.phx.gbl...
re:
Yes, the shared directory has full access for everyone account.

Sure it does, for the everyone account at *that* machine,
but not for any account at *your* machine.

The everyone account at the shared directory in another machine
does *not* include *any* acount in your machine.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...

Yes, the shared directory has full access for everyone account.

I can't run any code because any page can be loaded it
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OG***************@TK2MSFTNGP10.phx.gbl...
> re:
>> I have asp application in a machine with a virtual directory
>> referring a shared directory in another machine
>
> Does the account that ASP.NET is running as have
> read/execute rights to the shared directory in the other machine ?
>
> It's the ASP.NET account that's connecting and which needs
> access to \\calamaro2\tmp\global.asax , not your server.
>
> Run the code snippet at :
> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>
> and give the user which that snippet returns,
> the appropiate permissions to \\calamaro2\tmp\
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:u1**************@TK2MSFTNGP12.phx.gbl...
>> Hi
>>
>> I have asp application in a machine with a virtual directory
>> referring a shared directory in another machine
>>
>> When I try to load any aspx page of my portal I get the following
>> error:
>>
>>
>> Mensaje de error del analizador: We can't load the type
>> 'JULIAN.Global'.
>>
>> Error:
>>
>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>> Inherits="JULIAN.Global" %>
>>
>>
>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>
>>
>> Any clue?
>>
>> Thanks
>>
>> Javier


Nov 19 '05 #14

P: n/a
Maybe there's something you're doing wrong.

There's step-by-step instructions here :

http://support.microsoft.com/default...b;en-us;822316

Si te es mas cómodo leer las instrucciones en español, ve a :
http://support.microsoft.com/kb/822316/es
( Aunque la traducción no es muy perfecta, que digamos... )


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Thanks but I have tested it and it doesn't work.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:en*************@TK2MSFTNGP15.phx.gbl...
re:
I must declare a user with the same login and password in both machines?


Yes. Also, you must set ASP.NET to run *as* that account.

In other words, you must set <identity impersonate...> in web.config.

<identity
impersonate = "true"
userName = "TheUser"
password = "ThePassword"
/>

When your machine communicates with the machine which is
hosting the shared directory, the credentials it will pass are :

userName = "TheUser"
password = "ThePassword"

Since you created an account with those same credentials
at your shared directory's machine, you will have access.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl...
Thanks I understand you now but How can I grant a permission for another user in
another machine?

I must declare a user with the same login and password in both machines?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:eQ**************@TK2MSFTNGP10.phx.gbl...
re:
> Yes, the shared directory has full access for everyone account.

Sure it does, for the everyone account at *that* machine,
but not for any account at *your* machine.

The everyone account at the shared directory in another machine
does *not* include *any* acount in your machine.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
>
> Yes, the shared directory has full access for everyone account.
>
> I can't run any code because any page can be loaded it
>
>
> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:OG***************@TK2MSFTNGP10.phx.gbl...
>> re:
>>> I have asp application in a machine with a virtual directory referring a shared
>>> directory in another machine
>>
>> Does the account that ASP.NET is running as have
>> read/execute rights to the shared directory in the other machine ?
>>
>> It's the ASP.NET account that's connecting and which needs
>> access to \\calamaro2\tmp\global.asax , not your server.
>>
>> Run the code snippet at :
>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>
>> and give the user which that snippet returns,
>> the appropiate permissions to \\calamaro2\tmp\
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>> Hi
>>>
>>> I have asp application in a machine with a virtual directory referring a shared
>>> directory in another machine
>>>
>>> When I try to load any aspx page of my portal I get the following error:
>>>
>>>
>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>
>>> Error:
>>>
>>> Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
>>>
>>>
>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>
>>>
>>> Any clue?
>>>
>>> Thanks
>>>
>>> Javier



Nov 19 '05 #15

P: n/a
Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?

Also, did you change the <processModel> element and set the user
name and password attributes to match your new custom account ?

Default: <!-- userName="machine" password="AutoGenerate" -->
Becomes: <!-- userName="TheUser" password="ThePassword"

i.e.,
<processModel enable="true" userName="machine" password="AutoGenerate"/>
becomes
<processModel enable="true" userName="TheUser" password="ThePassword"/>

?

Otherwise, ASP.NET keeps on running as the machine account.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Thanks but I have tested it and it doesn't work.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:en*************@TK2MSFTNGP15.phx.gbl...
re:
I must declare a user with the same login and password in both machines?


Yes. Also, you must set ASP.NET to run *as* that account.

In other words, you must set <identity impersonate...> in web.config.

<identity
impersonate = "true"
userName = "TheUser"
password = "ThePassword"
/>

When your machine communicates with the machine which is
hosting the shared directory, the credentials it will pass are :

userName = "TheUser"
password = "ThePassword"

Since you created an account with those same credentials
at your shared directory's machine, you will have access.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl...
Thanks I understand you now but How can I grant a permission for another user in
another machine?

I must declare a user with the same login and password in both machines?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:eQ**************@TK2MSFTNGP10.phx.gbl...
re:
> Yes, the shared directory has full access for everyone account.

Sure it does, for the everyone account at *that* machine,
but not for any account at *your* machine.

The everyone account at the shared directory in another machine
does *not* include *any* acount in your machine.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
>
> Yes, the shared directory has full access for everyone account.
>
> I can't run any code because any page can be loaded it
>
>
> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:OG***************@TK2MSFTNGP10.phx.gbl...
>> re:
>>> I have asp application in a machine with a virtual directory referring a shared
>>> directory in another machine
>>
>> Does the account that ASP.NET is running as have
>> read/execute rights to the shared directory in the other machine ?
>>
>> It's the ASP.NET account that's connecting and which needs
>> access to \\calamaro2\tmp\global.asax , not your server.
>>
>> Run the code snippet at :
>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>
>> and give the user which that snippet returns,
>> the appropiate permissions to \\calamaro2\tmp\
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>> Hi
>>>
>>> I have asp application in a machine with a virtual directory referring a shared
>>> directory in another machine
>>>
>>> When I try to load any aspx page of my portal I get the following error:
>>>
>>>
>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>
>>> Error:
>>>
>>> Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global" %>
>>>
>>>
>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>
>>>
>>> Any clue?
>>>
>>> Thanks
>>>
>>> Javier



Nov 19 '05 #16

P: n/a
Where may I change the process model? In the web.config?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Oc**************@TK2MSFTNGP14.phx.gbl...
Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?

Also, did you change the <processModel> element and set the user
name and password attributes to match your new custom account ?

Default: <!-- userName="machine" password="AutoGenerate" -->
Becomes: <!-- userName="TheUser" password="ThePassword"

i.e.,
<processModel enable="true" userName="machine" password="AutoGenerate"/>
becomes
<processModel enable="true" userName="TheUser" password="ThePassword"/>

?

Otherwise, ASP.NET keeps on running as the machine account.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Thanks but I have tested it and it doesn't work.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:en*************@TK2MSFTNGP15.phx.gbl...
re:
I must declare a user with the same login and password in both
machines?

Yes. Also, you must set ASP.NET to run *as* that account.

In other words, you must set <identity impersonate...> in web.config.

<identity
impersonate = "true"
userName = "TheUser"
password = "ThePassword"
/>

When your machine communicates with the machine which is
hosting the shared directory, the credentials it will pass are :

userName = "TheUser"
password = "ThePassword"

Since you created an account with those same credentials
at your shared directory's machine, you will have access.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl...
Thanks I understand you now but How can I grant a permission for
another user in another machine?

I must declare a user with the same login and password in both
machines?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:eQ**************@TK2MSFTNGP10.phx.gbl...
> re:
>> Yes, the shared directory has full access for everyone account.
>
> Sure it does, for the everyone account at *that* machine,
> but not for any account at *your* machine.
>
> The everyone account at the shared directory in another machine
> does *not* include *any* acount in your machine.
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>
>> Yes, the shared directory has full access for everyone account.
>>
>> I can't run any code because any page can be loaded it
>>
>>
>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>> re:
>>>> I have asp application in a machine with a virtual directory
>>>> referring a shared directory in another machine
>>>
>>> Does the account that ASP.NET is running as have
>>> read/execute rights to the shared directory in the other machine ?
>>>
>>> It's the ASP.NET account that's connecting and which needs
>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>
>>> Run the code snippet at :
>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>
>>> and give the user which that snippet returns,
>>> the appropiate permissions to \\calamaro2\tmp\
>>>
>>>
>>>
>>> Juan T. Llibre, ASP.NET MVP
>>> ASP.NET FAQ : http://asp.net.do/faq/
>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>> ======================================
>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>> Hi
>>>>
>>>> I have asp application in a machine with a virtual directory
>>>> referring a shared directory in another machine
>>>>
>>>> When I try to load any aspx page of my portal I get the following
>>>> error:
>>>>
>>>>
>>>> Mensaje de error del analizador: We can't load the type
>>>> 'JULIAN.Global'.
>>>>
>>>> Error:
>>>>
>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>> Inherits="JULIAN.Global" %>
>>>>
>>>>
>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>
>>>>
>>>> Any clue?
>>>>
>>>> Thanks
>>>>
>>>> Javier



Nov 19 '05 #17

P: n/a
processModel is only configurable in machine.config,
since it's a machine-wide setting.

You didn't answer my question...

Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u2**************@TK2MSFTNGP09.phx.gbl...
Where may I change the process model? In the web.config?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Oc**************@TK2MSFTNGP14.phx.gbl...
Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?

Also, did you change the <processModel> element and set the user
name and password attributes to match your new custom account ?

Default: <!-- userName="machine" password="AutoGenerate" -->
Becomes: <!-- userName="TheUser" password="ThePassword"

i.e.,
<processModel enable="true" userName="machine" password="AutoGenerate"/>
becomes
<processModel enable="true" userName="TheUser" password="ThePassword"/>

?

Otherwise, ASP.NET keeps on running as the machine account.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Thanks but I have tested it and it doesn't work.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:en*************@TK2MSFTNGP15.phx.gbl...
re:
> I must declare a user with the same login and password in both machines?

Yes. Also, you must set ASP.NET to run *as* that account.

In other words, you must set <identity impersonate...> in web.config.

<identity
impersonate = "true"
userName = "TheUser"
password = "ThePassword"
/>

When your machine communicates with the machine which is
hosting the shared directory, the credentials it will pass are :

userName = "TheUser"
password = "ThePassword"

Since you created an account with those same credentials
at your shared directory's machine, you will have access.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl...
> Thanks I understand you now but How can I grant a permission for another user in
> another machine?
>
> I must declare a user with the same login and password in both machines?

> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>> re:
>>> Yes, the shared directory has full access for everyone account.
>>
>> Sure it does, for the everyone account at *that* machine,
>> but not for any account at *your* machine.
>>
>> The everyone account at the shared directory in another machine
>> does *not* include *any* acount in your machine.
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>
>>> Yes, the shared directory has full access for everyone account.
>>>
>>> I can't run any code because any page can be loaded it
>>>
>>>
>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>> re:
>>>>> I have asp application in a machine with a virtual directory referring a shared
>>>>> directory in another machine
>>>>
>>>> Does the account that ASP.NET is running as have
>>>> read/execute rights to the shared directory in the other machine ?
>>>>
>>>> It's the ASP.NET account that's connecting and which needs
>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>
>>>> Run the code snippet at :
>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>
>>>> and give the user which that snippet returns,
>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, ASP.NET MVP
>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>> ======================================
>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>> Hi
>>>>>
>>>>> I have asp application in a machine with a virtual directory referring a shared
>>>>> directory in another machine
>>>>>
>>>>> When I try to load any aspx page of my portal I get the following error:
>>>>>
>>>>>
>>>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>>>
>>>>> Error:
>>>>>
>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global"
>>>>> %>
>>>>>
>>>>>
>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>
>>>>>
>>>>> Any clue?
>>>>>
>>>>> Thanks
>>>>>
>>>>> Javier



Nov 19 '05 #18

P: n/a
Sorry, I can't run the script because the page can not be executed

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OO*************@TK2MSFTNGP10.phx.gbl...
processModel is only configurable in machine.config,
since it's a machine-wide setting.

You didn't answer my question...

Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u2**************@TK2MSFTNGP09.phx.gbl...
Where may I change the process model? In the web.config?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Oc**************@TK2MSFTNGP14.phx.gbl...
Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?

Also, did you change the <processModel> element and set the user
name and password attributes to match your new custom account ?

Default: <!-- userName="machine" password="AutoGenerate" -->
Becomes: <!-- userName="TheUser" password="ThePassword"

i.e.,
<processModel enable="true" userName="machine" password="AutoGenerate"/>
becomes
<processModel enable="true" userName="TheUser" password="ThePassword"/>

?

Otherwise, ASP.NET keeps on running as the machine account.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Thanks but I have tested it and it doesn't work.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:en*************@TK2MSFTNGP15.phx.gbl...
> re:
>> I must declare a user with the same login and password in both
>> machines?
>
> Yes. Also, you must set ASP.NET to run *as* that account.
>
> In other words, you must set <identity impersonate...> in web.config.
>
> <identity
> impersonate = "true"
> userName = "TheUser"
> password = "ThePassword"
> />
>
> When your machine communicates with the machine which is
> hosting the shared directory, the credentials it will pass are :
>
> userName = "TheUser"
> password = "ThePassword"
>
> Since you created an account with those same credentials
> at your shared directory's machine, you will have access.
>
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:%2***************@TK2MSFTNGP10.phx.gbl...
>> Thanks I understand you now but How can I grant a permission for
>> another user in another machine?
>>
>> I must declare a user with the same login and password in both
>> machines?
>
>
>
>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>> re:
>>>> Yes, the shared directory has full access for everyone account.
>>>
>>> Sure it does, for the everyone account at *that* machine,
>>> but not for any account at *your* machine.
>>>
>>> The everyone account at the shared directory in another machine
>>> does *not* include *any* acount in your machine.
>>>
>>>
>>>
>>> Juan T. Llibre, ASP.NET MVP
>>> ASP.NET FAQ : http://asp.net.do/faq/
>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>> ======================================
>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>
>>>> Yes, the shared directory has full access for everyone account.
>>>>
>>>> I can't run any code because any page can be loaded it
>>>>
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>> re:
>>>>>> I have asp application in a machine with a virtual directory
>>>>>> referring a shared directory in another machine
>>>>>
>>>>> Does the account that ASP.NET is running as have
>>>>> read/execute rights to the shared directory in the other machine ?
>>>>>
>>>>> It's the ASP.NET account that's connecting and which needs
>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>
>>>>> Run the code snippet at :
>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>
>>>>> and give the user which that snippet returns,
>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, ASP.NET MVP
>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>> ======================================
>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>> Hi
>>>>>>
>>>>>> I have asp application in a machine with a virtual directory
>>>>>> referring a shared directory in another machine
>>>>>>
>>>>>> When I try to load any aspx page of my portal I get the following
>>>>>> error:
>>>>>>
>>>>>>
>>>>>> Mensaje de error del analizador: We can't load the type
>>>>>> 'JULIAN.Global'.
>>>>>>
>>>>>> Error:
>>>>>>
>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>> Inherits="JULIAN.Global" %>
>>>>>>
>>>>>>
>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>
>>>>>>
>>>>>> Any clue?
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>> Javier
>
>



Nov 19 '05 #19

P: n/a
Can't you create a virtual directory on the same machine
in which ASP.NET is running, and run that script ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Sorry, I can't run the script because the page can not be executed

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OO*************@TK2MSFTNGP10.phx.gbl...
processModel is only configurable in machine.config,
since it's a machine-wide setting.

You didn't answer my question...

Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u2**************@TK2MSFTNGP09.phx.gbl...
Where may I change the process model? In the web.config?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Oc**************@TK2MSFTNGP14.phx.gbl...
Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?

Also, did you change the <processModel> element and set the user
name and password attributes to match your new custom account ?

Default: <!-- userName="machine" password="AutoGenerate" -->
Becomes: <!-- userName="TheUser" password="ThePassword"

i.e.,
<processModel enable="true" userName="machine" password="AutoGenerate"/>
becomes
<processModel enable="true" userName="TheUser" password="ThePassword"/>

?

Otherwise, ASP.NET keeps on running as the machine account.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
> Thanks but I have tested it and it doesn't work.
>
>
> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:en*************@TK2MSFTNGP15.phx.gbl...
>> re:
>>> I must declare a user with the same login and password in both machines?
>>
>> Yes. Also, you must set ASP.NET to run *as* that account.
>>
>> In other words, you must set <identity impersonate...> in web.config.
>>
>> <identity
>> impersonate = "true"
>> userName = "TheUser"
>> password = "ThePassword"
>> />
>>
>> When your machine communicates with the machine which is
>> hosting the shared directory, the credentials it will pass are :
>>
>> userName = "TheUser"
>> password = "ThePassword"
>>
>> Since you created an account with those same credentials
>> at your shared directory's machine, you will have access.
>>
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>> Thanks I understand you now but How can I grant a permission for another user in
>>> another machine?
>>>
>>> I must declare a user with the same login and password in both machines?
>>
>>
>>
>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>> re:
>>>>> Yes, the shared directory has full access for everyone account.
>>>>
>>>> Sure it does, for the everyone account at *that* machine,
>>>> but not for any account at *your* machine.
>>>>
>>>> The everyone account at the shared directory in another machine
>>>> does *not* include *any* acount in your machine.
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, ASP.NET MVP
>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>> ======================================
>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>
>>>>> Yes, the shared directory has full access for everyone account.
>>>>>
>>>>> I can't run any code because any page can be loaded it
>>>>>
>>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>> re:
>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>> shared directory in another machine
>>>>>>
>>>>>> Does the account that ASP.NET is running as have
>>>>>> read/execute rights to the shared directory in the other machine ?
>>>>>>
>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>
>>>>>> Run the code snippet at :
>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>
>>>>>> and give the user which that snippet returns,
>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>> ======================================
>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>> Hi
>>>>>>>
>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>> shared directory in another machine
>>>>>>>
>>>>>>> When I try to load any aspx page of my portal I get the following error:
>>>>>>>
>>>>>>>
>>>>>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>>>>>
>>>>>>> Error:
>>>>>>>
>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs" Inherits="JULIAN.Global"
>>>>>>> %>
>>>>>>>
>>>>>>>
>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>
>>>>>>>
>>>>>>> Any clue?
>>>>>>>
>>>>>>> Thanks
>>>>>>>
>>>>>>> Javier
>>
>>
>
>



Nov 19 '05 #20

P: n/a
Yes sorry, I have just do it
In the response script appears my login.

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:O7**************@tk2msftngp13.phx.gbl...
Can't you create a virtual directory on the same machine
in which ASP.NET is running, and run that script ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Sorry, I can't run the script because the page can not be executed

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OO*************@TK2MSFTNGP10.phx.gbl...
processModel is only configurable in machine.config,
since it's a machine-wide setting.

You didn't answer my question...

Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u2**************@TK2MSFTNGP09.phx.gbl...
Where may I change the process model? In the web.config?

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Oc**************@TK2MSFTNGP14.phx.gbl...
> Did you run the script I pointed you to ?
>
> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
> If you did, what was the account name returned ?
>
> Also, did you change the <processModel> element and set the user
> name and password attributes to match your new custom account ?
>
> Default: <!-- userName="machine" password="AutoGenerate" -->
> Becomes: <!-- userName="TheUser" password="ThePassword"
>
> i.e.,
> <processModel enable="true" userName="machine"
> password="AutoGenerate"/>
> becomes
> <processModel enable="true" userName="TheUser"
> password="ThePassword"/>
>
> ?
>
> Otherwise, ASP.NET keeps on running as the machine account.
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:%2****************@TK2MSFTNGP12.phx.gbl...
>> Thanks but I have tested it and it doesn't work.
>>
>>
>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>> news:en*************@TK2MSFTNGP15.phx.gbl...
>>> re:
>>>> I must declare a user with the same login and password in both
>>>> machines?
>>>
>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>
>>> In other words, you must set <identity impersonate...> in
>>> web.config.
>>>
>>> <identity
>>> impersonate = "true"
>>> userName = "TheUser"
>>> password = "ThePassword"
>>> />
>>>
>>> When your machine communicates with the machine which is
>>> hosting the shared directory, the credentials it will pass are :
>>>
>>> userName = "TheUser"
>>> password = "ThePassword"
>>>
>>> Since you created an account with those same credentials
>>> at your shared directory's machine, you will have access.
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, ASP.NET MVP
>>> ASP.NET FAQ : http://asp.net.do/faq/
>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>> ======================================
>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>> Thanks I understand you now but How can I grant a permission for
>>>> another user in another machine?
>>>>
>>>> I must declare a user with the same login and password in both
>>>> machines?
>>>
>>>
>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>> re:
>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>
>>>>> Sure it does, for the everyone account at *that* machine,
>>>>> but not for any account at *your* machine.
>>>>>
>>>>> The everyone account at the shared directory in another machine
>>>>> does *not* include *any* acount in your machine.
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, ASP.NET MVP
>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>> ======================================
>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>
>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>
>>>>>> I can't run any code because any page can be loaded it
>>>>>>
>>>>>>
>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>> mensaje news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>> re:
>>>>>>>> I have asp application in a machine with a virtual directory
>>>>>>>> referring a shared directory in another machine
>>>>>>>
>>>>>>> Does the account that ASP.NET is running as have
>>>>>>> read/execute rights to the shared directory in the other machine
>>>>>>> ?
>>>>>>>
>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>
>>>>>>> Run the code snippet at :
>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>
>>>>>>> and give the user which that snippet returns,
>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>> ======================================
>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>> Hi
>>>>>>>>
>>>>>>>> I have asp application in a machine with a virtual directory
>>>>>>>> referring a shared directory in another machine
>>>>>>>>
>>>>>>>> When I try to load any aspx page of my portal I get the
>>>>>>>> following error:
>>>>>>>>
>>>>>>>>
>>>>>>>> Mensaje de error del analizador: We can't load the type
>>>>>>>> 'JULIAN.Global'.
>>>>>>>>
>>>>>>>> Error:
>>>>>>>>
>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>
>>>>>>>>
>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>
>>>>>>>>
>>>>>>>> Any clue?
>>>>>>>>
>>>>>>>> Thanks
>>>>>>>>
>>>>>>>> Javier
>>>
>>>
>>
>>
>
>



Nov 19 '05 #21

P: n/a
You are impersonating ASP.NET with your Windows user login ?

What was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA*************@TK2MSFTNGP10.phx.gbl...
Yes sorry, I have just do it
In the response script appears my login.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:O7**************@tk2msftngp13.phx.gbl...
Can't you create a virtual directory on the same machine
in which ASP.NET is running, and run that script ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Sorry, I can't run the script because the page can not be executed

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OO*************@TK2MSFTNGP10.phx.gbl...
processModel is only configurable in machine.config,
since it's a machine-wide setting.

You didn't answer my question...

Did you run the script I pointed you to ?

( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
If you did, what was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:u2**************@TK2MSFTNGP09.phx.gbl...
> Where may I change the process model? In the web.config?
>
> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:Oc**************@TK2MSFTNGP14.phx.gbl...
>> Did you run the script I pointed you to ?
>>
>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>> If you did, what was the account name returned ?
>>
>> Also, did you change the <processModel> element and set the user
>> name and password attributes to match your new custom account ?
>>
>> Default: <!-- userName="machine" password="AutoGenerate" -->
>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>
>> i.e.,
>> <processModel enable="true" userName="machine" password="AutoGenerate"/>
>> becomes
>> <processModel enable="true" userName="TheUser" password="ThePassword"/>
>>
>> ?
>>
>> Otherwise, ASP.NET keeps on running as the machine account.
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>> Thanks but I have tested it and it doesn't work.
>>>
>>>
>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>> news:en*************@TK2MSFTNGP15.phx.gbl...
>>>> re:
>>>>> I must declare a user with the same login and password in both machines?
>>>>
>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>
>>>> In other words, you must set <identity impersonate...> in web.config.
>>>>
>>>> <identity
>>>> impersonate = "true"
>>>> userName = "TheUser"
>>>> password = "ThePassword"
>>>> />
>>>>
>>>> When your machine communicates with the machine which is
>>>> hosting the shared directory, the credentials it will pass are :
>>>>
>>>> userName = "TheUser"
>>>> password = "ThePassword"
>>>>
>>>> Since you created an account with those same credentials
>>>> at your shared directory's machine, you will have access.
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, ASP.NET MVP
>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>> ======================================
>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>> Thanks I understand you now but How can I grant a permission for another user
>>>>> in another machine?
>>>>>
>>>>> I must declare a user with the same login and password in both machines?
>>>>
>>>>
>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>> re:
>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>
>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>> but not for any account at *your* machine.
>>>>>>
>>>>>> The everyone account at the shared directory in another machine
>>>>>> does *not* include *any* acount in your machine.
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>> ======================================
>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>
>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>
>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>
>>>>>>>
>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>> re:
>>>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>>>> shared directory in another machine
>>>>>>>>
>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>> read/execute rights to the shared directory in the other machine ?
>>>>>>>>
>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>
>>>>>>>> Run the code snippet at :
>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>
>>>>>>>> and give the user which that snippet returns,
>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>> ======================================
>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>> Hi
>>>>>>>>>
>>>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>>>> shared directory in another machine
>>>>>>>>>
>>>>>>>>> When I try to load any aspx page of my portal I get the following error:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>>>>>>>
>>>>>>>>> Error:
>>>>>>>>>
>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Any clue?
>>>>>>>>>
>>>>>>>>> Thanks
>>>>>>>>>
>>>>>>>>> Javier
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #22

P: n/a
Yes, the response was my user login: javier
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Ox**************@TK2MSFTNGP10.phx.gbl...
You are impersonating ASP.NET with your Windows user login ?

What was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA*************@TK2MSFTNGP10.phx.gbl...
Yes sorry, I have just do it
In the response script appears my login.


"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:O7**************@tk2msftngp13.phx.gbl...
Can't you create a virtual directory on the same machine
in which ASP.NET is running, and run that script ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Sorry, I can't run the script because the page can not be executed

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:OO*************@TK2MSFTNGP10.phx.gbl...
> processModel is only configurable in machine.config,
> since it's a machine-wide setting.
>
> You didn't answer my question...
>
> Did you run the script I pointed you to ?
>
> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
> If you did, what was the account name returned ?
>
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:u2**************@TK2MSFTNGP09.phx.gbl...
>> Where may I change the process model? In the web.config?
>>
>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>> news:Oc**************@TK2MSFTNGP14.phx.gbl...
>>> Did you run the script I pointed you to ?
>>>
>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>> If you did, what was the account name returned ?
>>>
>>> Also, did you change the <processModel> element and set the user
>>> name and password attributes to match your new custom account ?
>>>
>>> Default: <!-- userName="machine" password="AutoGenerate" -->
>>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>>
>>> i.e.,
>>> <processModel enable="true" userName="machine"
>>> password="AutoGenerate"/>
>>> becomes
>>> <processModel enable="true" userName="TheUser"
>>> password="ThePassword"/>
>>>
>>> ?
>>>
>>> Otherwise, ASP.NET keeps on running as the machine account.
>>>
>>> Juan T. Llibre, ASP.NET MVP
>>> ASP.NET FAQ : http://asp.net.do/faq/
>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>> ======================================
>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>>> Thanks but I have tested it and it doesn't work.
>>>>
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>> news:en*************@TK2MSFTNGP15.phx.gbl...
>>>>> re:
>>>>>> I must declare a user with the same login and password in both
>>>>>> machines?
>>>>>
>>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>>
>>>>> In other words, you must set <identity impersonate...> in
>>>>> web.config.
>>>>>
>>>>> <identity
>>>>> impersonate = "true"
>>>>> userName = "TheUser"
>>>>> password = "ThePassword"
>>>>> />
>>>>>
>>>>> When your machine communicates with the machine which is
>>>>> hosting the shared directory, the credentials it will pass are :
>>>>>
>>>>> userName = "TheUser"
>>>>> password = "ThePassword"
>>>>>
>>>>> Since you created an account with those same credentials
>>>>> at your shared directory's machine, you will have access.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, ASP.NET MVP
>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>> ======================================
>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>>> Thanks I understand you now but How can I grant a permission for
>>>>>> another user in another machine?
>>>>>>
>>>>>> I must declare a user with the same login and password in both
>>>>>> machines?
>>>>>
>>>>>
>>>>>
>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>> mensaje news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>>> re:
>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>
>>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>>> but not for any account at *your* machine.
>>>>>>>
>>>>>>> The everyone account at the shared directory in another machine
>>>>>>> does *not* include *any* acount in your machine.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>> ======================================
>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>>
>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>
>>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>>
>>>>>>>>
>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>>>> mensaje news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>> re:
>>>>>>>>>> I have asp application in a machine with a virtual directory
>>>>>>>>>> referring a shared directory in another machine
>>>>>>>>>
>>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>>> read/execute rights to the shared directory in the other
>>>>>>>>> machine ?
>>>>>>>>>
>>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>>
>>>>>>>>> Run the code snippet at :
>>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>>
>>>>>>>>> and give the user which that snippet returns,
>>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>> ======================================
>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>>> Hi
>>>>>>>>>>
>>>>>>>>>> I have asp application in a machine with a virtual directory
>>>>>>>>>> referring a shared directory in another machine
>>>>>>>>>>
>>>>>>>>>> When I try to load any aspx page of my portal I get the
>>>>>>>>>> following error:
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Mensaje de error del analizador: We can't load the type
>>>>>>>>>> 'JULIAN.Global'.
>>>>>>>>>>
>>>>>>>>>> Error:
>>>>>>>>>>
>>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Any clue?
>>>>>>>>>>
>>>>>>>>>> Thanks
>>>>>>>>>>
>>>>>>>>>> Javier
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #23

P: n/a
That's the account that you have to give read permissions to,
in the machine which hosts your shared directory, then.

The other machine is in your domain network, right ?

It should accept allowing a domain account
to have read permissions to a shared directory.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:Ou**************@tk2msftngp13.phx.gbl...
Yes, the response was my user login: javier "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Ox**************@TK2MSFTNGP10.phx.gbl...
You are impersonating ASP.NET with your Windows user login ?

What was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA*************@TK2MSFTNGP10.phx.gbl...
Yes sorry, I have just do it
In the response script appears my login.


"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:O7**************@tk2msftngp13.phx.gbl...
Can't you create a virtual directory on the same machine
in which ASP.NET is running, and run that script ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
> Sorry, I can't run the script because the page can not be executed
>
> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:OO*************@TK2MSFTNGP10.phx.gbl...
>> processModel is only configurable in machine.config,
>> since it's a machine-wide setting.
>>
>> You didn't answer my question...
>>
>> Did you run the script I pointed you to ?
>>
>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>> If you did, what was the account name returned ?
>>
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:u2**************@TK2MSFTNGP09.phx.gbl...
>>> Where may I change the process model? In the web.config?
>>>
>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>> news:Oc**************@TK2MSFTNGP14.phx.gbl...
>>>> Did you run the script I pointed you to ?
>>>>
>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>> If you did, what was the account name returned ?
>>>>
>>>> Also, did you change the <processModel> element and set the user
>>>> name and password attributes to match your new custom account ?
>>>>
>>>> Default: <!-- userName="machine" password="AutoGenerate" -->
>>>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>>>
>>>> i.e.,
>>>> <processModel enable="true" userName="machine" password="AutoGenerate"/>
>>>> becomes
>>>> <processModel enable="true" userName="TheUser" password="ThePassword"/>
>>>>
>>>> ?
>>>>
>>>> Otherwise, ASP.NET keeps on running as the machine account.
>>>>
>>>> Juan T. Llibre, ASP.NET MVP
>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>> ======================================
>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>>>> Thanks but I have tested it and it doesn't work.
>>>>>
>>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>> news:en*************@TK2MSFTNGP15.phx.gbl...
>>>>>> re:
>>>>>>> I must declare a user with the same login and password in both machines?
>>>>>>
>>>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>>>
>>>>>> In other words, you must set <identity impersonate...> in web.config.
>>>>>>
>>>>>> <identity
>>>>>> impersonate = "true"
>>>>>> userName = "TheUser"
>>>>>> password = "ThePassword"
>>>>>> />
>>>>>>
>>>>>> When your machine communicates with the machine which is
>>>>>> hosting the shared directory, the credentials it will pass are :
>>>>>>
>>>>>> userName = "TheUser"
>>>>>> password = "ThePassword"
>>>>>>
>>>>>> Since you created an account with those same credentials
>>>>>> at your shared directory's machine, you will have access.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>> ======================================
>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>>>> Thanks I understand you now but How can I grant a permission for another user
>>>>>>> in another machine?
>>>>>>>
>>>>>>> I must declare a user with the same login and password in both machines?
>>>>>>
>>>>>>
>>>>>>
>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>>>> re:
>>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>
>>>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>>>> but not for any account at *your* machine.
>>>>>>>>
>>>>>>>> The everyone account at the shared directory in another machine
>>>>>>>> does *not* include *any* acount in your machine.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>> ======================================
>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>>>
>>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>>
>>>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>> re:
>>>>>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>>>>>> shared directory in another machine
>>>>>>>>>>
>>>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>>>> read/execute rights to the shared directory in the other machine ?
>>>>>>>>>>
>>>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>>>
>>>>>>>>>> Run the code snippet at :
>>>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>>>
>>>>>>>>>> and give the user which that snippet returns,
>>>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>> ======================================
>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>>>> Hi
>>>>>>>>>>>
>>>>>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>>>>>> shared directory in another machine
>>>>>>>>>>>
>>>>>>>>>>> When I try to load any aspx page of my portal I get the following error:
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>>>>>>>>>
>>>>>>>>>>> Error:
>>>>>>>>>>>
>>>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Any clue?
>>>>>>>>>>>
>>>>>>>>>>> Thanks
>>>>>>>>>>>
>>>>>>>>>>> Javier
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #24

P: n/a
There aren't domains are two machines standalones

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:%2****************@TK2MSFTNGP09.phx.gbl...
That's the account that you have to give read permissions to,
in the machine which hosts your shared directory, then.

The other machine is in your domain network, right ?

It should accept allowing a domain account
to have read permissions to a shared directory.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:Ou**************@tk2msftngp13.phx.gbl...
Yes, the response was my user login: javier

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Ox**************@TK2MSFTNGP10.phx.gbl...
You are impersonating ASP.NET with your Windows user login ?

What was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA*************@TK2MSFTNGP10.phx.gbl...
Yes sorry, I have just do it
In the response script appears my login.
"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:O7**************@tk2msftngp13.phx.gbl...
> Can't you create a virtual directory on the same machine
> in which ASP.NET is running, and run that script ?
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:%2****************@TK2MSFTNGP09.phx.gbl...
>> Sorry, I can't run the script because the page can not be executed
>>
>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>> news:OO*************@TK2MSFTNGP10.phx.gbl...
>>> processModel is only configurable in machine.config,
>>> since it's a machine-wide setting.
>>>
>>> You didn't answer my question...
>>>
>>> Did you run the script I pointed you to ?
>>>
>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>> If you did, what was the account name returned ?
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, ASP.NET MVP
>>> ASP.NET FAQ : http://asp.net.do/faq/
>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>> ======================================
>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>> news:u2**************@TK2MSFTNGP09.phx.gbl...
>>>> Where may I change the process model? In the web.config?
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>> news:Oc**************@TK2MSFTNGP14.phx.gbl...
>>>>> Did you run the script I pointed you to ?
>>>>>
>>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>>> If you did, what was the account name returned ?
>>>>>
>>>>> Also, did you change the <processModel> element and set the user
>>>>> name and password attributes to match your new custom account ?
>>>>>
>>>>> Default: <!-- userName="machine" password="AutoGenerate" -->
>>>>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>>>>
>>>>> i.e.,
>>>>> <processModel enable="true" userName="machine"
>>>>> password="AutoGenerate"/>
>>>>> becomes
>>>>> <processModel enable="true" userName="TheUser"
>>>>> password="ThePassword"/>
>>>>>
>>>>> ?
>>>>>
>>>>> Otherwise, ASP.NET keeps on running as the machine account.
>>>>>
>>>>> Juan T. Llibre, ASP.NET MVP
>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>> ======================================
>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>>>>> Thanks but I have tested it and it doesn't work.
>>>>>>
>>>>>>
>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>> mensaje news:en*************@TK2MSFTNGP15.phx.gbl...
>>>>>>> re:
>>>>>>>> I must declare a user with the same login and password in both
>>>>>>>> machines?
>>>>>>>
>>>>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>>>>
>>>>>>> In other words, you must set <identity impersonate...> in
>>>>>>> web.config.
>>>>>>>
>>>>>>> <identity
>>>>>>> impersonate = "true"
>>>>>>> userName = "TheUser"
>>>>>>> password = "ThePassword"
>>>>>>> />
>>>>>>>
>>>>>>> When your machine communicates with the machine which is
>>>>>>> hosting the shared directory, the credentials it will pass are :
>>>>>>>
>>>>>>> userName = "TheUser"
>>>>>>> password = "ThePassword"
>>>>>>>
>>>>>>> Since you created an account with those same credentials
>>>>>>> at your shared directory's machine, you will have access.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>> ======================================
>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>> Thanks I understand you now but How can I grant a permission
>>>>>>>> for another user in another machine?
>>>>>>>>
>>>>>>>> I must declare a user with the same login and password in both
>>>>>>>> machines?
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>>>> mensaje news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>> re:
>>>>>>>>>> Yes, the shared directory has full access for everyone
>>>>>>>>>> account.
>>>>>>>>>
>>>>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>>>>> but not for any account at *your* machine.
>>>>>>>>>
>>>>>>>>> The everyone account at the shared directory in another
>>>>>>>>> machine
>>>>>>>>> does *not* include *any* acount in your machine.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>> ======================================
>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>>>>
>>>>>>>>>> Yes, the shared directory has full access for everyone
>>>>>>>>>> account.
>>>>>>>>>>
>>>>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>>>>>> mensaje news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>> re:
>>>>>>>>>>>> I have asp application in a machine with a virtual
>>>>>>>>>>>> directory referring a shared directory in another machine
>>>>>>>>>>>
>>>>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>>>>> read/execute rights to the shared directory in the other
>>>>>>>>>>> machine ?
>>>>>>>>>>>
>>>>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>>>>
>>>>>>>>>>> Run the code snippet at :
>>>>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>>>>
>>>>>>>>>>> and give the user which that snippet returns,
>>>>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>>> ======================================
>>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>>>>> Hi
>>>>>>>>>>>>
>>>>>>>>>>>> I have asp application in a machine with a virtual
>>>>>>>>>>>> directory referring a shared directory in another machine
>>>>>>>>>>>>
>>>>>>>>>>>> When I try to load any aspx page of my portal I get the
>>>>>>>>>>>> following error:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Mensaje de error del analizador: We can't load the type
>>>>>>>>>>>> 'JULIAN.Global'.
>>>>>>>>>>>>
>>>>>>>>>>>> Error:
>>>>>>>>>>>>
>>>>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Any clue?
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks
>>>>>>>>>>>>
>>>>>>>>>>>> Javier
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #25

P: n/a
Are they both running XP Pro ?

If so, you need to disable "Simple File Sharing",
so that standard user authentication can be used.

Then, you can create matching name accounts for file/directory
permissions on the second box and for ASP.NET in the first box.

But, I guess, the bigger question is : Why do you need to access
files in a different computer if they are not on the same network,
and you have no network restrictions regarding creating websites
on your primary machine ? ( Since it's a standalone box... )

What stops you from, simply, running IIS/ASP.NET on the first box ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:OB**************@TK2MSFTNGP10.phx.gbl...
There aren't domains are two machines standalones

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:%2****************@TK2MSFTNGP09.phx.gbl...
That's the account that you have to give read permissions to,
in the machine which hosts your shared directory, then.

The other machine is in your domain network, right ?

It should accept allowing a domain account
to have read permissions to a shared directory.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:Ou**************@tk2msftngp13.phx.gbl...
Yes, the response was my user login: javier

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Ox**************@TK2MSFTNGP10.phx.gbl...
You are impersonating ASP.NET with your Windows user login ?

What was the account name returned ?


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uA*************@TK2MSFTNGP10.phx.gbl...
> Yes sorry, I have just do it
> In the response script appears my login.
> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:O7**************@tk2msftngp13.phx.gbl...
>> Can't you create a virtual directory on the same machine
>> in which ASP.NET is running, and run that script ?
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>> Sorry, I can't run the script because the page can not be executed
>>>
>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>> news:OO*************@TK2MSFTNGP10.phx.gbl...
>>>> processModel is only configurable in machine.config,
>>>> since it's a machine-wide setting.
>>>>
>>>> You didn't answer my question...
>>>>
>>>> Did you run the script I pointed you to ?
>>>>
>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>> If you did, what was the account name returned ?
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, ASP.NET MVP
>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>> ======================================
>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>> news:u2**************@TK2MSFTNGP09.phx.gbl...
>>>>> Where may I change the process model? In the web.config?
>>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>> news:Oc**************@TK2MSFTNGP14.phx.gbl...
>>>>>> Did you run the script I pointed you to ?
>>>>>>
>>>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>>>> If you did, what was the account name returned ?
>>>>>>
>>>>>> Also, did you change the <processModel> element and set the user
>>>>>> name and password attributes to match your new custom account ?
>>>>>>
>>>>>> Default: <!-- userName="machine" password="AutoGenerate" -->
>>>>>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>>>>>
>>>>>> i.e.,
>>>>>> <processModel enable="true" userName="machine" password="AutoGenerate"/>
>>>>>> becomes
>>>>>> <processModel enable="true" userName="TheUser" password="ThePassword"/>
>>>>>>
>>>>>> ?
>>>>>>
>>>>>> Otherwise, ASP.NET keeps on running as the machine account.
>>>>>>
>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>> ======================================
>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>>>>>> Thanks but I have tested it and it doesn't work.
>>>>>>>
>>>>>>>
>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>> news:en*************@TK2MSFTNGP15.phx.gbl...
>>>>>>>> re:
>>>>>>>>> I must declare a user with the same login and password in both machines?
>>>>>>>>
>>>>>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>>>>>
>>>>>>>> In other words, you must set <identity impersonate...> in web.config.
>>>>>>>>
>>>>>>>> <identity
>>>>>>>> impersonate = "true"
>>>>>>>> userName = "TheUser"
>>>>>>>> password = "ThePassword"
>>>>>>>> />
>>>>>>>>
>>>>>>>> When your machine communicates with the machine which is
>>>>>>>> hosting the shared directory, the credentials it will pass are :
>>>>>>>>
>>>>>>>> userName = "TheUser"
>>>>>>>> password = "ThePassword"
>>>>>>>>
>>>>>>>> Since you created an account with those same credentials
>>>>>>>> at your shared directory's machine, you will have access.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>> ======================================
>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>> Thanks I understand you now but How can I grant a permission for another
>>>>>>>>> user in another machine?
>>>>>>>>>
>>>>>>>>> I must declare a user with the same login and password in both machines?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>>>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>> re:
>>>>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>>>
>>>>>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>>>>>> but not for any account at *your* machine.
>>>>>>>>>>
>>>>>>>>>> The everyone account at the shared directory in another machine
>>>>>>>>>> does *not* include *any* acount in your machine.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>> ======================================
>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>>>>>
>>>>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>>>>
>>>>>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>>>>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>>> re:
>>>>>>>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>>>>>>>> shared directory in another machine
>>>>>>>>>>>>
>>>>>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>>>>>> read/execute rights to the shared directory in the other machine ?
>>>>>>>>>>>>
>>>>>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>>>>>
>>>>>>>>>>>> Run the code snippet at :
>>>>>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>>>>>
>>>>>>>>>>>> and give the user which that snippet returns,
>>>>>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>>>> ======================================
>>>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>>>>>> Hi
>>>>>>>>>>>>>
>>>>>>>>>>>>> I have asp application in a machine with a virtual directory referring a
>>>>>>>>>>>>> shared directory in another machine
>>>>>>>>>>>>>
>>>>>>>>>>>>> When I try to load any aspx page of my portal I get the following error:
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> Mensaje de error del analizador: We can't load the type 'JULIAN.Global'.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Error:
>>>>>>>>>>>>>
>>>>>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> Any clue?
>>>>>>>>>>>>>
>>>>>>>>>>>>> Thanks
>>>>>>>>>>>>>
>>>>>>>>>>>>> Javier
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #26

P: n/a
Even with mactching name accounts it desn't work.
Anyway tanks, I'm residign the app to set all the code in the same machine

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:uW**************@TK2MSFTNGP09.phx.gbl...
Are they both running XP Pro ?

If so, you need to disable "Simple File Sharing",
so that standard user authentication can be used.

Then, you can create matching name accounts for file/directory
permissions on the second box and for ASP.NET in the first box.

But, I guess, the bigger question is : Why do you need to access
files in a different computer if they are not on the same network,
and you have no network restrictions regarding creating websites
on your primary machine ? ( Since it's a standalone box... )

What stops you from, simply, running IIS/ASP.NET on the first box ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:OB**************@TK2MSFTNGP10.phx.gbl...
There aren't domains are two machines standalones

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:%2****************@TK2MSFTNGP09.phx.gbl...
That's the account that you have to give read permissions to,
in the machine which hosts your shared directory, then.

The other machine is in your domain network, right ?

It should accept allowing a domain account
to have read permissions to a shared directory.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:Ou**************@tk2msftngp13.phx.gbl...
Yes, the response was my user login: javier

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:Ox**************@TK2MSFTNGP10.phx.gbl...
> You are impersonating ASP.NET with your Windows user login ?
>
> What was the account name returned ?
>
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> ASPNETFAQ.COM : http://www.aspnetfaq.com/
> Foros de ASP.NET en Español : http://asp.net.do/foros/
> ======================================
> "Javier Martinez" <ja***@tid.es> wrote in message
> news:uA*************@TK2MSFTNGP10.phx.gbl...
>> Yes sorry, I have just do it
>> In the response script appears my login.
>
>
>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>> news:O7**************@tk2msftngp13.phx.gbl...
>>> Can't you create a virtual directory on the same machine
>>> in which ASP.NET is running, and run that script ?
>>>
>>>
>>>
>>> Juan T. Llibre, ASP.NET MVP
>>> ASP.NET FAQ : http://asp.net.do/faq/
>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>> ======================================
>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>> Sorry, I can't run the script because the page can not be executed
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>> news:OO*************@TK2MSFTNGP10.phx.gbl...
>>>>> processModel is only configurable in machine.config,
>>>>> since it's a machine-wide setting.
>>>>>
>>>>> You didn't answer my question...
>>>>>
>>>>> Did you run the script I pointed you to ?
>>>>>
>>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>>> If you did, what was the account name returned ?
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, ASP.NET MVP
>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>> ======================================
>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>> news:u2**************@TK2MSFTNGP09.phx.gbl...
>>>>>> Where may I change the process model? In the web.config?
>>>>>>
>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>> mensaje news:Oc**************@TK2MSFTNGP14.phx.gbl...
>>>>>>> Did you run the script I pointed you to ?
>>>>>>>
>>>>>>> (
>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>>>>> If you did, what was the account name returned ?
>>>>>>>
>>>>>>> Also, did you change the <processModel> element and set the user
>>>>>>> name and password attributes to match your new custom account ?
>>>>>>>
>>>>>>> Default: <!-- userName="machine" password="AutoGenerate" -->
>>>>>>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>>>>>>
>>>>>>> i.e.,
>>>>>>> <processModel enable="true" userName="machine"
>>>>>>> password="AutoGenerate"/>
>>>>>>> becomes
>>>>>>> <processModel enable="true" userName="TheUser"
>>>>>>> password="ThePassword"/>
>>>>>>>
>>>>>>> ?
>>>>>>>
>>>>>>> Otherwise, ASP.NET keeps on running as the machine account.
>>>>>>>
>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>> ======================================
>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>>>>>>> Thanks but I have tested it and it doesn't work.
>>>>>>>>
>>>>>>>>
>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>>>> mensaje news:en*************@TK2MSFTNGP15.phx.gbl...
>>>>>>>>> re:
>>>>>>>>>> I must declare a user with the same login and password in
>>>>>>>>>> both machines?
>>>>>>>>>
>>>>>>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>>>>>>
>>>>>>>>> In other words, you must set <identity impersonate...> in
>>>>>>>>> web.config.
>>>>>>>>>
>>>>>>>>> <identity
>>>>>>>>> impersonate = "true"
>>>>>>>>> userName = "TheUser"
>>>>>>>>> password = "ThePassword"
>>>>>>>>> />
>>>>>>>>>
>>>>>>>>> When your machine communicates with the machine which is
>>>>>>>>> hosting the shared directory, the credentials it will pass are
>>>>>>>>> :
>>>>>>>>>
>>>>>>>>> userName = "TheUser"
>>>>>>>>> password = "ThePassword"
>>>>>>>>>
>>>>>>>>> Since you created an account with those same credentials
>>>>>>>>> at your shared directory's machine, you will have access.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>> ======================================
>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>> Thanks I understand you now but How can I grant a permission
>>>>>>>>>> for another user in another machine?
>>>>>>>>>>
>>>>>>>>>> I must declare a user with the same login and password in
>>>>>>>>>> both machines?
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>>>>>> mensaje news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>> re:
>>>>>>>>>>>> Yes, the shared directory has full access for everyone
>>>>>>>>>>>> account.
>>>>>>>>>>>
>>>>>>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>>>>>>> but not for any account at *your* machine.
>>>>>>>>>>>
>>>>>>>>>>> The everyone account at the shared directory in another
>>>>>>>>>>> machine
>>>>>>>>>>> does *not* include *any* acount in your machine.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>>> ======================================
>>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>>>>>>
>>>>>>>>>>>> Yes, the shared directory has full access for everyone
>>>>>>>>>>>> account.
>>>>>>>>>>>>
>>>>>>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el
>>>>>>>>>>>> mensaje news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>>>> re:
>>>>>>>>>>>>>> I have asp application in a machine with a virtual
>>>>>>>>>>>>>> directory referring a shared directory in another machine
>>>>>>>>>>>>>
>>>>>>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>>>>>>> read/execute rights to the shared directory in the other
>>>>>>>>>>>>> machine ?
>>>>>>>>>>>>>
>>>>>>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Run the code snippet at :
>>>>>>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>>>>>>
>>>>>>>>>>>>> and give the user which that snippet returns,
>>>>>>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>>>>> ======================================
>>>>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>>>>>>> Hi
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> I have asp application in a machine with a virtual
>>>>>>>>>>>>>> directory referring a shared directory in another machine
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> When I try to load any aspx page of my portal I get the
>>>>>>>>>>>>>> following error:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Mensaje de error del analizador: We can't load the type
>>>>>>>>>>>>>> 'JULIAN.Global'.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Error:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea:
>>>>>>>>>>>>>> 1
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Any clue?
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Thanks
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Javier
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #27

P: n/a
re:
What stops you from, simply, running IIS/ASP.NET on the first box ? I'm residign the app to set all the code in the same machine


Smart move...

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:uV**************@TK2MSFTNGP10.phx.gbl... Even with mactching name accounts it desn't work.
Anyway tanks, I'm residign the app to set all the code in the same machine

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:uW**************@TK2MSFTNGP09.phx.gbl...
Are they both running XP Pro ?

If so, you need to disable "Simple File Sharing",
so that standard user authentication can be used.

Then, you can create matching name accounts for file/directory
permissions on the second box and for ASP.NET in the first box.

But, I guess, the bigger question is : Why do you need to access
files in a different computer if they are not on the same network,
and you have no network restrictions regarding creating websites
on your primary machine ? ( Since it's a standalone box... )

What stops you from, simply, running IIS/ASP.NET on the first box ?

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:OB**************@TK2MSFTNGP10.phx.gbl...
There aren't domains are two machines standalones

"Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
news:%2****************@TK2MSFTNGP09.phx.gbl...
That's the account that you have to give read permissions to,
in the machine which hosts your shared directory, then.

The other machine is in your domain network, right ?

It should accept allowing a domain account
to have read permissions to a shared directory.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
ASPNETFAQ.COM : http://www.aspnetfaq.com/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"Javier Martinez" <ja***@tid.es> wrote in message
news:Ou**************@tk2msftngp13.phx.gbl...
> Yes, the response was my user login: javier

> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
> news:Ox**************@TK2MSFTNGP10.phx.gbl...
>> You are impersonating ASP.NET with your Windows user login ?
>>
>> What was the account name returned ?
>>
>>
>>
>>
>> Juan T. Llibre, ASP.NET MVP
>> ASP.NET FAQ : http://asp.net.do/faq/
>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>> ======================================
>> "Javier Martinez" <ja***@tid.es> wrote in message
>> news:uA*************@TK2MSFTNGP10.phx.gbl...
>>> Yes sorry, I have just do it
>>> In the response script appears my login.
>>
>>
>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>> news:O7**************@tk2msftngp13.phx.gbl...
>>>> Can't you create a virtual directory on the same machine
>>>> in which ASP.NET is running, and run that script ?
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, ASP.NET MVP
>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>> ======================================
>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>> Sorry, I can't run the script because the page can not be executed
>>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>> news:OO*************@TK2MSFTNGP10.phx.gbl...
>>>>>> processModel is only configurable in machine.config,
>>>>>> since it's a machine-wide setting.
>>>>>>
>>>>>> You didn't answer my question...
>>>>>>
>>>>>> Did you run the script I pointed you to ?
>>>>>>
>>>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>>>> If you did, what was the account name returned ?
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>> ======================================
>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>> news:u2**************@TK2MSFTNGP09.phx.gbl...
>>>>>>> Where may I change the process model? In the web.config?
>>>>>>>
>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>> news:Oc**************@TK2MSFTNGP14.phx.gbl...
>>>>>>>> Did you run the script I pointed you to ?
>>>>>>>>
>>>>>>>> ( http://www.aspnetfaq.com/default.asp...&CategoryId=39 )
>>>>>>>> If you did, what was the account name returned ?
>>>>>>>>
>>>>>>>> Also, did you change the <processModel> element and set the user
>>>>>>>> name and password attributes to match your new custom account ?
>>>>>>>>
>>>>>>>> Default: <!-- userName="machine" password="AutoGenerate" -->
>>>>>>>> Becomes: <!-- userName="TheUser" password="ThePassword"
>>>>>>>>
>>>>>>>> i.e.,
>>>>>>>> <processModel enable="true" userName="machine" password="AutoGenerate"/>
>>>>>>>> becomes
>>>>>>>> <processModel enable="true" userName="TheUser" password="ThePassword"/>
>>>>>>>>
>>>>>>>> ?
>>>>>>>>
>>>>>>>> Otherwise, ASP.NET keeps on running as the machine account.
>>>>>>>>
>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>> ======================================
>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>> news:%2****************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>> Thanks but I have tested it and it doesn't work.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>>>> news:en*************@TK2MSFTNGP15.phx.gbl...
>>>>>>>>>> re:
>>>>>>>>>>> I must declare a user with the same login and password in both machines?
>>>>>>>>>>
>>>>>>>>>> Yes. Also, you must set ASP.NET to run *as* that account.
>>>>>>>>>>
>>>>>>>>>> In other words, you must set <identity impersonate...> in web.config.
>>>>>>>>>>
>>>>>>>>>> <identity
>>>>>>>>>> impersonate = "true"
>>>>>>>>>> userName = "TheUser"
>>>>>>>>>> password = "ThePassword"
>>>>>>>>>> />
>>>>>>>>>>
>>>>>>>>>> When your machine communicates with the machine which is
>>>>>>>>>> hosting the shared directory, the credentials it will pass are :
>>>>>>>>>>
>>>>>>>>>> userName = "TheUser"
>>>>>>>>>> password = "ThePassword"
>>>>>>>>>>
>>>>>>>>>> Since you created an account with those same credentials
>>>>>>>>>> at your shared directory's machine, you will have access.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>> ======================================
>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>> news:%2***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>> Thanks I understand you now but How can I grant a permission for another
>>>>>>>>>>> user in another machine?
>>>>>>>>>>>
>>>>>>>>>>> I must declare a user with the same login and password in both machines?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>>>>>> news:eQ**************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>>> re:
>>>>>>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>>>>>
>>>>>>>>>>>> Sure it does, for the everyone account at *that* machine,
>>>>>>>>>>>> but not for any account at *your* machine.
>>>>>>>>>>>>
>>>>>>>>>>>> The everyone account at the shared directory in another machine
>>>>>>>>>>>> does *not* include *any* acount in your machine.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>>>> ======================================
>>>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>>>> news:%2****************@TK2MSFTNGP09.phx.gbl...
>>>>>>>>>>>>>
>>>>>>>>>>>>> Yes, the shared directory has full access for everyone account.
>>>>>>>>>>>>>
>>>>>>>>>>>>> I can't run any code because any page can be loaded it
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> escribió en el mensaje
>>>>>>>>>>>>> news:OG***************@TK2MSFTNGP10.phx.gbl...
>>>>>>>>>>>>>> re:
>>>>>>>>>>>>>>> I have asp application in a machine with a virtual directory referring
>>>>>>>>>>>>>>> a shared directory in another machine
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Does the account that ASP.NET is running as have
>>>>>>>>>>>>>> read/execute rights to the shared directory in the other machine ?
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> It's the ASP.NET account that's connecting and which needs
>>>>>>>>>>>>>> access to \\calamaro2\tmp\global.asax , not your server.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Run the code snippet at :
>>>>>>>>>>>>>> http://www.aspnetfaq.com/default.asp...&CategoryId=39
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> and give the user which that snippet returns,
>>>>>>>>>>>>>> the appropiate permissions to \\calamaro2\tmp\
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Juan T. Llibre, ASP.NET MVP
>>>>>>>>>>>>>> ASP.NET FAQ : http://asp.net.do/faq/
>>>>>>>>>>>>>> ASPNETFAQ.COM : http://www.aspnetfaq.com/
>>>>>>>>>>>>>> Foros de ASP.NET en Español : http://asp.net.do/foros/
>>>>>>>>>>>>>> ======================================
>>>>>>>>>>>>>> "Javier Martinez" <ja***@tid.es> wrote in message
>>>>>>>>>>>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>>>>>>>>>> Hi
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> I have asp application in a machine with a virtual directory referring
>>>>>>>>>>>>>>> a shared directory in another machine
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> When I try to load any aspx page of my portal I get the following
>>>>>>>>>>>>>>> error:
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Mensaje de error del analizador: We can't load the type
>>>>>>>>>>>>>>> 'JULIAN.Global'.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Error:
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Línea 1: <%@ Application Codebehind="Global.asax.cs"
>>>>>>>>>>>>>>> Inherits="JULIAN.Global" %>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Archivo de origen: \\calamaro2\tmp\global.asax Línea: 1
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Any clue?
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Thanks
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Javier
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>



Nov 19 '05 #28

This discussion thread is closed

Replies have been disabled for this discussion.