By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,078 Members | 1,846 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,078 IT Pros & Developers. It's quick & easy.

Expire IE browser cache, again.

P: n/a
Hi,
I have checked this newsgroup and goggled in order to find out how to expire
the IE browser cache in order to ALWAYS get this text

Warning: Page has Expired The page you requested was created using
information you submitted in a form. This page is no longer available. As a
security precaution, Internet Explorer does not automatically resubmit your
information for you.

To resubmit your information and view this Web page, click the Refresh
button.


when the user presses the back button in IE 6.0.

I came up with this code:

Response.CacheControl = "no-cache"

Response.Cache.SetExpires(DateTime.Now.AddSeconds( 0))

Response.Cache.SetCacheability(HttpCacheability.No Cache)

Response.Cache.SetValidUntilExpires(False)

Response.Cache.SetNoStore()

Response.AppendHeader("Pragma", "no-cache")

Response.Cache.SetRevalidation(HttpCacheRevalidati on.AllCaches)

Infortunately it doesnt always works.

Tips anyone?

/k
Nov 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Try : <%@ OutputCache Location="None" %> in your aspx page.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"kurt sune" <ap*@apa.com> wrote in message news:e$**************@TK2MSFTNGP09.phx.gbl...
Hi,
I have checked this newsgroup and goggled in order to find out how to expire
the IE browser cache in order to ALWAYS get this text

Warning: Page has Expired The page you requested was created using
information you submitted in a form. This page is no longer available. As a
security precaution, Internet Explorer does not automatically resubmit your
information for you.

To resubmit your information and view this Web page, click the Refresh
button.


when the user presses the back button in IE 6.0.

I came up with this code:

Response.CacheControl = "no-cache"

Response.Cache.SetExpires(DateTime.Now.AddSeconds( 0))

Response.Cache.SetCacheability(HttpCacheability.No Cache)

Response.Cache.SetValidUntilExpires(False)

Response.Cache.SetNoStore()

Response.AppendHeader("Pragma", "no-cache")

Response.Cache.SetRevalidation(HttpCacheRevalidati on.AllCaches)

Infortunately it doesnt always works.

Tips anyone?

/k

Nov 19 '05 #2

P: n/a
Nope,
some of the pages I am backing to still shows up. Usually the first and
third.

/k
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2***************@tk2msftngp13.phx.gbl...
Try : <%@ OutputCache Location="None" %> in your aspx page.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"kurt sune" <ap*@apa.com> wrote in message

news:e$**************@TK2MSFTNGP09.phx.gbl...
Hi,
I have checked this newsgroup and goggled in order to find out how to expire the IE browser cache in order to ALWAYS get this text

Warning: Page has Expired The page you requested was created using
information you submitted in a form. This page is no longer available. As a security precaution, Internet Explorer does not automatically resubmit your information for you.

To resubmit your information and view this Web page, click the Refresh
button.


when the user presses the back button in IE 6.0.

I came up with this code:

Response.CacheControl = "no-cache"

Response.Cache.SetExpires(DateTime.Now.AddSeconds( 0))

Response.Cache.SetCacheability(HttpCacheability.No Cache)

Response.Cache.SetValidUntilExpires(False)

Response.Cache.SetNoStore()

Response.AppendHeader("Pragma", "no-cache")

Response.Cache.SetRevalidation(HttpCacheRevalidati on.AllCaches)

Infortunately it doesnt always works.

Tips anyone?

/k


Nov 19 '05 #3

P: n/a
the warning only occurs if the page navigated to in the history was the
result of a post. if it was a GET, user typed url, or the server sent a
redirect, then the warning will not appear.

-- bruce (sqlwork.com)
"kurt sune" <ap*@apa.com> wrote in message
news:Oh**************@TK2MSFTNGP10.phx.gbl...
Nope,
some of the pages I am backing to still shows up. Usually the first and
third.

/k
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2***************@tk2msftngp13.phx.gbl...
Try : <%@ OutputCache Location="None" %> in your aspx page.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
"kurt sune" <ap*@apa.com> wrote in message

news:e$**************@TK2MSFTNGP09.phx.gbl...
> Hi,
> I have checked this newsgroup and goggled in order to find out how to expire > the IE browser cache in order to ALWAYS get this text
>
> Warning: Page has Expired The page you requested was created using
> information you submitted in a form. This page is no longer available. As a > security precaution, Internet Explorer does not automatically resubmit your > information for you.
>
> To resubmit your information and view this Web page, click the Refresh
> button.
>
>
>
>
> when the user presses the back button in IE 6.0.
>
> I came up with this code:
>
> Response.CacheControl = "no-cache"
>
> Response.Cache.SetExpires(DateTime.Now.AddSeconds( 0))
>
> Response.Cache.SetCacheability(HttpCacheability.No Cache)
>
> Response.Cache.SetValidUntilExpires(False)
>
> Response.Cache.SetNoStore()
>
> Response.AppendHeader("Pragma", "no-cache")
>
> Response.Cache.SetRevalidation(HttpCacheRevalidati on.AllCaches)
>
>
>
>
>
> Infortunately it doesnt always works.
>
>
>
> Tips anyone?
>
>
>
> /k
>
>



Nov 19 '05 #4

P: n/a
THANKS!!!!

now i get it.

"Bruce Barker" <br******************@safeco.com> wrote in message
news:uX**************@tk2msftngp13.phx.gbl...
the warning only occurs if the page navigated to in the history was the
result of a post. if it was a GET, user typed url, or the server sent a
redirect, then the warning will not appear.

-- bruce (sqlwork.com)

Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.