471,316 Members | 983 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,316 software developers and data experts.

ASP.NET 1.1 Application Load Time

Hi,

I'm experiencing a problem when my asp.net 1.1 application starts. It
appears that when the application has not been used for 12 hours or so...I
experience a much longer load time then if the application was loaded
recently. I attempted to do some research on the subject and found a few
sites that talk about pre-compiling, which i attempted to do, however it
doesn't look like this helps if your application is unloaded do to
inactivity.

Has anyone experienced this? Any solutions out there?

Thanks,

Frank Walsh
Nov 19 '05 #1
4 1468
The application clears itself after (n) minutes, this is by design.
You can prolong the length through various IIS and ASP.NET settings though
if you must. Look at the timeout settings, in particular the application ones

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"Frank Walsh" wrote:
Hi,

I'm experiencing a problem when my asp.net 1.1 application starts. It
appears that when the application has not been used for 12 hours or so...I
experience a much longer load time then if the application was loaded
recently. I attempted to do some research on the subject and found a few
sites that talk about pre-compiling, which i attempted to do, however it
doesn't look like this helps if your application is unloaded do to
inactivity.

Has anyone experienced this? Any solutions out there?

Thanks,

Frank Walsh

Nov 19 '05 #2
Can you tell me what settings I would need to modify? Or a document I should
reference regarding this?

Thanks,

Frank Walsh

"Curt_C [MVP]" <software_at_darkfalz.com> wrote in message
news:03**********************************@microsof t.com...
The application clears itself after (n) minutes, this is by design.
You can prolong the length through various IIS and ASP.NET settings though
if you must. Look at the timeout settings, in particular the application
ones

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"Frank Walsh" wrote:
Hi,

I'm experiencing a problem when my asp.net 1.1 application starts. It
appears that when the application has not been used for 12 hours or
so...I
experience a much longer load time then if the application was loaded
recently. I attempted to do some research on the subject and found a few
sites that talk about pre-compiling, which i attempted to do, however it
doesn't look like this helps if your application is unloaded do to
inactivity.

Has anyone experienced this? Any solutions out there?

Thanks,

Frank Walsh

Nov 19 '05 #3
Hi Frank,

As Curt has mentioned, ASP.NET/IIS has a certain idle timeout setting for
asp.net worker process. When the worker process has been idle for more than
the timeout period, it'll be shutdown. Is your ASP.NET server IIS5 or IIS6?

For II5, you can lookup the setting in the server machine's machine.config
file, under the
<processModel> element. You can find the "idleTimeout" attribute within
that element.

For IIS6, by default ASP.NET use the IIS6 application pool model, so you
need to find the application pool of your asp.net application. Then, in the
applcation pool's configuration panel, lookup the "recycle worker process
in miniutes" setting which is under the Recycling tab. The default value is
1740 mins.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Frank Walsh" <f2**@community.nospam>
| References: <#0**************@TK2MSFTNGP09.phx.gbl>
<03**********************************@microsoft.co m>
| Subject: Re: ASP.NET 1.1 Application Load Time
| Date: Wed, 12 Oct 2005 13:29:19 -0400
| Lines: 44
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#H**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: pool-71-241-106-23.scr.east.verizon.net 71.241.106.23
| Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl!TK2MSF TNGP08.phx.gbl!TK2MSFTNGP1
2.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:350358
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Can you tell me what settings I would need to modify? Or a document I
should
| reference regarding this?
|
| Thanks,
|
| Frank Walsh
|
| "Curt_C [MVP]" <software_at_darkfalz.com> wrote in message
| news:03**********************************@microsof t.com...
| > The application clears itself after (n) minutes, this is by design.
| > You can prolong the length through various IIS and ASP.NET settings
though
| > if you must. Look at the timeout settings, in particular the
application
| > ones
| >
| > --
| > Curt Christianson
| > site: http://www.darkfalz.com
| > blog: http://blog.darkfalz.com
| >
| >
| >
| > "Frank Walsh" wrote:
| >
| >> Hi,
| >>
| >> I'm experiencing a problem when my asp.net 1.1 application starts. It
| >> appears that when the application has not been used for 12 hours or
| >> so...I
| >> experience a much longer load time then if the application was loaded
| >> recently. I attempted to do some research on the subject and found a
few
| >> sites that talk about pre-compiling, which i attempted to do, however
it
| >> doesn't look like this helps if your application is unloaded do to
| >> inactivity.
| >>
| >> Has anyone experienced this? Any solutions out there?
| >>
| >> Thanks,
| >>
| >> Frank Walsh
| >>
| >>
| >>
|
|
|

Nov 19 '05 #4
Hi Frank,

How are you doing on this issue, does the things in my former reply helps a
little? If there're anything else we can help, please feel free to post
here.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 77190788
| References: <#0**************@TK2MSFTNGP09.phx.gbl>
<03**********************************@microsoft.co m>
<#H**************@TK2MSFTNGP12.phx.gbl>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Thu, 13 Oct 2005 04:41:15 GMT
| Subject: Re: ASP.NET 1.1 Application Load Time
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <8u**************@TK2MSFTNGXA01.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 80
| Path: TK2MSFTNGXA01.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:131009
| NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
|
| Hi Frank,
|
| As Curt has mentioned, ASP.NET/IIS has a certain idle timeout setting for
| asp.net worker process. When the worker process has been idle for more
than
| the timeout period, it'll be shutdown. Is your ASP.NET server IIS5 or
IIS6?
|
| For II5, you can lookup the setting in the server machine's
machine.config
| file, under the
| <processModel> element. You can find the "idleTimeout" attribute within
| that element.
|
| For IIS6, by default ASP.NET use the IIS6 application pool model, so you
| need to find the application pool of your asp.net application. Then, in
the
| applcation pool's configuration panel, lookup the "recycle worker process
| in miniutes" setting which is under the Recycling tab. The default value
is
| 1740 mins.
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
| --------------------
| | From: "Frank Walsh" <f2**@community.nospam>
| | References: <#0**************@TK2MSFTNGP09.phx.gbl>
| <03**********************************@microsoft.co m>
| | Subject: Re: ASP.NET 1.1 Application Load Time
| | Date: Wed, 12 Oct 2005 13:29:19 -0400
| | Lines: 44
| | X-Priority: 3
| | X-MSMail-Priority: Normal
| | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| | X-RFC2646: Format=Flowed; Original
| | Message-ID: <#H**************@TK2MSFTNGP12.phx.gbl>
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | NNTP-Posting-Host: pool-71-241-106-23.scr.east.verizon.net 71.241.106.23
| | Path:
|
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl!TK2MSF TNGP08.phx.gbl!TK2MSFTNGP1
| 2.phx.gbl
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:350358
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Can you tell me what settings I would need to modify? Or a document I
| should
| | reference regarding this?
| |
| | Thanks,
| |
| | Frank Walsh
| |
| | "Curt_C [MVP]" <software_at_darkfalz.com> wrote in message
| | news:03**********************************@microsof t.com...
| | > The application clears itself after (n) minutes, this is by design.
| | > You can prolong the length through various IIS and ASP.NET settings
| though
| | > if you must. Look at the timeout settings, in particular the
| application
| | > ones
| | >
| | > --
| | > Curt Christianson
| | > site: http://www.darkfalz.com
| | > blog: http://blog.darkfalz.com
| | >
| | >
| | >
| | > "Frank Walsh" wrote:
| | >
| | >> Hi,
| | >>
| | >> I'm experiencing a problem when my asp.net 1.1 application starts. It
| | >> appears that when the application has not been used for 12 hours or
| | >> so...I
| | >> experience a much longer load time then if the application was loaded
| | >> recently. I attempted to do some research on the subject and found a
| few
| | >> sites that talk about pre-compiling, which i attempted to do,
however
| it
| | >> doesn't look like this helps if your application is unloaded do to
| | >> inactivity.
| | >>
| | >> Has anyone experienced this? Any solutions out there?
| | >>
| | >> Thanks,
| | >>
| | >> Frank Walsh
| | >>
| | >>
| | >>
| |
| |
| |
|
|

Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Dinesh Jain | last post: by
4 posts views Thread by Ravi Ambros Wallau | last post: by
1 post views Thread by my cats, Gag and yak | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.