By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,378 Members | 3,020 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,378 IT Pros & Developers. It's quick & easy.

Deploy to remote server

P: n/a
Hello all,

I hope I am posting to the right forum. I have made my very first
ASP.NET web app and am trying to deploy my baby to a remote server. All
I know about my remote server is that it has frontpage extensions
installed and is compatible with .NET v1.1.4322. From the IDE, I have
chosen the 'Copy project...' option and have copied the files needed to
run the application to another folder on my machine via the FrontPage
web access method. I then take those files and copy them via FTP to the
remote server.

The FTP client I use is the client built in to IE. My original project
name is GetOpData (Virtual Directory). I deploy it to my local machine
as GetOpDatav2 (Virtual Directory). I copy the project to a subweb named
dev.

The result is a runtime error asking me to change the customErrors mode
to Off so I can look at what is causing the problem. I try to do this
and I still get the same error. Everything in my Web.config file is set
to default values except the debug which is set to false. The project
was last built in Release mode and deployed the same. This project does
work on my local network.

I know enough about IIS to be dangerous on my own network, but when it
comes to the remote host, I am sadly ignorant (probably best for my
ISP). Basically I am an ameteur when it comes to remote deployment.

If anyone has some tips, tricks or questions about my project, please
respond. I have also looked in other posts for some help, but I don't
think they apply to this situation or I am not thinking hard enough
about what others are saying.

Regards,
Jeff Jones
Nov 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Jeffrey Jones <je**********@kc.rr.com> wrote in news:uI5C7Y1yFHA.916
@TK2MSFTNGP10.phx.gbl:
The result is a runtime error asking me to change the customErrors mode
to Off so I can look at what is causing the problem. I try to do this
and I still get the same error. Everything in my Web.config file is set
to default values except the debug which is set to false. The project
was last built in Release mode and deployed the same. This project does
work on my local network.


Was the directory configured as a web application?

That is probably all that is missing...

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.

Newmarket Volvo Sucks! http://newmarketvolvo.tripod.com
Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.