By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,882 Members | 2,489 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,882 IT Pros & Developers. It's quick & easy.

Windows Service not installing.

P: n/a
I have a small Windows Service program that just has a timer on it and it
built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or does
not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it has
to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** **************************
****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** **************************
*************

Thanks,

Tom
Nov 19 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a

"tshad" <tf*@dslextreme.com> wrote in message
news:O2**************@TK2MSFTNGP10.phx.gbl...
I have a small Windows Service program that just has a timer on it and it
built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or does
not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it has
to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** ************************** ****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og. Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og. Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** ************************** *************

I also have a file in my bin folder - MyService..InstallLog that has this in
it:

************************************************** ********************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** *********

So I assume it is finding it fine.
Thanks,

Tom

Nov 19 '05 #2

P: n/a
I finally got it to work.

I changed the Account from LocalService (which was what my instructions said
to use) to LocalSystem. Now it installed.

Why wouldn't it install with the other account (LocalService)?

Thanks,

Tom

"tshad" <tf*@dslextreme.com> wrote in message
news:un*************@TK2MSFTNGP15.phx.gbl...

"tshad" <tf*@dslextreme.com> wrote in message
news:O2**************@TK2MSFTNGP10.phx.gbl...
I have a small Windows Service program that just has a timer on it and it built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or does not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it has to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** **************************
****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at

c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at

c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>

************************************************** **************************
*************


I also have a file in my bin folder - MyService..InstallLog that has this

in it:

************************************************** ********************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og. Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og. Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** *********

So I assume it is finding it fine.
Thanks,

Tom


Nov 19 '05 #3

P: n/a
You'll probably get a better/faster response if you post this
in the windowsforms or .net framework newsgroups,
or at : http://forums.microsoft.com/msdn/ in the same ng's.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espaņol : http://asp.net.do/foros/
======================================
"tshad" <tf*@dslextreme.com> wrote in message
news:O2**************@TK2MSFTNGP10.phx.gbl...
I have a small Windows Service program that just has a timer on it and it
built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or does
not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it has
to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** **************************
****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** **************************
*************

Thanks,

Tom

Nov 19 '05 #4

P: n/a
This is the .net framework group, isn't it?

"microsoft.public.dotnet.framework.aspnet" is where I posted it.

Tom

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...
You'll probably get a better/faster response if you post this
in the windowsforms or .net framework newsgroups,
or at : http://forums.microsoft.com/msdn/ in the same ng's.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espaņol : http://asp.net.do/foros/
======================================
"tshad" <tf*@dslextreme.com> wrote in message
news:O2**************@TK2MSFTNGP10.phx.gbl...
I have a small Windows Service program that just has a timer on it and it
built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or does
not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it
has
to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** **************************
****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at
c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at
c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** **************************
*************

Thanks,

Tom


Nov 19 '05 #5

P: n/a
Hi, Tom.

re:
This is the .net framework group, isn't it?
Actually, no.

This is the ASP.NET newsgroup, but since your question is about
Windows Services (unless you intend to control them via a web app)
this is not the place where you can get the best help.

The .net framework group is microsoft.public.dotnet.framework

Again, you *might* get a good answer here, but you *probably*
will find a quicker/better response in a newsgroup more focused
towards the heart of your question.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espaņol : http://asp.net.do/foros/
======================================
"tshad" <ts**********@ftsolutions.com> wrote in message
news:ux****************@tk2msftngp13.phx.gbl... This is the .net framework group, isn't it?

"microsoft.public.dotnet.framework.aspnet" is where I posted it.

Tom "Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...
You'll probably get a better/faster response if you post this
in the windowsforms or .net framework newsgroups,
or at : http://forums.microsoft.com/msdn/ in the same ng's.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espaņol : http://asp.net.do/foros/
======================================
"tshad" <tf*@dslextreme.com> wrote in message
news:O2**************@TK2MSFTNGP10.phx.gbl...
I have a small Windows Service program that just has a timer on it and it
built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or does
not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it has
to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** **************************
****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** **************************
*************

Thanks,

Tom

Nov 19 '05 #6

P: n/a
"tshad" <tf*@dslextreme.com> wrote in news:eJK3k69xFHA.2228
@TK2MSFTNGP11.phx.gbl:
Why wouldn't it install with the other account (LocalService)?


You can...

For the username, did you try:

ComputerName\Username

or

Domain\Username

?
--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.

Newmarket Volvo Sucks! http://newmarketvolvo.tripod.com
Nov 19 '05 #7

P: n/a
"Lucas Tam" <RE********@rogers.com> wrote in message
news:Xn***************************@127.0.0.1...
"tshad" <tf*@dslextreme.com> wrote in news:eJK3k69xFHA.2228
@TK2MSFTNGP11.phx.gbl:
Why wouldn't it install with the other account (LocalService)?
You can...

For the username, did you try:

ComputerName\Username

or

Domain\Username

?


Where do I do that?

In VS, I just set it up to LocalService, build it and then from the console
I do "InstallUtil "...".

I never get a question about user name.

Should I be getting it?

Thanks,

Tom

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.

Newmarket Volvo Sucks! http://newmarketvolvo.tripod.com

Nov 19 '05 #8

P: n/a
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Oy**************@TK2MSFTNGP12.phx.gbl...
Hi, Tom.

re:
This is the .net framework group, isn't it?
Actually, no.

This is the ASP.NET newsgroup, but since your question is about
Windows Services (unless you intend to control them via a web app)
this is not the place where you can get the best help.

The .net framework group is microsoft.public.dotnet.framework


Ok,

I'll post it there.

These problems have been driving me nuts - hopefully someone there can help

Thanks,

Tom
Again, you *might* get a good answer here, but you *probably*
will find a quicker/better response in a newsgroup more focused
towards the heart of your question.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espaņol : http://asp.net.do/foros/
======================================
"tshad" <ts**********@ftsolutions.com> wrote in message
news:ux****************@tk2msftngp13.phx.gbl...
This is the .net framework group, isn't it?

"microsoft.public.dotnet.framework.aspnet" is where I posted it.

Tom

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...
You'll probably get a better/faster response if you post this
in the windowsforms or .net framework newsgroups,
or at : http://forums.microsoft.com/msdn/ in the same ng's.

Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espaņol : http://asp.net.do/foros/
======================================
"tshad" <tf*@dslextreme.com> wrote in message
news:O2**************@TK2MSFTNGP10.phx.gbl...
I have a small Windows Service program that just has a timer on it and
it
built fine.

I try to install it using InstallUtil and I get the following message:

System.ComponentModel.Win32Exception: The account name is invalid or
does
not exist, or the password is invalid for the account name specified

I am in the same folder my program is in (MyService.exe). I assume it
has
to do with Logon Credentials.

What do I do to get this installed?

Here is the whole install problem with Path:

************************************************** **************************
****************
C:\DotNetProjects\MyService\bin>installUtil
"c:\DotNetProjects\MyService\bin\MyS
ervice.exe"
Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at
c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Installing assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Installing service Service1...
Creating EventLog source Service1 in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The account name is invalid or
does
not ex
ist, or the password is invalid for the account name specified

The Rollback phase of the installation is beginning.
See the contents of the log file for the
c:\dotnetprojects\myservice\bin\myservi
ce.exe assembly's progress.
The file is located at
c:\dotnetprojects\myservice\bin\myservice.InstallL og.
Rolling back assembly 'c:\dotnetprojects\myservice\bin\myservice.exe'.
Affected parameters are:
assemblypath = c:\dotnetprojects\myservice\bin\myservice.exe
logfile = c:\dotnetprojects\myservice\bin\myservice.InstallL og
Restoring event log to previous state for source Service1.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.

C:\DotNetProjects\MyService\bin>
************************************************** **************************
*************

Thanks,

Tom


Nov 19 '05 #9

P: n/a
"tshad" <ts**********@ftsolutions.com> wrote in
news:#L**************@TK2MSFTNGP14.phx.gbl:
Where do I do that?

In VS, I just set it up to LocalService, build it and then from the
console I do "InstallUtil "...".

I never get a question about user name.

Should I be getting it?


Yes... It asks me for a username when I run the InstallUtil:

installutil "C:\Service.exe"

During the install, it pops a message box asking for the username.

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.

Newmarket Volvo Sucks! http://newmarketvolvo.tripod.com
Nov 19 '05 #10

P: n/a
"Lucas Tam" <RE********@rogers.com> wrote in message
news:Xn***************************@127.0.0.1...
"tshad" <ts**********@ftsolutions.com> wrote in
news:#L**************@TK2MSFTNGP14.phx.gbl:
Where do I do that?

In VS, I just set it up to LocalService, build it and then from the
console I do "InstallUtil "...".

I never get a question about user name.

Should I be getting it?
Yes... It asks me for a username when I run the InstallUtil:

installutil "C:\Service.exe"

During the install, it pops a message box asking for the username.


Doesn't do that for me.

Just gives a file does not exist or access denied message (which of it
shouldn't since, I never got a chance to enter the username)
Tom

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.

Newmarket Volvo Sucks! http://newmarketvolvo.tripod.com

Nov 19 '05 #11

P: n/a
"tshad" <ts**********@ftsolutions.com> wrote in news:eeKhqWTyFHA.464
@TK2MSFTNGP15.phx.gbl:
installutil "C:\Service.exe"

During the install, it pops a message box asking for the username.


Doesn't do that for me.

Just gives a file does not exist or access denied message (which of it
shouldn't since, I never got a chance to enter the username)


Oh the installutil.exe tool is in your .NET framework directory.

Try running it from:

C:\WINDOWS\Microsoft.NET\Framework\xxxxxxx <-- Version # here

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.

Newmarket Volvo Sucks! http://newmarketvolvo.tripod.com
Nov 19 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.