By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,962 Members | 1,791 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,962 IT Pros & Developers. It's quick & easy.

State Service error with space in Virtual Directory

P: n/a
Hi,

ENV: Windows 2003 Server SP1 (+all updates), VS 2003, .Net 1.1 SP1

We've got an ASP.Net web application using State Service. All is fine until
we tried to use the app through a virtual directory with a space in it.
e.g. 'http://localhost/My%20App'.

The following exception is thrown:
----------
System.Web.HttpException: Unable to make the session state request to the
session state server. Please ensure that the ASP.NET State service is
started and that the client and server ports are the same. If the server is
on a remote machine, please ensure that it accepts remote requests by
checking the value of
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters\AllowRemoteConnection.
-----------

IIS allows us to create Virtual Directories with a space, so does the State
Service not support it? I couldn't find any documentation on this or any
previous posts via Google...

If it doesn't support it, can you point me to any docs which list what are
invalid characters. The real reason is that we have an app which allows
customers to create new Virtual Directories that run our other ASP.Net apps.
We just need to know so we can stop customers creating VD's with spaces and
any other dodgy characters.

Thanks,
Stuart
Nov 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hi Stuart,

Welcome to ASPNET newsgroup.
As for the problem of stateserver session when the asp.net app's virtual
dir folder name contains space char, I've checked our internal product
database and did found this issue. This has been recorded as a known issue
of the current ASP.NET's stateserver session manager's implemtation. So
basically, there doesn't have any particular limtation on the chars used
for web application's virtual dir(just as the IIS's rule). Also, this
issue has been confirmed to be fixed in whidbey and based on my test on a
whidbey beta2 environment, I did manage to get this work. I think this
behavior will be consistent in the final release of ASP.NET whidbey.
Currently, as for the asp.net 1.x , for your scenario, I'd still recommend
that you add limitation for the space char in your application so as to
prevent the user from creating virtual dir with names that contains spaces.
Sorry for the inconvenience this has brought you.

Thanks for your understanding.

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Stu Carter" <St********@nospam.nospam>
| Subject: State Service error with space in Virtual Directory
| Date: Tue, 27 Sep 2005 09:23:16 +0100
| Lines: 32
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| X-RFC2646: Format=Flowed; Original
| Message-ID: <eF**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:127325
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
|
| ENV: Windows 2003 Server SP1 (+all updates), VS 2003, .Net 1.1 SP1
|
| We've got an ASP.Net web application using State Service. All is fine
until
| we tried to use the app through a virtual directory with a space in it.
| e.g. 'http://localhost/My%20App'.
|
| The following exception is thrown:
| ----------
| System.Web.HttpException: Unable to make the session state request to the
| session state server. Please ensure that the ASP.NET State service is
| started and that the client and server ports are the same. If the server
is
| on a remote machine, please ensure that it accepts remote requests by
| checking the value of
|
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters
\AllowRemoteConnection.
| -----------
|
| IIS allows us to create Virtual Directories with a space, so does the
State
| Service not support it? I couldn't find any documentation on this or any
| previous posts via Google...
|
| If it doesn't support it, can you point me to any docs which list what
are
| invalid characters. The real reason is that we have an app which allows
| customers to create new Virtual Directories that run our other ASP.Net
apps.
| We just need to know so we can stop customers creating VD's with spaces
and
| any other dodgy characters.
|
| Thanks,
| Stuart
|
|
|

Nov 19 '05 #2

P: n/a
Hi Steven,

Thanks for the quick reply. I just need clarification on your response:
This has been recorded as a known issue
of the current ASP.NET's stateserver session manager's implemtation. So
basically, there doesn't have any particular limtation on the chars used
for web application's virtual dir(just as the IIS's rule).
I don't understand what you mean when you say 'there isn't any particular
limitation on the characters used - just the IIS rules'. We followed the
IIS rules and it broke! :)

Is it only a space that causes the issue or can other characters cause a
problem too?

Thanks again,
Stuart

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:S9*************@TK2MSFTNGXA01.phx.gbl... Hi Stuart,

Welcome to ASPNET newsgroup.
As for the problem of stateserver session when the asp.net app's virtual
dir folder name contains space char, I've checked our internal product
database and did found this issue. This has been recorded as a known issue
of the current ASP.NET's stateserver session manager's implemtation. So
basically, there doesn't have any particular limtation on the chars used
for web application's virtual dir(just as the IIS's rule). Also, this
issue has been confirmed to be fixed in whidbey and based on my test on a
whidbey beta2 environment, I did manage to get this work. I think this
behavior will be consistent in the final release of ASP.NET whidbey.
Currently, as for the asp.net 1.x , for your scenario, I'd still recommend
that you add limitation for the space char in your application so as to
prevent the user from creating virtual dir with names that contains
spaces.
Sorry for the inconvenience this has brought you.

Thanks for your understanding.

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Stu Carter" <St********@nospam.nospam>
| Subject: State Service error with space in Virtual Directory
| Date: Tue, 27 Sep 2005 09:23:16 +0100
| Lines: 32
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| X-RFC2646: Format=Flowed; Original
| Message-ID: <eF**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:127325
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
|
| ENV: Windows 2003 Server SP1 (+all updates), VS 2003, .Net 1.1 SP1
|
| We've got an ASP.Net web application using State Service. All is fine
until
| we tried to use the app through a virtual directory with a space in it.
| e.g. 'http://localhost/My%20App'.
|
| The following exception is thrown:
| ----------
| System.Web.HttpException: Unable to make the session state request to
the
| session state server. Please ensure that the ASP.NET State service is
| started and that the client and server ports are the same. If the server
is
| on a remote machine, please ensure that it accepts remote requests by
| checking the value of
|
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters
\AllowRemoteConnection.
| -----------
|
| IIS allows us to create Virtual Directories with a space, so does the
State
| Service not support it? I couldn't find any documentation on this or
any
| previous posts via Google...
|
| If it doesn't support it, can you point me to any docs which list what
are
| invalid characters. The real reason is that we have an app which allows
| customers to create new Virtual Directories that run our other ASP.Net
apps.
| We just need to know so we can stop customers creating VD's with spaces
and
| any other dodgy characters.
|
| Thanks,
| Stuart
|
|
|

Nov 19 '05 #3

P: n/a
Hi Stuart,

Sorry for my unclear description. the

==========
'there isn't any particular
limitation on the characters used - just the IIS rules'.
=============

I mentioned just means, from a developer perspective, there has no
limitation on the name of the asp.net application's virtual dir name. In
other words, the NAME IIS allowed is also allowed to be used for ASP.NET
app.
The "space" char problem is due to an existing BUG of our current ASP.NET's
stateserver session manager implementation. Also, if you find any other
new problems with it, please feel free to report to us.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Stu Carter" <St********@nospam.nospam>
| References: <eF**************@TK2MSFTNGP12.phx.gbl>
<S9*************@TK2MSFTNGXA01.phx.gbl>
| Subject: Re: State Service error with space in Virtual Directory
| Date: Tue, 27 Sep 2005 15:09:49 +0100
| Lines: 116
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#V**************@TK2MSFTNGP11.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP11.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:127414
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Steven,
|
| Thanks for the quick reply. I just need clarification on your response:
|
| > This has been recorded as a known issue
| > of the current ASP.NET's stateserver session manager's implemtation. So
| > basically, there doesn't have any particular limtation on the chars used
| > for web application's virtual dir(just as the IIS's rule).
|
| I don't understand what you mean when you say 'there isn't any particular
| limitation on the characters used - just the IIS rules'. We followed the
| IIS rules and it broke! :)
|
| Is it only a space that causes the issue or can other characters cause a
| problem too?
|
| Thanks again,
| Stuart
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:S9*************@TK2MSFTNGXA01.phx.gbl...
| > Hi Stuart,
| >
| > Welcome to ASPNET newsgroup.
| > As for the problem of stateserver session when the asp.net app's virtual
| > dir folder name contains space char, I've checked our internal product
| > database and did found this issue. This has been recorded as a known
issue
| > of the current ASP.NET's stateserver session manager's implemtation. So
| > basically, there doesn't have any particular limtation on the chars used
| > for web application's virtual dir(just as the IIS's rule). Also, this
| > issue has been confirmed to be fixed in whidbey and based on my test on
a
| > whidbey beta2 environment, I did manage to get this work. I think this
| > behavior will be consistent in the final release of ASP.NET whidbey.
| > Currently, as for the asp.net 1.x , for your scenario, I'd still
recommend
| > that you add limitation for the space char in your application so as to
| > prevent the user from creating virtual dir with names that contains
| > spaces.
| > Sorry for the inconvenience this has brought you.
| >
| > Thanks for your understanding.
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| > --------------------
| > | From: "Stu Carter" <St********@nospam.nospam>
| > | Subject: State Service error with space in Virtual Directory
| > | Date: Tue, 27 Sep 2005 09:23:16 +0100
| > | Lines: 32
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| > | X-RFC2646: Format=Flowed; Original
| > | Message-ID: <eF**************@TK2MSFTNGP12.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| > | Xref: TK2MSFTNGXA01.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:127325
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi,
| > |
| > | ENV: Windows 2003 Server SP1 (+all updates), VS 2003, .Net 1.1 SP1
| > |
| > | We've got an ASP.Net web application using State Service. All is fine
| > until
| > | we tried to use the app through a virtual directory with a space in
it.
| > | e.g. 'http://localhost/My%20App'.
| > |
| > | The following exception is thrown:
| > | ----------
| > | System.Web.HttpException: Unable to make the session state request to
| > the
| > | session state server. Please ensure that the ASP.NET State service is
| > | started and that the client and server ports are the same. If the
server
| > is
| > | on a remote machine, please ensure that it accepts remote requests by
| > | checking the value of
| > |
| >
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters
| > \AllowRemoteConnection.
| > | -----------
| > |
| > | IIS allows us to create Virtual Directories with a space, so does the
| > State
| > | Service not support it? I couldn't find any documentation on this or
| > any
| > | previous posts via Google...
| > |
| > | If it doesn't support it, can you point me to any docs which list what
| > are
| > | invalid characters. The real reason is that we have an app which
allows
| > | customers to create new Virtual Directories that run our other ASP.Net
| > apps.
| > | We just need to know so we can stop customers creating VD's with
spaces
| > and
| > | any other dodgy characters.
| > |
| > | Thanks,
| > | Stuart
| > |
| > |
| > |
| >
|
|
|

Nov 19 '05 #4

P: n/a
OK, thanks Steven

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:%2******************@TK2MSFTNGXA01.phx.gbl...
Hi Stuart,

Sorry for my unclear description. the

==========
'there isn't any particular
limitation on the characters used - just the IIS rules'.
=============

I mentioned just means, from a developer perspective, there has no
limitation on the name of the asp.net application's virtual dir name. In
other words, the NAME IIS allowed is also allowed to be used for ASP.NET
app.
The "space" char problem is due to an existing BUG of our current
ASP.NET's
stateserver session manager implementation. Also, if you find any other
new problems with it, please feel free to report to us.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Stu Carter" <St********@nospam.nospam>
| References: <eF**************@TK2MSFTNGP12.phx.gbl>
<S9*************@TK2MSFTNGXA01.phx.gbl>
| Subject: Re: State Service error with space in Virtual Directory
| Date: Tue, 27 Sep 2005 15:09:49 +0100
| Lines: 116
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#V**************@TK2MSFTNGP11.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP11.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:127414
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Steven,
|
| Thanks for the quick reply. I just need clarification on your response:
|
| > This has been recorded as a known issue
| > of the current ASP.NET's stateserver session manager's implemtation.
So
| > basically, there doesn't have any particular limtation on the chars
used
| > for web application's virtual dir(just as the IIS's rule).
|
| I don't understand what you mean when you say 'there isn't any
particular
| limitation on the characters used - just the IIS rules'. We followed
the
| IIS rules and it broke! :)
|
| Is it only a space that causes the issue or can other characters cause a
| problem too?
|
| Thanks again,
| Stuart
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:S9*************@TK2MSFTNGXA01.phx.gbl...
| > Hi Stuart,
| >
| > Welcome to ASPNET newsgroup.
| > As for the problem of stateserver session when the asp.net app's
virtual
| > dir folder name contains space char, I've checked our internal product
| > database and did found this issue. This has been recorded as a known
issue
| > of the current ASP.NET's stateserver session manager's implemtation.
So
| > basically, there doesn't have any particular limtation on the chars
used
| > for web application's virtual dir(just as the IIS's rule). Also, this
| > issue has been confirmed to be fixed in whidbey and based on my test
on
a
| > whidbey beta2 environment, I did manage to get this work. I think this
| > behavior will be consistent in the final release of ASP.NET whidbey.
| > Currently, as for the asp.net 1.x , for your scenario, I'd still
recommend
| > that you add limitation for the space char in your application so as
to
| > prevent the user from creating virtual dir with names that contains
| > spaces.
| > Sorry for the inconvenience this has brought you.
| >
| > Thanks for your understanding.
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| > --------------------
| > | From: "Stu Carter" <St********@nospam.nospam>
| > | Subject: State Service error with space in Virtual Directory
| > | Date: Tue, 27 Sep 2005 09:23:16 +0100
| > | Lines: 32
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| > | X-RFC2646: Format=Flowed; Original
| > | Message-ID: <eF**************@TK2MSFTNGP12.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| > | Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| > | Xref: TK2MSFTNGXA01.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:127325
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi,
| > |
| > | ENV: Windows 2003 Server SP1 (+all updates), VS 2003, .Net 1.1 SP1
| > |
| > | We've got an ASP.Net web application using State Service. All is
fine
| > until
| > | we tried to use the app through a virtual directory with a space in
it.
| > | e.g. 'http://localhost/My%20App'.
| > |
| > | The following exception is thrown:
| > | ----------
| > | System.Web.HttpException: Unable to make the session state request
to
| > the
| > | session state server. Please ensure that the ASP.NET State service
is
| > | started and that the client and server ports are the same. If the
server
| > is
| > | on a remote machine, please ensure that it accepts remote requests
by
| > | checking the value of
| > |
| >
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters
| > \AllowRemoteConnection.
| > | -----------
| > |
| > | IIS allows us to create Virtual Directories with a space, so does
the
| > State
| > | Service not support it? I couldn't find any documentation on this
or
| > any
| > | previous posts via Google...
| > |
| > | If it doesn't support it, can you point me to any docs which list
what
| > are
| > | invalid characters. The real reason is that we have an app which
allows
| > | customers to create new Virtual Directories that run our other
ASP.Net
| > apps.
| > | We just need to know so we can stop customers creating VD's with
spaces
| > and
| > | any other dodgy characters.
| > |
| > | Thanks,
| > | Stuart
| > |
| > |
| > |
| >
|
|
|

Nov 19 '05 #5

P: n/a
You're welcome Stu,

Good luck!

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Stu Carter" <St********@nospam.nospam>
| References: <eF**************@TK2MSFTNGP12.phx.gbl>
<S9*************@TK2MSFTNGXA01.phx.gbl>
<#V**************@TK2MSFTNGP11.phx.gbl>
<##**************@TK2MSFTNGXA01.phx.gbl>
| Subject: Re: State Service error with space in Virtual Directory
| Date: Wed, 28 Sep 2005 10:43:06 +0100
| Lines: 197
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| X-RFC2646: Format=Flowed; Original
| Message-ID: <#t**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:127617
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| OK, thanks Steven
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:%2******************@TK2MSFTNGXA01.phx.gbl...
| > Hi Stuart,
| >
| > Sorry for my unclear description. the
| >
| > ==========
| > 'there isn't any particular
| > limitation on the characters used - just the IIS rules'.
| > =============
| >
| > I mentioned just means, from a developer perspective, there has no
| > limitation on the name of the asp.net application's virtual dir name. In
| > other words, the NAME IIS allowed is also allowed to be used for ASP.NET
| > app.
| > The "space" char problem is due to an existing BUG of our current
| > ASP.NET's
| > stateserver session manager implementation. Also, if you find any other
| > new problems with it, please feel free to report to us.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| > --------------------
| > | From: "Stu Carter" <St********@nospam.nospam>
| > | References: <eF**************@TK2MSFTNGP12.phx.gbl>
| > <S9*************@TK2MSFTNGXA01.phx.gbl>
| > | Subject: Re: State Service error with space in Virtual Directory
| > | Date: Tue, 27 Sep 2005 15:09:49 +0100
| > | Lines: 116
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| > | X-RFC2646: Format=Flowed; Original
| > | Message-ID: <#V**************@TK2MSFTNGP11.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP11.phx.gbl
| > | Xref: TK2MSFTNGXA01.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:127414
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi Steven,
| > |
| > | Thanks for the quick reply. I just need clarification on your
response:
| > |
| > | > This has been recorded as a known issue
| > | > of the current ASP.NET's stateserver session manager's
implemtation.
| > So
| > | > basically, there doesn't have any particular limtation on the chars
| > used
| > | > for web application's virtual dir(just as the IIS's rule).
| > |
| > | I don't understand what you mean when you say 'there isn't any
| > particular
| > | limitation on the characters used - just the IIS rules'. We followed
| > the
| > | IIS rules and it broke! :)
| > |
| > | Is it only a space that causes the issue or can other characters
cause a
| > | problem too?
| > |
| > | Thanks again,
| > | Stuart
| > |
| > | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | news:S9*************@TK2MSFTNGXA01.phx.gbl...
| > | > Hi Stuart,
| > | >
| > | > Welcome to ASPNET newsgroup.
| > | > As for the problem of stateserver session when the asp.net app's
| > virtual
| > | > dir folder name contains space char, I've checked our internal
product
| > | > database and did found this issue. This has been recorded as a known
| > issue
| > | > of the current ASP.NET's stateserver session manager's
implemtation.
| > So
| > | > basically, there doesn't have any particular limtation on the chars
| > used
| > | > for web application's virtual dir(just as the IIS's rule). Also,
this
| > | > issue has been confirmed to be fixed in whidbey and based on my
test
| > on
| > a
| > | > whidbey beta2 environment, I did manage to get this work. I think
this
| > | > behavior will be consistent in the final release of ASP.NET whidbey.
| > | > Currently, as for the asp.net 1.x , for your scenario, I'd still
| > recommend
| > | > that you add limitation for the space char in your application so
as
| > to
| > | > prevent the user from creating virtual dir with names that contains
| > | > spaces.
| > | > Sorry for the inconvenience this has brought you.
| > | >
| > | > Thanks for your understanding.
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > --------------------
| > | > | From: "Stu Carter" <St********@nospam.nospam>
| > | > | Subject: State Service error with space in Virtual Directory
| > | > | Date: Tue, 27 Sep 2005 09:23:16 +0100
| > | > | Lines: 32
| > | > | X-Priority: 3
| > | > | X-MSMail-Priority: Normal
| > | > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
| > | > | X-RFC2646: Format=Flowed; Original
| > | > | Message-ID: <eF**************@TK2MSFTNGP12.phx.gbl>
| > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | > | NNTP-Posting-Host: brooklyn-bridge.emea.veritas.com 62.172.234.2
| > | > | Path:
| > TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP12.phx.gbl
| > | > | Xref: TK2MSFTNGXA01.phx.gbl
| > | > microsoft.public.dotnet.framework.aspnet:127325
| > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | > |
| > | > | Hi,
| > | > |
| > | > | ENV: Windows 2003 Server SP1 (+all updates), VS 2003, .Net 1.1 SP1
| > | > |
| > | > | We've got an ASP.Net web application using State Service. All is
| > fine
| > | > until
| > | > | we tried to use the app through a virtual directory with a space
in
| > it.
| > | > | e.g. 'http://localhost/My%20App'.
| > | > |
| > | > | The following exception is thrown:
| > | > | ----------
| > | > | System.Web.HttpException: Unable to make the session state
request
| > to
| > | > the
| > | > | session state server. Please ensure that the ASP.NET State
service
| > is
| > | > | started and that the client and server ports are the same. If the
| > server
| > | > is
| > | > | on a remote machine, please ensure that it accepts remote
requests
| > by
| > | > | checking the value of
| > | > |
| > | >
| >
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters
| > | > \AllowRemoteConnection.
| > | > | -----------
| > | > |
| > | > | IIS allows us to create Virtual Directories with a space, so does
| > the
| > | > State
| > | > | Service not support it? I couldn't find any documentation on
this
| > or
| > | > any
| > | > | previous posts via Google...
| > | > |
| > | > | If it doesn't support it, can you point me to any docs which list
| > what
| > | > are
| > | > | invalid characters. The real reason is that we have an app which
| > allows
| > | > | customers to create new Virtual Directories that run our other
| > ASP.Net
| > | > apps.
| > | > | We just need to know so we can stop customers creating VD's with
| > spaces
| > | > and
| > | > | any other dodgy characters.
| > | > |
| > | > | Thanks,
| > | > | Stuart
| > | > |
| > | > |
| > | > |
| > | >
| > |
| > |
| > |
| >
|
|
|

Nov 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.