By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,058 Members | 1,209 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,058 IT Pros & Developers. It's quick & easy.

Cookieless session problem...

P: n/a
Hi,

I am building a mobile site. It has to have cookieless sessions enabled as
asp.net mobile stores viewstate information for controls in session. I need
one directory in the application (that takes input from a remote site), to
not have cookieless sessions as it can't redirect the call from
/_test/scriptname.aspx to /{sessionID}/_test/scriptname.aspx. I am able to do
this using the web.config location element, however I get the error "It is an
error to use a section registered as allowDefinition='MachineToApplication'
beyond application level. This error can be caused by a virtual directory not
being configured as an application in IIS.".

This can be solved by making the "_test" directory an application in iis,
but then it needs its on bin folder for the dll's etc. I was wonder if anyone
knew of a way around this, so I don't need to make the "_test" directory an
application or can just disable sessions for certain scripts.

Thanks in advance for any suggestions...
-Jac
Nov 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Have you tried the EnableSessionState attribute of the @ Page directive?

"Jac Timms" wrote:
Hi,

I am building a mobile site. It has to have cookieless sessions enabled as
asp.net mobile stores viewstate information for controls in session. I need
one directory in the application (that takes input from a remote site), to
not have cookieless sessions as it can't redirect the call from
/_test/scriptname.aspx to /{sessionID}/_test/scriptname.aspx. I am able to do
this using the web.config location element, however I get the error "It is an
error to use a section registered as allowDefinition='MachineToApplication'
beyond application level. This error can be caused by a virtual directory not
being configured as an application in IIS.".

This can be solved by making the "_test" directory an application in iis,
but then it needs its on bin folder for the dll's etc. I was wonder if anyone
knew of a way around this, so I don't need to make the "_test" directory an
application or can just disable sessions for certain scripts.

Thanks in advance for any suggestions...
-Jac

Nov 19 '05 #2

P: n/a
brilliant, thank you!
i can't believe i missed that...
i looked on this page thinking there might be something i could do in the
page directive.
http://msdn.microsoft.com/library/de.../cpconpage.asp
thanks again.
-jac
"Brad Roberts" wrote:
Have you tried the EnableSessionState attribute of the @ Page directive?

"Jac Timms" wrote:
Hi,

I am building a mobile site. It has to have cookieless sessions enabled as
asp.net mobile stores viewstate information for controls in session. I need
one directory in the application (that takes input from a remote site), to
not have cookieless sessions as it can't redirect the call from
/_test/scriptname.aspx to /{sessionID}/_test/scriptname.aspx. I am able to do
this using the web.config location element, however I get the error "It is an
error to use a section registered as allowDefinition='MachineToApplication'
beyond application level. This error can be caused by a virtual directory not
being configured as an application in IIS.".

This can be solved by making the "_test" directory an application in iis,
but then it needs its on bin folder for the dll's etc. I was wonder if anyone
knew of a way around this, so I don't need to make the "_test" directory an
application or can just disable sessions for certain scripts.

Thanks in advance for any suggestions...
-Jac

Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.