By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,383 Members | 2,070 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,383 IT Pros & Developers. It's quick & easy.

All new VS2003 projects result in 404 errors

P: n/a
Just installed VS2003 and tried a hello world app. Getting 404 error even
when I explictly specify the start page in the url.

In IIS Mgr (v 5.1), App has .aspx mapped to
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.

The file in question IS in the virtual directory and this is the inetmgr log
file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
GET /UP1/WebForm1.aspx 404

If I put a test HTML file (Default.htm) into the virtual directory and bring
up http://localhost/UP1 in my browser, I get the test page OK.

Interestingly, an app that I installed BEFORE installing VS2003 works. I
compared its properties to new apps generated by VS2003 and only difference I
see is that the new apps have the "Local Path" box in the Directory tab
greyed out. The old app has an absolute pathname
(c:\inetput\wwwroot\InstantForum41).

Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
installing VS2003. Wonder if I broke something.

Also, another symptom is that debugger won't start. Says I need to "verify
that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
speak) or that "ATL Server is correctly installed" (not sure how to test
that).

Nov 19 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Sounds to me like you have to re-register your IIS with aspnet_regiis.exe

Check the following link:

http://msdn.microsoft.com/library/de..._regiisexe.asp

"EmmanuelE" wrote:
Just installed VS2003 and tried a hello world app. Getting 404 error even
when I explictly specify the start page in the url.

In IIS Mgr (v 5.1), App has .aspx mapped to
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.

The file in question IS in the virtual directory and this is the inetmgr log
file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
GET /UP1/WebForm1.aspx 404

If I put a test HTML file (Default.htm) into the virtual directory and bring
up http://localhost/UP1 in my browser, I get the test page OK.

Interestingly, an app that I installed BEFORE installing VS2003 works. I
compared its properties to new apps generated by VS2003 and only difference I
see is that the new apps have the "Local Path" box in the Directory tab
greyed out. The old app has an absolute pathname
(c:\inetput\wwwroot\InstantForum41).

Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
installing VS2003. Wonder if I broke something.

Also, another symptom is that debugger won't start. Says I need to "verify
that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
speak) or that "ATL Server is correctly installed" (not sure how to test
that).

Nov 19 '05 #2

P: n/a
Thanks but no luck. I had done that anyways (-c and -i from within my
1.1.4322 directory). I tried again and this time removed ASP.NET and scripts
from all apps and then reinstalled. No luck.

However, I did run into something interesting. When I do a aspnet_regiis -k
<dir> on a <dir> for a newly created and built "Hello World" app (VS2003
asp.net app with a single Label on start page), I get an error message saying
it is a valid App:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis -k
c:\inetpub\wwwroot\WebApplication2
Start removing any version of ASP.NET DLL recursively at
c:\inetpub\wwwroot\WebA
pplication2.
Installation stopped because the specified path
(c:\inetpub\wwwroot\WebApplicati
on2) is not a valid web application.

Help!
"Kevin Schlegelmilch" wrote:
Sounds to me like you have to re-register your IIS with aspnet_regiis.exe

Check the following link:

http://msdn.microsoft.com/library/de..._regiisexe.asp

"EmmanuelE" wrote:
Just installed VS2003 and tried a hello world app. Getting 404 error even
when I explictly specify the start page in the url.

In IIS Mgr (v 5.1), App has .aspx mapped to
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.

The file in question IS in the virtual directory and this is the inetmgr log
file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
GET /UP1/WebForm1.aspx 404

If I put a test HTML file (Default.htm) into the virtual directory and bring
up http://localhost/UP1 in my browser, I get the test page OK.

Interestingly, an app that I installed BEFORE installing VS2003 works. I
compared its properties to new apps generated by VS2003 and only difference I
see is that the new apps have the "Local Path" box in the Directory tab
greyed out. The old app has an absolute pathname
(c:\inetput\wwwroot\InstantForum41).

Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
installing VS2003. Wonder if I broke something.

Also, another symptom is that debugger won't start. Says I need to "verify
that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
speak) or that "ATL Server is correctly installed" (not sure how to test
that).

Nov 19 '05 #3

P: n/a
Have you tried the "-ir" option?

Also if you right click on "Web Sites" in IIS, what's the ISAPI Filters? It
should be ASP.NET_1.1.4322.2300.

Have you checked the web services logs? They should be in
C:\WINDOWS\system32\LogFiles

One last thing I can think of is to manually configure the sites.

http://msdn.microsoft.com/library/de...tml/vs03f6.asp

ex: aspnet_regiis -s W3SVC/1/ROOT/yourwebappfolder

There's a .NET application someone wrote that will do this for you ... but I
can't find the link right now ...

"EmmanuelE" wrote:
Thanks but no luck. I had done that anyways (-c and -i from within my
1.1.4322 directory). I tried again and this time removed ASP.NET and scripts
from all apps and then reinstalled. No luck.

However, I did run into something interesting. When I do a aspnet_regiis -k
<dir> on a <dir> for a newly created and built "Hello World" app (VS2003
asp.net app with a single Label on start page), I get an error message saying
it is a valid App:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis -k
c:\inetpub\wwwroot\WebApplication2
Start removing any version of ASP.NET DLL recursively at
c:\inetpub\wwwroot\WebA
pplication2.
Installation stopped because the specified path
(c:\inetpub\wwwroot\WebApplicati
on2) is not a valid web application.

Help!
"Kevin Schlegelmilch" wrote:
Sounds to me like you have to re-register your IIS with aspnet_regiis.exe

Check the following link:

http://msdn.microsoft.com/library/de..._regiisexe.asp

"EmmanuelE" wrote:
Just installed VS2003 and tried a hello world app. Getting 404 error even
when I explictly specify the start page in the url.

In IIS Mgr (v 5.1), App has .aspx mapped to
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.

The file in question IS in the virtual directory and this is the inetmgr log
file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
GET /UP1/WebForm1.aspx 404

If I put a test HTML file (Default.htm) into the virtual directory and bring
up http://localhost/UP1 in my browser, I get the test page OK.

Interestingly, an app that I installed BEFORE installing VS2003 works. I
compared its properties to new apps generated by VS2003 and only difference I
see is that the new apps have the "Local Path" box in the Directory tab
greyed out. The old app has an absolute pathname
(c:\inetput\wwwroot\InstantForum41).

Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
installing VS2003. Wonder if I broke something.

Also, another symptom is that debugger won't start. Says I need to "verify
that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
speak) or that "ATL Server is correctly installed" (not sure how to test
that).

Nov 19 '05 #4

P: n/a
Nope. Didn't try -ir but I just uninstalled and reinstalled .net 1.1 and
everything works now.

But thanks for the tips on aspnet_regiis. I will surely need them at some
point in the future.

Emmanuel

"Kevin Schlegelmilch" wrote:
Have you tried the "-ir" option?

Also if you right click on "Web Sites" in IIS, what's the ISAPI Filters? It
should be ASP.NET_1.1.4322.2300.

Have you checked the web services logs? They should be in
C:\WINDOWS\system32\LogFiles

One last thing I can think of is to manually configure the sites.

http://msdn.microsoft.com/library/de...tml/vs03f6.asp

ex: aspnet_regiis -s W3SVC/1/ROOT/yourwebappfolder

There's a .NET application someone wrote that will do this for you ... but I
can't find the link right now ...

"EmmanuelE" wrote:
Thanks but no luck. I had done that anyways (-c and -i from within my
1.1.4322 directory). I tried again and this time removed ASP.NET and scripts
from all apps and then reinstalled. No luck.

However, I did run into something interesting. When I do a aspnet_regiis -k
<dir> on a <dir> for a newly created and built "Hello World" app (VS2003
asp.net app with a single Label on start page), I get an error message saying
it is a valid App:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis -k
c:\inetpub\wwwroot\WebApplication2
Start removing any version of ASP.NET DLL recursively at
c:\inetpub\wwwroot\WebA
pplication2.
Installation stopped because the specified path
(c:\inetpub\wwwroot\WebApplicati
on2) is not a valid web application.

Help!
"Kevin Schlegelmilch" wrote:
Sounds to me like you have to re-register your IIS with aspnet_regiis.exe

Check the following link:

http://msdn.microsoft.com/library/de..._regiisexe.asp

"EmmanuelE" wrote:

> Just installed VS2003 and tried a hello world app. Getting 404 error even
> when I explictly specify the start page in the url.
>
> In IIS Mgr (v 5.1), App has .aspx mapped to
> C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.
>
> The file in question IS in the virtual directory and this is the inetmgr log
> file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
> GET /UP1/WebForm1.aspx 404
>
> If I put a test HTML file (Default.htm) into the virtual directory and bring
> up http://localhost/UP1 in my browser, I get the test page OK.
>
> Interestingly, an app that I installed BEFORE installing VS2003 works. I
> compared its properties to new apps generated by VS2003 and only difference I
> see is that the new apps have the "Local Path" box in the Directory tab
> greyed out. The old app has an absolute pathname
> (c:\inetput\wwwroot\InstantForum41).
>
> Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
> installing VS2003. Wonder if I broke something.
>
> Also, another symptom is that debugger won't start. Says I need to "verify
> that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
> speak) or that "ATL Server is correctly installed" (not sure how to test
> that).
>

Nov 19 '05 #5

P: n/a
"-ir" reinstalls ASP.NET and registers it with IIS. I had the same problem
with the errors you were seeing and it ended up being ASP.NET not being
installed right.

"EmmanuelE" wrote:
Nope. Didn't try -ir but I just uninstalled and reinstalled .net 1.1 and
everything works now.

But thanks for the tips on aspnet_regiis. I will surely need them at some
point in the future.

Emmanuel

"Kevin Schlegelmilch" wrote:
Have you tried the "-ir" option?

Also if you right click on "Web Sites" in IIS, what's the ISAPI Filters? It
should be ASP.NET_1.1.4322.2300.

Have you checked the web services logs? They should be in
C:\WINDOWS\system32\LogFiles

One last thing I can think of is to manually configure the sites.

http://msdn.microsoft.com/library/de...tml/vs03f6.asp

ex: aspnet_regiis -s W3SVC/1/ROOT/yourwebappfolder

There's a .NET application someone wrote that will do this for you ... but I
can't find the link right now ...

"EmmanuelE" wrote:
Thanks but no luck. I had done that anyways (-c and -i from within my
1.1.4322 directory). I tried again and this time removed ASP.NET and scripts
from all apps and then reinstalled. No luck.

However, I did run into something interesting. When I do a aspnet_regiis -k
<dir> on a <dir> for a newly created and built "Hello World" app (VS2003
asp.net app with a single Label on start page), I get an error message saying
it is a valid App:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis -k
c:\inetpub\wwwroot\WebApplication2
Start removing any version of ASP.NET DLL recursively at
c:\inetpub\wwwroot\WebA
pplication2.
Installation stopped because the specified path
(c:\inetpub\wwwroot\WebApplicati
on2) is not a valid web application.

Help!
"Kevin Schlegelmilch" wrote:

> Sounds to me like you have to re-register your IIS with aspnet_regiis.exe
>
> Check the following link:
>
> http://msdn.microsoft.com/library/de..._regiisexe.asp
>
> "EmmanuelE" wrote:
>
> > Just installed VS2003 and tried a hello world app. Getting 404 error even
> > when I explictly specify the start page in the url.
> >
> > In IIS Mgr (v 5.1), App has .aspx mapped to
> > C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.
> >
> > The file in question IS in the virtual directory and this is the inetmgr log
> > file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
> > GET /UP1/WebForm1.aspx 404
> >
> > If I put a test HTML file (Default.htm) into the virtual directory and bring
> > up http://localhost/UP1 in my browser, I get the test page OK.
> >
> > Interestingly, an app that I installed BEFORE installing VS2003 works. I
> > compared its properties to new apps generated by VS2003 and only difference I
> > see is that the new apps have the "Local Path" box in the Directory tab
> > greyed out. The old app has an absolute pathname
> > (c:\inetput\wwwroot\InstantForum41).
> >
> > Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
> > installing VS2003. Wonder if I broke something.
> >
> > Also, another symptom is that debugger won't start. Says I need to "verify
> > that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
> > speak) or that "ATL Server is correctly installed" (not sure how to test
> > that).
> >

Nov 19 '05 #6

P: n/a
Thanks

"Kevin Schlegelmilch" wrote:
"-ir" reinstalls ASP.NET and registers it with IIS. I had the same problem
with the errors you were seeing and it ended up being ASP.NET not being
installed right.

"EmmanuelE" wrote:
Nope. Didn't try -ir but I just uninstalled and reinstalled .net 1.1 and
everything works now.

But thanks for the tips on aspnet_regiis. I will surely need them at some
point in the future.

Emmanuel

"Kevin Schlegelmilch" wrote:
Have you tried the "-ir" option?

Also if you right click on "Web Sites" in IIS, what's the ISAPI Filters? It
should be ASP.NET_1.1.4322.2300.

Have you checked the web services logs? They should be in
C:\WINDOWS\system32\LogFiles

One last thing I can think of is to manually configure the sites.

http://msdn.microsoft.com/library/de...tml/vs03f6.asp

ex: aspnet_regiis -s W3SVC/1/ROOT/yourwebappfolder

There's a .NET application someone wrote that will do this for you ... but I
can't find the link right now ...

"EmmanuelE" wrote:

> Thanks but no luck. I had done that anyways (-c and -i from within my
> 1.1.4322 directory). I tried again and this time removed ASP.NET and scripts
> from all apps and then reinstalled. No luck.
>
> However, I did run into something interesting. When I do a aspnet_regiis -k
> <dir> on a <dir> for a newly created and built "Hello World" app (VS2003
> asp.net app with a single Label on start page), I get an error message saying
> it is a valid App:
>
> C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis -k
> c:\inetpub\wwwroot\WebApplication2
> Start removing any version of ASP.NET DLL recursively at
> c:\inetpub\wwwroot\WebA
> pplication2.
> Installation stopped because the specified path
> (c:\inetpub\wwwroot\WebApplicati
> on2) is not a valid web application.
>
> Help!
>
>
> "Kevin Schlegelmilch" wrote:
>
> > Sounds to me like you have to re-register your IIS with aspnet_regiis.exe
> >
> > Check the following link:
> >
> > http://msdn.microsoft.com/library/de..._regiisexe.asp
> >
> > "EmmanuelE" wrote:
> >
> > > Just installed VS2003 and tried a hello world app. Getting 404 error even
> > > when I explictly specify the start page in the url.
> > >
> > > In IIS Mgr (v 5.1), App has .aspx mapped to
> > > C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_isapi.dll.
> > >
> > > The file in question IS in the virtual directory and this is the inetmgr log
> > > file entry that occurs when my browser requests the page: 19:42:27 127.0.0.1
> > > GET /UP1/WebForm1.aspx 404
> > >
> > > If I put a test HTML file (Default.htm) into the virtual directory and bring
> > > up http://localhost/UP1 in my browser, I get the test page OK.
> > >
> > > Interestingly, an app that I installed BEFORE installing VS2003 works. I
> > > compared its properties to new apps generated by VS2003 and only difference I
> > > see is that the new apps have the "Local Path" box in the Directory tab
> > > greyed out. The old app has an absolute pathname
> > > (c:\inetput\wwwroot\InstantForum41).
> > >
> > > Important info. I HAD VS2005 Beta2 installed. I uninstalled it before
> > > installing VS2003. Wonder if I broke something.
> > >
> > > Also, another symptom is that debugger won't start. Says I need to "verify
> > > that ASP.NET is correctly installed" (it is and wp_aspnet.exe is running as I
> > > speak) or that "ATL Server is correctly installed" (not sure how to test
> > > that).
> > >

Nov 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.