By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,492 Members | 1,289 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,492 IT Pros & Developers. It's quick & easy.

SSL beginner

P: n/a
I have a web application hosted by an ISP that has a login page called
"default.aspx" - the user enters username and password which is then
checked in an SQL Server database. Everything worked fine until I
recently subscribed to a Personal SSL certificate for the web app.from
my ISP - now, after entering username and password and clicking the
"Login" button absolutely nothing happens - no error message shows.

Can anybody advise on what I have missed?

I have not changed any configurations in Web.config from their pre-SSL
settings which were:

<system.web>

<customErrors mode="RemoteOnly"
defaultRedirect="error.aspx" />

<authentication mode="Windows" />
<authorization>
<allow users="*" />
</authorization>

<!-- GLOBALIZATION
<globalization requestEncoding="utf-8"
responseEncoding="utf-8" />

Nov 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
fully path out the error page perhaps, including the HTTPS://
With SSL it's the best way to ensure you dont switch secutity contexts and
cause issues.

By the way... sounds like WebHost4Life? (had similar issue but didnt really
pursue it).

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"da**@bluehills.co.uk" wrote:
I have a web application hosted by an ISP that has a login page called
"default.aspx" - the user enters username and password which is then
checked in an SQL Server database. Everything worked fine until I
recently subscribed to a Personal SSL certificate for the web app.from
my ISP - now, after entering username and password and clicking the
"Login" button absolutely nothing happens - no error message shows.

Can anybody advise on what I have missed?

I have not changed any configurations in Web.config from their pre-SSL
settings which were:

<system.web>

<customErrors mode="RemoteOnly"
defaultRedirect="error.aspx" />

<authentication mode="Windows" />
<authorization>
<allow users="*" />
</authorization>

<!-- GLOBALIZATION
<globalization requestEncoding="utf-8"
responseEncoding="utf-8" />

Nov 19 '05 #2

P: n/a

Curt_C wrote:
fully path out the error page perhaps, including the HTTPS://
With SSL it's the best way to ensure you dont switch secutity contexts and
cause issues.

By the way... sounds like WebHost4Life? (had similar issue but didnt really
pursue it).

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com


Curt,

Many thanks for taking the trouble to reply. The problem has now been
resolved by my ISP - simplewebhosting - apparently, as they describe
it:

"Looks like the site had some out of date client side .NET javascript
files installed. I have upgraded these, which has corrected the issue
(for what it is worth, only Internet Explorer had trouble with the
login action button, other browsers worked fine throughout)"

Now everything seems to work fine without me having to change a single
line of code from pre-SSL days - SO FAR!!

Dave Rudlin

Nov 19 '05 #3

P: n/a
You really shouldnt "have to" change any code to go from http to https...
it's really a connectivity thing.

Glad you got it working.. :}

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"da**@bluehills.co.uk" wrote:

Curt_C wrote:
fully path out the error page perhaps, including the HTTPS://
With SSL it's the best way to ensure you dont switch secutity contexts and
cause issues.

By the way... sounds like WebHost4Life? (had similar issue but didnt really
pursue it).

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com


Curt,

Many thanks for taking the trouble to reply. The problem has now been
resolved by my ISP - simplewebhosting - apparently, as they describe
it:

"Looks like the site had some out of date client side .NET javascript
files installed. I have upgraded these, which has corrected the issue
(for what it is worth, only Internet Explorer had trouble with the
login action button, other browsers worked fine throughout)"

Now everything seems to work fine without me having to change a single
line of code from pre-SSL days - SO FAR!!

Dave Rudlin

Nov 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.